Настройка сетевого оборудования компании HUAWEI (коммутация, статическая маршрутизация)

HUAWEI – одна из крупнейших китайских компаний в сфере телекоммуникаций. Основана в 1988 году.

Компания HUAWEI достаточно недавно вышла на российский рынок сетевого оборудования уровня Enterprise. С учётом тенденции тотальной экономии, на нашем предприятии очень остро встал вопрос о подборе достойной замены оборудованию Cisco.
В статье я попытаюсь рассмотреть базовые аспекты настройки сервисов коммутации и маршрутизации оборудования HUAWEI на примере коммутатора Quidway серии 5300.

Глобальные команды, режимы работы, cходства и различия с CLI CISCO.


Оборудование HUAWEI, построенное на базе операционной системы VRP, имеет cisco-like интерфейс командной строки. Принципы остаются теми же самыми, меняется только синтаксис.
В CLI оборудования HUAWEI существуют 2 режима командного интерфейса:
  1. system-view – аналог цисковского режима конфигурирования conf t. В этом режиме приглашение командной строки выглядит как [Switch].
  2. user-view – аналог цисковского непривилегированного режима. Режим приглашения выглядит так: <Switch>.

В отличие от непривилегированного режима Cisco из user-view доступны многие функции, в частности можно ресетнуть запущенные процессы. Подключения по telnet и ssh так же доступны только из user-view.
После некоторых претензий со стороны компании Cisco Systems, в ОС VRP были заменены часть служебных слов. Таблица соответствия некоторых служебных слов CLI представлена ниже.
Cisco HUAWEI
show display
running-configuration current-configuration
clear reset
configure terminal system-view
write save
quit exit
no undo

Основные команды:

  • system-view – переход из user-view в привилегированный режим system-view;
  • save – запись текущих настроек в энергонезависимую память устройства;
  • display current-configuration – вывод текущего файла конфигурации
  • display current-configuration configuration XXXX – вывод настроек секции XXXX.
  • display this – вывод конфигурации текущей секции;
  • quit – выход из текущей секции в родительскую.


Настройка vlan интерфейсов, режимы работы физических портов коммутатора


Создание vlan

Для создания vlan как сущности, на коммутаторе в режиме system-view выполняется команда vlan XXX, где XXX – номер vlan.
<Quidway>system-view
Enter system view, return user view with Ctrl+Z.
[Quidway]vlan
[Quidway]vlan 1
[Quidway-vlan1]

Vlan создан. Так же командой description можно задать описание или название vlan. В отличие от Cisco имя не является обязательным атрибутом при создании vlan.

Для передачи созданых vlan в пределах локальной сети используется протокол GVRP. Включается он командой gvrp в режиме system-view.
[Quidway]gvrp
Info: GVRP has been enabled.
[Quidway]

Так же gvrp должен быть разрешён на интерфейсе:
#
interface GigabitEthernet0/0/23
 port link-type trunk
 port trunk allow-pass vlan 100 to 200
 gvrp
#

Совместимости с Cisco VTP (vlan transfer protocol) нет и быть не может.

Создание vlan интерфейса.

<Quidway>
<Quidway>system-view
Enter system view, return user view with Ctrl+Z.
[Quidway]int vlanif 1
[Quidway-Vlanif1]ip address 2.2.2.2 24
[Quidway-Vlanif1]display this
#
interface Vlanif1
 ip address 2.2.2.2 255.255.255.0
#
return
[Quidway-Vlanif1]

В отличие от Cisco, маску можно писать сокращённо. Очень удобно.
Думаю, что комментарии излишни.

Режимы работы портов

Собственно, ничего нового. Существуют два основных режима работы порта: access и trunk.
Режим trunk
Настройка порта:
<Quidway>system-view
Enter system view, return user view with Ctrl+Z.
[Quidway]int gi0/0/1
[Quidway-GigabitEthernet0/0/1]port link-type trunk
[Quidway-GigabitEthernet0/0/1]port trunk allow-pass vlan 1
[Quidway-GigabitEthernet0/0/1]di th
#
interface GigabitEthernet0/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 900
#
return

В отличие от коммутаторов Cisco, по-умолчанию, все vlan запрещены и их необходимо принудительно разрешить командой port trunk allow-pass vlan.
Нетэггированный native vlan на порту включается командой:
[Quidway-GigabitEthernet0/0/1]port trunk pvid vlan 600


Режим access

[Quidway-GigabitEthernet0/0/1]port link-type access
[Quidway-GigabitEthernet0/0/1]port default vlan 2
[Quidway-GigabitEthernet0/0/1]di th
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 2
#
return


Настройка eth-trunk

interface Vlanif100
 ip address 1.1.1.2 255.255.255.252
#
interface GigabitEthernet0/0/23
eth-trunk 1
#
interface GigabitEthernet0/0/24
eth-trunk 1
#
interface Eth-Trunk0
 port link-type trunk
 port trunk allow-pass vlan 100
#


Комментарии излишни.

Настройка STP


Для тестирование STP были соединены коммутаторы Cisco 2960 и HUAWEI Quidway S5328C-EI.
Для включения STP на коммутаторе необходимо в режиме system-view ввести команду
[Quidway] stp enable

По умолчанию, приоритет коммутатора HUAWEI, так же как и коммутатора Cisco равен 32768.
Просмотр информации о текущем состоянии портов:
[Quidway]display stp brief
 MSTID  Port                        Role  STP State     Protection
   0    GigabitEthernet0/0/1        ALTE  DISCARDING      NONE
   0    GigabitEthernet0/0/2        ROOT  FORWARDING      NONE


Видно, что один из портов заблокирован, т. к. приоритет коммутатора Cisco оказался больше.
Просмотр глобальной информации об STP:

[Quidway]disp stp
-------[CIST Global Info][Mode STP]-------
CIST Bridge         :32768.781d-baa4-b6a7
Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
CIST Root/ERPC      :8192 .2893-fe2a-9a80 / 199999
CIST RegRoot/IRPC   :32768.781d-baa4-b6a7 / 0
CIST RootPortId     :128.2
BPDU-Protection     :Disabled
TC or TCN received  :107
TC count per hello  :0
STP Converge Mode   :Normal
Share region-configuration :Enabled
Time since last TC  :0 days 1h:16m:17s
Number of TC        :9
Last TC occurred    :GigabitEthernet0/0/2


Изменим приоритет коммутатора HUAWEI. Сделаем его наименьшим: 4096.
[Quidway]stp priority 4096

Посмотрим, что порт разблокировался:
[Quidway]disp stp brief
 MSTID  Port                        Role  STP State     Protection
   0    GigabitEthernet0/0/1        DESI  FORWARDING      NONE
   0    GigabitEthernet0/0/2        DESI  FORWARDING      NONE
[Quidway]

Общая информация об STP:
[Quidway]disp stp
-------[CIST Global Info][Mode STP]-------
CIST Bridge         :4096 .781d-baa4-b6a7
Config Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
Active Times        :Hello 2s MaxAge 20s FwDly 15s MaxHop 20
CIST Root/ERPC      :4096 .781d-baa4-b6a7 / 0
CIST RegRoot/IRPC   :4096 .781d-baa4-b6a7 / 0
CIST RootPortId     :0.0
BPDU-Protection     :Disabled
TC or TCN received  :123
TC count per hello  :0
STP Converge Mode   :Normal
Share region-configuration :Enabled
Time since last TC  :0 days 0h:0m:44s
Number of TC        :11
Last TC occurred    :GigabitEthernet0/0/1


Статическая маршрутизация

Статические маршруты прописываются точно так же, как на оборудовании Cisco:
[Quidway]ip route 0.0.0.0 0.0.0.0 1.1.1.1

Просмотр таблицы маршрутизации:
[Quidway]disp ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 6        Routes : 6

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        2.2.2.0/24  Direct  0    0           D   2.2.2.2         Vlanif1
        2.2.2.2/32  Direct  0    0           D   127.0.0.1       Vlanif1
       10.0.0.3/32  Direct  0    0           D   127.0.0.1       LoopBack0
       90.0.0.1/32  Direct  0    0           D   127.0.0.1       LoopBack10
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0



На этом всё.
Если уважаемое сообщество заинтересуется материалом, планирую продолжить освещать настройку оборудования HUAWEI. В следующей статье рассмотрим настройку динамической маршрутизации.

Спасибо за внимание.
Поделиться публикацией
Ой, у вас баннер убежал!

Ну. И что?
Реклама
Комментарии 37
  • 0
    Команда port default vlan так же работает на портах trunk включая нетэгированный native vlan.

    Выглядит только по разному для разных режимов. По умолчанию порт находится в режиме гибрид.
    interface GigabitEthernet0/0/5
    port link-type access
    port default vlan 600

    interface GigabitEthernet0/0/5
    port hybrid pvid vlan 600

    interface GigabitEthernet0/0/5
    port link-type trunk
    port trunk pvid vlan 600

    Вот до сих пор не могу понять, в чем разница между гибридом и транком. Может просветите?
    • 0
      Выдержка из документации по свитчу:

      A trunk interface connects to a switch and can connect only to a trunk link. A trunk interface allows frames from multiple VLANs to pass.
      A hybrid interface can connect to either a user device or a switch, and it can connect to an access link or a trunk link. A hybrid interface allows frames from multiple VLANs to pass and can remove VLAN tags of outgoing frames.


      Т. е. транковый порт может соединяться только с другим свитчём и только в транковый порт, а гибридный порт может работать как с конечным оборудованием, так и со свитчами, причём на другом свитче порт может быть access.
      • 0
        А для чего же тогда можно задавать pvid на транковом порту? Гибрид тоже может передавать несколько вланов. Можно коммутаторы между собой гибридом включать. Имхо какой-то лишний режим китайцы навертели.
        • 0
          Вот кстати в режиме гибрид:
          interface GigabitEthernet0/0/2
          port hybrid pvid vlan 873
          undo port hybrid vlan 1
          port hybrid tagged vlan 1606 2606
          port hybrid untagged vlan 873
          stp edged-port enable

          873 идет нейтивом, 1606 и 2606 идут тегированными.
          • 0
            То есть в режиме «транк» никакого нейтива нет? А что — неплохая идея, это имеет смысл в большинстве сценариев использования транка.
            • 0
              Ну учитывая, что после ввода «port tr pvid vlan 1», команда в конфиге не отображается можно предполагать, что нейтивом идет всё-таки первая влан, как и на циске.
              • 0
                Да, забавно.
                Может, тут что-то касается работы их аналога DTP?
              • 0
                Нейтив в транке тоже есть — его не может не есть. BPDU например, насколько, я помню, летят в нейтив влане. Как иначе сойдётся MSTP?
        • 0
          Спасибо! Исправил про native vlan.
          • 0
            Гибридный порт может использоваться для QinQ, об этом можно почитать в HedEx'е.
            Второе его использование — мультикаст. Например у вас в двух вланах по агрегации идёт к абоненту ШПД и IPTV, на конечном порту аксес-коммутатора, снимается тег с обоих типов трафика, и у вас будет и юникастовый обмен данными и также будет бежать мультикастовый трафик.

            Дело в том, что гибридный порт отличается от транкового тем, что он может снимать верхнюю метку больше чем с одного влана.
          • 0
            Хотелось бы увидеть хотя бы примерное сравнение порядка цен на аналогичные модели Cisco и Huawei.
            • 0
              В среднем по больничке цены отличаются в 2-3 раза.

              Рассказывали коллеги из МТС про опыт внедрения Huawei. Положительных отзывов мало. Очень не понравилось лицензирования фич, вплоть до кол-ва VLAN (по крайней мере у них было так!). Через пол года жизни сети появилась необходимость в фиче, которая у таких вендоров как Cisco и Juniper считается более чем стандартная, а тут завалили такие цены.

              Изначально компания очень настроена на продажу оборудования, чуть ли ни даром. Стоит набраться оборудования, втянуться — Вы оказываетесь на крючке.

              Тут многие писали о неудовлетворительном сервисе Cisco TAC и JTAC. По заявлением коллег, в сравнении с поддержкой Huawei, выше описанные суппорты — просто мечта.
              • 0
                А можно подробнее про эти отрицательные моменты?
                • 0
                  Лицензирование фич, наверное, все-таки относится немного к другим железкам, по типу CX-600 (что-то вроде Cisco 76xx), но на цисках 12К серии фичи тоже отдельно ставятся.
                  Пришлось столкнуться с саппортом хуавея — реагируют очень быстро и профессионально. Плохого пока ничего сказать не могу.
                  • 0
                    Ну покупка фич — это удобно. Главное что бы суммарная стоимость такого решения не превзошла аналоги у которых сразу всё из коробки есть.
                    Схема покупки фич, например используется у NetApp, мне кажется, что во многих случаях это удобно. Не нужны тебе VLAN'ы можешь не покупать — удобно ведь?
                    • 0
                      Удобно, до тех пор, пока (например) железка с коробки поддерживает 100 VLAN, а за еще 200 необходимо платить. Не понятно в чем тут фича?
                      • 0
                        Ну тут собственно всё логично. Платите за функционал, вместо покупки более мощного железа, просто докупаете лицензии, а изначально оплатили только нужную часть, остальное(оплата переизбытка мощности) можно сказать производитель взял на себя.
                        Некоторую аналогию можно произвести с процами от AMD, когда они продают абсолютно одинаковые камни за разные деньги в виду того, что на части из них, они блочат ядра, тем самым уменьшая общую производительность. Правда тут мы не можем доплатить за разлочку, нам придётся купить новый проц.

                        И вообще это логично покупать железо отдельно, софт отдельно.
                        Ваше негодование по поводу количества VLAN'ов, можно сравнить с покупкой лицензий на антивирус, оплатили пакет на 25лицензий и хорошо, расширился бизнес — докупите нужное количество лицензий.
                        • 0
                          Check Point этим промышляет очень давно даже на железках начального уровня.
                • 0
                  на нашем предприятии очень остро встал вопрос о подборе достойной замены оборудованию Cisco.

                  Любопытства ради — какое конкретно оборудование Cisco заменяется? И какие технологии задействованы?
                  • 0
                    Это железки уровня 35хх-37хх. То есть свитч, с небольшими возможностями роутинга, с несколькими интерфейсвланами и протоколами ospf/isis/bgp. Конечно надо подходить с головой и понимать, что фулвью в него запихнуть не удастся.
                    • 0
                      Это понятно — пользовательские аксессные свитчи как правило весьма скучны. Меня больше конкретный use-case интересует. Наверняка ведь не только эти железки заменяли.
                      • 0
                        Ну это скорее на аксесс все-таки. Аксесс это хуавей 2300 (аналог 29 кошки). А 5300 скорее аггрегация. Use case — в нашем случае аггрегирование оптических каналов и передача на рутер (циску). Потому как стоимость порта раза в полтора-два ниже получается, чем у циски. Плюс не надо играться с ансуппортед трансиверами. Почему я и привел в аналоги 37.
                        • 0
                          У хуавея на аксесс больше похожа серия S3300, аналог метрошной циски me3400.
                    • 0
                      Пока думаем исключительно про WiFi и контроллеры, ну и как замену 3750.
                    • +1
                      Если сравнивать CLI от Cisco и Huawei, то надо отметить команду «display this», выводящую кусок конфигурации относящийся к текущему контексту. В цисках такой команды нет, на сколько я знаю, а между тем она очень удобна.
                      • 0
                        но можно выйти из положения, хоть и не так элегантно:
                        do sh run | interface fa0/0
                        do sh run | section bgp
                        • 0
                          прошу прощения, рука дрогнула, конечно же первая команда без пайпа:
                          do sh run interface fa0/0
                          • 0
                            ну так можно вообще альясов наделать: alias interface sh do sh
                        • +1
                          Для сохранения конфигурации: в Cisco — write, Huawai — save, а не наоборот.
                        • 0
                          Различия в CLI начинают напрягать, когда у тебя в сети «зоопарк». У нас вот бордер Cisco ASR1002, BRAS — Ericsson SE600, на агрегации и Catalyst 3650G/E и Huawei S9303, а на доступе D-Link DES-3526, DES-3200-28/26/18, DES-1228ME плюс Huawei S2326 и S3328.
                          И как, блин, тут не ругаться?!
                          • 0
                            Почти cisco cli у ZTE\DCN\ZELAX. Где-то рядом awplus AT
                            синтаксис Huawei аналогичен покойному 3com, хотя и от cisco cli отличий мало
                            => кто-то изобретает велосипед, а кто-то копирует, с некоторыми незначительными изменениями. Ну а длинк… такой длинк…
                            • 0
                              SNR/QTECH из той же песни…
                            • 0
                              У вас в таблице quit и exit перепутаны. А еще — end return
                              • 0
                                Добрый день, год назад делал бэкап S5700-28C-SI huawei коммутатора. Сейчас не могу вспомнить, как бы это глупо не звучало( в интернете нашел запись backup current-configuration. Буду признателен
                                • 0
                                  Подключаюсь через putty, набираю логин и пароль, далее system-view и дальше у меня стопор(

                                Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.

                                Самое читаемое