Вышел PDT 2.1

    image
    Обновился популярный среди PHP-разработчиков плагин для Eclipse — PHP Development Tools

    Из основных нововведений:
    • Eclipse 3.5 (Galileo)
    • Поддержка PHP 5.3 (неймспейсы, лямбда-функции, замыкания)

    Официальный анонс
    Страница загрузки

    P.S. Теперь только осталось дождаться релиза PHP 5.3
    Поделиться публикацией
    Похожие публикации
    Ой, у вас баннер убежал!

    Ну. И что?
    Реклама
    Комментарии 23
      0
      Скачал еще вчера, впечатления положительные =),
      Работает действительно шустрее
        0
        All-In-One Mac OSX Cocoa — просто великолепно! :)
          0
          На php.net обещали выпустить на этой неделе RC5 либо final, но пока ничего нет.
          A stable release is expected next week. In case of critical issues we will continue producing weekly RCs.
            +2
            Ну а я уже говорил в соседнем топике про Эклипс — что новый релиз у меня работает заметно медленнее и жрет как минимум в два раза больше памяти, чем старенький Europa.
              –3
              лучше бы нормальный плагин для ftp сделали бы.
                +3
                мне так нравятся подобные комментарии…
                кто сделали бы? они? а кто они?
                  0
                  Ну так в платной версии Aptana он вполне сносный.
                  За удобство надо платить.
                    +1
                    при чем FTP к PHP и вообще PDT?
                      0
                        0
                        вы пробывали работать с сайтами по ftp через RSE?
                        это же ппц, чтобы добраться до корня надо пройти через огонь, воду и медные трубы…
                          0
                          Конечно пробовал!
                          Более того, я с ним и сейчас работаю!
                          А какие, собственно, проблемы? Корень — он и в RSE корень. Всегда вначале дерева каталогов. Или Вы о каком-то другом корне?
                          А RSE хорош еще и тем, что позволяет юзать ssh, local drives, telnet
                          Лично для меня набор must have — QuickREx, RSE, SVN, jsEclipse — разумеется, в дополнение к сборке PDT
                            0
                            я бы еще добавил Spket. Кстати, на релиз 2.1. у мня не поставился QuickRegEx
                              0
                              у меня лично сначала открывается сервер, потом FILES, потом папка и только тут корень директории!
                              до локальных файлов не лучше: Local->Local Files->My Home

                              Почему не сделать как в Zend Studio 5.5?
                        0
                        good
                          0
                          Кстати, кто-нибудь знает, как PDT 2.1 установить на Ganymede?
                            0
                            Отличная новость, к сожалению, сейчас скачать не могу.

                            Скажите пожалуйста, люди добрые, появилась наконец-то поддержа drag&drop?
                              0
                              у меня он крашится после установки субклипса, причем на таком мифе — в настройках в строке поиска сверху ввожу «keys» и все, краш ))
                              ЖРЕ 1.6, сп2-звер
                                0
                                я кстати вас обманул, крашитя он не навинде, а на леоперде с последними апдейтами на сегодня)
                                  0
                                  очень странно, 10.5.7 полет нормальный
                                0
                                Попробовал завести под винду.

                                По ощущениям, работает пошустрее Ганимеда (хотя у меня на машине Ганимед притормаживал по сравнению с Европой :-)).

                                Зато не удалось собрать проект с указанием версии «PHP 5.1 / PHP 5.2», вылетело сообщение
                                «Build path contains duplicate entry: 'C:eclipse/plugins/org.eclipse.php.core_2.0.1.v20090617-2341/Resources/language/php5/' for project %projectname%»


                                А с указанием версии PHP 5.3 всё работает. Пока без нареканий.
                                  0
                                  Какой-то очень-очень задумчивый code assist. Автодполнение не работает внутри квадратных скобок. В общем, как-то сыровато.
                                    0
                                    У вас работает подсказка типа параметра функции и значения по умолчанию?

                                    Например, function x(array $a = null) в PDT 1 подсказывал что параметр типа array и значение null по умолчанию. В PDT 2.1 не подсказывает, просто в подсказке $a и все.
                                      0
                                      Не работает. Я было подумал, что это у меня одного вечно что-то не работает… Итого юзаю PDT 1, который на Европе.

                                    Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.

                                    Самое читаемое