Как стать автором
Обновить
Selectel
IT-инфраструктура для бизнеса

Базовая настройка коммутатора Cisco 2960: особенности и фишки

Уровень сложностиПростой
Время на прочтение6 мин
Количество просмотров24K

Cisco 2960 – это один из наиболее распространенных коммутаторов в мире сетевых технологий. Гибкость, надежность и возможности делают его привлекательным выбором для различных сетевых инфраструктур.

Привет! Меня зовут Гоша, я студент и начинающий сетевик. Относительно недавно я прошел курс по Cisco, получил сертификат (да, это было тяжело), и хочу поделиться опытом настройки коммутатора 2960. А еще рассказать о фишках, которые могут значительно улучшить работу вашей сети. Подробности под катом!

Немного о моем опыте


Когда я был на производственной практике вещательной организации от университета, мне поставили задачу настроить сетевое оборудование для внутренней лабораторной инфраструктуры. Тогда для меня это было вызовом, который заставил погрузиться в особенности Cisco 2960. Я создавал VLAN-ы и работал с QoS и вот, захотел поделиться опытом.

Моя статья больше для новичков. Если у вас есть рекомендации или корректировки, давайте обсудим в комментариях — они для меня будут полезны! Между тем хочу предупредить, что настройка ниже — не решение для продакшена. Как минимум, дополнительно необходимо настраивать NTP-клиент и указать часовой пояс, чтобы избежать нестыковок из-за времени.

Используйте навигацию, если не хотите читать текст полностью:

Подключение к коммутатору
Приступаем к базовой настройке!
Как установить VLAN
Интересные фишки и особенности коммутатора
Настройка QoS

Подключение к коммутатору


Что понадобится


Для базовой настройки коммутатора Cisco 2960 вам понадобится:

  • сам коммутатор,
  • кабель RJ-45-RS-232,
  • компьютер с COM-портом или переходник USB 2.0-RS232 при его отсутствии,
  • кабель питания CEE 7/7.


Что понадобится для инсталляции.

Step by step


1. Подключите кабель питания CEE 7/7 к коммутатору и вставьте в розетку. Убедитесь, что в момент подачи питания на коммутаторе загорелись лампочки, каждая из которых отвечает за свой интерфейс.

2. Подключите кабель RJ-45–RS-232 к порту с надписью «Console».


Порт Console.

3. Подключите переходник USB 2.0-RS232 к RJ-45–RS-232.

4. Установите специальный драйвер Cisco USB console driver на ваш компьютер для последующей работы через программу Putty. 5. Установите программу Putty на компьютер.

6. Подключите переходник USB 2.0-RS232 в USB порт вашего компьютера.

7. После подключения в диспетчере устройств отобразится раздел «Порты (COM и LPT)». Запомните номер порта.

8. В программе Putty выберите тип подключения (Connection type) – Serial. В Serial line укажите номер порта, например, COM3.


Настройки в Putty.


Приступаем к базовой настройке!


Первое подключение к коммутатору


1. Когда вы подключаетесь к коммутатору в первый раз и установочный мастер предлагает пошаговую настройку (Continue with configuration dialog? [yes/no]), необходимо отказаться от нее.

2. После этого загрузится пользовательский режим вводы «Switch>» — перейдите в привилегированный режим:

Switch>enable 
Password: (нажмите «Enter», пароль по умолчанию отсутствует) 
Switch# (режим привилегированного доступа обозначается символом #)

Переход в привилегированный режим.

3. Измените имя коммутатора. Для этого нужно активировать режим глобальной конфигурации, что позволит настраивать конфигурацию всего коммутатора:

Switch# configure terminal 
Switch(config)# hostname 
Switch00 (новое имя – Switch00) 
Switch00(config)#

Замена имени коммутатора.

4. Задайте пароль для привилегированного режима:

Switch00(config)# enable secret admin (пароль admin) 
Switch00(config)#

Установка пароля для привилегированного режима.

5. Рекомендация: запретите несанкционированный поиск в DNS:

Switch00(config)# no ip domain-lookup
Switch00(config)#

6. Установите IP-адрес для порта управления коммутатором:

Switch00(config)# interface fa0/0
Switch00(config-if)# no shutdown
Switch00(config-if)# ip address 192.168.0.1 255.255.255.0
Switch00(config-if)# exit
Switch00(config)#

На порт fa0/0 установили адрес 192.168.0.1 255.255.255.0.

7. Для дальнейшего безопасного соединения используйте SSH:

Switch00# clock set 18:32:00 08 January 2024 (установка текущего времени и даты)
Switch00# conf t
Switch00(config)# ip domain name google.com (задаем домен, если его нет пишется любой)
Switch00(config)# crypto key generate rsa (генерируем RSA-ключа под ssh)
Switch00(config)# ip ssh version 2 (указываем версию SSH-протокола)
Switch00(config)# ip ssh autentification-retries 3 (устанавливаем допустимое число попыток подключения по SSH)
Switch00(config)# service password-encryption (добавляем сохранение паролей в зашифрованном виде )
Switch00(config)# line vty 0 2 (переход к режиму конф-и терминальных линий
Switch00(config-line)# transport input ssh (подключение только по SSH)
Switch00(config-line)# exec timeout 20 0 (активируем автоматическую смерть SSH-сессии через 20 минут)
Switch00(config—line)# end
Switch00# copy running-config startup-config (сохраняем настройки)

Базовая настройка коммутатора Cisco 2960 на этом завершается.

Как установить VLAN


Настройка Virtual LANs (VLANs) позволяет создавать виртуальные сегменты сети и логически разделять трафик между ними. Рассмотрим, что нужно сделать для установки VLAN.

1. Перейдите в режим глобальной конфигурации:

Switch00# configure terminal 
Switch00(config)#

Переход в привилегированный режим.

2. Создайте VLAN:

Switch00(config)# vlan 10 
Switch00(config-vlan)# name Sales Switch00(config-vlan)# exit

Создаем VLAN 10 с именем Sales.

3. Назначьте порты VLAN:

Switch00(config)# interface <т_и> <н_и> (например, fa0/1)
Switch00(config-if)# switchport mode access 
Switch00(config-if)# switchport access vlan 10 
Switch00(config-if)# exit

Назначаем порт на VLAN 10. <ти> — тип интерфейса, например FastEthernet или GigabitEthernet, <н_и> — номер интерфейса, который вы хотите настроить, например 0/1.

4. После завершения настройки не забудьте сохранить изменения:

Switch00# copy running-config startup-config

Сохранение изменений.

Поздравляю — вы создали VLAN с номером 10 и именем Sales, а затем назначили порт fat0/1 к этому VLAN на коммутаторе с именем Switch00.

После создания VLAN на коммутаторы Cisco 2960 у вас появляется множество возможностей для управления и оптимизации сетевого трафика. Теперь мы можете:

  • настроить маршрутизацию между VLAN,
  • настроить Trunk-порты,
  • использовать VLAN для управления сетевым трафиком,
  • применять Security и Voice VLAN,
  • использовать VLAN для управления широковещательным трафиком,
  • интеграция c VLAN в больших сетях.

Интересные фишки и особенности коммутатора


FlexStack и FlexStack-Plus


Модели Cisco 2960 поддерживают технологию FlexStack, которая позволяет объединять несколько коммутаторов в стек и управлять ими как единым устройством.

Power over Ethernet (PoE)


Множество моделей данного коммутатора оборудованы портами с поддержкой Power over Ethernet. Это позволяет подавать электропитание на устройства, такие как IP-камеры, телефоны VoIP и беспроводные точки доступа, уменьшая необходимость в дополнительных источниках питания.

Enhanced Security Features


Cisco 2960 предлагает различные функции безопасности, включая Port Security, DHCP Snooping, Dynamic ARP Inspection (DAI) и IP Source Guard. Эти функции помогают предотвращать атаки и обеспечивать безопасность в сети.

Smart Operations


Функции Smart Operations включают Smart Install, которая упрощает деплоймент новых коммутаторов в сети, и Smart Configuration, облегчающую начальную настройку и управление.

Quality of Service (QoS)


Cisco 2960 поддерживает QoS, что позволяет приоритезировать трафик в сети. Это особенно полезно для обеспечения качественного обслуживания голосового и видеотрафика. Поговорим о QoS подробнее.

Возможно, эти тексты тоже вас заинтересуют:

Одноплатники начала 2024 года: 5 моделей для самых разных целей
Цены не удержать: оперативная память продолжает дорожать. Что происходит на рынке электроники
Китай прорывает блокаду в битве за чипы? Страна планирует удвоить производство в течение пяти лет

Настройка QoS


Настройка QoS позволяет приоритезировать трафик в сети, что особенно важно для обеспечения качественного обслуживания голосового и видеотрафика.

1. Перейдите в режим глобальной конфигурации:

Switch00# configure terminal 
Switch00(config)#

Переход в привилегированный режим.

2. Включите QoS и настройте глобальные параметры:

Switch00(config)# mls qos

Включение QoS.

3. Настройте классы QoS (Class Maps):

Switch00(config)# class-map match-any VOICE 
Switch00(config-cmap)# match ip dscp ef Switch00(config-cmap)# exit 
Switch00(config)# class-map match-any VIDEO 
Switch00(config-cmap)# match ip dscp af41 Switch00(config-cmap)# exit

Включение классов VOICE и VIDEO.

В этом примере мы создали два класса: VOICE и VIDEO. Класс VOICE соответствует DSCP-метке ef (Expedited Forwarding), а класс VIDEO — DSCP-метке af41 (Assured Forwarding, Class 4, DSCP 1).

4. Заведите политики QoS (Policy Maps):

Switch00(config)# policy-map QOS-POLICY 
Switch00(config-pmap)# class VOICE Switch00(config-pmap-c)# priority percent 30 Switch00(config-pmap-c)# exit Switch00(config-pmap)# class VIDEO 
Switch00(config-pmap-c)# bandwidth remaining percent 20 
Switch00(config-pmap-c)# exit

Создание политики для классов VOICE и VIDEO.

Здесь мы создали политику с именем QOS-POLICY. Для класса VOICE мы установили приоритет в 30% от общей пропускной способности, а для класса VIDEO — оставшуюся пропускную способность в 20%.

5. Примените политики к интерфейсу:

Switch00(config)# interface fa0/1
Switch00(config-if)# service-policy input QOS-POLICY 
Switch00(config-if)# exit

Подключение интерфейса fa0/1 к созданной политике.

6. Последним этапом не забудьте сохранить изменения:

Switch00# copy running-config startup-config

Сохранение изменений.

Готово — теперь QoS настроен для коммутатора. Этот пример фокусируется на приоритезации голосового трафика (класс VOICE) и выделении пропускной способности для видеотрафика (класс VIDEO).

И вот, мы успешно настроили Cisco 2960. Помните, если что-то пошло не так, даже в мире сетевых технологий иногда нужен резервный план. Как говорит сам коммутатор перед выключением: «Если не заработало, перезагрузи все и поговорим».

Успешных вам настроек, минимум бургеров в сети и больше целых пакетов! Если у вас есть идеи, о какой железке еще рассказать, пишите в комментариях.
Теги:
Хабы:
Всего голосов 27: ↑20 и ↓7+20
Комментарии36

Публикации

Информация

Сайт
selectel.ru
Дата регистрации
Дата основания
Численность
501–1 000 человек
Местоположение
Россия
Представитель
Влад Ефименко