<!DOCTYPE html>
<html lang="ru" class="no-js">
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta content='width=1024' name='viewport'>
<title>8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода / Блог компании RUVDS.com / Хабр</title>

  <meta name="description" content="Когда тот, кто работает в сфере Data Science, собирается показать результаты своей деятельности другим людям, оказывается, что таблиц и отчётов, полных текстов, недостаточно для того чтобы..." />

  <meta name="keywords" content="Data Science, визуализация данных, разработка" />

  <meta property="fb:app_id" content="444736788986613" />
<meta property="og:type" content="article" />
<meta property="fb:pages" content="472597926099084"/>
<meta property="og:url" content="https://habr.com/ru/company/ruvds/blog/536962/" />
<meta property="og:title" content="8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода" />

    <meta property="og:image" content="https://habr.com/share/publication/536962/e64c7af0d91e87fbfabff068aa6d3ce1/?v=1" />
    <meta property="og:image:width" content="1200"/>
    <meta property="og:image:height" content="630"/>
    <link rel="image_src" href="https://habr.com/share/publication/536962/e64c7af0d91e87fbfabff068aa6d3ce1/?v=1" />
    <meta name="twitter:image" content="https://habr.com/share/publication/536962/e64c7af0d91e87fbfabff068aa6d3ce1/?v=1">
    <meta property="aiturec:image" content="https://habr.com/share/publication/536962/e64c7af0d91e87fbfabff068aa6d3ce1/?v=1">
      <meta property="vk:image"  content="https://habr.com/share/publication/536962/e64c7af0d91e87fbfabff068aa6d3ce1/?format=vk&v=1" />
    <meta property="og:image" content="https://habrastorage.org/webt/vu/-j/4r/vu-j4r9hwgqc3gnjljjv2xe8lsa.jpeg" />
    <link rel="image_src" href="https://habrastorage.org/webt/vu/-j/4r/vu-j4r9hwgqc3gnjljjv2xe8lsa.jpeg" />
    <meta property="og:image" content="https://lh5.googleusercontent.com/8OihthfU5sKCZ3FY6Tr4vV8Ms7nvb1poLdhXmU4SgG4AhbVVOPzaiVIj3LdxD3V92cQtiDQOXLZDQKfHWNWlwUS7eXDqVTh5fVU3E9BTUdzr3dtBWbUBXv_EOjJ55OT3oxoDBjY" />
    <link rel="image_src" href="https://lh5.googleusercontent.com/8OihthfU5sKCZ3FY6Tr4vV8Ms7nvb1poLdhXmU4SgG4AhbVVOPzaiVIj3LdxD3V92cQtiDQOXLZDQKfHWNWlwUS7eXDqVTh5fVU3E9BTUdzr3dtBWbUBXv_EOjJ55OT3oxoDBjY" />
    <meta property="og:image" content="https://lh3.googleusercontent.com/eMLcb6-QoLNCWaY8BiK-kzQ-NWkxV4ztU-LExEUsLa-gPhBiZ4WkgACLV7CtlwZXtGXE3HucFJcc4yuiDCbc4GMS0h5TV__oA981baXNYjH-_RiQM5o5klNegC_YzpQ4CZXke6Q" />
    <link rel="image_src" href="https://lh3.googleusercontent.com/eMLcb6-QoLNCWaY8BiK-kzQ-NWkxV4ztU-LExEUsLa-gPhBiZ4WkgACLV7CtlwZXtGXE3HucFJcc4yuiDCbc4GMS0h5TV__oA981baXNYjH-_RiQM5o5klNegC_YzpQ4CZXke6Q" />
    <meta property="og:image" content="https://lh6.googleusercontent.com/GPOVV_6Lmq4FGKGA2svG7iDDRY6eCTKou91wNnjPR6754GAa96I8zXfk7ma8PadZB8vOW2hClkbN_S5iQUQ1XdgYAsMgTE2rcv7CTqczVpyCSH6nMIrgLjQUD8pXKjuKZ91I_08" />
    <link rel="image_src" href="https://lh6.googleusercontent.com/GPOVV_6Lmq4FGKGA2svG7iDDRY6eCTKou91wNnjPR6754GAa96I8zXfk7ma8PadZB8vOW2hClkbN_S5iQUQ1XdgYAsMgTE2rcv7CTqczVpyCSH6nMIrgLjQUD8pXKjuKZ91I_08" />
    <meta property="og:image" content="https://lh6.googleusercontent.com/hq0YGcIJfvtqb6H6nfUAbe6SR2aPlTFTDC-qW4AGC2m3-lbEcoOViS-Gv0htfO4MgaGJC4ZVifycfSeOKExdyjE0NYtzR0jRMla1x5_IrApcF98871Jlv-vRrFyA8U8veFSyYp8" />
    <link rel="image_src" href="https://lh6.googleusercontent.com/hq0YGcIJfvtqb6H6nfUAbe6SR2aPlTFTDC-qW4AGC2m3-lbEcoOViS-Gv0htfO4MgaGJC4ZVifycfSeOKExdyjE0NYtzR0jRMla1x5_IrApcF98871Jlv-vRrFyA8U8veFSyYp8" />
    <meta property="og:image" content="https://miro.medium.com/max/700/1*nVYOFyEC7085qeRAnl_B2A.gif" />
    <link rel="image_src" href="https://miro.medium.com/max/700/1*nVYOFyEC7085qeRAnl_B2A.gif" />
    <meta property="og:image" content="https://lh4.googleusercontent.com/zCX4hdGn-X7TURiyYKObcSCkBTJDkHjhTWhDYCO_BmRWTTivwzoud_fPZ_WdBQO1_v9K9GIxa1bQZhZ2RwN8vaCXBsAo_R6AZHFgDMBEyy20JcSZOiU2nUSsecSo1SJLSk8EiCE" />
    <link rel="image_src" href="https://lh4.googleusercontent.com/zCX4hdGn-X7TURiyYKObcSCkBTJDkHjhTWhDYCO_BmRWTTivwzoud_fPZ_WdBQO1_v9K9GIxa1bQZhZ2RwN8vaCXBsAo_R6AZHFgDMBEyy20JcSZOiU2nUSsecSo1SJLSk8EiCE" />
    <meta property="og:image" content="https://miro.medium.com/max/1000/1*rEnj4Pe87dXsm3wGYrRHsA.gif" />
    <link rel="image_src" href="https://miro.medium.com/max/1000/1*rEnj4Pe87dXsm3wGYrRHsA.gif" />
    <meta property="og:image" content="https://lh6.googleusercontent.com/uRIZXdJXD4LH7FjhcAm61yy8RyXMqrLYe6IJIa_jAQvbyjxbwiZIjcMFd0fzvDfFOUBq7moCxBmLzWhDOKgzVd2d6HCoHhQF7zaaWJlbR96u9kb8Z7XK31Ocuhla-pS_svHEhrQ" />
    <link rel="image_src" href="https://lh6.googleusercontent.com/uRIZXdJXD4LH7FjhcAm61yy8RyXMqrLYe6IJIa_jAQvbyjxbwiZIjcMFd0fzvDfFOUBq7moCxBmLzWhDOKgzVd2d6HCoHhQF7zaaWJlbR96u9kb8Z7XK31Ocuhla-pS_svHEhrQ" />
    <meta property="og:image" content="https://habrastorage.org/webt/ou/g5/kh/oug5kh6sjydt9llengsiebnp40w.png" />
    <link rel="image_src" href="https://habrastorage.org/webt/ou/g5/kh/oug5kh6sjydt9llengsiebnp40w.png" />

<meta property="aiturec:title" content="8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода">
<meta property="aiturec:description" content="Когда тот, кто работает в сфере Data Science, собирается показать результаты своей деятельности другим людям, оказывается, что таблиц и отчётов, полных текстов,...">
<meta property="aiturec:item_id" content="536962">
<meta property="aiturec:datetime" content="2021-01-16T16:10:02+03:00">

<meta property="og:description" content="Когда тот, кто работает в сфере Data Science, собирается показать результаты своей деятельности другим людям, оказывается, что таблиц и отчётов, полных текстов,..." />
<meta name="twitter:description" content="Когда тот, кто работает в сфере Data Science, собирается показать результаты своей деятельности другим людям, оказывается, что таблиц и отчётов, полных текстов,...">
<meta name="twitter:title" content="8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@habr_com" />

  <meta property="al:android:url" content="habrahabr://post/536962" />
<meta property="al:android:app_name" content="Habrahabr" />
<meta property="al:android:package" content="ru.habrahabr" />
<meta property="al:windows_phone:url" content="habrahabr://post/536962" />
<meta property="al:windows_phone:app_name" content="Habrahabr" />
<meta property="al:windows_phone:app_id" content="460a6bd6-8955-470f-935e-9ea1726a6060" />

  <link rel="canonical" href="https://habr.com/ru/company/ruvds/blog/536962/"/>
  <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.habr.com/ru/company/ruvds/blog/536962/" >
<link rel="amphtml" href="https://m.habr.com/ru/amp/post/536962/">

  <script type="application/ld+json">
    {
    "@context": "http:\/\/schema.org",
    "@type": "Article",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https:\/\/habr.com\/ru\/company\/ruvds\/blog\/536962\/"
    },
    "headline": "8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода",
    "datePublished": "2021-01-16T16:10:02+03:00",
    "dateModified": "2021-01-16T16:10:02+03:00",
    "author": {
        "@type": "Person",
        "name": "ru_vds"
    },
    "publisher": {
        "@type": "Organization",
        "name": "Habr",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/dr.habracdn.net\/habr\/images\/habr_google.png"
        }
    },
    "description": "Когда тот, кто работает в сфере Data Science, собирается показать результаты своей деятельности другим людям, оказывается, что таблиц и отчётов, полных текстов,...",
    "url": "https:\/\/habr.com\/ru\/company\/ruvds\/blog\/536962\/#post-content-body",
    "about": [
        "c_ruvds",
        "h_webdev",
        "h_db_admins"
    ],
    "image": [
        "https:\/\/habrastorage.org\/webt\/vu\/-j\/4r\/vu-j4r9hwgqc3gnjljjv2xe8lsa.jpeg",
        "https:\/\/lh5.googleusercontent.com\/8OihthfU5sKCZ3FY6Tr4vV8Ms7nvb1poLdhXmU4SgG4AhbVVOPzaiVIj3LdxD3V92cQtiDQOXLZDQKfHWNWlwUS7eXDqVTh5fVU3E9BTUdzr3dtBWbUBXv_EOjJ55OT3oxoDBjY",
        "https:\/\/lh3.googleusercontent.com\/eMLcb6-QoLNCWaY8BiK-kzQ-NWkxV4ztU-LExEUsLa-gPhBiZ4WkgACLV7CtlwZXtGXE3HucFJcc4yuiDCbc4GMS0h5TV__oA981baXNYjH-_RiQM5o5klNegC_YzpQ4CZXke6Q",
        "https:\/\/lh6.googleusercontent.com\/GPOVV_6Lmq4FGKGA2svG7iDDRY6eCTKou91wNnjPR6754GAa96I8zXfk7ma8PadZB8vOW2hClkbN_S5iQUQ1XdgYAsMgTE2rcv7CTqczVpyCSH6nMIrgLjQUD8pXKjuKZ91I_08",
        "https:\/\/lh6.googleusercontent.com\/hq0YGcIJfvtqb6H6nfUAbe6SR2aPlTFTDC-qW4AGC2m3-lbEcoOViS-Gv0htfO4MgaGJC4ZVifycfSeOKExdyjE0NYtzR0jRMla1x5_IrApcF98871Jlv-vRrFyA8U8veFSyYp8",
        "https:\/\/miro.medium.com\/max\/700\/1*nVYOFyEC7085qeRAnl_B2A.gif",
        "https:\/\/lh4.googleusercontent.com\/zCX4hdGn-X7TURiyYKObcSCkBTJDkHjhTWhDYCO_BmRWTTivwzoud_fPZ_WdBQO1_v9K9GIxa1bQZhZ2RwN8vaCXBsAo_R6AZHFgDMBEyy20JcSZOiU2nUSsecSo1SJLSk8EiCE",
        "https:\/\/miro.medium.com\/max\/1000\/1*rEnj4Pe87dXsm3wGYrRHsA.gif",
        "https:\/\/lh6.googleusercontent.com\/uRIZXdJXD4LH7FjhcAm61yy8RyXMqrLYe6IJIa_jAQvbyjxbwiZIjcMFd0fzvDfFOUBq7moCxBmLzWhDOKgzVd2d6HCoHhQF7zaaWJlbR96u9kb8Z7XK31Ocuhla-pS_svHEhrQ",
        "https:\/\/habrastorage.org\/webt\/ou\/g5\/kh\/oug5kh6sjydt9llengsiebnp40w.png"
    ]
}
  </script>


<meta name='yandex-verification' content='71593b225aeafc4e' />
<meta name='referrer' content='unsafe-url' />
<meta name="pocket-site-verification" content="ed24b2b9721edf0a282c5b4a3232c4" />
<meta name="biu" content="https://dr.habracdn.net/habr/6001a5d9/images/">

<style type="text/css">
  @font-face{font-family:'Fira Sans';font-style:normal;font-weight:500;src:url(https://dr.habracdn.net/habr/6001a5d9/fonts/FiraSans/firaSans-medium.eot);src:local("Fira Sans Medium"),local("FiraSans-Medium"),url(https://dr.habracdn.net/habr/6001a5d9/fonts/FiraSans/firaSans-medium.eot?#iefix) format("embedded-opentype"),url(https://dr.habracdn.net/habr/6001a5d9/fonts/FiraSans/firaSans-medium.woff2) format("woff2"),url(https://dr.habracdn.net/habr/6001a5d9/fonts/FiraSans/firaSans-medium.woff) format("woff"),url(https://dr.habracdn.net/habr/6001a5d9/fonts/FiraSans/firaSans-medium.ttf) format("truetype")}
</style>

<link href="https://dr.habracdn.net/habr/6001a5d9/styles/main.bundle.css" rel="stylesheet" media="all" />





<meta name='yandex-verification' content='67d46b975fa41645' />

<link rel="apple-touch-icon" sizes="180x180" href="https://dr.habracdn.net/habr/6001a5d9/images/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://dr.habracdn.net/habr/6001a5d9/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://dr.habracdn.net/habr/6001a5d9/images/favicon-16x16.png">
<link rel="manifest" href="https://dr.habracdn.net/habr/6001a5d9/site.webmanifest">
<link rel="mask-icon" href="https://dr.habracdn.net/habr/6001a5d9/images/safari-pinned-tab.svg" color="#77a2b6">
<meta name="application-name" content="Хабр"/>
<meta name="msapplication-TileColor" content="#77a2b6">
<meta name="theme-color" content="#77a2b6">


  <link title="Комментарии к публикации «8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода»" type="application/rss+xml" rel="alternate" href="https://habr.com/ru/rss/post/536962/"/>

<script>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</script>
<script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/libs/jquery-1.8.3.min.js"></script>
<script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/libs/chance.min.js"></script>
<script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/libs/html2canvas.min.js"></script>
<script src="https://unpkg.com/pure-md5@latest/lib/index.js"></script>
<script>
  window.create_callback_for_blocked = function(key) {
    return function() {
      googletag.cmd.push(function () {
        googletag.display(key);
      });
    }
  }

  window.habr_blockers_checker = new function() {
    var result;
    var callbacksQueue = [];
    var calledOnce = false;

    function fireCallbacks() {
      callbacksQueue.forEach(function(callback) {
        callback(result);
      });
      callbacksQueue = [];
    }

    this.detect = function(imgUrl, callback) {
      var checksRemain = 2;
      var detected = false;
      var error1 = false;
      var error2 = false;

      if (typeof callback !== 'function') {
        return;
      };

      callbacksQueue.push(callback);

      if (typeof result !== 'undefined') {
        fireCallbacks();
      };

      if (calledOnce) {
        return;
      }
      calledOnce = true;

      imgUrl += '?ch=*&rn=*';

      function beforeCheck(timeout) {
        if (checksRemain === 0 || timeout > 1E3) {
          result = checksRemain === 0 && detected;
          fireCallbacks();
        } else {
          setTimeout(function() {
            beforeCheck(timeout * 2)
          }, timeout * 2);
        }
      }

      function checkImages() {
        if (--checksRemain) {
          return;
        };
        detected = !error1 && error2;
      }

      var random = Math.random() * 11;

      var img1 = new Image;
      img1.onload = checkImages;
      img1.onerror = function() {
        error1 = true;
        checkImages()
      };
      img1.src = imgUrl.replace(/\*/, 1).replace(/\*/, random);

      var img2 = new Image;
      img2.onload = checkImages;
      img2.onerror = function() {
        error2 = true;
        checkImages()
      };
      img2.src = imgUrl.replace(/\*/, 2).replace(/\*/, random);

      beforeCheck(250, callback)
    };

    this.detectWrapper = function(callback) {
      return this.detect('/images/px.gif', callback);
    };
  };

  window.display_dfp_slot = function(key) {
    if (window.habr_blockers_checker) {
      window.habr_blockers_checker.detectWrapper(window.create_callback_for_blocked(key));
    } else {
      window.create_callback_for_blocked(key)();
    }
  };
</script>


<script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/libs/raven.min.js"></script>
<script>Raven.config('https://830576edd4b7478086093f693a5a0df5@s.tmtm.ru/37', {
  maxBreadcrumbs: 50,
  sampleRate: 0.5,
  whitelistUrls: [/https?:\/\/((www)\.)?(m\.)?habr\.com/],
}).install()</script>

<script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/_parts/advertise.js"></script>
<script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/_parts/adriver.js"></script>

<script type="text/javascript">
  $(document).ready(function () {
    if (!$.cookie('split201901')) {
      $.cookie(
        'split201901',
        'B',
        {
          expires: 3 * 7,
          domain: 'habr.com',
          path: '/',
          secure: true
        }
      );
    }
  });
</script>


  </head>

  <body class="nl">

    <div class="layout">
      <div class="layout__row layout__row_services">
        <div id="TMpanel">
  <div class="container">
    <div class="logo-wrapper">
      <a href="https://habr.com/ru/" class="logo" title="">
          <svg width="62" height="24" viewBox="0 0 62 24" xmlns="http://www.w3.org/2000/svg">
    <path d="M16.875 19L11.075 10.225L16.825 1.4H12.6L8.75 7.4L4.94999 1.4H0.574994L6.32499 10.15L0.524994 19H4.79999L8.64999 12.975L12.525 19H16.875Z" />
    <path d="M24.2607 5.775C20.8857 5.775 18.9607 7.625 18.6107 9.85H22.0107C22.2107 9.175 22.8607 8.6 24.1107 8.6C25.3357 8.6 26.2357 9.225 26.2357 10.425V11.025H23.4107C20.1107 11.025 18.1107 12.55 18.1107 15.2C18.1107 17.8 20.1107 19.3 22.6107 19.3C24.2857 19.3 25.6357 18.65 26.4357 17.6V19H29.8107V10.55C29.8107 7.4 27.5857 5.775 24.2607 5.775ZM23.6107 16.475C22.4857 16.475 21.7607 15.925 21.7607 15.025C21.7607 14.1 22.5607 13.55 23.6857 13.55H26.2357V14.125C26.2357 15.625 25.0107 16.475 23.6107 16.475Z" />
    <path d="M39.925 6.3C38.125 6.3 36.65 6.95 35.7 8.275C35.95 5.85 36.925 4.65 39.375 4.275L44.3 3.55V0.375L39.025 1.25C33.925 2.1 32.35 5.5 32.35 11.175C32.35 16.275 34.825 19.3 39.2 19.3C43.125 19.3 45.55 16.3 45.55 12.7C45.55 8.825 43.3 6.3 39.925 6.3ZM39.025 16.25C37.125 16.25 36.075 14.725 36.075 12.675C36.075 10.7 37.175 9.275 39.05 9.275C40.875 9.275 41.9 10.75 41.9 12.7C41.9 14.65 40.9 16.25 39.025 16.25Z" />
    <path d="M55.2855 5.775C53.3855 5.775 52.1605 6.6 51.5105 7.575V6.075H48.0105V23.775H51.6605V17.75C52.3105 18.65 53.5355 19.3 55.1855 19.3C58.3605 19.3 60.8855 16.8 60.8855 12.55C60.8855 8.225 58.3605 5.775 55.2855 5.775ZM54.4105 16.15C52.7105 16.15 51.5855 14.775 51.5855 12.6V12.5C51.5855 10.325 52.7105 8.925 54.4105 8.925C56.1105 8.925 57.2105 10.35 57.2105 12.55C57.2105 14.75 56.1105 16.15 54.4105 16.15Z" />
</svg>

      </a>
      

        <span class="projects-dropdown" id="dropdown-control">
          <svg width="10" height="6" viewBox="0 0 10 6" fill="none" xmlns="http://www.w3.org/2000/svg">
    <path fill-rule="evenodd" clip-rule="evenodd" d="M5.70711 5.70711C5.31658 6.09763 4.68342 6.09763 4.29289 5.70711L0.292892 1.70711C-0.097632 1.31658 -0.0976319 0.683417 0.292892 0.292893C0.683417 -0.0976308 1.31658 -0.0976308 1.70711 0.292893L5 3.58579L8.29289 0.292894C8.68342 -0.0976301 9.31658 -0.0976301 9.70711 0.292894C10.0976 0.683418 10.0976 1.31658 9.70711 1.70711L5.70711 5.70711Z" />
</svg>

        </span>
        <div class="dropdown hidden" id="dropdown">
          <div class="dropdown-heading">
            Все сервисы Хабра
          </div>
          <a class="service" href="/">
            <div class="service-title">
              <svg width="52" height="22" viewBox="0 0 52 22" fill="none" xmlns="http://www.w3.org/2000/svg">
                <path d="M13.86 17.0001L8.514 9.23405L13.816 1.51205H11.528L7.26 7.76005L2.97 1.51205H0.659997L5.984 9.19005L0.615997 17.0001H2.926L7.194 10.6861L11.528 17.0001H13.86Z" fill="#333333"/>
                <path d="M20.181 5.67005C17.651 5.67005 16.111 7.10005 15.759 8.81605H17.585C17.893 8.00205 18.685 7.34205 20.137 7.34205C21.567 7.34205 22.645 8.11205 22.645 9.65205V10.4001H19.697C16.991 10.4001 15.341 11.6981 15.341 13.8321C15.341 15.9441 17.013 17.2421 19.169 17.2421C20.577 17.2421 21.897 16.7141 22.733 15.6801V17.0001H24.515V9.65205C24.515 7.16605 22.777 5.67005 20.181 5.67005ZM19.411 15.5921C18.179 15.5921 17.255 14.9761 17.255 13.8101C17.255 12.6221 18.289 12.0061 19.807 12.0061H22.645V12.8201C22.645 14.5141 21.171 15.5921 19.411 15.5921Z" fill="#333333"/>
                <path d="M32.9685 5.91205C31.2965 5.91205 29.9545 6.55005 29.1185 7.78205C29.3825 5.27405 30.3945 3.88805 32.9025 3.42605L36.9505 2.67805V0.852051L32.5065 1.75405C28.7665 2.52405 27.2045 4.96605 27.2045 10.5101C27.2045 14.8001 29.4045 17.2421 32.7925 17.2421C36.0265 17.2421 38.0505 14.7121 38.0505 11.5441C38.0505 7.91405 35.8285 5.91205 32.9685 5.91205ZM32.7045 15.5261C30.6145 15.5261 29.2065 13.9641 29.2065 11.4561C29.2065 8.97005 30.7685 7.60605 32.7265 7.60605C34.7725 7.60605 36.1145 9.23405 36.1145 11.5441C36.1145 13.8541 34.7945 15.5261 32.7045 15.5261Z" fill="#333333"/>
                <path d="M46.1431 5.67005C44.2291 5.67005 43.0631 6.55005 42.5131 7.49605V5.91205H40.6871V21.2021H42.5791V15.6361C43.1071 16.4501 44.2951 17.2421 46.0771 17.2421C48.6291 17.2421 51.1371 15.3721 51.1371 11.4561C51.1371 7.56205 48.6511 5.67005 46.1431 5.67005ZM45.9011 15.5261C43.8551 15.5261 42.5131 13.9641 42.5131 11.5001V11.4121C42.5131 8.94805 43.8551 7.38605 45.9011 7.38605C47.8811 7.38605 49.2011 9.03605 49.2011 11.4561C49.2011 13.8761 47.8811 15.5261 45.9011 15.5261Z" fill="#333333"/>
              </svg>
            </div>
            <p class="service-description">
              Сообщество IT-специалистов
            </p>
          </a>
          <a class="service" href="https://qna.habr.com?utm_source=habr&utm_medium=habr_top_panel">
            <h4 class="service-title">
            <svg width="46" height="18" viewBox="0 0 46 18" fill="none" xmlns="http://www.w3.org/2000/svg">
              <path d="M14.4 8.25602C14.4 3.65802 11.606 0.27002 7.27201 0.27002C2.93801 0.27002 0.144012 3.65802 0.144012 8.25602C0.144012 12.854 2.93801 16.242 7.27201 16.242C8.41601 16.242 9.45001 16.022 10.352 15.604L11.518 17.342H13.696L11.848 14.614C13.476 13.184 14.4 10.918 14.4 8.25602ZM7.27201 14.416C4.10401 14.416 2.14601 11.864 2.14601 8.25602C2.14601 4.64802 4.10401 2.09602 7.27201 2.09602C10.44 2.09602 12.398 4.64802 12.398 8.25602C12.398 10.236 11.826 11.908 10.77 12.986L9.64801 11.314H7.47001L9.29601 14.02C8.70201 14.284 8.02001 14.416 7.27201 14.416Z" fill="#333333"/>
              <path d="M30.965 16L27.973 12.766L30.921 9.11402H28.699L26.829 11.534L23.331 7.77202C25.377 6.80402 26.455 5.59402 26.455 3.85602C26.455 1.78802 24.871 0.27002 22.583 0.27002C20.207 0.27002 18.535 1.89802 18.535 3.87802C18.535 5.19802 19.305 6.12202 20.163 7.00202L20.427 7.26602C17.985 8.25602 16.753 9.73002 16.753 11.732C16.753 14.196 18.667 16.242 21.835 16.242C23.749 16.242 25.311 15.494 26.565 14.24L26.763 14.042L28.567 16H30.965ZM22.539 1.92002C23.705 1.92002 24.629 2.62402 24.629 3.83402C24.629 5.00002 23.793 5.90202 22.187 6.62802L21.571 6.01202C21.109 5.55002 20.405 4.82402 20.405 3.81202C20.405 2.66802 21.329 1.92002 22.539 1.92002ZM21.945 14.504C19.877 14.504 18.755 13.316 18.755 11.666C18.755 10.258 19.591 9.20202 21.593 8.43202L25.641 12.832L25.509 12.964C24.541 13.976 23.309 14.504 21.945 14.504Z" fill="#333333"/>
              <path d="M43.5619 16H45.6739L39.8219 0.512019H37.7979L31.9459 16H34.0579L35.5539 11.908H42.0439L43.5619 16ZM38.7879 2.97602L41.3839 10.104H36.2139L38.7879 2.97602Z" fill="#333333"/>
            </svg>
            </h4>
            <p class="service-description">
              Ответы на&nbsp;любые вопросы об&nbsp;IT
            </p>
          </a>
          <a class="service" href="https://career.habr.com?utm_source=habr&utm_medium=habr_top_panel">
            <div class="service-title">
            <svg width="84" height="21" viewBox="0 0 84 21" fill="none" xmlns="http://www.w3.org/2000/svg">
              <path d="M12.442 16L4.96201 7.92596L12.31 0.511963H9.78001L2.894 7.41996V0.511963H0.936005V16H2.894V8.60796L9.84601 16H12.442Z" fill="#333333"/>
              <path d="M18.3646 4.66996C15.8346 4.66996 14.2946 6.09996 13.9426 7.81596H15.7686C16.0766 7.00196 16.8686 6.34196 18.3206 6.34196C19.7506 6.34196 20.8286 7.11196 20.8286 8.65196V9.39996H17.8806C15.1746 9.39996 13.5246 10.698 13.5246 12.832C13.5246 14.944 15.1966 16.242 17.3526 16.242C18.7606 16.242 20.0806 15.714 20.9166 14.68V16H22.6986V8.65196C22.6986 6.16596 20.9606 4.66996 18.3646 4.66996ZM17.5946 14.592C16.3626 14.592 15.4386 13.976 15.4386 12.81C15.4386 11.622 16.4726 11.006 17.9906 11.006H20.8286V11.82C20.8286 13.514 19.3546 14.592 17.5946 14.592Z" fill="#333333"/>
              <path d="M31.3501 4.66996C29.4361 4.66996 28.2701 5.54996 27.7201 6.49596V4.91196H25.8941V20.202H27.7861V14.636C28.3141 15.45 29.5021 16.242 31.2841 16.242C33.8361 16.242 36.3441 14.372 36.3441 10.456C36.3441 6.56196 33.8581 4.66996 31.3501 4.66996ZM31.1081 14.526C29.0621 14.526 27.7201 12.964 27.7201 10.5V10.412C27.7201 7.94796 29.0621 6.38596 31.1081 6.38596C33.0881 6.38596 34.4081 8.03596 34.4081 10.456C34.4081 12.876 33.0881 14.526 31.1081 14.526Z" fill="#333333"/>
              <path d="M43.3561 8.49796H40.8701V4.91196H38.9781V16H43.3341C45.7101 16 47.2501 14.372 47.2501 12.216C47.2501 10.06 45.7101 8.49796 43.3561 8.49796ZM43.1141 14.328H40.8701V10.17H43.1141C44.5661 10.17 45.3581 11.028 45.3581 12.216C45.3581 13.404 44.5661 14.328 43.1141 14.328Z" fill="#333333"/>
              <path d="M59.1788 11.028V10.06C59.1788 6.75996 57.2868 4.66996 54.3388 4.66996C51.3028 4.66996 49.1248 6.86996 49.1248 10.456C49.1248 14.02 51.2808 16.242 54.4928 16.242C57.3748 16.242 58.7608 14.438 59.0468 13.14H57.1328C56.9348 13.712 56.0548 14.548 54.5148 14.548C52.4688 14.548 51.1048 13.052 51.1048 11.072V11.028H59.1788ZM54.2948 6.36396C56.0768 6.36396 57.1768 7.50796 57.2648 9.42196H51.1268C51.2808 7.59596 52.4468 6.36396 54.2948 6.36396Z" fill="#333333"/>
              <path d="M67.272 4.66996C65.358 4.66996 64.192 5.54996 63.642 6.49596V4.91196H61.816V20.202H63.708V14.636C64.236 15.45 65.424 16.242 67.206 16.242C69.758 16.242 72.266 14.372 72.266 10.456C72.266 6.56196 69.78 4.66996 67.272 4.66996ZM67.03 14.526C64.984 14.526 63.642 12.964 63.642 10.5V10.412C63.642 7.94796 64.984 6.38596 67.03 6.38596C69.01 6.38596 70.33 8.03596 70.33 10.456C70.33 12.876 69.01 14.526 67.03 14.526Z" fill="#333333"/>
              <path d="M79.058 4.66996C76.528 4.66996 74.988 6.09996 74.636 7.81596H76.462C76.77 7.00196 77.562 6.34196 79.014 6.34196C80.444 6.34196 81.522 7.11196 81.522 8.65196V9.39996H78.574C75.868 9.39996 74.218 10.698 74.218 12.832C74.218 14.944 75.89 16.242 78.046 16.242C79.454 16.242 80.774 15.714 81.61 14.68V16H83.392V8.65196C83.392 6.16596 81.654 4.66996 79.058 4.66996ZM78.288 14.592C77.056 14.592 76.132 13.976 76.132 12.81C76.132 11.622 77.166 11.006 78.684 11.006H81.522V11.82C81.522 13.514 80.048 14.592 78.288 14.592Z" fill="#333333"/>
            </svg>
            </div>
            <p class="service-description">
              Профессиональное развитие в&nbsp;IT
            </p>
          </a>
          <a class="service" href="https://freelance.habr.com?utm_source=habr&utm_medium=habr_top_panel">
            <div class="service-title">
            <svg width="91" height="21" viewBox="0 0 91 21" fill="none" xmlns="http://www.w3.org/2000/svg">
              <path d="M9.032 1.65602V0.0720215H7.118V1.65602C3.268 1.72202 0.0339966 4.01002 0.0339966 8.16802C0.0339966 12.304 3.268 14.592 7.118 14.658V16.242H9.032V14.658C12.882 14.592 16.116 12.304 16.116 8.16802C16.116 4.01002 12.882 1.72202 9.032 1.65602ZM7.118 12.898C4.082 12.832 2.014 11.05 2.014 8.16802C2.014 5.26402 4.082 3.48202 7.118 3.41602V12.898ZM9.032 12.898V3.41602C12.068 3.48202 14.136 5.26402 14.136 8.16802C14.136 11.05 12.068 12.832 9.032 12.898Z" fill="#333333"/>
              <path d="M24.2603 4.67002C22.3463 4.67002 21.1803 5.55002 20.6303 6.49602V4.91202H18.8043V20.202H20.6963V14.636C21.2243 15.45 22.4123 16.242 24.1943 16.242C26.7463 16.242 29.2543 14.372 29.2543 10.456C29.2543 6.56202 26.7683 4.67002 24.2603 4.67002ZM24.0183 14.526C21.9723 14.526 20.6303 12.964 20.6303 10.5V10.412C20.6303 7.94802 21.9723 6.38602 24.0183 6.38602C25.9983 6.38602 27.3183 8.03602 27.3183 10.456C27.3183 12.876 25.9983 14.526 24.0183 14.526Z" fill="#333333"/>
              <path d="M39.4123 4.91202L33.7583 13.074V4.91202H31.8883V16H33.7583L39.4123 7.83802V16H41.2823V4.91202H39.4123Z" fill="#333333"/>
              <path d="M46.0815 4.91202L45.5095 11.71C45.3555 13.624 44.9595 14.328 43.5735 14.328H43.2655V16.044H43.7935C46.0595 16.044 47.0935 14.856 47.3355 11.842L47.7755 6.60602H51.8455V16H53.7375V4.91202H46.0815Z" fill="#333333"/>
              <path d="M61.2045 4.67002C58.6745 4.67002 57.1345 6.10002 56.7825 7.81602H58.6085C58.9165 7.00202 59.7085 6.34202 61.1605 6.34202C62.5905 6.34202 63.6685 7.11202 63.6685 8.65202V9.40002H60.7205C58.0145 9.40002 56.3645 10.698 56.3645 12.832C56.3645 14.944 58.0365 16.242 60.1925 16.242C61.6005 16.242 62.9205 15.714 63.7565 14.68V16H65.5385V8.65202C65.5385 6.16602 63.8005 4.67002 61.2045 4.67002ZM60.4345 14.592C59.2025 14.592 58.2785 13.976 58.2785 12.81C58.2785 11.622 59.3125 11.006 60.8305 11.006H63.6685V11.82C63.6685 13.514 62.1945 14.592 60.4345 14.592Z" fill="#333333"/>
              <path d="M76.104 4.91202V9.37802H70.626V4.91202H68.734V16H70.626V11.094H76.104V16H77.996V4.91202H76.104Z" fill="#333333"/>
              <path d="M85.9003 14.526C83.8983 14.526 82.5783 12.876 82.5783 10.456C82.5783 8.05802 83.8543 6.38602 85.8783 6.38602C87.6383 6.38602 88.4523 7.53002 88.7383 8.45402H90.6303C90.3443 6.69402 88.8263 4.67002 85.8783 4.67002C82.6883 4.67002 80.6423 7.13402 80.6423 10.456C80.6423 13.844 82.7323 16.242 85.8783 16.242C88.6283 16.242 90.3883 14.394 90.6303 12.414H88.7383C88.4963 13.36 87.7483 14.526 85.9003 14.526Z" fill="#333333"/>
            </svg>
            </div>
            <p class="service-description">
              Удаленная работа для IT-специалистов
            </p>
          </a>
        </div>
    </div>
    <div class="bmenu">
      <a
        class="bmenu__conversion"
        href="https://habr.com/sandbox/start/"
        onclick="if (typeof ga === 'function') { ga('send', 'event', 'habr_top_panel', 'become_an_author'); }"
      >Как стать автором</a>

    </div>

      <div class="bmenu_inner" style="display:flex!important;visibility:visible!important;">
  <span class="bmenu slink">
    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'habr_top_panel', 'megapost', 'https://u.habr.com/mkbmsb'); }" href="https://u.habr.com/mkbmsb" target="_blank" style="color: #F3FFB5" rel=" noopener">Изобретаем колесо для качественно новой архитектуры</a>
  </span>
</div>

  </div>
</div>

<script>
  var dropdown = document.querySelector('#dropdown');
  var dropdownControl = document.querySelector('#dropdown-control');
  var logoWrapper = document.querySelector('.logo-wrapper');

  document.addEventListener('click', function(e) {
      if (dropdown) {
        var isClickInside = logoWrapper.contains(e.target);
        var dropdownClosed = dropdown.classList.contains('hidden');
        if (!isClickInside && !dropdownClosed) {
          dropdown.classList.add('hidden');
          dropdownControl.classList.remove('reverted');
        }
      }
  });
  if (dropdownControl) {
    dropdownControl.onclick = function () {
      dropdown.classList.toggle('hidden');
      dropdownControl.classList.toggle('reverted');
    }
  }
</script>

      </div>

      <div class="layout__row layout__row_navbar">
        <div class="layout__cell">
          <div class="main-navbar">
  <div class="main-navbar__section main-navbar__section_left">
    <ul class="nav-links" id="navbar-links">
    <li class="nav-links__item">
      <a href="https://habr.com/ru/top/" class="nav-links__item-link ">Все потоки</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/develop/" class="nav-links__item-link ">Разработка</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/admin/" class="nav-links__item-link ">Администрирование</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/design/" class="nav-links__item-link ">Дизайн</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/management/" class="nav-links__item-link ">Менеджмент</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/marketing/" class="nav-links__item-link ">Маркетинг</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/popsci/" class="nav-links__item-link ">Научпоп</a>
    </li>
</ul>

    <form action="https://habr.com/ru/search/#h" method="get" class="search-form" id="search-form">
  <button type="button" class="btn btn_navbar_search icon-svg_search" id="search-form-btn" title="Поиск по сайту">
    <svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M17 11C17 14.3137 14.3137 17 11 17C7.68629 17 5 14.3137 5 11C5 7.68629 7.68629 5 11 5C14.3137 5 17 7.68629 17 11ZM15.5838 17.5574C14.2857 18.4665 12.7051 19 11 19C6.58172 19 3 15.4183 3 11C3 6.58172 6.58172 3 11 3C15.4183 3 19 6.58172 19 11C19 12.9998 18.2662 14.8282 17.0533 16.2307C17.0767 16.2502 17.0994 16.2709 17.1214 16.2929L20.4143 19.5858C20.8048 19.9763 20.8048 20.6095 20.4143 21C20.0238 21.3905 19.3906 21.3905 19.0001 21L15.7072 17.7071C15.6605 17.6604 15.6194 17.6102 15.5838 17.5574Z" />
</svg>

  </button>
  <label class="search-form__field-wrapper">
    <input type="text" name="q" class="search-form__field" id="search-form-field" placeholder="Поиск" tabindex="-1"/>
    <button type="button" class="btn btn_search-close" id="search-form-clear" title="Закрыть">
      <svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>

    </button>
  </label>
</form>

  </div>

  <div class="main-navbar__section main-navbar__section_right">
      <button type="button" class="btn btn_medium btn_navbar_lang js-show_lang_settings">
        <svg class="icon-svg" width="18" height="18">
          <use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#globus-v2" />
        </svg>
      </button>
      <a href="https://habr.com/ru/auth/login/" id="login" class="btn btn_medium btn_navbar_login">Войти</a>
      <a href="https://habr.com/ru/auth/register/" class="btn btn_medium btn_navbar_registration">Регистрация</a>


  </div>
</div>

        </div>
      </div>

      <div class="layout__row layout__row_body">
        <div class="layout__cell layout__cell_body">
          
            
  
  
  
      <div class="page-header__banner">
      <a href="https://ruvds.com/ru-rub" target="_blank"><img src="//habrastorage.org/getpro/habr/branding/b77/8d5/a41/b778d5a41f83016379c6630262c3294c.png" alt="company_banner"/></a>
  </div>

  <div class="page-header_bordered page-header_tall">
    <div class="page-header page-header_full" id="company_3593">
  <div class="page-header_wrapper">
    <div class="media-obj media-obj_page-header">
        <a href="/company/ruvds/" class="media-obj__image page-header__image">
            <img src="//habrastorage.org/getpro/habr/company/ffa/3df/965/ffa3df965d0a214a40ca505b87d0a69e.png" width="48" height="48" class="company-info__image-pic"/>
        </a>

      <div class="media-obj__body media-obj__body_page-header">
        <div class="page-header__stats">
          <div class="page-header__stats-value">2 258,08</div>
          <div class="page-header__stats-label" title="Хабраиндекс - абстрактный показатель популярности компании на Хабре">Рейтинг</div>
        </div>
      </div>
    </div>

  </div>

  <div class="page-header__info">
      <a href="/company/ruvds/" class="page-header__info-title">RUVDS.com</a>
      <div class="page-header__info-desc">VDS/VPS-хостинг. Скидка 10% по коду <b>HABR</b></div>
  </div>
</div>

  </div>
  <div class="column-wrapper js-sticky-wrapper">
    <div class="content_left js-content_left">
      <div class="company_post">
        
    <article class="post post_full" id="post_536962" lang="ru">
  <div class="post__wrapper">
    <header class="post__meta">
        <a href="https://habr.com/ru/users/ru_vds/" class="post__user-info user-info" title="Автор публикации">
            <img src="//habrastorage.org/getpro/habr/avatars/e36/812/d3d/e36812d3de38eb3d479d7a13228717ef.png" width="24" height="24" class="user-info__image-pic user-info__image-pic_small">
          <span class="user-info__nickname user-info__nickname_small">ru_vds</span>
        </a>

      <span class="post__time" data-time_published="2021-01-16T13:10Z">вчера в 16:10</span>

      
    </header>

    <h1 class="post__title post__title_full">
      <span class="post__title-text">8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода</span>
    </h1>

      <div class="post__translatation">
        <a href="https://towardsdatascience.com/8-free-tools-to-make-interactive-data-visualizations-in-2021-no-coding-required-2b2c6c564b5b" class="post__translatation-link" title="Автор оригинала: Frank Andrade" target="_blank">Автор оригинала: Frank Andrade</a>
      </div>

      <ul class="post__hubs post__hubs_full-post inline-list">
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/company/ruvds/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Блог компании RUVDS.com'); }">Блог компании RUVDS.com</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/webdev/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Разработка веб-сайтов'); }">Разработка веб-сайтов</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/db_admins/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Администрирование баз данных'); }">Администрирование баз данных</a>
          </li>
      </ul>

    <ul class="post__marks inline-list"><li class="inline-list__item inline-list__item_post-type"><span class="post__type-label" title="Перевод">Перевод</span></li></ul>

    <div class="post__body post__body_full">
      <div class="post__text post__text-html post__text_v1" id="post-content-body">Когда тот, кто работает в сфере Data Science, собирается показать результаты своей деятельности другим людям, оказывается, что таблиц и отчётов, полных текстов, недостаточно для того чтобы представить всё наглядно и понятно. Именно в таких ситуациях возникает нужда в визуализации данных, в такой их обработке, которая позволит всем желающим в них разобраться и ухватить суть тех сложных процессов, которые они описывают.<br/>
<br/>
В этом материале я расскажу о лучших бесплатных инструментах, позволяющих без особых сложностей создавать впечатляющие визуальные представления данных. При этом тут я не буду говорить о сложных системах вроде Power BI и Google Studio. Я выбрал те 8 инструментов, о которых пойдёт речь, из-за того, что ими легко пользоваться, из-за их приятного внешнего вида, из-за того, что работать с ними можно, не написав ни единой строчки программного кода и из-за того, что они бесплатны. Кроме того, они позволяют создавать интерактивные визуализации. А это значит, что графики, представляющие некие данные, могут содержать в себе больше сведений об этих данных, чем обычные изображения. Да и работать с такими графиками интереснее.<br/>
<br/>
<a href="https://habr.com/ru/company/ruvds/blog/536962/"><img src="https://habrastorage.org/webt/vu/-j/4r/vu-j4r9hwgqc3gnjljjv2xe8lsa.jpeg"/></a><br/>
<br/>
Так как инструменты для визуализации данных то появляются, то исчезают, я включил в этот материал только те из них, которые, вероятнее всего, ещё долго будут пребывать в добром здравии. А это значит, что вполне разумным шагом будет вложение некоторого времени в их изучение. Как уже было сказано, пользоваться этими инструментам можно без написания кода. Но если вас интересует визуализация данных именно через код — взгляните на <a href="https://towardsdatascience.com/avatar-meets-data-visualization-60631f86ba7d">этот</a> материал.<br/>
<a name="habracut"></a><br/>
<h2><font color="#3AC1EF">1. Flourish</font></h2><br/>
<a href="https://flourish.studio">Flourish</a> позволяет создавать привлекательные диаграммы, карты и интерактивные истории. Это — простой и понятный инструмент, который включает в себя библиотеку шаблонов и поддерживает различные возможности визуализации данных.<br/>
<br/>
Кому стоит присмотреться к Flourish? Любому, кого интересует составление историй на основе данных (data storytelling). В этом ему поможет множество возможностей системы, касающихся визуализации данных и анимации.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Помимо обычных диаграмм и карт система позволяет создавать и многое другое. Например, это так называемые Bar Chart Race — диаграммы, демонстрирующие процесс изменения неких показателей. Это викторины, содержащие вопросы с вариантами ответа. Это материалы, оформленные в виде «карусели».</li>
<li>Система отлично подходит для составления историй на основе данных. В частности, можно создавать впечатляющие «прокручиваемые» истории без необходимости писать код.</li>
<li>В распоряжении пользователя имеется множество настроек.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Данные и проекты являются общедоступными, их нельзя скрыть.</li>
<li>В бесплатной версии нельзя подключить визуализацию к CSV-файлу, меняющемуся в режиме реального времени, или к файлу системы Google Таблицы.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
На <a href="https://app.flourish.studio/@flourish/bar-chart-race">этой</a> странице можно найти интерактивную Bar Race-диаграмму, демонстрирующую изменение численности населения в различных странах между 1960 и 2016 годами.<br/>
<br/>
<div style="text-align:center;"><img src="https://lh5.googleusercontent.com/8OihthfU5sKCZ3FY6Tr4vV8Ms7nvb1poLdhXmU4SgG4AhbVVOPzaiVIj3LdxD3V92cQtiDQOXLZDQKfHWNWlwUS7eXDqVTh5fVU3E9BTUdzr3dtBWbUBXv_EOjJ55OT3oxoDBjY" /></div><br/>
<i><font color="#999999">Сведения о численности населения разных стран</font></i><br/>
<br/>
<h2><font color="#3AC1EF">2. Datawrapper</font></h2><br/>
<a href="https://www.datawrapper.de">Datawrapper</a> — это инструмент, который позволяет создавать интерактивные диаграммы, карты и таблицы. При этом для его эффективного использования не нужно обладать знаниями в области дизайна. Разработчики этого инструмента учли множество правил дизайна, которыми имеет смысл следовать при визуализации данных. Кроме этого надо отметить, что всё то, что создаётся с помощью Datawrapper, подходит для просмотра на любых устройствах.<br/>
<br/>
Кому стоит обратить внимание на этот инструмент? Он рассчитан, преимущественно, на творческих людей — на писателей, блогеров, журналистов. В целом можно сказать, что он направлен на создание интерактивных изображений, дополняющих какие-либо текстовые материалы.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Поддерживается подключение изменяющихся CSV-файлов и файлов из системы Google Таблицы.</li>
<li>Бесплатный тарифный план позволяет создавать и публиковать неограниченное количество диаграмм, карт и таблиц.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Бесплатная версия позволяет экспортировать диаграммы только в PNG-файлы.</li>
<li>Тому, кто решит перейти на платную версию системы, придётся заплатить 499 евро за месяц подписки.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
<a href="https://www.datawrapper.de/_/hWPS6/">Вот</a> диаграмма разброса данных, созданная для оценки языковых особенностей сериалов Netflix.<br/>
<br/>
<div style="text-align:center;"><img src="https://lh3.googleusercontent.com/eMLcb6-QoLNCWaY8BiK-kzQ-NWkxV4ztU-LExEUsLa-gPhBiZ4WkgACLV7CtlwZXtGXE3HucFJcc4yuiDCbc4GMS0h5TV__oA981baXNYjH-_RiQM5o5klNegC_YzpQ4CZXke6Q" /></div><br/>
<i><font color="#999999">Анализ языковых особенностей сериалов Netflix</font></i><br/>
<br/>
<h2><font color="#3AC1EF">3. ChartBlocks</font></h2><br/>
<a href="https://www.chartblocks.com/ru/">ChartBlocks</a> является частью Ceros — облачной дизайн-платформы, которая позволяет всем желающим, будь то специалисты по маркетингу или дизайнеры, создавать интересные материалы, привлекающие внимание пользователей. Писать код при работе с этой платформой не требуется.<br/>
<br/>
ChartBlocks позволяет очень быстро создавать отлично выглядящие диаграммы. Среди типов диаграмм, доступных в этой системе можно отметить столбчатые, линейные, круговые, точечные диаграммы. Для того чтобы приступить к работе с системой достаточно создать учётную запись.<br/>
<br/>
Кому подойдёт ChartBlocks? Любому, кого интересует создание простых визуализаций данных за короткое время.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Процесс создания диаграмм в ChartBlocks отличается крайней простотой и понятностью. Это — один из самых простых среди существующих инструментов такого рода.</li>
<li>Доступ посторонних к диаграммам можно ограничивать даже в бесплатной версии проекта.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Система не позволяет иметь более 50 активных диаграмм.</li>
<li>Поддерживается лишь до 50000 просмотров в месяц.</li>
<li>Загружать в систему данные можно только в форматах CSV и Microsoft Excel. Максимальный размер файла — 50 Мб.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
Вот пример столбчатой диаграммы, на которой показано число строк, приходящихся на главных героев «Игры престолов» в 7 сезонах. На создание этой диаграммы ушло всего несколько минут.<br/>
<br/>
<div style="text-align:center;"><img src="https://lh6.googleusercontent.com/GPOVV_6Lmq4FGKGA2svG7iDDRY6eCTKou91wNnjPR6754GAa96I8zXfk7ma8PadZB8vOW2hClkbN_S5iQUQ1XdgYAsMgTE2rcv7CTqczVpyCSH6nMIrgLjQUD8pXKjuKZ91I_08" /></div><br/>
<i><font color="#999999">Столбчатая диаграмма, созданная с помощью ChartBlocks</font></i><br/>
<br/>
<h2><font color="#3AC1EF">4. Infogram</font></h2><br/>
<a href="https://infogram.com">Infogram</a> — это инструмент для визуализации данных, который помогает создавать привлекательные материалы. Помимо поддержки системой обычных диаграмм — столбчатых, линейных, круговых, она позволяет создавать инфографику и отчёты.<br/>
<br/>
Кому стоит присмотреться к Infogram? Тем, кого интересует создание различных информационных материалов, а не только обычных диаграмм.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Infogram, в отличие от других инструментов, поддерживает анимации, позволяющие изменять масштаб объектов, организовывать их перемещение, отражение, появление и исчезновение, прокрутку.</li>
<li>В визуализации можно добавлять собственные элементы, изображения и фигуры.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>В бесплатной версии можно создать не более 10 проектов, в каждом из которых может содержаться до 5 страниц.</li>
<li>Infogram поддерживает более 550 типов карт. Но в бесплатной версии доступно лишь 13 типов.</li>
<li>В бесплатной версии нельзя создавать проекты, закрытые от посторонних.</li>
<li>Нельзя организовывать подключение к источникам данных и работать с данными, изменяющимися в режиме реального времени.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
<a href="https://infogram.com/world-map-1hnp27mmqwl9y2g">Вот</a> пример использования одного из типов карт, доступных бесплатно. На такую карту можно добавить любые элементы и анимации.<br/>
<br/>
<div style="text-align:center;"><img src="https://lh6.googleusercontent.com/hq0YGcIJfvtqb6H6nfUAbe6SR2aPlTFTDC-qW4AGC2m3-lbEcoOViS-Gv0htfO4MgaGJC4ZVifycfSeOKExdyjE0NYtzR0jRMla1x5_IrApcF98871Jlv-vRrFyA8U8veFSyYp8" /></div><br/>
<i><font color="#999999">Карта, созданная средствами Infogram</font></i><br/>
<br/>
<h2><font color="#3AC1EF">5. Chart Studio</font></h2><br/>
<a href="https://plotly.com/chart-studio/">Chart Studio</a> — это проект Plotly, представляющий собой онлайн-инструмент для создания диаграмм. Фактически это — редактор для создания диаграмм, основанных на D3.js и WebGL.<br/>
<br/>
Кому подойдёт Chart Studio? На сайте проекта сказано, что Chart Studio — это инструмент, предназначенный для всех, кто работает с диаграммами. Это, например, дата-сайентисты, Dash-разработчики, люди, создающие отчёты и презентации, журналисты.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Тот, кто умеет программировать, может воспользоваться API Chart Studio, доступный для Python, R, Julia и MATLAB.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Количество просмотров общедоступных диаграмм ограничено 1000 в день.</li>
<li>Система поддерживает загрузку данных с использованием более чем 20 типов файлов, подключение к SQL-хранилищам с использованием Falcon — бесплатного SQL-клиента Plotly. Но в бесплатной версии данные можно загружать только в виде файлов Microsoft Excel и CSV-файлов.</li>
<li>Материалы можно экспортировать только в форматах PNG и JPEG.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
Вот диаграмма разброса данных, построенная для анализа воздействия количества сказанных слов в каждом эпизоде сериала «Аватар» на рейтинги IMDB.<br/>
<br/>
<div style="text-align:center;"><img src="https://miro.medium.com/max/700/1*nVYOFyEC7085qeRAnl_B2A.gif" /></div><br/>
<i><font color="#999999">Диаграмма, созданная с помощью Chart Studio</font></i><br/>
<br/>
<h2><font color="#3AC1EF">6. Knight Lab</font></h2><br/>
<a href="https://knightlab.northwestern.edu/projects/">Knight Lab</a> — это опенсорсные, нетребовательные к ресурсам инструменты, поддающиеся глубокой настройке и предназначенные для тех, кто занимается составлением историй на основе данных. Эти инструменты визуализации данных отличаются от других аналогичных проектов. Истории, основанные на данных, можно «рассказывать» с использованием Storyline, с использованием карт (Storymap) и временных рядов (Timeline).<br/>
<br/>
Кому стоит взглянуть на Knight Lab? Проект нацелен, преимущественно, на журналистов, но он будет интересен всем, кто занимается созданием интерактивных историй на основе данных.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Для создания историй разных видов нужны лишь данные, хранящиеся в системе Google Таблицы.</li>
<li>Тот, кто умеет программировать, может воспользоваться возможностями по динамическому созданию или обновлению материалов с использованием формата JSON.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Knight Lab, в отличие от других инструментов для визуализации данных, не предлагает своим пользователей возможностей по созданию традиционных диаграмм и таблиц.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
Вот результат применения одного из бесплатных шаблонов, имеющихся в системе.<br/>
<br/>
<div style="text-align:center;"><img src="https://lh4.googleusercontent.com/zCX4hdGn-X7TURiyYKObcSCkBTJDkHjhTWhDYCO_BmRWTTivwzoud_fPZ_WdBQO1_v9K9GIxa1bQZhZ2RwN8vaCXBsAo_R6AZHFgDMBEyy20JcSZOiU2nUSsecSo1SJLSk8EiCE" /></div><br/>
<i><font color="#999999">Результат использования Knight Lab</font></i><br/>
<br/>
<h2><font color="#3AC1EF">7. Tableau Public</font></h2><br/>
<a href="https://public.tableau.com/en-us/s/">Tableau Public</a> — это один из самых популярных инструментов, но если вы о нём не слышали — знайте, что это — бесплатная платформа, которая позволяет создавать визуализации, делиться ими с другими людьми, исследовать данные. С помощью этой платформы можно легко и быстро создавать интерактивные диаграммы, карты, информационные панели.<br/>
<br/>
Кому будет интересен этот инструмент? Всем, кто работает с данными и хочет создавать их качественные интерактивные визуальные представления.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Все визуализации, созданные с помощью Tableau Public, могут бесплатно просматривать миллионы пользователей.</li>
<li>Существует много учебных руководство по Tableau.</li>
<li>Система поддерживает обширные возможности по настройке диаграмм.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Визуализации, опубликованные на Tableau Public, доступны абсолютно всем. Это платформа, которая ориентирована на работу с общедоступными данными.</li>
<li>Импортировать данные в систему можно из CSV-файлов, из файлов Microsoft Excel и из системы Google Таблицы. А вот, например, подключение к базе данных бесплатная версия платформы не поддерживает.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
<a href="https://public.tableau.com/views/TableauPublicExplorer/TableauPublicExplorer?%3Alanguage=en&amp;%3Adisplay_count=y&amp;%3Aorigin=viz_share_link">Вот</a> схема, демонстрирующая сведения о тех, кто создаёт визуализации с помощью Tableau Public.<br/>
<br/>
<div style="text-align:center;"><img src="https://miro.medium.com/max/1000/1*rEnj4Pe87dXsm3wGYrRHsA.gif" /></div><br/>
<i><font color="#999999">Результаты использования Tableau Public</font></i><br/>
<br/>
<h2><font color="#3AC1EF">8. RAWGraphs</font></h2><br/>
Платформа <a href="https://rawgraphs.io">RAWGraphs</a> находится последней в нашем списке, но это не значит, что она хуже других. С её помощью, правда, нельзя создавать интерактивные визуализации, но это не значит, что она недостойна внимания. Цель RAWGraphs заключается в том, чтобы организовать связь между приложениями для работы с электронными таблицами, вроде Microsoft Excel, и векторными графическими редакторами наподобие Adobe Illustrator, Inkscape и Sketch.<br/>
<br/>
<h3><font color="#3AC1EF">Сильные стороны бесплатной версии</font></h3><br/>
<ul>
<li>Диаграммы в RAWGraphs очень просто создавать, для работы с системой не нужно даже регистрировать учётную запись.</li>
<li>Система поддерживает различные форматы входных данных — TSV, CSV, DSV, JSON и Excel-файлы(.xls, .xlsx).</li>
<li>По сведениям RAWGraphs обработка данных производится исключительно средствами браузера. Платформа не занимается серверной обработкой или хранением данных. Никто из тех, кто не имеет отношения к данным, не сможет их просматривать, модифицировать или копировать.</li>
<li>RAWGraphs — это система, поддающаяся расширению. Например, добавлять в неё новые диаграммы можно, обладая базовыми знаниями D3.js.</li>
</ul><br/>
<h3><font color="#3AC1EF">Слабые стороны бесплатной версии</font></h3><br/>
<ul>
<li>Диаграммы, создаваемые в RAWGraphs, иногда выглядят слишком простыми. У пользователей системы есть не особенно много механизмов для подстройки их под свои нужды.</li>
<li>Визуализации данных не являются интерактивными.</li>
</ul><br/>
<h3><font color="#3AC1EF">Пример</font></h3><br/>
Вот пример визуализации данных, где в виде иерархической структуры представлено количество жителей некоторых городов.<br/>
<br/>
<div style="text-align:center;"><img src="https://lh6.googleusercontent.com/uRIZXdJXD4LH7FjhcAm61yy8RyXMqrLYe6IJIa_jAQvbyjxbwiZIjcMFd0fzvDfFOUBq7moCxBmLzWhDOKgzVd2d6HCoHhQF7zaaWJlbR96u9kb8Z7XK31Ocuhla-pS_svHEhrQ" /></div><br/>
<i><font color="#999999">Результат визуализации данных с использованием RAWGraph</font></i><br/>
<br/>
<h2><font color="#3AC1EF">Итоги</font></h2><br/>
Не существует идеального инструмента для визуализации данных. Именно поэтому полезно освоить 2-3 таких инструмента, дополняющих друг друга, и пользоваться их наиболее удачными возможностями.<br/>
<br/>
Вы ознакомились с 8 новыми инструментами для создания интерактивных визуализаций, не требующих навыков программирования. После того, как вы научитесь работать с некоторыми из них, я рекомендую найти библиотеки для визуализации данных, созданные для используемого вами языка. Это даст вам больше возможностей по настройке визуализаций под ваши нужды.<br/>
<br/>
Если вы, например, пишете на Python — взгляните на <a href="https://towardsdatascience.com/avatar-meets-data-visualization-60631f86ba7d">этот</a> материал. В нём речь идёт о работе с Plotly, Seaborn и Matplotlib.<br/>
<br/>
Какими инструментами для визуализации данных вы пользуетесь?<br/>
<br/>
<a href="http://ruvds.com/ru-rub?utm_source=habr&amp;utm_medium=perevod&amp;utm_campaign=ruvds&amp;utm_content=oldnewyeartree#order"><img src="https://habrastorage.org/webt/ou/g5/kh/oug5kh6sjydt9llengsiebnp40w.png"/></a></div>
      
    </div>

    

    <dl class="post__tags">
      <dt class="post__tags-label">Теги:</dt>
      <dd class="post__tags-list">    <ul class="inline-list inline-list_fav-tags js-post-tags">
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5BData%20Science%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">Data Science</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5B%D0%B2%D0%B8%D0%B7%D1%83%D0%B0%D0%BB%D0%B8%D0%B7%D0%B0%D1%86%D0%B8%D1%8F%20%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">визуализация данных</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5B%D1%80%D0%B0%D0%B7%D1%80%D0%B0%D0%B1%D0%BE%D1%82%D0%BA%D0%B0%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">разработка</a></li>
    </ul>
    <button type="button" class="btn btn_outline_grey btn_mini hidden js-fav-edit-link" data-type="2" data-id="536962" onclick="show_edit_tags(this)">Добавить метки</button>
</dd>
    </dl>
      <dl class="post__tags">
        <dt class="post__tags-label">Хабы:</dt>
        <dd class="post__tags-list">
          <ul class="inline-list inline-list_fav-tags js-post-hubs">
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/company/ruvds/" rel="tag" class="inline-list__item-link post__tag">
                  Блог компании RUVDS.com
                </a>
              </li>
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/webdev/" rel="tag" class="inline-list__item-link post__tag">
                  Разработка веб-сайтов
                </a>
              </li>
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/db_admins/" rel="tag" class="inline-list__item-link post__tag">
                  Администрирование баз данных
                </a>
              </li>
          </ul>
        </dd>
      </dl>
  </div>
    <div class="overlay hidden" id="js-vote-reason">
  <div class="popup popup_reasons">
    <div class="popup__head popup__head_lang-settings">
      <span class="popup__head-title">Укажите причину минуса, чтобы автор поработал над ошибками</span>
      <button type="button" class="btn btn_small btn_popup-close js-hide_vote-reason">
        <svg class="icon-svg" width="12" height="12">
          <use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#close" />
        </svg>
      </button>
    </div>
    <div class="popup__body">
       <span class="radio radio_custom reasons-vote__item js-vote-popup_list-item">
          <input type="radio" id="reasonList" name="reasonList" class="radio__input js-vote_radio" value="">
          <label for="reasonList" class="radio__label radio__label_another js-vote_title"></label>
        </span>
      <div id="js-vote-popup_list"></div>
      <button type="button" class="btn btn_blue btn_huge js-vote_send" disabled>Отправить анонимно</button>
    </div>
  </div>
</div>

</article>


        <form action="/json/favorites/" method="post" class="form form_bordered form_favorites-tags hidden" id="edit_tags_form">
  <input type="hidden" name="action" value="add" />
  <input type="hidden" name="ti" value="0" />
  <input type="hidden" name="tt" value="0" />

  <button type="button" class="btn form__close-btn" onclick="closeForm(this)" title="Закрыть"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

  <fieldset class="form__fieldset">
    <legend class="form__legend">Пометьте публикацию своими метками</legend>
    <input type="text" name="tags_string" class="form__text-field" />
    <span class="form__desc">Метки лучше разделять запятой. Например: <i>программирование, алгоритмы</i></span>
  </fieldset>

  <div class="form__footer">
    <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Сохранить</button>
  </div>
</form>

        <div class="post-additionals post-additionals_company">
            <ul class="post-stats post-stats_post js-user_" data-post-type="publish_corp_ru,c_ruvds,h_91,h_17681" id="infopanel_post_536962">
          <li class="post-stats__item post-stats__item_voting-wjt">
            <div class="voting-wjt voting-wjt_post js-post-vote" data-id="536962" data-type="2">
              <button type="button" class="btn voting-wjt__button " data-action="plus" onclick="posts_vote_plus(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

              <span class="voting-wjt__counter  voting-wjt__counter_positive  js-score" onclick="posts_vote_result(17, 16, 1)" title="Всего голосов 17: &uarr;16 и &darr;1">+15</span>

              <button type="button" class="btn voting-wjt__button " data-action="minus" title="Голосовать могут только зарегистрированные пользователи" onclick="posts_vote_minus(this);" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
            </div>
          </li>
    <li class="post-stats__item post-stats__item_bookmark">
      <button type="button" class="btn bookmark-btn bookmark-btn_post " data-post-type="publish_corp_ru,c_ruvds,h_91,h_17681" data-type="2" data-id="536962" data-action="add" title="Только зарегистрированные пользователи могут добавлять публикации в закладки" onclick="posts_add_to_favorite(this);" disabled>
        <span class="btn_inner"><svg class="icon-svg_bookmark" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="bookmark__counter js-favs_count" title="Количество пользователей, добавивших публикацию в закладки">118</span></span>
      </button>
    </li>

    <li class="post-stats__item post-stats__item_views">
      <div class="post-stats__views" title="Количество просмотров">
        <svg class="icon-svg_views-count" width="21" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-stats__views-count">5,1k</span>
      </div>
    </li>

      <li class="post-stats__item post-stats__item_comments">
          <a href="https://habr.com/ru/company/ruvds/blog/536962/#comments" class="post-stats__comments-link" rel="nofollow">
            <svg class="icon-svg_post-comments" width="16" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-stats__comments-count" title="Читать комментарии">8</span>
          </a>
      </li>


      <li class="post-stats__item post-stats__item_share">
        <div class="dropdown dropdown_share">
          <div href="https://habr.com/ru/company/ruvds/blog/536962/#comments" data-toggle="dropdown" class="post-stats__share" rel="nofollow">
            <svg class="icon-svg_post-share" width="24" height="24">
              <use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#share">
            </svg>
            <span class="post-stats__comments-text" title="Поделиться">
              Поделиться
            </span>
          </div>

          <div class="dropdown-container">
            <div class="post-share">
  <ul class="post-share__buttons">
    <li class="post-share__item post-share__item_post">
      <span
        class="post-share__item-link post-share__item-link_normal post-share__item-link_copy"
        title="Скопировать ссылку"
        onclick="copyCurrentUrl(), $('.dropdown_share').removeClass('dropdown_active')"
      >
        Скопировать ссылку
      </span>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://www.facebook.com/sharer/sharer.php?u=https://habr.com/ru/company/ruvds/blog/536962/"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_facebook"
        title="Facebook"
        onclick="window.open(this.href, 'Facebook', 'width=640,height=436,toolbar=0,status=0'); return false"
      >
        Facebook
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://twitter.com/intent/tweet?text=8+%D0%B1%D0%B5%D1%81%D0%BF%D0%BB%D0%B0%D1%82%D0%BD%D1%8B%D1%85+%D0%B8%D0%BD%D1%81%D1%82%D1%80%D1%83%D0%BC%D0%B5%D0%BD%D1%82%D0%BE%D0%B2+%D0%B4%D0%BB%D1%8F+%D1%81%D0%BE%D0%B7%D0%B4%D0%B0%D0%BD%D0%B8%D1%8F+%D0%B8%D0%BD%D1%82%D0%B5%D1%80%D0%B0%D0%BA%D1%82%D0%B8%D0%B2%D0%BD%D1%8B%D1%85+%D0%B2%D0%B8%D0%B7%D1%83%D0%B0%D0%BB%D0%B8%D0%B7%D0%B0%D1%86%D0%B8%D0%B9+%D0%B4%D0%B0%D0%BD%D0%BD%D1%8B%D1%85+%D0%B1%D0%B5%D0%B7+%D0%BD%D0%B5%D0%BE%D0%B1%D1%85%D0%BE%D0%B4%D0%B8%D0%BC%D0%BE%D1%81%D1%82%D0%B8+%D0%BD%D0%B0%D0%BF%D0%B8%D1%81%D0%B0%D0%BD%D0%B8%D1%8F+%D0%BA%D0%BE%D0%B4%D0%B0+https://habr.com/p/536962/+via+%40habr_com"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_twitter"
        title="Twitter"
        onclick="window.open(this.href, 'Twitter', 'width=800,height=300,resizable=yes,toolbar=0,status=0'); return false"
      >
        Twitter
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://vk.com/share.php?url=https://habr.com/ru/company/ruvds/blog/536962/"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_vkontakte"
        title="ВКонтакте"
        onclick="window.open(this.href, 'ВКонтакте', 'width=800,height=300,toolbar=0,status=0'); return false"
      >
        ВКонтакте
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://t.me/share/url?url=https://habr.com/ru/company/ruvds/blog/536962/&title=8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_telegram"
        title="Telegram"
        onclick="window.open(this.href, 'Telegram', 'width=800,height=300,toolbar=0,status=0'); return false"
      >
        Telegram
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://getpocket.com/edit?url=https://habr.com/ru/company/ruvds/blog/536962/&title=8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_pocket"
        title="Pocket"
        target="_blank"
      >
        Pocket
      </a>
    </li>
  </ul>
</div>

          </div>
        </div>
      </li>






  </ul>

            <form action="/json/complaints/add/" class="form form_bordered form_abuse hidden" method="post" id="abuse_form">
  <input type="hidden" name="tt" value="2" />
  <input type="hidden" name="ti" value="536962" />

  <button type="button" class="btn form__close-btn" onclick="closeForm(this)"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

  <fieldset class="form__fieldset">
    <legend class="form__legend">Нарушение</legend>
    <input type="text" name="text" class="form__text-field" />
    <span class="form__desc">Опишите суть нарушения</span>
  </fieldset>

  <div class="form__footer">
    <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Отправить</button>
  </div>
</form>


            

            <div class="company-info company-info_post-additional author-panel">
              <div class="company-info__about">
                <div class="media-obj media-obj_company">
    <a href="/company/ruvds/" class="media-obj__image page-header__image">
        <img src="//habrastorage.org/getpro/habr/company/ffa/3df/965/ffa3df965d0a214a40ca505b87d0a69e.png" width="48" height="48" class="company-info__image-pic"/>
    </a>

  <div class="media-obj__body media-obj__body_page-header media-obj__body_page-header_branding">

    <div class="page-header__info">
        <a href="/company/ruvds/"  class="page-header__info-title">RUVDS.com</a>
        <div class="page-header__info-desc">
          VDS/VPS-хостинг. Скидка 10% по коду <b>HABR</b>
        </div>
    </div>
  </div>
</div>


              </div>
              <div class="author-panel__user-info">
                <div class="user-info" data-user-login="ru_vds">
  <div class="user-info__stats">
      <div class="media-obj">
        <a href="https://habr.com/ru/users/ru_vds/" class="media-obj__image" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_bottom', 'profile', 'ru_vds');}">
            <img src="//habrastorage.org/getpro/habr/avatars/e36/812/d3d/e36812d3de38eb3d479d7a13228717ef.png" width="48" height="48" class="media-obj__image-pic media-obj__image-pic_user"/>
        </a>

        <div class="media-obj__body media-obj__body_user-info">
              <a href="https://habr.com/ru/info/help/karma/" class="user-info__stats-item stacked-counter" title="848 голосов">
                <div class="stacked-counter__value stacked-counter__value_green ">201,5</div>
                <div class="stacked-counter__label">Карма</div>
              </a>

            <a href="https://habr.com/ru/info/help/karma/#rating" class="user-info__stats-item stacked-counter stacked-counter_rating" title="Рейтинг пользователя">
              <div class="stacked-counter__value stacked-counter__value_magenta">465,1</div>
              <div class="stacked-counter__label">Рейтинг</div>
            </a>
        </div>
      </div>

  </div>

  <div class="user-info__about">
    <div class="user-info__links">
        <a href="/users/ru_vds/" class="user-info__nickname user-info__nickname_doggy" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_top', 'profile', 'ru_vds');}">ru_vds</a>
        
    </div>

      <div class="user-info__specialization">Пользователь</div>
  </div>
</div>

<div class="overlay hidden" id="js-donate">
  <div class="popup">
    <div class="popup__head popup__head_lang-settings">
      <span class="popup__head-title js-popup_title" data-section="1">Платежная система</span>
      <button type="button" class="btn btn_small btn_popup-close js-hide-donate">
        <svg class="icon-svg" width="12" height="12">
          <use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#close" />
        </svg>
      </button>
    </div>
    <div class="popup__body js-donate-popup_body">
    </div>
  </div>
</div>


              </div>
                  <ul class="company-info__contacts inline-list">
          <li class="inline-list__item inline-list__item_contact-link"><a href="https://facebook.com/ruvds">Facebook</a></li>
          <li class="inline-list__item inline-list__item_contact-link"><a href="https://twitter.com/ru_vds">Twitter</a></li>
          <li class="inline-list__item inline-list__item_contact-link"><a href="https://vk.com/ru_vds">ВКонтакте</a></li>
    </ul>

            </div>
            
        </div>

          

    <div class="default-block default-block_content">
      <div class="default-block__header default-block__header_large">
        <h2 class="default-block__header-title default-block__header-title_large">Похожие публикации</h2>
      </div>
      <div class="default-block__content">

        <ul class="content-list">
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">15 августа 2020 в 17:18</span>
                <h3 class="post-info__title post-info__title_large">
                  <a href="https://habr.com/ru/post/515258/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common', '1'); }">
                    Структуры данных и алгоритмы, которыми я пользовался, работая в технологических компаниях
                  </a>
                </h3>

              <div class="post-info__meta">
                <span class="post-info__meta-item" title="Рейтинг">
                  <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg>
                      <span class="post-info__meta-counter">+67</span>
                </span>
                <span class="post-info__meta-item" title="Количество просмотров">
                  <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">35,3k</span>
                </span>
                <span class="post-info__meta-item" title="Закладки">
                  <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">343</span>
                </span>
                <a href="https://habr.com/ru/post/515258#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                  <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">53</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">17 июля 2020 в 12:30</span>
                <h3 class="post-info__title post-info__title_large">
                  <a href="https://habr.com/ru/post/510944/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common', '2'); }">
                    Что может пойти не так с Data Science? Сбор данных
                  </a>
                </h3>

              <div class="post-info__meta">
                <span class="post-info__meta-item" title="Рейтинг">
                  <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg>
                      <span class="post-info__meta-counter">+41</span>
                </span>
                <span class="post-info__meta-item" title="Количество просмотров">
                  <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">10,2k</span>
                </span>
                <span class="post-info__meta-item" title="Закладки">
                  <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">95</span>
                </span>
                <a href="https://habr.com/ru/post/510944#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                  <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">3</span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">21 сентября 2018 в 11:49</span>
                <h3 class="post-info__title post-info__title_large">
                  <a href="https://habr.com/ru/post/423983/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common', '3'); }">
                    11 JavaScript-библиотек для визуализации данных, о которых стоит знать в 2018 году
                  </a>
                </h3>

              <div class="post-info__meta">
                <span class="post-info__meta-item" title="Рейтинг">
                  <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg>
                      <span class="post-info__meta-counter">+28</span>
                </span>
                <span class="post-info__meta-item" title="Количество просмотров">
                  <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">35k</span>
                </span>
                <span class="post-info__meta-item" title="Закладки">
                  <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">342</span>
                </span>
                <a href="https://habr.com/ru/post/423983#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                  <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">19</span>
                </a>
              </div>
            </li>
        </ul>

      </div>
    </div>

        
        



            <div class="comments-section" id="comments">
    <header class="comments-section__head">
      <h2 class="comments-section__head-title">
        Комментарии
        <span class="comments-section__head-counter" id="comments_count">
          8
        </span>
      </h2>
      
    </header>
    
    

    <ul class="content-list content-list_comments" id="comments-list">
        <li class="content-list__item content-list__item_comment js-comment " rel="22551892">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_22551892">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22551892"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22551892">
          <a href="https://habr.com/ru/users/Ivan22/" class="user-info user-info_inline"  data-user-login="Ivan22">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_pink" width="24" height="24"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Ivan22</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 18:01</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22551892" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22551892" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22551892" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22551892" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22551892" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message "><blockquote>При этом тут я не буду говорить о сложных системах вроде Power BI</blockquote><br>
Как по мне Tableau Public ни разу не проще PowerBI. И в целом PowerBi в этом списке точно нужен.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_22551892"></ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="22552252">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_22552252">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22552252"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22552252">
          <a href="https://habr.com/ru/users/beduin01/" class="user-info user-info_inline"  data-user-login="beduin01">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_lilac" width="24" height="24"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">beduin01</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 20:28</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22552252" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22552252" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22552252" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22552252" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22552252" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message "><p>Пробовал PowerBI. Показалось что он только для совсем типовых случаев подходит. Шаг влево и все. Проще код написать. </p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_22552252">  <li class="content-list__item content-list__item_comment js-comment " rel="22553026">
    
    <span class="parent_id" data-parent_id="22552252"></span>
    <div class="comment" id="comment_22553026">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22553026"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22553026">
          <a href="https://habr.com/ru/users/Pavel1114/" class="user-info user-info_inline"  data-user-login="Pavel1114">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_green" width="24" height="24"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Pavel1114</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">сегодня в 04:15</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22553026" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22553026" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="22553026" data-parent_id="22552252" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_22552252" class="icon_comment-arrow-up js-comment_parent" data-id="22553026" data-parent_id="22552252" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22553026" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22553026" data-parent_id="22552252" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22553026" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message ">PowerBI довольно мощный. Не знаю есть ли среди представленных сервисов сравнимые с ним по функционалу. Но он настолько не последовательный и не интуитивный, что разобраться в нём довольно сложно, если вообще возможно. К примеру запуск итеративного обновления данных из источника. Не представляю сколько звёзд должно сойтись чтобы заветная галочка стала активной. Но даже и после её активации не факт что всё заработает. И это притом что microsoft загадочно молчит о причинах — просто галочка неактивна и думай что хочешь. И так всюду.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_22553026"></ul>
  </li>
</ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="22552772">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_22552772">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22552772"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22552772">
          <a href="https://habr.com/ru/users/slavapro/" class="user-info user-info_inline"  data-user-login="slavapro">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_green" width="24" height="24"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">slavapro</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">сегодня в 00:38</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22552772" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22552772" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22552772" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22552772" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22552772" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message ">Не увидел Ap</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_22552772"></ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="22552782">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_22552782">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22552782"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22552782">
          <a href="https://habr.com/ru/users/Staser/" class="user-info user-info_inline"  data-user-login="Staser">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/58a/d4d/641/58ad4d641a1c1313d2040183199535d6.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Staser</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">сегодня в 00:53</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22552782" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22552782" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22552782" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22552782" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22552782" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message ">Добавлю сюда пару selfhosted решений, которыми сам пользуюсь и могу точно сказать, что они отлично справляются с поставленными задачами =)<br>
<br>
1. Metabase — <a href="https://www.metabase.com/" rel="nofollow">www.metabase.com</a><br>
Пользователи задают вопросы о данных, а Metabase отображает ответы в осмысленных форматах, таких как гистограмма или таблица. Вопросы к данным сохраняются и группируются в информативные дашборды, которые испольует вся команда.<br>
Есть коннекторы ко всем актуальным базам, я бы назвал систему как очень современная, как визуально, так и по подходу.<br>
<br>
Киллер фича — автоматический поиск данных (по сути группировка тех или иных данных по столбцу даты в базе)<br>
<br>
2. Superset от Apache — <a href="https://superset.apache.org/" rel="nofollow">superset.apache.org</a><br>
Больше функций, чем в мете, но она и немного сложнее. Есть коннекторы также +- ко всему актуальному.<br>
<br>
3. Redash — <a href="https://redash.io/" rel="nofollow">redash.io</a><br>
По сравнению с первыми это уже ближе к чисто BI системе, пишем запрос, группируем — строим график. Для программистов отличный и понятный инструмент.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_22552782">  <li class="content-list__item content-list__item_comment js-comment " rel="22553036">
    
    <span class="parent_id" data-parent_id="22552782"></span>
    <div class="comment" id="comment_22553036">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22553036"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22553036">
          <a href="https://habr.com/ru/users/Pavel1114/" class="user-info user-info_inline"  data-user-login="Pavel1114">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_green" width="24" height="24"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Pavel1114</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">сегодня в 04:27</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22553036" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22553036" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="22553036" data-parent_id="22552782" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_22552782" class="icon_comment-arrow-up js-comment_parent" data-id="22553036" data-parent_id="22552782" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22553036" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22553036" data-parent_id="22552782" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22553036" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message ">redash показался очень интересным. Да ещё и на python/reactjs. Надо поиграться. А то намучался уже помогая внедрить powerbi. Спасибо!</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_22553036"></ul>
  </li>
</ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="22552904">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_22552904">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22552904"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22552904">
          <a href="https://habr.com/ru/users/fivec/" class="user-info user-info_inline"  data-user-login="fivec">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_lilac" width="24" height="24"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">fivec</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">сегодня в 02:08</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22552904" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22552904" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22552904" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22552904" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22552904" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message ">Очень интересный продукт от Microsoft — <a href="https://charticulator.com/gallery/index.html" rel="nofollow">charticulator.com/gallery/index.html</a> позволяет строить очень интересные визуализации, при этом это открытое решение (MIT License)</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_22552904"></ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="22553060">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_22553060">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="22553060"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="22553060">
          <a href="https://habr.com/ru/users/Kaputmaher/" class="user-info user-info_inline"  data-user-login="Kaputmaher">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/c12/6e9/15a/c126e915ae1b384cdc9d786552ed1f74.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Kaputmaher</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">сегодня в 05:02</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_22553060" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="22553060" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_22553060" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="22553060" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="22553060" data-post-target="536962" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message "><a href="http://data-illustrator.com" rel="nofollow">http://data-illustrator.com</a> — эксперимент при участии Adobe по созданию одновременно и новой парадигмы создания визуализаций, и сочетания подходов традиционных инструментов<br>
<br>
<a href="https://quadrigram.com" rel="nofollow">https://quadrigram.com</a> — незаслуженно забытый мощный онлайн-инструмент визуального сторителлинга, который вырос из нодовой среды разработки Impure<br>
<br>
<a href="https://app.morph.graphics/" rel="nofollow">app.morph.graphics</a> — скорее для создания анимированного дата-арта и виз-медитаций<br>
<br>
<a href="https://graphcommons.com" rel="nofollow">https://graphcommons.com</a>, <a href="https://kumu.io/" rel="nofollow">https://kumu.io/</a>, <a href="https://onodo.org/" rel="nofollow">https://onodo.org/</a> — сервисы онлайн визуализации и публикации графов<br>
<br>
<a href="https://piktochart.com/" rel="nofollow">https://piktochart.com/</a> — очень близкий по уровню простоты к infogram.com сервис (Кстати, из всех тулов в обсуждении, кроме «взрослых» Tableau, PowerBI, etc., только в Infogram.com есть возможность подключения к базам данных. Я нахожу это очень ироничным, что самый простой сервис создания графиков для домохозяек обладает этим функционалом. И только в нем есть настройка белых списков доменов для публикации их работ)</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_22553060"></ul>
  </li>

      
    </ul>
      <div class="js-form_placeholder">
                <p class="for_users_only_msg">Только&nbsp;<a href="/info/help/registration/">полноправные пользователи</a> могут оставлять комментарии. <a href="https://habr.com/ru/auth/login/">Войдите</a>, пожалуйста.</p>

      </div>
  </div>


      </div>
    </div>

    <div class="sidebar">
      <div class="sidebar_right_ad">
        
      </div>
      <div class="sidebar_right sidebar_content-area">
          
  <div class="default-block default-block_sidebar" id="profile-company">
  <div class="default-block__header">
    <h2 class="default-block__header-title">Информация</h2>
  </div>
  <div class="default-block__content default-block__content_profile-summary">
      <ul class="defination-list">
          <li class="defination-list__item defination-list__item_profile-summary">
            <h3 class="defination-list__label defination-list__label_profile-summary">Дата основания</h3>
            <span class="defination-list__value">27 июля 2015 г.</span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <h3 class="defination-list__label defination-list__label_profile-summary">Локация</h3>
            <span class="defination-list__value">
              Москва<br/>Россия
            </span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <h3 class="defination-list__label defination-list__label_profile-summary">Сайт</h3>
            <span class="defination-list__value"><a href="https://ruvds.com" target="_blank" class="defination-list__link" title="https://ruvds.com">ruvds.com</a></span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <h3 class="defination-list__label defination-list__label_profile-summary">Численность</h3>
            <span class="defination-list__value">11&#8211;30 человек</span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
            <h3 class="defination-list__label defination-list__label_profile-summary">Дата регистрации</h3>
            <span class="defination-list__value">18 марта 2016 г.</span>
          </li>

          <li class="defination-list__item defination-list__item_profile-summary">
              <h3 class="defination-list__label defination-list__label_profile-summary">Представитель</h3>
              <span class="defination-list__value"><a title="ruvds" href="https://habr.com/ru/users/ruvds/">ruvds</a></span>
          </li>
      </ul>
  </div>
</div>

  

        <div class="default-block default-block_sidebar" id="company-links">
    <div class="default-block__header">
      <h2 class="default-block__header-title">Ссылки</h2>
    </div>
    <div class="default-block__content">
      <ul class="content-list content-list_company-links">
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/vps_start" class="company-links__title">VPS / VDS сервер от 130 рублей в месяц.</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/data" class="company-links__title">Дата-центры RUVDS в Москве, Санкт-Петербурге, Казани, Екатеринбурге, Новосибирске, Лондоне, Франкфурте, Цюрихе, Амстердаме</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/faq" class="company-links__title">Помощь и вопросы</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/partner" class="company-links__title">Партнерская программа RUVDS</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/vps_start" class="company-links__title">VPS (CPU 1x2ГГц, RAM 512Mb, SSD 10 Gb) — 190 рублей в месяц</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/" class="company-links__title">VPS Windows от 307 рублей в месяц. Бесплатный тестовый период 3 дня.</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/data/zur1" class="company-links__title">VDS в Цюрихе. Дата-центр TIER III — швейцарское качество по низкой цене.</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/kaspersky" class="company-links__title">Антивирусная защита виртуального сервера. Легкий агент для VPS.</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/data/eng" class="company-links__title">VPS в Лондоне. Дата-центр TIER III — английская точность за рубли.</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
          <li class="content-list__item content-list__item_company-links company-links">
            <a href="https://ruvds.com/ru-rub/" class="company-links__title">VPS с видеокартой на мощных серверах 3,4ГГц</a>
            <div class="company-links__link">ruvds.com</div>
          </li>
      </ul>
    </div>
  </div>
















      <div class="default-block default-block_sidebar" id="apps">
  <div class="default-block__header">
    <h2 class="default-block__header-title">Приложения</h2>
  </div>
  <div class="default-block__content">
    <ul class="content-list content-list_company-wjt" id="company-wjt">
        <li class="content-list__item content-list__item_company-wjt ">
          <div class="media-obj company-app">
  <div class="media-obj__image media-obj__image_company-wjt">
    <img src="//habrastorage.org/getpro/habr/app/6ee/74b/d87/6ee74bd87dbf84e43cdcc0abd0d13a3f.png" class="company-app__image" width="48" height="48" />
  </div>
  <div class="media-obj__body media-obj__body_company-wjt">
    <h3 class="company-app__title">RUVDS Client</h3>
    <div class="company-app__description">Приложение для мониторинга и управления виртуальными серверами RUVDS с мобильных устройств.</div>
  </div>
</div>
<ul class="app-links">
    <li class="app-links__item">
      <a href="https://play.google.com/store/apps/details?id=com.rudvs.ruvdsclient" class="app-links__item-link">
        <span class="app-links__item-name">Android</span>
      </a>
    </li>
    <li class="app-links__item">
      <a href="https://apps.apple.com/ru/app/ruvds-client/id1492272255?ign-mpt=uo%3D4" class="app-links__item-link">
        <span class="app-links__item-name">iOS</span>
      </a>
    </li>
</ul>

        </li>
    </ul>
  </div>
</div>





      <div class="default-block default-block_sidebar" id="widget">
  <div class="default-block__header">
    <h2 class="default-block__header-title">Виджет</h2>
  </div>
  <div class="default-block__content  sidebar-block">
    <div class="sidebar-block__banner">
      <a href="https://ruvds.com/ru-rub/" class="sidebar-block__banner-link">
        <img src="//habrastorage.org/getpro/habr/widget/e12/28e/7f1/e1228e7f11865e9e73aeeb89a805f1f2.jpg" class="sidebar-block__banner-image" />
        
      </a>
    </div>

    <div class="sidebar-block__paragraph">
      
    </div>
  </div>
</div>









      <div class="default-block default-block_sidebar" id="widget">
  <div class="default-block__header">
    <h2 class="default-block__header-title">Виджет</h2>
  </div>
  <div class="default-block__content  sidebar-block">
    <div class="sidebar-block__banner">
      <a href="https://ruvds.com/turbo_vps/" class="sidebar-block__banner-link">
        <img src="//habrastorage.org/getpro/habr/widget/c45/e2f/d33/c45e2fd33f8bb04e5dbaf1fcd1b6acc4.png" class="sidebar-block__banner-image" />
        
      </a>
    </div>

    <div class="sidebar-block__paragraph">
      
    </div>
  </div>
</div>









    <div class="default-block">
    <div class="default-block__header">
      <h2 class="default-block__header-title">Блог на Хабре</h2>
    </div>
    <div class="default-block__content">
      <ul class="content-list">
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536962/" class="post-info__title">8 бесплатных инструментов для создания интерактивных визуализаций данных без необходимости написания кода</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">5,1k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536962/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">8</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/537564/" class="post-info__title">Как разрабатывают и выпускают игры в пандемию: интервью со Стивом Гибсоном</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">982</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/537564/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">0</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/537478/" class="post-info__title">Как мы в RUVDS спасаем наших пользователей от брутфорса</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">6,1k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/537478/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">12</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536966/" class="post-info__title">Ускорение JPEG-кодирования с использованием нескольких потоков</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">3,1k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536966/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">13</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536964/" class="post-info__title">Умная новогодняя ёлка</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">4,3k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536964/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">16</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/537148/" class="post-info__title">История развития Boston Dynamics: от Плоского Одноногого Прыгуна до танцующего Atlas</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">7,9k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/537148/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">28</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536968/" class="post-info__title">Заметки о Unix: два сценария работы с конвейерами</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">3,2k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536968/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">2</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/537010/" class="post-info__title">Что лучше выбрать: Wireguard или OpenVPN? Любимый VPN Линуса Торвальдса</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">23k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/537010/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">104</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536336/" class="post-info__title">Пишем макет 16-битного ядра на C/C++</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">4,8k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536336/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">5</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536824/" class="post-info__title">Чистый Cython VS nvc++: жжем металлические пластины на GPU для сравнения скорости</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">4,7k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536824/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">4</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/534106/" class="post-info__title">Практика использования спецификации CSS Scroll Snap</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">4,7k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/534106/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">6</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/535762/" class="post-info__title">Эмуляция компьютера: интерпретатор CHIP-8, графика и стриминг текстур</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">2,1k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/535762/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">1</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536156/" class="post-info__title">Пишем загрузчик на Ассемблере и С. Часть 2</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">5,4k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536156/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">20</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536324/" class="post-info__title">Разработка PWA с поддержкой распознавания лица и голоса</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">5k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536324/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">1</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536132/" class="post-info__title">Пишем загрузчик на Ассемблере и C. Часть 1</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">15,8k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536132/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">68</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536296/" class="post-info__title">Самые упоротые и забавные расширения для браузера: подборка</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">17k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536296/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">11</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/535564/" class="post-info__title">Первое знакомство с отладчиком Ghidra и взлом игры Spiderman</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">6k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/535564/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">1</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/536072/" class="post-info__title">Как дата-саентисты в ВК делают рекламу эффективной</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">3,2k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/536072/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">18</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/535764/" class="post-info__title">Эмуляция компьютера: интерпретатор CHIP-8, таймеры и обработка ввода</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">2,8k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/535764/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">2</span>
              </a>
            </div>
          </li>
          <li class="content-list__item content-list__item_devided post-info">
              <h3 class="post-info__title">
                <a href="https://habr.com/ru/company/ruvds/blog/535904/" class="post-info__title">Обзор GameLisp: нового языка для написания игр на Rust</a>
              </h3>
            <div class="post-info__meta">
              <span class="post-info__meta-item" title="Количество просмотров">
                <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">6k</span>
              </span>

              <a href="https://habr.com/ru/company/ruvds/blog/535904/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">7</span>
              </a>
            </div>
          </li>
      </ul>
    </div>
  </div>

  

      </div>
    </div>
  </div>


  <script type="text/javascript">
    var userLabel = 'reader';
  </script>

        </div>
      </div>

        <div class="layout__row layout__row_promo-blocks">
          <div class="layout__cell">
              <div class="column-wrapper column-wrapper_bottom column-wrapper_bordered">
    <div class="content_left">
      


  <div class="default-block default-block_content">
    <div class="default-block__header default-block__header_large">
      <h2 class="default-block__header-title default-block__header-title_large">Самое читаемое</h2>
    </div>
    <div class="default-block__content default-block__content_most-read" id="broadcast_tabs_posts">
      <ul class="toggle-menu toggle-menu__most-read">
        <li class="toggle-menu__item">
          <a href="#broadcast_posts_today" class="toggle-menu__item-link active" rel="nofollow">Сутки</a>
        </li>
        <li class="toggle-menu__item">
          <a href="#broadcast_posts_week" class="toggle-menu__item-link" rel="nofollow">Неделя</a>
        </li>
        <li class="toggle-menu__item">
          <a href="#broadcast_posts_month" class="toggle-menu__item-link" rel="nofollow">Месяц</a>
        </li>
      </ul>

        <div class="tabs__content tabs__content_reading" id="broadcast_posts_today">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/537454/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Интернет в Беларуси блокировали по прямому указу Лукашенко — и это стало катализатором революции</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;39</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">96,1k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">11</span>
                    </span>
                    <a href="https://habr.com/ru/news/t/537454/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">118</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/englishdom/blog/537470/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Все имена персонажей из «Властелина колец» говорят нам что-то. А что именно?</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;41</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">29,2k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">47</span>
                    </span>
                    <a href="https://habr.com/ru/company/englishdom/blog/537470/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">38</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/537446/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Дуров отказался продать даже 5% Telegram</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;29</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">44,1k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">4</span>
                    </span>
                    <a href="https://habr.com/ru/news/t/537446/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">47</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/lamptest/blog/537576/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Светодиодная лампа Экономка 15 Вт за 39 рублей</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;73</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">20,3k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">15</span>
                    </span>
                    <a href="https://habr.com/ru/company/lamptest/blog/537576/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">108</span>
                    </a>
                  </div>
                </li>
              <li class="content-list__item content-list__item_devided post-info">
                <a href="https://u.habr.com/mkbmsb3" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'https://u.habr.com/mkbmsb3'); }">Не просто цифровизация: IT-платформа МКБ для малого и среднего бизнеса</a>
                <div class="post-info__meta-label">
                  Мегапост
                </div>
              </li>
            </ul>
        </div>
        <div class="tabs__content tabs__content_reading" id="broadcast_posts_week">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/536750/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Самый беззащитный — уже не Сапсан. Всё оказалось куда хуже…</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;1349</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">372k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">572</span>
                    </span>
                    <a href="https://habr.com/ru/post/536750/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">938</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/vdsina/blog/535688/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Какой софт и базы использует Bellingcat в своих расследованиях?</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;196</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">67,2k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">256</span>
                    </span>
                    <a href="https://habr.com/ru/company/vdsina/blog/535688/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">763</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/536880/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Как и ожидалось, в полночь Adobe Flash превратился в тыкву</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;42</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">49,1k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">31</span>
                    </span>
                    <a href="https://habr.com/ru/post/536880/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">194</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/536738/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">В интернете опять кто-то неправ</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;91</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">44,4k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">53</span>
                    </span>
                    <a href="https://habr.com/ru/post/536738/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">773</span>
                    </a>
                  </div>
                </li>
              <li class="content-list__item content-list__item_devided post-info">
                <a href="https://u.habr.com/happy-farmer-reading" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'https://u.habr.com/happy-farmer-reading'); }">Счастливый фермер: как сделать маркетплейс натуральных продуктов за полгода</a>
                <div class="post-info__meta-label">
                  Мегапост
                </div>
              </li>
            </ul>
        </div>
        <div class="tabs__content tabs__content_reading" id="broadcast_posts_month">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/536750/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Самый беззащитный — уже не Сапсан. Всё оказалось куда хуже…</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;1349</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">372k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">572</span>
                    </span>
                    <a href="https://habr.com/ru/post/536750/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">938</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/yandex/blog/534586/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Яндекс отключил расширения с аудиторией в 8 млн пользователей. Объясняем, почему мы пошли на такой шаг</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;346</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">151k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">205</span>
                    </span>
                    <a href="https://habr.com/ru/company/yandex/blog/534586/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">502</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/534242/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Смерть MAPS.ME?</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;357</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">117k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">133</span>
                    </span>
                    <a href="https://habr.com/ru/post/534242/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">399</span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/534590/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Как и почему я перестал покупать новые ноутбуки</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;49</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">93,2k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">118</span>
                    </span>
                    <a href="https://habr.com/ru/post/534590/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">623</span>
                    </a>
                  </div>
                </li>
              <li class="content-list__item content-list__item_devided post-info">
                <a href="https://u.tmtm.ru/iris-reading" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'https://u.tmtm.ru/iris-reading'); }">Мониторим оборудование в реальном времени. Причем тут ИИ?</a>
                <div class="post-info__meta-label">
                  Интересно
                </div>
              </li>
            </ul>
        </div>
    </div>
  </div>

    </div>

    <div class="sidebar">
      <div class="sidebar_right">
      </div>
    </div>
  </div>

          </div>
        </div>

      <div class="layout__row layout__row_footer-links">
        <div class="layout__cell">
          <div class="footer-grid footer-grid_menu">
  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">
      Ваш аккаунт
    </h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
          <li class="footer-menu__item">
            <a href="https://habr.com/ru/auth/login/" class="footer-menu__item-link">Войти</a>
          </li>
          <li class="footer-menu__item">
            <a href="https://habr.com/ru/auth/register/" class="footer-menu__item-link">Регистрация</a>
          </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Разделы</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/posts/top/" class="footer-menu__item-link">Публикации</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/news/" class="footer-menu__item-link">Новости</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/hubs/" class="footer-menu__item-link">Хабы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/companies/" class="footer-menu__item-link">Компании</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/users/" class="footer-menu__item-link">Пользователи</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/sandbox/" class="footer-menu__item-link">Песочница</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Информация</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/help/" class="footer-menu__item-link">Устройство сайта</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/authors/" class="footer-menu__item-link">Для авторов</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/companies/" class="footer-menu__item-link">Для компаний</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/docs/" class="footer-menu__item-link">Документы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://account.habr.com/info/agreement/?hl=ru_RU" class="footer-menu__item-link">Соглашение</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://account.habr.com/info/confidential/?hl=ru_RU" class="footer-menu__item-link">Конфиденциальность</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Услуги</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/advertising/" target="_blank" class="footer-menu__item-link">Реклама</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/corpblog/" target="_blank" class="footer-menu__item-link">Тарифы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/content/" target="_blank" class="footer-menu__item-link">Контент</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/workshops/" target="_blank" class="footer-menu__item-link">Семинары</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/megaprojects/" target="_blank" class="footer-menu__item-link">Мегапроекты</a>
        </li>
          <li class="footer-menu__item">
            <a href="https://habr.market/" target="_blank" class="footer-menu__item-link">Мерч</a>
          </li>
      </ul>
    </div>
  </div>
</div>


        </div>
      </div>

      <div class="layout__row layout__row_footer">
        <div class="layout__cell">
          <script>
  $(document).ready(function () {
    window.voteReasonsList = JSON.parse('{"1":{"id":"1","title":"Низкий технический уровень материала","order":1},"2":{"id":"2","title":"Больше рекламы, чем пользы","order":2},"3":{"id":"3","title":"Не соответствует тематике Хабра","order":3},"4":{"id":"4","title":"В тексте много ошибок и опечаток","order":4},"5":{"id":"5","title":"Пост небрежно оформлен","order":5},"6":{"id":"6","title":"Личная неприязнь к автору или компании","order":6},"7":{"id":"7","title":"В статье нет новой для меня информации","order":7},"8":{"id":"8","title":"Ничего не понял после прочтения","order":8},"22":{"id":"22","title":"Не согласен с изложенным","order":9},"9":{"id":"9","title":"Другое","order":10}}');
  });
</script>
<script>

$(document).on('hljsUpdate', function () {
  if (typeof hljs === 'undefined') {
    initHighlightJS();
  } else {
    $('pre code').each(function (i, e) {
      hljs.highlightBlock(e, '    ');
    });
  }
})

function createScript(url) {
  var hljsScript = document.createElement("script");
  hljsScript.src = url;
  hljsScript.type = 'text/javascript';
  document.body.appendChild(hljsScript)

  return hljsScript;
}

function initHighlightJS() {
  if (typeof hljs !== 'undefined') {
    $('pre code').each(function (i, e) {
      hljs.highlightBlock(e, '    ');
    });
    return;
  };

  var hljsScript = createScript('https://dr.habracdn.net/habr/6001a5d9/javascripts/highlight.pack.js');

  hljsScript.onload = function() {
    var hljsLangs = createScript('https://dr.habracdn.net/habr/6001a5d9/javascripts/highlight.langs.js');
    hljsLangs.onload = function () {
      hljs.initHighlighting();
    }
  }
}


var codeElements = document.querySelectorAll('pre code');

if (codeElements.length) {
  initHighlightJS();
}

</script>

<script>

var mathElements = document.getElementsByTagName('math');

function mathJaxConfig() {
  MathJax.Hub.Config({
    showProcessingMessages: false,
    showMathMenu: true,
    tex2jax: {
      inlineMath: [['$inline$','$inline$']],
      displayMath: [['$$display$$','$$display$$']],
      processEscapes: true
    },
    MathMenu: {
      showRenderer: true,
      showContext:  true
    }
  });

  MathJax.Extension.Img2jax = {
    PreProcess: function (element) {
      var hasMath = false;
      var images = element.querySelectorAll('[data-tex]');
      for (var i = images.length - 1; i >= 0; i--) {
        var img = images[i];
        var tex = img.alt.replace(/(\r\n|\n|\r)/gm, " ");
        if (tex && tex[0] === '$'){
          var script = document.createElement("script"); script.type = "math/tex";
          hasMath = true;
          if (img.getAttribute('data-tex') == "display"){script.type += ";mode=display"}
          MathJax.HTML.setScript(script, tex.substring(1,tex.length-1));
          img.parentNode.replaceChild(script,img);
        }
      }
    }
  };

  MathJax.Hub.Register.PreProcessor(["PreProcess", MathJax.Extension.Img2jax]);
}

function mathjaxInit() {
 if (typeof MathJax === 'undefined') {
    var url = 'https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js?config=TeX-AMS_SVG-full&locale=ru';
    var mathScript = document.createElement("script");
    mathScript.src = url;
    mathScript.type = 'text/javascript';
    document.body.appendChild(mathScript)

    mathScript.onload = function() {
      mathJaxConfig();
    }
  } else {
    mathJaxConfig();
  }
}

if (mathElements.length) {
  mathjaxInit();
}

</script>
<div class="footer-grid footer">
  <div class="footer-grid__item footer-grid__item_copyright">
    <span class="footer__copyright">&copy; 2006 &ndash; 2021 «<a href="https://company.habr.com/" class="footer__link">Habr</a>»</span>
  </div>
  <div class="footer-grid__item footer-grid__item_link footer-grid__item_lang">
    <svg class="icon-svg icon-svg_lang-footer" width="16" height="16">
      <use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#globus-v2" />
    </svg>
    <a href="#" class="footer__link js-show_lang_settings">Настройка языка</a>
  </div>
  <div class="footer-grid__item footer-grid__item_link">
      <a href="https://habr.com/ru/about/" class="footer__link">О сайте</a>
  </div>
  <div class="footer-grid__item footer-grid__item_link">
    <a href="https://habr.com/ru/feedback/" class="footer__link">Служба поддержки</a>
  </div>
  <div class="footer-grid__item footer-grid__item_link">
      <a href="https://m.habr.com/post/536962/?mobile=yes" class="footer__link">Мобильная версия</a>
  </div>

  <div class="footer-grid__item footer-grid__item_social">
    <ul class="social-icons">
      <li class="social-icons__item">
        <a href="https://twitter.com/habr_com"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_twitter"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'twitter'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.414 8.642c-.398.177-.826.296-1.276.35.459-.275.811-.71.977-1.229-.43.254-.905.439-1.41.539-.405-.432-.982-.702-1.621-.702-1.227 0-2.222.994-2.222 2.222 0 .174.019.344.058.506-1.846-.093-3.484-.978-4.579-2.322-.191.328-.301.71-.301 1.117 0 .77.392 1.45.988 1.849-.363-.011-.706-.111-1.006-.278v.028c0 1.077.766 1.974 1.782 2.178-.187.051-.383.078-.586.078-.143 0-.282-.014-.418-.04.282.882 1.103 1.525 2.075 1.542-.76.596-1.718.951-2.759.951-.179 0-.356-.01-.53-.031.983.63 2.15.998 3.406.998 4.086 0 6.321-3.386 6.321-6.321l-.006-.287c.433-.314.81-.705 1.107-1.15z"/></svg>
        </a>
      </li>
      <li class="social-icons__item">
        <a href="https://www.facebook.com/habrahabr.ru"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_facebook"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'facebook'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M14.889 8.608h-1.65c-.195 0-.413.257-.413.6v1.192h2.063v1.698h-2.063v5.102h-1.948v-5.102h-1.766v-1.698h1.766v-1c0-1.434.995-2.6 2.361-2.6h1.65v1.808z"/></svg>
        </a>
      </li>
        <li class="social-icons__item">
          <a href="https://vk.com/habr"
            class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_vkontakte"
            target="_blank"
            onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'vkontakte'); }"
          >
            <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M16.066 11.93s1.62-2.286 1.782-3.037c.054-.268-.064-.418-.343-.418h-1.406c-.322 0-.44.139-.537.343 0 0-.76 1.619-1.685 2.64-.297.33-.448.429-.612.429-.132 0-.193-.11-.193-.408v-2.607c0-.365-.043-.472-.343-.472h-2.254c-.172 0-.279.1-.279.236 0 .343.526.421.526 1.352v1.921c0 .386-.022.537-.204.537-.483 0-1.631-1.663-2.274-3.552-.129-.386-.268-.494-.633-.494h-1.406c-.204 0-.354.139-.354.343 0 .375.44 2.114 2.167 4.442 1.159 1.566 2.683 2.414 4.056 2.414.838 0 1.041-.139 1.041-.494v-1.202c0-.301.118-.429.29-.429.193 0 .534.062 1.33.848.945.901 1.01 1.276 1.525 1.276h1.578c.161 0 .311-.075.311-.343 0-.354-.462-.987-1.17-1.738-.29-.386-.762-.805-.912-.998-.215-.226-.151-.354-.001-.59z"/></svg>
          </a>
        </li>
      <li class="social-icons__item">
        <a href="https://telegram.me/habr_com"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_telegram"
          target="_blank"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'telegram'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.17 7.621l-10.498 3.699c-.169.059-.206.205-.006.286l2.257.904 1.338.536 6.531-4.796s.189.057.125.126l-4.68 5.062-.27.299.356.192 2.962 1.594c.173.093.397.016.447-.199.058-.254 1.691-7.29 1.728-7.447.047-.204-.087-.328-.291-.256zm-6.922 8.637c0 .147.082.188.197.084l1.694-1.522-1.891-.978v2.416z"/></svg>
        </a>
      </li>
        <li class="social-icons__item">
          <a href="https://www.youtube.com/channel/UCd_sTwKqVrweTt4oAKY5y4w"
            class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_youtube"
            target="_blank"
            onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'youtube'); }"
          >
            <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="32" height="32" viewBox="0 0 32 32"><path d="M3.2 0h25.6c1.767 0 3.2 1.433 3.2 3.2v25.6c0 1.767-1.433 3.2-3.2 3.2h-25.6c-1.767 0-3.2-1.433-3.2-3.2v-25.6c0-1.767 1.433-3.2 3.2-3.2zm18.133 16l-10.667-5.333v10.667l10.667-5.333z"/></svg>

          </a>
        </li>
        <li class="social-icons__item">
          <a href="https://zen.yandex.ru/habr"
            class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_zen"
            target="_blank"
            onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'zen'); }"
          >
            <svg width="30" height="30" viewBox="0 0 30 30" fill="none" xmlns="http://www.w3.org/2000/svg">
    <rect width="30" height="30" rx="3" fill="#2C3036"/>
    <path fill-rule="evenodd" clip-rule="evenodd" d="M26.25 15.1241V14.9998V14.8759C21.2684 14.7252 18.9904 14.6009 17.1735 12.8263C15.3994 11.0098 15.2747 8.73179 15.1243 3.75H15H14.8757C14.7253 8.73179 14.6006 11.0098 12.8264 12.8263C11.0095 14.6009 8.73151 14.7252 3.75 14.8759V14.9998V15.1241C8.73151 15.2748 11.0095 15.3991 12.8264 17.1733C14.6006 18.9903 14.7253 21.2682 14.8757 26.25H15H15.1243C15.2747 21.2682 15.3994 18.9903 17.1735 17.1733C18.9904 15.3991 21.2684 15.2748 26.25 15.1241Z" fill="white"/>
</svg>

          </a>
        </li>
    </ul>
  </div>
</div>

        </div>
      </div>

      <a href="#" class="layout__elevator hidden" id="scroll_to_top" title="Наверх"  onclick="if (typeof ga === 'function') { ga('send', 'event', 'navigation_button', 'down'); }">
        <svg class="icon-svg icon-svg_scroll-up" width="32" height="32" viewBox="0 0 32 32" aria-hidden="true" version="1.1" role="img"><path d="M16 0C7.164 0 0 7.164 0 16s7.164 16 16 16 16-7.164 16-16S24.836 0 16 0zm8.412 19.523c-.517.512-1.355.512-1.872 0L16 13.516l-6.54 6.01c-.518.51-1.356.51-1.873 0-.516-.513-.517-1.343 0-1.855l7.476-7.326c.517-.512 1.356-.512 1.873 0l7.476 7.327c.516.513.516 1.342 0 1.854z"/></svg>
      </a>
    </div>

    <div class="overlay hidden" id="js-lang_settings">
  <div class="popup">
    <div class="popup__head popup__head_lang-settings">
      <span class="popup__head-title js-popup_title" data-section="1">Настройка языка</span>
      <button type="button" class="btn btn_small btn_popup-close js-hide_lang_settings">
        <svg class="icon-svg" width="12" height="12">
          <use xlink:href="https://habr.com/6001a5d9/images/common-svg-sprite.svg#close" />
        </svg>
      </button>
    </div>
    <div class="popup__body">
      <form action="/json/settings/i18n/" method="post" class="form form_lang-settings" id="lang-settings-form">
        <fieldset class="form__fieldset form__fieldset_thin" data-section="2">
          <legend class="form__legend form__legend_lang-settings js-popup_hl_legend">Интерфейс</legend>
            <div class="form-field form-field_lang-settings">
              <span class="radio radio_custom ">
                <input type="radio" name="hl" id="hl_langs_ru" class="radio__input js-hl_langs" value="ru" checked>
                <label for="hl_langs_ru" class="radio__label radio__label_another">Русский</label>
              </span>
            </div>
            <div class="form-field form-field_lang-settings">
              <span class="radio radio_custom ">
                <input type="radio" name="hl" id="hl_langs_en" class="radio__input js-hl_langs" value="en" >
                <label for="hl_langs_en" class="radio__label radio__label_another">English</label>
              </span>
            </div>
        </fieldset>

        <fieldset class="form__fieldset form__fieldset_thin">
          <legend class="form__legend form__legend_lang-settings js-popup_fl_legend" data-section="3">Язык публикаций</legend>
            <div class="form-field form-field_lang-settings">
              <span class="checkbox checkbox_custom">
                <input type="checkbox" name="fl[]" id="fl_langs_ru" class="checkbox__input js-fl_langs" value="ru" checked>
                <label for="fl_langs_ru" class="checkbox__label checkbox__label_another js-popup_feed_ru">Русский</label>
              </span>
            </div>
            <div class="form-field form-field_lang-settings">
              <span class="checkbox checkbox_custom">
                <input type="checkbox" name="fl[]" id="fl_langs_en" class="checkbox__input js-fl_langs" value="en" >
                <label for="fl_langs_en" class="checkbox__label checkbox__label_another js-popup_feed_en">Английский</label>
              </span>
            </div>
        </fieldset>

        <div class="form__footer form__footer_lang-settings">
          <button type="submit" class="btn btn_blue btn_huge btn_full-width js-popup_save_btn">Сохранить настройки</button>
        </div>
      </form>
    </div>
  </div>
</div>



    <script>
  function composeTeaser(t, blockType) {
    const listener = " onclick=\"if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'promo,"
      + blockType + "', '"+ t.linkUrl +"'); }\"";
    let teaser = '<li class="megapost-teasers__item teaser">'
    + '<a href="' + t.linkUrl + '" target="_blank" class="teaser__image" rel="nofollow';

    if (t.external) teaser += ' sponsored';

    teaser += '"';

    teaser += listener;

    teaser += '>'
    + '<img src="' + t.imageUrl + '" class="teaser__image-pic"/>'
    + '<div class="megapost-teasers__label">'
    + t.label;

    if (t.external) teaser += `<svg width="11" height="11" viewBox="0 0 11 11" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M7.5 0C7.22386 0 7 0.223858 7 0.5C7 0.776142 7.22386 1 7.5 1H9.29289L5.14645 5.14645C4.95118 5.34171 4.95118 5.65829 5.14645 5.85355C5.34171 6.04882 5.65829 6.04882 5.85355 5.85355L10 1.70711V3.5C10 3.77614 10.2239 4 10.5 4C10.7761 4 11 3.77614 11 3.5V0.5C11 0.223858 10.7761 0 10.5 0H7.5ZM0.5 1C0.223858 1 0 1.22386 0 1.5V10.5C0 10.7761 0.223858 11 0.5 11H9.5C9.77614 11 10 10.7761 10 10.5V6C10 5.72386 9.77614 5.5 9.5 5.5C9.22386 5.5 9 5.72386 9 6V10H1V2H5C5.27614 2 5.5 1.77614 5.5 1.5C5.5 1.22386 5.27614 1 5 1H0.5Z" fill="#6667A2"/>
</svg>
`;

    teaser += '</div></a>'
    + '<a href="' + t.linkUrl + '" target="_blank" class="teaser__body" rel="nofollow';

    if (t.external) teaser += ' sponsored';

    teaser += '"';

    teaser += listener;

    teaser += '>'
    + '<h3 class="teaser__body-title">'
    + t.title
    + '</h3></a></li>';

    return teaser;
  }
</script>
    <script type="text/javascript">
  // global vars
  var g_base_url = 'habr.com/ru';
  var g_base_fullurl = 'https://habr.com/ru/';
  var g_tmid_fullurl = 'https://account.habr.com/';
  var g_is_guest = false;
  var g_show_xpanel = false;
  var g_is_enableShortcuts = '1';
  var g_is_ugc_post = '';
  var g_is_company_post = '1';
  var g_current_hl = 'ru';
  var g_current_fl = 'ru';

</script>

    <script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/vendors.bundle.js"></script>
    <script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/main.bundle.js"></script>
      <script src="https://hsto.org/getpro/neuro-habr/2.1.1/neuro-habr.js"></script>

<script>
if (window.fetch) {
  var nh = window.neuroHabr;
  var host = 'https://b2b.ainews.kz/api';

  var projectId = '4bf28fae-b05a-4f44-b28e-9a0c4a658524';
  var widgetId = 'cab341f3-0932-4b6d-9664-d6b4d38dd2c5';

  nh.init(host, projectId, widgetId);

  var articleId = "536962";
  var articleLang = "ru";
  var articleCanonical = document.querySelector("link[rel='canonical']").getAttribute("href");

  if (articleId) {
    nh.send('p_view', articleId, articleCanonical, articleLang);
  }

  var nhState = {
    viewTime: 0,
    interval: null,
    scrolledDown: false,
    likeSent: false,
  };

  var hidden;
  var visibilityChange;

  if (typeof document.hidden !== 'undefined') { // Opera 12.10 and Firefox 18 and later support
    hidden = 'hidden';
    visibilityChange = 'visibilitychange';
  } else if (typeof document.msHidden !== 'undefined') {
    hidden = 'msHidden';
    visibilityChange = 'msvisibilitychange';
  } else if (typeof document.webkitHidden !== 'undefined') {
    hidden = 'webkitHidden';
    visibilityChange = 'webkitvisibilitychange';
  }


  var articleBody = document.querySelector('.post__body') || document.querySelector('.article__body');

  if (articleBody) {
    var MINIMUM_ARTICLE_READ_SECONDS = 10;

    var isInViewport = function(e) {
      if (!e) return false;
      var b = e.getBoundingClientRect();
      return b.top <= window.innerHeight && b.top + b.height >= 0;
    };

    var isAtTheEnd = function(e) {
      if (!e) return false;
      return e.getBoundingClientRect().bottom - window.innerHeight <= 0;
    };

    var hasReadArticle = function() {
      return nhState.scrolledDown && nhState.viewTime >= MINIMUM_ARTICLE_READ_SECONDS;
    };

    function incrementViewTime(e) {
      if (!nhState.likeSent && !nhState.interval) {
        nhState.interval = setInterval(() => {
          if (hasReadArticle()) {
            if (!nhState.likeSent) {
              nhState.likeSent = true;
              nh.send('p_like', articleId, articleCanonical, articleLang);
            }
            clearInterval(nhState.interval);
            nhState.interval = null;
          } else if (isInViewport(e)) {
            nhState.viewTime += 2;
          }
        }, 2000);
      }
    };

    incrementViewTime(articleBody);

    if (typeof document.addEventListener !== 'undefined' && hidden !== undefined) {
      document.addEventListener(visibilityChange, () => {
        if (!hasReadArticle() && !nhState.likeSent) {
          if (document[hidden]) {
            clearInterval(nhState.interval);
            nhState.interval = null;
          } else {
            incrementViewTime(articleBody);
          }
        }
      });

      document.addEventListener('scroll', () => {
        if (!nhState.scrolledDown) {
          if (isAtTheEnd(articleBody)) {
            nhState.scrolledDown = true;
          }
        }
      });
    } else {
      nhState.scrolledDown = true;
    }
  }
}
</script>


      <script src="https://dr.habracdn.net/habr/6001a5d9/javascripts/check-login.js"></script>
      <script type="text/javascript" src="https://habr.com/ru/viewcount/post/536962/"></script>

    
<!-- Yandex.Metrika counter -->
<script type="text/javascript">
(function(m,e,t,r,i,k,a){
  m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)};
  m[i].l=1*new Date();
  k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)
})(window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym");

    ym(24049213, "init", {
      clickmap:true,
      trackLinks:true,
      accurateTrackBounce:true,
      webvisor:true
    });
      if (window.ym) {
        var ymCounterId = '33905479';
        window.ym(ymCounterId, 'init', { defer: true });
        window.ym(ymCounterId, 'hit', window.location.href);
      }
</script>
<noscript>
  <div>
      <img src="https://mc.yandex.ru/watch/24049213" style="position:absolute; left:-9999px;" alt="" />
          <img src="https://mc.yandex.ru/watch/33905479" style="position:absolute; left:-9999px;" alt="" />
  </div>
</noscript>
<!-- /Yandex.Metrika counter -->

    <script type="text/javascript">
  function stripUrl(currentUrl, queryParam) {
   return currentUrl.replace(/\?([^#]*)/, function(_, search) {
      var result = search.split('&').map(function(param) {
        var regexp = new RegExp(`^${queryParam}`);
        if (regexp.test(param)) {
          return '';
        }
        return param;
      }).filter(Boolean).join('&');
      return result ? '?' + result : '';
    });
  }

  (function() {
    if (location.search.indexOf('cv') != -1 && history.replaceState) {
      var currentUrl = location.toString();
      var strippedUrl = stripUrl(currentUrl, 'cv');
      history.replaceState({}, '', strippedUrl);
    }
  })();

  function callGA(usesABP) {
    if (typeof window.adb1 === 'undefined') { window.adb1 = 'yes';}
    if (usesABP) { window.adb1 = 'aa'; }

    var user_type = 'guest';

    var page_type = "publish_corp_ru,c_ruvds,h_91,h_17681";

    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-726094-1',  'auto');
        ga('create', 'UA-726094-24', 'auto', {'name': 'HGM', 'allowLinker': true});

    ga('HGM.require', 'linker');
    ga('HGM.linker:autoLink', ['toster.ru', 'habr.com', 'account.habr.com', 'm.habr.com']);

    ga('require', 'displayfeatures');
    ga('set', 'dimension1', user_type); // user type - guest/readonly/habrauser
    ga('set', 'dimension2', page_type);
    ga('set', 'dimension3', 'na');
    ga('set', 'dimension4', window.adb1);
    ga('set', 'dimension6', 'ru');
    ga('set', 'dimension7', 'B');


    (function() {
      var removeUtms = function(){
        var location = window.location;
        if (location.search.indexOf('utm_') != -1 && history.replaceState) {
          var currentUrl = location.toString();
          var strippedUrl = stripUrl(currentUrl, 'utm_');
          history.replaceState({}, '', strippedUrl);
        }
      };
      ga('require', 'GTM-559GVC8');
      ga('send', 'pageview', { 'hitCallback': removeUtms });
    })();

    ga('HGM.set', 'dimension1', user_type);
    ga('HGM.set', 'dimension2', "habrahabr");
    ga('HGM.set', 'dimension4', window.adb1);

    ga('HGM.send', 'pageview');
  }


  if (window.habr_blockers_checker) {
    window.habr_blockers_checker.detectWrapper(callGA);
  } else {
    callGA(false)
  }

</script>

    <!-- Facebook Pixel Code -->
<img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=317458588730613&ev=PageView&noscript=1"/>
<!-- End Facebook Pixel Code -->

    <img src="https://vk.com/rtrg?p=VK-RTRG-421343-57vKE" style="position:fixed; left:-999px;" alt=""/>
    
  </body>
</html>
