Mikrotik Router OS, Ищем свой сервер в чужой сети. Или как не платить большие деньги

    Mikrotik Router OS, Ищем свой сервер в чужой сети. Или как не платить большие деньги



    Все мы не раз слышали о грандиозной поддержке малого бизнеса и частного предпринимательства в нашей стране. Пока ты физическое лицо, у тебя нет никаких проблем. Но как только ты собрался с мыслями и решил открыть свое дело, ты моментально попадаешь на деньги (конские проценты в банках, налоги, отчисления в ПФР, поборы, штрафы, инфляция, и прочая вата). Особенно отличились в этом плане провайдеры, если к простому домашнему пользователю требования минимальны, то к частным предпринимателям и организациям подход особенный. А именно: если ты арендовал нежилое помещение для работы, это означает что ты дойная корова и должен платить кучу денег провайдеру. Да, конечно очень хорошо, если вам удалось договорится с провайдером и составить договор на физическое лицо, ну или скажем недалеко живет ваш знакомый который согласен поставить wifi в форточку. Но если данные варианты не прокатывают, есть еще один способ не платить провайдеру кучу денег. :)

    Идея заключается в том, что в наше время не сложно найти провайдера с внутренней локальной сетью 10.0.0.0/255.0.0.0 или 192.168.0.0/255.255.0.0 и в ней организовать две точки (Физическое лицо с дешевым, безлимитным интернетом будет Сервером) (Организация с дорогим помегабайтным интернетом будет Клиентом) между ними поднимаем VPN.

    В принципе, никакой проблемы нет, если серые адреса у провайдера статические, ну а если нет, то нам придется воспользоваться DDNS сервисом в интернете т.к. локального сервиса может и не быть.

    image

    Полноразмерная пикча

    DDNS сервисов в интернете солидное количество, но большая часть из них отходит на задний план, потому что микротик не важно работает с ними, либо они не подходят для наших целей.

    Мы будем использовать DDNS сервис changeip.com по причине его поддержки начиная с версий 2.X

    В процессе разработки скрипта для отправки серого ip адреса возникла одна существенная проблема. Сервис changeip.com при каждом обновлении DNS имени проверяет принадлежность ip адреса, который был отправлен в сообщении, к сетям с первыми октетами 10 и 192.168. Если данная принадлежность имеет место, заменяет адрес, из сообщения на белый ip, который определяется автоматически сервисом changeip.com, и к нашему сожалению отключить эту опцию нельзя :(

    Было принято решение маскировать первый октет ip адреса перед отправкой, и заменять его обратно при получении.

    Серверная часть, параметры:

    :local interfacename ("eth1"); -Имя интерфейса локальной сети провайдера.
    :local replacement ("222"); -Маска для первого октета ip адреса, имейте ввиду, что количество цифр должно совпадать. Если маскируете 10. -устанавливайте 00-99, если 192. то 100-254.
    :local dnsname ("my.server.ddns.info"); -DNS имя для обновления.
    :local login ("login"); - Логин в changeip.com
    :local password ("password"); - Пароль в changeip.com


    Серверная часть, код:

    ##################################################
    #Server Part
    ##################################################

    #Settings
    ##################################################

    :local interfacename ("eth1");
    :local replacement ("222");
    :local dnsname ("my.server.ddns.info");
    :local login ("login");
    :local password ("password");

    ##################################################

    ##################################################

    :local CurrentDynDNSIP ([:resolve $dnsname]);
    :local TMPDynDNSIP ([/ip address get [/ip address find interface=$interfacename] address]);
    :local RealDynDNSIP ([:pick $TMPDynDNSIP 0 ([:len $TMPDynDNSIP]-3)]);
    :local ShortIP ([:pick $RealDynDNSIP ([:len $replacement]) ([:len $RealDynDNSIP])]);
    :local FakeIP ($replacement . $ShortIP);
    :if ($CurrentDynDNSIP != $FakeIP) do={/tool dns-update name=$dnsname address=$FakeIP key-name=$login key=$password};

    ##################################################
    #(C) Inlarion icq 429-587 mikrotik.axiom-pro.ru Copyright!
    ##################################################


    Описание:

    Принцип работы серверной части очень простой, с указанного интерфейса берется ip адрес, обрезается маска подсети, заменяется первый октет на маскирование и отправляется на changeip.com

    Клиетская часть, параметры:

    :local dnsname ("my.server.ddns.info"); -DNS имя с которого снимаем маскированный ip адрес.
    :local replacement ("192"); - Параметр для замены маскированного октета.
    :local gateoctet ("1"); - Параметр работает только в случае если :local internettype равен "ethernet" и если шлюз интернета провайдера отличается от 192.168.ХХХ.1 его можно изменить.

    :local internetname ("LAN"); - Имя интерфейса в который приходит интернет от провайдера.
    :local internettype ("ethernet"); - Тип интерфейса провайдера принимает два значения "ethernet" и любой другой.
    :local internetdns ("192.168.3.1"); DNS сервер провайдера.

    :local tunnelname ("ISP1"); - Имя интерфейса через который мы подключаемся к серверу.
    :local tunneltype ("pptp"); - Тип интерфейса, принимает два значения "pptp" или "l2tp".
    :local tunneldns ("192.168.90.1"); - DNS нашего PPTP или L2TP сервера.


    Клиентская часть, код:

    ####################################################
    #Client part
    ####################################################

    #Settings
    ####################################################

    :local dnsname ("my.server.ddns.info");
    :local replacement ("192");
    :local gateoctet ("1");

    :local internetname ("LAN");
    :local internettype ("ethernet");
    :local internetdns ("192.168.3.1");

    :local tunnelname ("ISP1");
    :local tunneltype ("pptp");
    :local tunneldns ("192.168.90.1");

    ####################################################

    :global internetgate (" ");

    ####################################################
    :if ( $internettype != "ethernet" ) do={
    :set internetgate ([/ip address get [/ip address find interface=$internetname] network]);
    } else={
    :set internetgate ([/ip address get [/ip address find interface=$internetname] network]);
    :local ShortIP ([:pick $internetgate 0 ([:len $internetgate]-1)] );
    :set internetgate ($ShortIP . $gateoctet);
    };
    ####################################################

    :if ($tunneltype = "pptp") do={
    /interface pptp-client monitor [/interface pptp-client find name=$tunnelname] once do={
    :if ($status != "connected") do={
    :if ($internetdns != [/ip dns get servers]) do={ /ip dns set servers=$internetdns; };
    } else={
    :if ($tunneldns != [/ip dns get servers]) do={ /ip dns set servers=$tunneldns; };
    };
    };
    };

    :if ($tunneltype = "l2tp") do={
    /interface l2tp-client monitor [/interface l2tp-client find name=$tunnelname] once do={
    :if ($status != "connected") do={
    :if ($internetdns != [/ip dns get servers]) do={ /ip dns set servers=$internetdns; };
    } else={
    :if ($tunneldns != [/ip dns get servers]) do={ /ip dns set servers=$tunneldns; };
    };
    };
    };

    ####################################################
    :local WWW ([:resolve changeip.com]);
    :local NIC ([:resolve nic.changeip.com]);
    :if ( [/ip route find comment="WWW_changeip.com"] = "" ) do={ /ip route add dst-address=$WWW gateway=$internetgate comment="WWW_changeip.com" };
    :if ( [/ip route find comment="NIC_changeip.com"] = "") do={ /ip route add dst-address=$NIC gateway=$internetgate comment="NIC_changeip.com" };
    :if ( [/ip route find comment="INTERNET_DNS"] = "") do={ /ip route add dst-address=$internetdns gateway=$internetgate comment="INTERNET_DNS" };
    :if ( [/ip route get [/ip route find comment="WWW_changeip.com"] dst-address] != $WWW) do={ /ip route set [/ip route find comment="WWW_changeip.com"] dst-address=$WWW gateway=$internetgate };
    :if ( [/ip route get [/ip route find comment="NIC_changeip.com"] dst-address] != $NIC) do={ /ip route set [/ip route find comment="NIC_changeip.com"] dst-address=$NIC gateway=$internetgate };
    :if ( [/ip route get [/ip route find comment="INTERNET_DNS"] dst-address] != $internetdns) do={ /ip route set [/ip route find comment="INTERNET_DNS"] dst-address=$internetdns gateway=$internetgate };
    ####################################################

    :if ($tunneltype = "pptp") do={
    :local CurrentVHNIP ([:resolve $dnsname]);
    :local TMPVHNIP ([/interface pptp-client get [/interface pptp-client find name=$tunnelname] connect-to]);
    :local ShortIP ([:pick $CurrentVHNIP ([:len $replacement]) ([:len $CurrentVHNIP])]);
    :local RealDNSIP ($replacement . $ShortIP);
    :if ($RealDNSIP != $TMPVHNIP) do={/interface pptp-client set [/interface pptp-client find name=$tunnelname] connect-to=$RealDNSIP; };
    };

    :if ($tunneltype = "l2tp") do={
    :local CurrentVHNIP ([:resolve $dnsname]);
    :local TMPVHNIP ([/interface l2tp-client get [/interface l2tp-client find name=$tunnelname] connect-to]);
    :local ShortIP ([:pick $CurrentVHNIP ([:len $replacement]) ([:len $CurrentVHNIP])]);
    :local RealDNSIP ($replacement . $ShortIP);
    :if ($RealDNSIP != $TMPVHNIP) do={/interface l2tp-client set [/interface l2tp-client find name=$tunnelname] connect-to=$RealDNSIP; };
    };

    ####################################################
    #(C) Inlarion icq 429-587 mikrotik.axiom-pro.ru Copyright!
    ####################################################


    Описание:

    Принцип работы клиентской части немного посложнее. В первую очередь происходит определение шлюза в интернет через дорогого провайдера. Вторым действием происходит проверка соединения с VPN сервером, если соединения нет, устанавливается DNS провайдера, если соединение есть, устанавливается DNS VPN-сервера. Третим шагом устанавиливаются/обновляются маршруты через основного провайдера для DNS и серверов changeip.com. Последним шагом является проверка ip адреса сервера в свойствах соединения с тем адресом который был получен от changeip.com с обрано-измененным октетом.

    В заключение хочется отметить, что данный способ не является нарушением условий договора, в случае если договор с провайдером заключен на вас, и вы же лично его и используете.
    Данный способ имеет очевидные минусы, про сильном отдалении клиента от сервера трафик будет проходить через подсети провайдера, и в каждой подсети помимо маршрутизаторов есть и умные свитчи с поддержкой QoS, которые во время «прайм-тайм», будут сводить на нет всю передачу.

    Чтобы избежать потери пакетов и сильно не попадать под QoS, желательно расположить сервер и клиент в одной подсети, либо обратить внимание на услугу «Платный межабонентский трафик» где передача информации идет между двумя белыми адресами абонентов одного провайдера. Данная услуга стоит от 2-15коп./Мб. и имеет такой же приоритет как и интернет трафик.
    Поделиться публикацией

    Комментарии 78

      0
      Подойдет лишь тем, кто не превышает трафик обычного юзера.
        0
        Все зависит от провайдера, у нас по данной схеме работают три организации. Ежемесячный трафик одной организации приблизительно 30-80 гигабайт.
        Понятно что это не подойдет тем, у кого лимиты на месяц.
        У меня лично на домашней машине которой пользуюсь только я, ежемесячный входящий трафик от 350 гигабайт, а исходящий за счет торрентов около 1 тб.
          0
          У нас для физ.лиц 200гб ограничение на безлимите, а для юр.лиц 10-15 раз дороже в месяц.
            +17
            200гб ограничение на безлимите
            Шикарная фраза, характеризующая бизнес.
              0
              Это только в России так, или за рубежом тоже есть ограничения для безлимитных тарифов?
                0
                За рубежом тарифы с ограничениями не называют безлимитами.
                  0
                  Ошибка провайдеров (их маркетологов) в том, что они продают такие безлимиты как _высокоскоростные_ безлимиты с ограничением скорости по выбору определённого количества траффика. Что и приводит к неприятию таких тарифов как безлимитных.

                  Если бы они их продавали как _низкоскоростные_ безлимиты с бонусом в виде первоначальных xyz гигабайт на высокой скорости то и не возникало бы никаких внутренних противоречий.
                    0
                    За рубежом на безлимитных тарифах есть понятие FUP (fair use policy).
            +10
            (по секрету) У меня домашний трафик больше, чем трафик двух контор с суммарным количеством пользователей больше 100шт.
              0
              Аналогичная ситуация — и ни один из многочисленных провайдеров так и не смог объяснить почему же цены для юрлиц в 10 раз выше, а качество обслуживания зачастую хуже чем у меня дома.
                +2
                тупо доят. на самом деле — ситуация смешная получается.
                  –3
                  Ничего не доят. 1 мегабит на точке обмена трафиком (скажем на рынке) стоит примерно столько, сколько вы в Москве платите за 10 Мегабит дома. Они, что должны в минус работать? Лично мое мнение, что домашние пользователи и пользуются интернетом дешево, только потому-что юрики платят хорошо. Т.е ваша оплата, символическая, для галочки.
                    +4
                    Не пи*дите.
                    Никто мегабитами не пириться.
                    Среднестатистический Гбит Московскому — питерскому провайдеру, с учетом икса стоит порядка 200 к руб.
                    Дак какого *уя брать с моего офиса за 256 кбит 5 круб? Мы потребляем трафик с 10 до 18 совсем внепики. И не грузим канал торентами, не качаем порево. Мне мои клиенты юрлица с менеджерами, бумагами и прочей фигней стоят рублей 100 в месяц.

                    Честно признайтесь, есть монополизм, есть дойные коровы. Будете доить их до последнего, когда распространение 4G убъет ваш монополизм.

                    И никому, НИКОМУ вас жалко не будет.
                      0
                      1 Мбит, взял как за единицу измерения. На Рынке за такие деньги берут от 100 мегабит и выше.

                      За 5 К вы получаете.
                      Гарантированный канал?
                      Персональный менеджер есть?
                      Быстро восстанавливают, если чего ломается?
                      Вообще как обслуживание?

                      Напишите мне ваш адрес в личку ваше ООО и вашего провайдера, я в силу своих возможностей постараюсь решить ваш вопрос.

                      4G это мобильный интернет. В офисе должен быть всеже проводной. Сам сижу Подмосковье в частном доме и плачу 1000р за 5 Мбит, после Москвы это мне сильно глаза резало.

                      Но сейчас я понимаю, в Москве нас было 300 Квартир по 300р, а тут я один в доме и у меня волокно.

                      По поводу пиринга, есть платный пиринг и бесплатный и много чего есть, но к сожалению, это не для этого поста тема. Для тех кто не знает, откуда у интернет ноги растут, им не понять ценообразование услуг.

                        +1
                        мЛя.
                        Ну хоть колегам не надо лапшу на уши вешать?
                        Знаю я ваше ценообразование, отличился даже тем, что 10 лет назад домовую сетку строил. Наг читаю, на MSK-IX присутствую, Кипчатову руку жал.

                        Кстати, что там продавцы проводной телефонии говорили о сотовых операторах лет 10 назад?
                          0
                          Иван, вы та уж точно все знаете. Че спорим та?

                          зы вас лично знаю :)
                            0
                            А ну да. Везде у нас Филаночка влезет, что бы мне доказать очевидные вещи.

                            Если всем интересно.
                            Огородный проезд дом 20 стр 4.
                            Провайдер.
                            Зебра — Телеком ( В этом заводе есть еще Совинтел с фантастическими ценами образца 1997 года и Тел, не сильно отличающийся от Зебры)
                            Насчет стабильности, ничем не стабильнее, например ADSL от Комстара. Падали, чинили не за час, и не за 2. Как то до следующего утра провалялись.
                            Персональный менеджер мне там требовался значительно реже, чем раз в год. 60 тр в год я плачу низачто. За статус юрлица и нахождение в БЦ.
                              0
                              Посмотрю, завтра что можно сделать. :)

                                0
                                Все же это Москва!
                                  0
                                  Ага.
                                  В иркутском офисе ценник на интернет НИЖЕ!
                                    0
                                    Вы лучше не спрашивайте, сколько инет в норильске стоит. уже пять лет туда ВОЛС тянуть с красноярска :) Я там дома за 64К платил 1000р, пока не строился куда надо ;)

                                    Про Юриков вообще молчу и все это при задержке в 600ms
                                      0
                                      Мда, Камчатка смотрит на вас непонимающе :)
                          0
                          Проводной интернет никогда не умрет. Так как есть стандарты и на мобильном интернете, были, есть и будут задержки. 90% ЮрЛицам не нужны задержки, им важен отличный интернет, бизнес-интернет. Чтоб все было быстро и классно. В противном случае, письмо, может не отправиться, потому что ваш 4G ip который за NAT, попал в блек лист и вообще ветка выросла у вас под окном и пока вы ее будете резать, ваш партнер опять чего не увидит, вовремя…

                          У меня кучу клиентов, которые слезли с 4G и очень довольны тем, что они не зависят от веток и спамеров. У них все быстро и красиво.
                            0
                            Мелких клиентов у вас рано или поздно уведут беспроводные сети. Так или иначе. Не для кого это не секрет.

                            Монополизм в бц не вечен.
                              0
                              У нас нет, монопольных объектов. Это так к сведению.
                              И например в БЦ класса А+ нельзя войти другим операторам по одной причине. Там все заложено при строительстве и городить провода, не хочется владельцу, вот и не пускают.
                              Дальше говорить не буду.
                                +1
                                Это монополизм в чистом виде.
                                Зайти на любой объект можно, так и просто перетыкнуть патчкорд из одного порта в другой.
                                  0
                                  А если нужно не переткнуть, а получить резервный канал? В Украине тоже тяжело зайти в БЦ. Самый дешевый способ который непросто выбить — провайдер оплачивает ремонт здания, и согласовывает дизайн прокладки с владельцами здания.
                      0
                      Тут все зависит от наглости.
                      А вообще в высокую стоимость входит.
                      1. Гарантированные каналы не шареные.
                      2. Надежная схема подключения.
                      3. Персональная схема подключения.
                      4. Связанность.

                      Да, согласен, клиент покупая гигабит, может не пользоваться им на 100%, скажем процентов на 40% использует и сколько таких? Но я вам могу сказать точно, как только канал подойдет к потолку, провайдер тут, же начнет его расширять. Все почему? Потому-что цены у этих клиентов соответствующие.

                      В случае с домашними пользователями, такого никогда не будет. Провайдер будет просто смотреть в потолок своей полосы и отвечать на звонки а в случае как в подмосковье, они просто не берут трубку и работают до 19. И вообще у них только одна линия. Как вам?

                  +2
                  Для нахождения «своего адреса» можно и не использовать dyndns, интернет соединение не нужно вообще.
                  Обычно подсеть всегда одинаковая для пользователя:
                  К примеру при текущем адресе 10.58.131.5/255.255.252.0
                  Считаем какие хосты принадлежат (http://www.ispreview.ru/ipcalc.html)
                  Получаем что то 10.58.128.1 — 10.58.131.254
                  Открываем дома какой либо порт (для примера iptables -A INPUT -p tcp --dport 54278 -j DELUDE, ну или тот же vpn перевесить на 54278)
                  Не из дома ищем nmap -p 54278 10.58.128-131.1-254
                  Для сети из ≈8200 хостов требуется 10-15 минут (личный опыт, трафик через разные районы)
                  И смотрим у какого хоста он открытый, тот и нужен.
                  Это долго, но ради дешевого интернета же.

                  К слову, мой провайдер предоставляет свой DynDNS для внутренних IP без какого либо дополнительного софта.
                    0
                    Конечно красивое решение, но к микротику никакого отношения не имеет.
                      +1
                      Да, я прочитал «что такое микротик» после того как написал этот комментарий.
                      –2
                      +1
                      Вообще, я всегда считал, что корпоративные Интернет-пакеты дороже потому, что в договоре указываются определенные гарантии скорости и стабильности подключения. По крайней мере так бы должно быть. У меня дома сейчас быстрый и дешевый безлимитный Интернет через локальную сеть, но раз в пол года где-нибуть горит магистральный свич и сеть может пропасть на сутки, например. Для домашнего пользователя это не критично, а вот для организации, которая работает с клиентами через Интернет, и у которой через два часа дедлайн, такая авария может привести к серьезным проблемам. При чем если в случае корпоративного пакета вы можете в ту же минуту перезвонить и потребовать восстановить подключение, то в случае с домашним пакетом это будет сложнее.
                      Все вышесказанное — сугубо мое ИМХО, опыта общения с провайдерами на такие темы не имею. Знаю только, что в организации, где я работаю, в случае любых проблем на стороне провайдера он часто сам перезванивает и говорит что случилось и когда восстановится. Ну и резервный канал от другого провайдера тоже есть, естественно.
                        +2
                        Я понимаю что в бизнес-центре, возможно есть резервирование канала и т.д. Но если юр.лицо располагается в цокольном/первом этаже жилого дома? Неужели для него специально будет отдельная линия, независящая от физ.лиц? Не верю!
                          +3
                          Единственное видимое отличие — втыкают в последний порт, а не по порядку как обычно. ;)
                            +2
                            Не могу говорить за всех провайдеров, могу говорить только за себя. Различия между пользователями физ. лицом и юр. лицом достаточно большие:
                            1) Одно из самых важных отличий — при оказании услуг для юр. лица провайдер устанавливает свое оборудование на территории Заказчика, то есть его зона ответственности заканчивается именно на вашей территории и отмазки типа у нас порвали кабель в вашем здании и мы за него не отвечаем — уже не действуют.
                            2) В нашем типовом договоре, как и во многих типовых договорах московских провайдеров четко прописаны сроки устранения неисправностей, например максимальных срок устранения неисправности без обрыва кабеля 6 часов, с обрывом кабеля 48 часов. В случае нарушения данных сроков клиент имеет право не оплачивать услугу оказанную в данный расчетный период. В договоре с физ. лицом никто и никогда оговаривать сроки не будет.
                            3) Для юр. лиц все нормальные провайдеры создают отдельные службы тех. поддержки и время ожидания ответа в них разнится кардинально. Например стандартное время ответа оператора в рабочее время у саппорта юр. лиц не более 2-х минут.
                            4) Не секрет, что среди физ. прльзователей большинство составляют те, кто использует интернет для простых нужд (почта, сайт) и загружают свои каналы примерно на 20-30%, юр. лица же зачастую используют свои каналы примерно на 70%, то есть нагрузка на сеть провайдера в любом случае днем будет выше чем вечером, когда люде вернуться с работы. Так как провайдер несет ответственность за предоставление услуги в полном объеме, то продажа 1 гигабитного волокна в виде 500 10 мегабитных каналов (как делают многие провайдеры физ. лиц, считая в среднем, что пользователь использует именно 20% от пропускной способности), то и затраты на такие линии увеличиваются в 5 раз.

                            Итого получается, что для юр. лиц должен быть более догорой саппорт, более качественное оборудование, больше затрат на обслуживающий персонал (менеджеры по продажам, финансисты, курьеры для доставки документов, проект менеджеры), приводит это все к тому, что обслуживаение 1 юр. лица для провайдера обходится примерно как обслуживание 15-20 физ. лиц. Так что когда вы в следующий раз будете ругаться на своего провайдера, сначала посчитайте все сами.
                              0
                              1) Надо смотреть где именно происходит подключение. Бизнес-центр или жилой дом. Какое именно подключение: оптика, витая пара, радио-канал.
                              2) home.corbina.ru/clientcare/agreement/#II пункт 4.5
                              3) Саппорт провайдера с графиком работы — это для меня признак плохого провайдера. Саппорт у провайдера должен работать 24/7.
                              4) Про нагрузку уже писали выше, сам обслуживаю несколько компаний, в суме в них человек 100. Их бизнес, с IT ни как не связан. Суммарный трафик up/down 1-1.2 терабайта. У меня дома 3.
                                +2
                                1) Я, конечно же, имел ввиду оптических провайдеров, так как цены на тот же адсл значительно ниже чем на оптику, радио, честно говоря, в расчет не брал, так как у них много своей специфики.
                                2) 4.5. В случае прекращения предоставления Услуг по вине Исполнителя свыше 4 часов, Исполнитель, по требованию Заказчика, вернет на лицевой счет Заказчика 1/720 (одну семьсот двадцатую) ежемесячной абонентской платы Заказчика за каждый час простоя, путем предоставления скидки в следующем календарном месяце. Время отсутствия Услуг учитывается начиная с момента обращения Заказчика в техническую службу Исполнителя.
                                Теперь давайте посчитаем, возьмем к примеру ту же корбину со стоимостью канала 12 Мбит/с 650 руб. и возьмем средний по Москве тариф за анлим 10 по оптике — 20 тыс. рублей без НДС, то есть 23600 руб. в месяц; в случае если заказчик потребовал возврата за неисполнение обязательств, то исполнитель заплатит физ. лицу 1/720*650 руб.=90 коп. за 1 час простоя, то есть если интернет не работал 30 дней то провайдер потеряет 650 рублей. Если говорить о юр. лице, то если интернет не работал больше 48 часов при обрыве кабеля то провайдер теряет 23 600 руб. Притом давайте еще и учитывать, что количество физ. лиц потребовавших возврата будет в разы меньше чем количество юр. лиц (в процентном соотношении, конечно).
                                3) Заметьте, я ни где не писал про то, что наш саппорт не круглосуточный, а написал что даже в рабочее время время ответа не более 2-х минут. Не искажайте мои слова!
                                4) Еще раз напишу, что таких как вы, кто за месяц скачивает 3 террабайта — очень и очень мало.
                                Так что вы можете сколько угодно считать и применять данные слова только на себя, но не забывайте, что не все пользователи потребляют услуги в том объеме в котором их потребляете вы.

                                  0
                                  Если бы Вы говорили о возмещении потерь клиента от отсутствия связи (скажем, есть клиенты, теряющие миллионы в час от этого отсутствия — а в БЦ альтернатив, скажем, нет, не мне Вам рассказывать, как оно бывает), то я бы возмещения как-то понял. Что на фоне миллиона за час ваши 1/720 от 23600, т.е. 32 рубля?!!! Про них (на что провайдеры и расчитывают) никто не вспоминает, ибо бумаг больше, чем вернется денег.

                                  Суровая такая ответственность, да.

                                  Про ответ в рабочее время — 2 минуты это просто сказка. Хорошо бы хоть за 10 минут дозвониться до (среднего провайдера), про нерабочее вообще молчать можно.
                                  0
                                  Должен быть отдельный саппорт для юр.лиц и для домашних сетей.
                              0
                              увы у нас на Украине не так насчет гарантий=)
                                0
                                Почитайте «Закон про телекомунікації». Провайдер, как организация, предоставляющая средства телекомуникации несет ответственность за качество каналов и устранение проблем. Согласно этого закона, если проблему (в моем случае был обрыв кабеля в доме) не устраняют в течении условленого законом срока, оператор телекомуникации начинает выплачивать пеню в Вашу пользу. Если у Вас проблемы с интернетом, пишете письмо на имя директора, с указанием пунктов этого закона, несете в компанию и регистрируете, если не принимают — отправляете заказным письмом с уведомлением о доставке. А потом наблюдаете с какой скоростью провайдер решает проблему с Вашим ДОМАШНИМ интернетом.
                                Проверено лично.
                                  0
                                  Да вы что?? Если вы не юзаете укртелекомовские 2Мbs, и потребляете по оптике\витой N Mbs — Будут у вас гарантии.
                                  0
                                  Ну был у нас договор с РосТелекомом. 30 страниц описания гарантированной скорости реакции на каждую мелочь. А по факту все решалось днями и неделями.

                                  Я не скажу, что они худшие. Просто есть стремление менеджмента взять высокие стандарты обслуживания, есть желание угодить заказчикам, а есть суровая такая реальность — что и как можно сделать в текущих условиях.

                                  Вообще, крупные конторы очень плохой пример для объяснения цен для юриков: у них уклад старый, они не могут взять, и все в 3 раза дешевле сделать. И поэтому поют байки про стандарты качества, про ответственность. Мне-то что, что с моих (пусть) 30 тыс в мес. за суточный простой мне вернули 1 тыс., если бизнес за это время потерял во много раз больше из-за отсутствия связи? SLA же прописать с реальными возмещениями хоть и можно, но тогда вместо 30 я заплачу (ой-сколько) тыс, а по факту ничего не получу, ибо еще надо будет доказать, что интернета, когда не было, действительно не было, а не чуть-чуть, но было.

                                  Из предельного маразма: серьезный оператор, при обрыве его радиолинка из-за того, что ураган повернул антенну, устами техдира отвечает (пофиг на договор!) — «я своих людей в такой ветер на крышу не пущу». Я его понимаю, но, простите, о чем мы говорим? За что тогда деньги? А когда 2 часа ночью я по телефону ищу хоть кого-то у них же, кто возьмется за мою проблему со связью, а мне говорят «ой, вы позвоните по номеру ..., может, они помогут?»

                                  4G не решение. Но конкуренции очень часто не хватает, чтобы нюх кое-кто (особенно — «мамонты» не терял).
                                  +1
                                  Мой офис по подобной схеме работает. есть понятие городского трафика по 6 коппек за мегабайт, и есть сервер в серверной левого провайдера подключён как физическое лицо.

                                  Реализовано на OpenVPN c опцией redirect-gateway def1
                                  трафик офиса на 20 человек составляет 60-100Гб в месяц. без органичения скоростей…
                                  Прямые безлимные тарифы у этого же провайдера стоят безумных денег.
                                    0
                                    если ты арендовал нежилое помещение для работы, это означает что ты дойная корова и должен платить кучу денег провайдеру
                                    слегка оффтопик: а разве у вас юридическому лицу не положено SLA и гарантированная полоса? и разве куча денег платится не за это?
                                      +1
                                      Положено. И техподдержка разная обычно и реагирует на заявки через разное время для физиков и юриков. Но на практике юрики также мультиплексируются как и физики, просто их трафик помечается более высоким приоритетом. Платить там в 10-15 раз больше не за что. Другое дело, что бизнес-модели провайдеров построены с расчетом привлечения низкими ценами на инет физиков (и набора большой абонбазы для более эффективного мультиплексирования), и при этом завышенными ценами для юриков, которые частично покрывают расходы на физиков — деваться то им [юрикам] обычно некуда :(
                                      0
                                      маленький офф: а чем нарисована такая картинка?
                                        0
                                        Похоже на MS Visio.
                                          0
                                          Нарисовано в Edraw Max
                                          0
                                          а почему нельзя было сделать так:
                                          1. 2 компа в одной сети провайдера (пингаются естественно)
                                          2. Один комп с дешевым инетом, второй с дорогим
                                          3. На дешевом поднимаем VPN-сервер или прокси и со второго дорогого конектимся к серверу с дешевым инетом?
                                          Если под виндой делать пойдет CCProxy
                                            0
                                            Когда сеть упадет из за повисшего коммутатора и поменяются ip адреса, что будете делать? Поедете в другой конец города конфигурировать роутер? Ну или как вариант с серверным скриптом получите ip роутера и будете ручками набивать новый ip сервера? А если адреса будут меняться по 5 раз в день?
                                            Задача данных скриптов полностью автоматизировать процесс и в случае внештатных ситуаций автоматически исправить свойства соединения без вашего внимания и участия.
                                            Что касается третьего пункта, забудте о прокси, никакой банальной секурности в нем нет, и скорее всего вас не столько хакнут, сколько вас запалит провайдер и резко скажет вам досвидос.
                                              0
                                              Когда сеть упадет из за повисшего коммутатора и поменяются ip адреса, что будете делать?

                                              если только у Вас в сети динамическая адресация, за всю практику видел только две сети (небольшие) где используется динамические ip-адреса. Ну в плане стабильности с Вами соглашусь
                                                0
                                                Извиняюсь за грубость, но вы видимо невнимательно читали пост. В посте явно сказано что адреса у провайдера динамические. И я думаю что многие специалисты согласятся со мной, что в большинстве случаев провайдеры выдают динамические адреса, причем не только адреса, но и маршруты средствами DHCP серверов, и как показывает практика, таких сетей значительно больше, просто потому, что если провайдер захочет изменить размеры подсетей, либо добавить еще пару маршрутов, не придется тревожить своих абонентов и заставлять вкалывать техническую поддержку.
                                                0
                                                Что касается третьего пункта, забудте о прокси, никакой банальной секурности в нем нет, и скорее всего вас не столько хакнут, сколько вас запалит провайдер и резко скажет вам досвидос.
                                                а то, что на машине с дорогим инетом нету внешнего трафика это Вас не выдает?
                                                  0
                                                  ну, я немного траффика по «дорогому» пускаю (route add 8.8.8.8 via ppp1 например)
                                                    0
                                                    Нет, не выдает, можно пускать часть трафика через основной канал, в любом случае схема проверена и спокойно отработала 2 года без претензий со стороны провайдера.
                                                    Куда проще отловить «физика» красиво смотрится на выходе трафик с разными цепочками TTL и Id пакетов… а если еще снифануть, что провайдер не имеет права делать, то может увидеть 50 асек, 60 ящиков и еще всего вкусного. Так что лучше брать инет от другого провайдера, либо лепить vpn куда нить подальше :)
                                                      0
                                                      сомневаюсь что из пары тысяч абонентов, провайдер будет снифать именно Вас, но опять же это личное мнение, статья интересная и информативная, спасибо.
                                                  0
                                                  Серый ip адреса иногда меняются.
                                                  Для этого и нужен DynDNS
                                                  0
                                                  Мне всегда было интересно, чем аргументируются такие цены на интернет для юрлиц, кроме «понимаешь, просто деньги очень нужны». Еще очень хотелось бы знать, как с этим обстоят дела в Европе/США. Кто-нибудь в курсе?
                                                    0
                                                    Варианты аргументации:
                                                    1. Мы тут в площадь (нового офиса например) вложились, надо проценты отбивать, вы уж поймите
                                                    2. Фин. клерки (не прознавшие про торренты) думают что частник поюзает инет немного днем, да и спать ляжет. А юрик будет забивать канал на 110% круглосуточно («у них ведь сервер»).
                                                    3. Заплатят, нах!, куда денутся, на клиентов своих расходы включат да и все.Чо париться.
                                                      0
                                                      Как-то всё неубедительно, все варианты.
                                                    0
                                                    Уже год как у нас в организации работает подобная система только без сторонних сервисов и автоматически переключает с физического канала на юридический если тот не доступен, при этом отправляя сообщение на мыло с информацией по какому каналу сейчас доступен интернет.
                                                      0
                                                      Скриптик на bash если нетрудно можете в личку кинуть — сам такое сейчас делаю (автопереключение)?
                                                        0
                                                        Представляю, сколько может уйти денег на дорогом канале, при таком раскладе, когда ответственного человека на месте не будет.
                                                          0
                                                          А не при таком раскладе в некоторых организациях могут сорваться сделки на 5 лямов и потом админа на че нить натянуть, за отсутствие отказоустоичивости.
                                                          Улавливайте основную мысль! Остальное все мелочи, любой параметр можно подкорректировать на любой системе и ничего, никуда не уйдет.
                                                            0
                                                            Такие сделки от интернета мало зависят :)
                                                            Если фирмачи просчитали час простоя своей конторы, то исходя из этого подбирается и канал, и (не)квалифицированный сисадмин.
                                                            В большинстве случаев это не делается и виноватым остается админ.
                                                        0
                                                        У нас провайдер особо не парился по поводу объема трафика. Дело было давно-сейчас это может быть изменилось.

                                                        Прямо рядом с офисом жила сотрудница. К ней и подключили безлимитный инет, в офис он залетал по вай-фаю. Однако, еще нескольким сотрудникам было дано право использовать офисный интернет по «внутренней» сети провайдера. Трафик был-мама не горюй! Но за пару лет никаких вопросов не возникло.
                                                          0
                                                          Кстати эту же схему можно использовать для связи двух офисов.
                                                          У нас используется для связи офисов между городами, так как mpls жутко дорогой.
                                                          Просто до жути!
                                                            0
                                                            Все замечательно, но в договорах большинства провайдеров есть пунктик типа
                                                            «абонент не имеет права на предоставление услуг поставщика третьим лицам»
                                                              0
                                                              Провайдеру, пофиг. Но если вас поймает, россвязьнадзор, вам же хуже будет.
                                                              0
                                                              У нас всё проще. Делают так. Берёшь самый дешёвый тариф ADSL и используешь на работе домашние имя пользователя и пароль. Скорость выше, дешевле (естественно эта сумма уже из своего кармана), есть возможность использовать статический IP.
                                                                0
                                                                Интересно, как быстро это могут вычислить и что за это будет?
                                                                  0
                                                                  Да собственно пока не встречалось такое. Если хозяин логина претензию предъявит, тогда возможно и будут последствия. А если логин твой, не будешь же на себя наезжать.
                                                                0
                                                                Не нае… шь — не проживешь. Особенности национального бизнеса.
                                                                С одной стороны — грабительские тарифы, с другой стороны — вот подобные извраты. Хорошо хоть диалап через IP-телефонию не предложили.
                                                                  0
                                                                  Кстати, напомнили. Немного абсурдная вещь. SIP-телефония с прямым городским номером у нас есть. Для всех вновь подключившихся юриков цена с тремя городскими номерами по цене интернета (в пределах 3 тысяч за 2 мегабита). Голосовой трафик примерно по цене трафика по обычному телефону. Всё бы хорошо, но технология ADSL уже подразумевает телефон :) Ну а физики конечно за 710 рублей могут получить 8 мегабит…
                                                                  0
                                                                  А у нас провайдер даже внутренний трафик для Юриков считает как внешний, хотя для физлиц. он бесплатный
                                                                    –1


                                                                    и

                                                                    Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.

                                                                    Самое читаемое