Краткие заметки по Cisco CCNA (часть ICND1)

  • Tutorial
Приветствую!

В этом посте я структурировал заметки, созданные вместе со слушателями на курсах в процессе повторения пройденного материала. Изначально все это делалось в блокноте. В посте нет детальных описаний и т.д. Добавил немного графиков и оформил по порядку. В общем, рассматривайте информацию, как краткие шпаргалки, которые можно почитать вечером перед сдачей экзамена, чтобы быстро все освежить в памяти. Если будет интересно, то можно выложить ICND2, да и много чего еще есть в таком же духе.

Сетевой уровень: IP


  • Длина адреса 32-bit
  • Для записи используется нотация Dotted-Decimal. Бьем на октеты по 8 бит, записываем в десятичном виде, отделяем точкой: 10.1.1.1

Классы адресов и правило первого октета:
Класс Диапазон адресов (первый октет) Длина сетевой/хостовой части Правило первого октета
A 1-127 8.24 0xxxxxxx
B 128-191 16.16 10xxxxxx
C 192-223 24.8 110xxxxx
D 224-239 Multicast 1110xxxx
E 240-255 Экспериментальный 1111xxxx

Проблема нехватки IP адресов и ее решения:

1. Private / Public адреса
  a. A 10.x.x.x
  b. B 172.16.x.x — 172.31.x.x
  c. C 192.168.x.x
2. Subnet Mask / VLSM / CIDR
3. NAT
4. IPv6

Транспортный уровень: UDP/TCP


Протокол Характеристики
TCP Надежный (Reliable) Формирует предварительно соединение (Connection-oriented)
UDP Ненадежный (Best-Effort) Соединение не формируется (Connectionless)

Процесс формирования соединения TCP (3-Way Handshake):

image

TCP-Window:
  • Возможность отправить N-сегментов данных и получить единственный ACK.
  • Fixed (размер окна фиксирован) & Scaling (размен меняется в течение сессии) Window.

Работа с Cisco IOS


Процесс загрузки:
  1. BIOS > POST
  2. BIOS > Bootstrap
  3. Bootstrap > IOS
  4. IOS > Startup-config

Способы конфигурирования:
1. CLI
  a. Console
  b. AUX (Routers)
  c. VTY (Telnet/ssh)
2. GUI
  a. Web Server (жуть)
  b. SDM
3. SNMP

Конфигурационные режимы:
Название Описание Приглашение Вглубь Вверх
USER EXEC Пользовательский режим. Прав почти нет. > enable exit
logout
PRI EXEC Привилегированный режим. Права администратора. Логирование, дебаг. Переход в конфигурационные режимы. # configure
terminal
Exit
Logout
Disable
GLOBAL
CONFIG
Режим глобального конфигурирования. Настраиваются параметры, влияющие на устройство в целом. (config) # Interface …
Vlan …
Router …
Controller …
Exit
CTRL-Z (сразу в PRI EXEC)
SUB
CONFIG
Настраиваем интерфейсы, вланы, протоколы маршрутизации и т.д. (config-if)#
(config-line)#
И д.р.
  Exit
CTRL-Z (сразу в PRI EXEC)

Получение справки:
  • ? — все команды режима
  • ab? — команды, начинающиеся на ab
  • command? — аргументы команды command

Базовая настройка коммутатора


!
! Задаем имя устройства и название домена. FQDN требуется для настройки SSH.
!
hostname SW1
ip domain-name CISCO.LOCAL
!
! Создаем виртуальный L3 интерфейс. Закидываем его в 1-ый vlan. Назначаем IP. 
! Включаем.
! Чтобы интерфейс поднялся, требуется хотя бы 1 активный интерфейс в указанном Vlan.
!
interface vlan 1
 ip address 1.1.1.1 255.0.0.0
 no shutdown
!
! Default Gateway в глобальном режиме. Для администрирования коммутатора из других 
! сетей.
!
ip default-gateway 1.1.1.254
!


Базовый Security


!
! Защита подключений (USER EXEC).
!
! Защита подключений к консольному порту
!
line console 0
 login					-- включение аутентификации по паролю
 password PASSWORD			-- пароль для аутентификации
!
! Защита подключений по сети. Виртуальные терминалы (vty).
! Настраиваем и разрешаем только протокол SSH.
!
! Создание пользователей
!
username ROOT secret CISCO
username ADMIN secret OCSIC
!
! Включение SSH и генерация ключей
!
crypto key genereate rsa
!
! Настройка vty портов
!
line vty 0 15
 login local                    -- аутентификация по базе пользователей и паролей
 transport input ssh    -- разрешаем только подключения по SSH
!
! Защита перехода в привилегированный режим
!
enable password OCSIC      -- пароль хранится в открытом виде
enable secret CISCO             -- пароль хранится в виде хэша
!
! Шифруем пароли, хранимые в открытом виде
!
service password-encryption
!
! Создание баннера
!
banner motd @
------------------------------------------------------
Unauthorized access is blah-blah-blah
---------------------------------------------------- @
!
! Безопасность портов (Port-Security)
!
interface fa0/1
 switchport mode access
! Определяем безопасные (легальные) адреса:
! -- максимальное количество легальных адресов
 switchport port-security maximum 10	
! -- статическое указание легального адреса
 switchport port-security mac-address 0001.0002.0003 	
! -- динамическое определение легальных адресов и их запись в running-config
 switchport port-security mac-address sticky	
 switchport port-security violation shutdown	-- в случае нарушения, выключить порт
 switchport port-security      -- включение port-security на интерфейсе


Проверка:

show running-config    -- текущий файл конфигурации
show startup-config     -- загрузочный файл конфигурации
	
show int	                         -- информация по интерфейсам
show int vlan 1
show int fa0/1
show ip int brie

show port-security       -- проверка безопасности портов	
show port-security int fa0/1
show port-security address

show version                -- информация об устройстве


Сохранение файла конфигурации:

copy running-config startup-config


Маршрутизация


Metric – выбор маршрута внутри протокола.

Administrative distance (AD) – выбор маршрута между протоколами. От 0 до 255. Меньше = лучше.
Протокол Метрика AD
Connected - 0
Static - 1
EIGRP Metric = 256*(BW+Delay) 90
OSPF Cost = 100/BW Mbps 110
RIP Hop Count 120

Классы протоколов:
  • Distance Vector (RIP, IGRP, EIGRP)
  • Link-State (OSPF, IS-IS)


Маскирование


Пример 1:

192.168.2.0/24

11000000.10101000.00000010. 00000000 192.168.2.0 /24 network

11111111.11111111.11111111. 00000000 255.255.255.0 mask

11000000.10101000.00000010. 00000001 192.168.2.1 1 host

11000000.10101000.00000010. 11111110 192.168.2.254 Last host

11000000.10101000.00000010. 11111111 192.168.2.255 Broadcast

Пример 2:

Данный диапазон 195.1.1.0 /24 разделить на посети:
  • 2 сети по 30 хостов
  • 4 сети по 6 хостов
  • 2 транспортных сети


1. 30 hosts		2^n-2 >=30	n=5
                           ---------
11000011.00000001.00000001.000 00000	195.1.1.0 /27			Subnet Zero
11111111.11111111.11111111.111 00000 	255.255.255.224
11000011.00000001.00000001.000 00001	195.1.1.1 /27			1 host
11000011.00000001.00000001.000 11110	195.1.1.30 /27		last host
11000011.00000001.00000001.000 11111	195.1.1.31 /27		broadcast

11000011.00000001.00000001.001 00000	195.1.1.32 /27		Вторая сеть
11000011.00000001.00000001.001 00001	195.1.1.33 /27
11000011.00000001.00000001.001 11110	195.1.1.62 /27
11000011.00000001.00000001.001 11111	195.1.1.63 /27

11000011.00000001.00000001.010 00000	195.1.1.64 /27		Третья …
11000011.00000001.00000001.010 00001	195.1.1.65 /27
11000011.00000001.00000001.010 11110	195.1.1.94 /27
11000011.00000001.00000001.010 11111	195.1.1.95 /27

11000011.00000001.00000001.011 00000	195.1.1.96 /27
11000011.00000001.00000001.011 00001	195.1.1.97 /27
11000011.00000001.00000001.011 11110	195.1.1.126 /27
11000011.00000001.00000001.011 11111	195.1.1.127 /27

...

11000011.00000001.00000001.111 00000	195.1.1.224 /27
11000011.00000001.00000001.111 00001	195.1.1.225 /27
11000011.00000001.00000001.111 11110	195.1.1.254 /27
11000011.00000001.00000001.111 11111	195.1.1.255 /27

2. 6 hosts		2^n-2 >=6	n=3

11000011.00000001.00000001.010 00 000	195.1.1.64 /29
11111111.11111111.11111111.111 11 000	255.255.255.248
11000011.00000001.00000001.010 00 001	195.1.1.65 /29
11000011.00000001.00000001.010 00 110	195.1.1.70 /29
11000011.00000001.00000001.010 00 111	195.1.1.71 /29

11000011.00000001.00000001.010 01 000	195.1.1.72 /29
11000011.00000001.00000001.010 01 001	195.1.1.73 /29
11000011.00000001.00000001.010 01 110	195.1.1.78 /29
11000011.00000001.00000001.010 01 111	195.1.1.79 /29

11000011.00000001.00000001.010 10 000	195.1.1.80 /29
11000011.00000001.00000001.010 10 001	195.1.1.81 /29
11000011.00000001.00000001.010 10 110	195.1.1.86 /29
11000011.00000001.00000001.010 10 111	195.1.1.87 /29

11000011.00000001.00000001.010 11 000	195.1.1.88 /29
11000011.00000001.00000001.010 11 001	195.1.1.89 /29
11000011.00000001.00000001.010 11 110	195.1.1.94 /29
11000011.00000001.00000001.010 11 111	195.1.1.95 /29

3. 2 hosts n=2

11000011.00000001.00000001.010 10 0 00	195.1.1.80 /30
11111111.11111111.11111111.111 11 1 00 	255.255.255.252
11000011.00000001.00000001.010 10 0 01	195.1.1.81 /30
11000011.00000001.00000001.010 10 0 10	195.1.1.82 /30
11000011.00000001.00000001.010 10 0 01	195.1.1.83 /30

11000011.00000001.00000001.010 10 1 00	195.1.1.84 /30
11000011.00000001.00000001.010 10 1 01	195.1.1.85 /30
11000011.00000001.00000001.010 10 1 10	195.1.1.86 /30
11000011.00000001.00000001.010 10 1 11	195.1.1.87 /30


Терминология:

195.1.1.0 /24			Network (Маска = класс)
195.1.0.0 /16			Summary (Маска < Класс)
195.1.1.0 /30			Subnet (Маска > Класс)
195.1.1.1 /32			Host (Маска = 32)
0.0.0.0 /0			Default Route


Использование роутера в качестве DHCP-сервера


image

Настройка RTR-DHCP:

! Исключающий диапазон (адреса роутеров)
!
ip dhcp excluded-address 1.1.1.1 
ip dhcp excluded-address 2.1.1.2 2.1.1.20
!
! Создание пула адресов для сети 1.1.1.0 (подключенная)
!
ip dhcp pool NET1
 network 1.1.1.0 255.255.255.0			-- пул адресов
 default-router 1.1.1.1				-- шлюз по умолчанию
 dns-server 1.1.1.1 8.8.8.8			-- DNS сервера
!
!
! Создание пула адресов для сети 2.2.2.0 (удаленная, через relay)
!
ip dhcp pool NET2
 network 2.2.2.0 255.255.255.0			-- пул адресов
 default-router 2.2.2.1				-- шлюз по умолчанию
 dns-server 1.1.1.1 8.8.8.8.			-- DNS сервер

Проверка:
Sh ip dhcp bindings
Sh ip dhcp conflicts
Sh ip dhcp s


Настройка RTR-RELAY:

! Проброс широковещательных пакетов на указанный адрес

int fa0/1
 ip address 2.2.2.1 255.255.255.0		-- интерфейс в удаленной сети 2.2.2.0	
 ip helper-address 1.1.1.1				-- куда пробрасывать (адрес DHCP)
!
! Пробрасываем только UDP67 бродкасты
Ip forward-protocol udp 67


Удаленный доступ (telnet / ssh)


Команды клиента Описание
1.1.1.1
HOSTNAME
telnet 1.1.1.1
ssh -l USERNAME 1.1.1.1

Открыть соединение
CTRL+SHIFT+6 – X возврат в локальную сессию
show sessions просмотр соединений
ENTER-ENTER возврат в последнюю активную сессию (*)
2
Resume 2
возврат в соединение #2
disconnect 2 закрыть соединение #2
Команды сервера Описание
Show users кто подключен
Send Чат
Clear line vty 1 отключить vty 1
Show ssh просмотр ssh соединений

WAN


PPP:
     1. LCP = Link Control Protocol
                a.  Compession
                b.  Error Detection
                c.  Authentication

     2. NCP = Network Control Protocol
                a.  IPCP
                b.  IPV6CP
                c.  CDPCP


Настройка Serial интерфейсов:
show controllers 			-- определяем DCE или DTE
!
interface serial 1/0		 
 clock rate 64000			-- скорость в bps (на DCE интерфейсе)
 bandwidth 64			-- используется для расчета метрики (kbps)
 encapsulation ppp		-- устанавливаем инкапсуляцию
 ip address 4.4.4.1 255.255.255.252
 no shutdown	
! 

Для проверки:
Sh interface s1/0
Sh controllers s1/0


Протокол RIP


Протоколы на 3 уровне:
  • Routing (RIP, OSPF, EIGRP)
  • Routed (IP, IPv6, IPX, AppleTalk)

Протоколы маршрутизации:

  • IGP — Inside AS (RIP, OSPF, EIGRP)
  • EGP — Between AS (BGP)

Классы протоколов маршрутизации:
  • Distance-Vector: RIP, IGRP
  • Advanced Distance-Vector: EIGRP, BGP
  • Link-State: OSPF, IS-IS

Поддержка VLSM/CIDR:
  • Classfull (RIPv1, IGRP)
  • Classless (RIPv2, BGP, OSPF, EIGRP, IS-IS)

Шаги настройки:
  • 1. Включить протокол маршрутизации
  • 2. Выбрать локальные интерфейсы. Выбор интерфейса означает, что:
  • a. Интерфейс отправляет апдейты
  • b. Интерфейс получает апдейты
  • c. Сеть интерфейса будет включена в апдейты

RIP:
RIPv1 RIPv2
Классовый Бесклассовый
UDP520 UDP520
Обновления отправляет на 255.255.255.255 Обновления отправляет на 224.0.0.9
Поддерживает аутентификацию
Поддерживает ручное суммирование

image

RTR-A
sh ip interface brief	-- посмотрели интерфейсы
!
router rip			-- включили RIP
 version 2			-- включили RIPv2
 network 1.0.0.0		-- выбираем локальные интерфейсы. В RIP – классовые сети
 network 2.0.0.0
 no auto-summary		-- отключаем автосуммирование (роутер будет передавать 
!				подсети, вместо адресов классовых сетей) 


RTR-B:
router rip			
 version 2			
 network 2.0.0.0
 no auto-summary


Проверка:
show ip protocols
show ip route rip 
show ip rip ?
debug ip rip


Управление


Поиск IOS в процессе загрузки:
  1. NVRAM:config-register
  2. NVRAM:startup-config (команды boot system)
  3. Первый файл IOS из Flash:
  4. Если не нашел, то 3 раза пытается найти IOS на tftp (бродкастом)
  5. ROMMON

Конфигурационный регистр:
•	16 бит
•	Каждый бит как-то влияет на процесс загрузки
•	За поиск IOS отвечают биты c 0 по 3-ий: 
              o   0x0	ROMMON
              o   0x1	Boot IOS from ROM
              o   0x2-F	Standard boot


Просмотр и изменение:
Show version
Config-register 0x2100		-- загрузка в ROMMON (последний 0)

IOS Update
sh flash		-- убедиться в наличии свободного места
dir flash


Если свободного места для копирования нового IOS нет:
#copy flash:ios.old tftp://1.1.1.1		-- Backup старый IOS (на всякий)
! Освобождаем место: 
! Форматирование flash (если не жалко)
#erase flash:						
! Или удаляем отдельные файлы
#del flash:ios.old			
!
#copy tftp://1.1.1.1/newios flash:		-- Копируем новый IOS
! 
#reload						-- Перезугружаемся


Если свободное место есть:
#copy tftp://1.1.1.1/newios flash:		-- Копируем новый IOS
(config)#boot system flash:newios		-- Инструктируем загружаться в новый IOS
#copy running startup				-- Сохраняем конфиг
#reload						-- Перезагружаемся


IOS Recovery:

ROMMON > tftpdnld

Password Recovery:

  • Перезагружаемся (выключаем)
  • Жмем CTRL-Break
  • Попадаем в ROMMON


! В ROMMOM меняем в конфигурационном регистре 6-ой бит (2142). Значение бита – 
! игнорировать загрузочный конфиг
ROMMON>confreg 0x2142		
! Перегружаемся
ROMMON>reset

! Startup-config при загрузке будет проигнорирован. Восстанавливаем его.
#copy startup runn
! Возвращаем конфигурационный регистр
(config)#config-register 0x2102
! Меняем пароль
(config)#enable secret cisco
! Сохраняем конфиг
#copy runn start

Дополнительные команды, связанные с мониторингом и управлением

show tech-support | redirect tftp://1.1.1.1/filename		-- показать все
show processes					-- использование CPU и RAM
show processes cpu history
Поделиться публикацией

Комментарии 43

    0
    Хороший конспект, спасибо!
    У меня не хватило пороху переписать из блокнота.

    Единственное, я бы перед описанием настройки упомянул аппаратную конфигурацию — что, как, с чего, куда консольный кабель втыкать.
      0
      Не забывайте про отложеную перегрузку при конфиге устройства, которое находится далеко от вас. Бывает, что сильно помогает :)

      router#reload in 30

      (перегрузка через 30 минут)
        0
        Паршивое решение. Надо делать configure replace — он не перезагружает железку целиком, а сравнивает текущую конфигурацию с указанным конфигурационным файлом, находит несоответствия и вводит команды для устранения несоответствий. В том числе по таймеру.

        www.cisco.com/en/US/docs/ios/fundamentals/configuration/guide/cf_config-rollback.html#wp1146581

        Все-таки курс CCNA сильно оторван от жизни. Например, ну кто в реальной жизни делает «copy runn start»? Покажите мне этого человека, я хочу убедиться, что он действительно существует.
          0
          Пусть паршивое, но универсальное и работает везде, в отличие от configure replace.
            0
            А где (из IOS либо IOS XE устройств) не работает config replace?

            «Reload in» лучше не использовать никогда, кроме как в качестве дополнительной страховки (в случае острой паранойи) — к примеру, replace через 2 минуты и reload in через 5, если первый что-то сломает. Хотя ни разу с таким не сталкивался.
              0
              На старом железе и со старыми иосами не работает. Также не нашел этой фичи в ASA/PIX. Такого добра у нас еще много, оно работает и менять живое железо нету смысла. Например с2621, с2509, С2950…
                0
                Сочувствую.
                Но это не отменяет того факта, что на железе, которое не «древнее как говно мамонта и объявлено EOL чуть ли не в прошлом веке», надо пользоваться современными средствами. И желательно сразу к ним привыкать.
                  0
                  Зачем же сразу привыкать. Наверное для того, чтобы, столкнувшись потом с железкой, где эта фича не работает (в жизни все бывает, да), вспоминать, как же называлась та команда, которая позволяла перегруз по заданому времени? :)
                  Я за универсальные решения. Хотя «config replace» хороша, спору нет.
                    0
                    Ну я вот например очень привык к командам ios.sh. Очень удобно сделать «show XXX | grep YYY | grep -v ZZZ | wc -l» или что-то вроде того. Но работает оно только на софтовых роутерных платформах с иосом 15.1.4М и выше. Тем не менее, это не мешает получать массу удовольствия от использования этой фичи там, где она поддерживается.
            +1
            Хм… а чем copy runn start не угодил?? я так делаю, например. поделись мудростью почему не стоит и как стоит делать?

            или ты про wr? )
              +1
              или ты про wr? )

              Само собой.
              Почему не стоит? Много букв. И любая цискина платформа умеет либо «wr», либо в крайнем случае «wr mem» (ACE/CSS).
                0
                да не это ясно, я думал есть какая-то глубинная мудрость ) в духе той же архивации конфига каждые 10 мин.
                  0
                  А можно поподробнее?
                    0
                    Что именно поподробнее?
                0
                Я делаю.
              0
              Стоит ещё добавить секцию про t1/e1 и секцию про frame relay. К сожалению, очень часто попадаются на практике tdm-потоки, да и fr ещё многие любят.
                +1
                … и ещё — у большинства цыскиных свитчей rommon включается не кнопкой контрол-брык, а надо выдернуть кабель питания, зажать кнопочку на морде (смена режима индикации которая), удерживаяя её воткнуть кабель питания, чуть подождать начала загрузки и отпустить кнопку.
                  0
                  FR никто не любит :)
                  0
                  Господа, это заметки с курса ICND1. Я сразу предупредил про «неполноту» этих заметок. Есть “configure replace” -можно спорить про полезность команды (не всегда и не везде); есть команда “archive” (полезна). Да и вообще, Cisco свой банальный менеджмент маскирует, много чего примитивного есть в TSHOOT, IINS. В общем, разбросано. Да, многие из вас правы – доки с cisco.com.

                  Цель поста немного другая – расшевелить интересующихся cisco, развлечь спецов. Может кто добавит, чего-нибудь и будет нормальный русский гайд.
                    0
                    Дык никаких претензий к вам, претензии есть к курсу.
                    0
                    очень хорошо структурировано.
                      0
                      >Поддержка VLSM/CIDR…

                      Не совсем верно указано.

                      Classfull — RIPv1 и IGRP — С этим согласен.
                      Но! Classless, (он же CIDR) это только RIPv2.
                      А вот BGP, OSPF, EIGRP и IS-IS это уже не просто CIDR, а ещё и VLSM.

                      Принципиальная разница в том, что RIPv2 не умеет VLSM, поэтому некорректно ставить его в один ряд с OSPF и прочими.
                        0
                        RIPv2 не умеет VLSM

                        www.ciscopress.com/articles/article.asp?p=102174&seqNum=4

                        RIPv2 improves upon RIPv1 with the ability to use VLSM, with support for route authentication, and with multicasting of route updates. RIPv2 supports CIDR

                        А расскажите-ка своими словами про разницу между CIDR и VLSM :)
                          0
                          Что вы понимаете под «не умеет VLSM»? RIPv2 маску в апдейтах передает, как и прочие classless протоколы. Хоть subnets (no auto), хоть суммарные (ip summary-address rip…). Т.е. умеет.
                            0
                            CIDR — предполагает что маска сети может отличаться от классовой и предлагает форму записи таких масок в виде длины префикса. Да, RIPv2 передаёт в пакете маску подсети и она может отличаться от стандартных масок классовых сетей.

                            VLSM — предполагает дробление одной классовой сети на множество подсетей более узких (речь идёт именно про подсети — SUBNET MASK), но с переменной длинной префикса (собственно в этом и заключается VARIBLE LENGTH). Да, RIPv2 может передать информацию о нескольких подсетях входящих в одну сеть с маской более узкой, чем классовая и даже c разной длиной префикса.

                            Но! В RIP (независимо от версии) вы не можете указать в команде network маску, а выполнение комнады «network 10.10.10.0», например, в конфиге превратится в 10.0.0.0 фактически с маской /8. RIP умеет охватывать только всю классовую сеть целиком. Конечно можно использовать passive-interface и distribute list'ы, но это уже костыли.

                            В случае если у вас на роутере все интерфейсы из диапазона 10.0.0.0/8, и вам нужно через один из них поднять RIP с соседом, но не сообщать ему о своих остальных сетях, а только принимать маршруты от него, то эта задача решается только с помощью distribute-list'ов. В OSPF, EIGRP или BGP этот вопрос закрывается командой network c узкой маской (как правило /30 на транзитных сетях).

                            Я наверное погорячился на счёт того что RIPv2 совсем не умеет VLSM. С точки зрения передачи информации о сетях — конечно умеет, но вот с точки зрения настроек самого протокола маршрутизации — нет.
                              0
                              CIDR — предполагает что маска сети может отличаться от классовой и предлагает форму записи таких масок в виде длины префикса.

                              CIDR может существовать без VLSM?
                              В RIP (независимо от версии) вы не можете указать в команде network маску, а выполнение комнады «network 10.10.10.0», например, в конфиге превратится в 10.0.0.0 фактически с маской /8.

                              Я паршиво помню RIP, но из того, что помню: требуется одна команда, чтобы анонс сетей начал производиться в точности как на OSPF/EIGRP. То ли ":ip classless", то ли просто «version 2». В итоге можно привычно указать адрес и инверсную маску.

                              Вы, кстати, в курсе, что и в RIP, и в EIGRP, и в OSPF инверсная маска после «network» не имеет ни малейшего отношения к маске подсети? ;)
                                0
                                CIDR может существовать без VLSM?

                                Да, если это суммаризация сетей, у нас может быть сеть класса B (172.0.0.0), а маска /8. Т.е. маска отличается от классовой, но речь не идёт про VLSM, так как это суперсеть, а не подсеть.
                                В прочем это уже скорее тавтология ))))

                                В итоге можно привычно указать адрес и инверсную маску.

                                Увы, нельзя. Ip classless не помогает.

                                Вы, кстати, в курсе, что и в RIP, и в EIGRP, и в OSPF инверсная маска после «network» не имеет ни малейшего отношения к маске подсети? ;)

                                1) Я по прежнему настаиваю на том, что в RIP указать маску нельзя, ни прямую ни инверсную.
                                2) Ну в том же OSPF она только обратная и используется и указывает именно на МАСКУ. Не понял, что вы имели ввиду?
                                  0
                                  Да, если это суммаризация сетей

                                  Правильный ответ — нет.
                                  CIDR — концепция отказа от классовых масок.
                                  VLSM — возможность передавать префиксы с маской.
                                  Я по прежнему настаиваю на том, что в RIP указать маску нельзя

                                  Да, я был не прав. Но: это лишь особенность работы команды network. Во всех анонсах маска передается. Соответственно — VLSM полностью поддерживается.
                                  в том же OSPF она только обратная и используется и указывает именно на МАСКУ

                                  То есть если есть интерфейс 10.0.0.1/24, и в процессе OSPF сказать «network 10.0.0.1 0.0.0.0 area 0», то OSPF на данном интерфейсе не заработает?
                                    0
                                    Что-то я вас совсем не понимаю…

                                    Заработает, так как в команде network указана сеть 10.0.0.1 и маска 0.0.0.0, которая объявляет все биты этой сети значимыми, а на интерфейсе у нас ровно то же занчение — 10.0.0.1. Т.е. OSPF вот только на этом интерфейсе и заработает (ну при условии, что нет других команд network).

                                    Но ведь 0.0.0.0 — это и есть МАСКА, которая указывает нам какие биты считать значимыми, а какие нет.

                                    А ну да… к маске ПОДСЕТИ это точно не имеет никакого отношения! Это другая МАСКА. Конечно, согласен. Не учёл слово «подсети», получилось, что «инверсная маска после «network» не имеет ни малейшего отношения к маске», что и вызвало непонимание.
                                      0
                                      А ну да… к маске ПОДСЕТИ это точно не имеет никакого отношения!

                                      Поднимаем переписку:
                                      «инверсная маска после «network» не имеет ни малейшего отношения к маске подсети»
                                      «в том же OSPF она [маска] только обратная и используется и указывает именно на МАСКУ»
                                      Так на какую маску указывает инверсная маска? :)

                                      Эх, жалко, что softline_education всё испортил подробным объяснением :)
                                        0
                                        Я прекрасно представляю, на что указывает МАСКА в команде network в OSPF и EIGRP.
                                        Распространённым мифом, про который он упомнил не страдал и не страдаю.

                                        Маска — она и в Африке маска и указывает именно на маску, очевидно же! )))))
                                          +1
                                          Эх, красиво отмазывается :)
                              0
                              промахнулся с ответом…
                                0
                                что-то тупит у меня хабр, не мог я три раза промахнуться, пытаясь ответить JDima!
                                )))))))
                                  0
                                  Да вроде все правильно…
                              0
                              VLSM и CIDR обуславливают возможность отказаться от класса сети ииспользовать для определения сетевой\хостовой части маску. Маска включается для передачи информации о сетях. RIPv2 это все умеет.

                              Другой момент, о котором вы указали, состоит в том, что реализация RIPv2 в IOS не позволяет выбрать конкретные интерфейсы, участвующие в работе протокола. OSPF, EIGRP позволяет вам четко выбирать интерфейсы, указывая маску. Синтаксис OSPF/EIGRP: network 10.1.1.0 0.0.0.255 …

                              К примеру:
                              fa0/0 10.1.1.1/24
                              fa0/1 10.2.2.1/24

                              Ospf или EIGRP (с EIGRP используем no auto-sum):
                              Network 10.0.0.0 0.255.255.255
                              Отдаст две сетки 10.1.1.0 и 10.2.2.0/24

                              Network 10.1.1.0 0.0.0.255
                              Отдаст только 10.1.1.0/24

                              RIP:
                              Network 10.0.0.0 — иначе не позволяет. В итоге и fa0/0 и fa0/1 участвуют в рипе.
                              А отдаваемые сети будут зависеть от наличия суммирования (auto-summ или ip summary-addr). Если включено суммирование, то уходит 10/8, если нет, то обе подсети.

                              С RIP вы указываете классовый адрес и, как следствие, все интерфейсы в этом классе начинают работать в RIP. И, да, для исключения определенного интерфейса нужны distribute-lists, passive-interface и т.д. Надо посмотреть на RIP у других вендоров, как все это реализовано у них. Cisco видимо его особо значимым протоколом не считает (что верно) и не заморачиваясь синтаксис тупо перенесла с первого рипа.

                              А с BGP совсем другая история… Если в остальных протоколах вы выбираете интерфейсы и сеть интерфейса анонсится, то в BGP вы сами анонсите сети. У команды network в BGP совсем другое значение.
                                0
                                Это всё понятно и известно.
                                Но в рамках поста про CCNA мы всё же говорим именно о cisco-вской реализации этих протоколов.
                                А в ней к сожалению RIPv2 не позволяет указывать маску в команде network и приходится лепить костыли.

                                Повторюсь, я не очень удачно назвал это отсутствием поддержки VLSM, но некоторое ограничение в работе тем не менее присутствует.
                                0
                                В догонку ответу для g0ff и JDima:

                                Это, кстати, распространенный миф, что команда network чего-то там анонсирует (исключение, BGP). Ничего подобного – это просто выбор интерфейсов: интерфейс отправляет\получает апдейты, сетка интерфейса передается в апдейтах. Как анонсировать сеть интерфейса, IOS решит самостоятельно, в зависимости от наличия или отсутствия суммирования. И в IPv6 от подобной практики отказались, команды network нет. Вместо этого:

                                Int fa0/1
                                Ipv6 rip X enable
                                Ipv6 ospf X area Y

                                Для OSPF это можно делать и для IPv4:
                                Int fa0/1
                                Ip ospf X area Y

                                И в OSPF показательна show ip proto. Увидите там явно выбранные интерфейсы. Они как-то по другому отображаются.
                                  0
                                  В догонку ответу для g0ff и JDima:

                                  Мне это рассказывать не надо, я как раз всеми силами намекал на это :)
                                    0
                                    ну я в целом в тему дискуссии :)
                                  +1
                                  Так как развивается дискуссия, и ушли далеко за ICND1, хочется подключить коммунити для составления нормального ИТ-словаря, хотя бы для сетей. Есть Олиферы, есть переводные книги, но нужен нормальный общеупотребимый сленг. Термины, используемые в этих книгах никто из нас не выговаривает. Мы используем англицизмы. У Cisco был прецедент перевода, как учебников, так и экзаменов. Провалился. Давайте определимся с языком, а то каждый на своем «английском» :)
                                    0
                                    Вы предлагаете стартовать проект сетевого глоссария прямо тут в комментах, или просто порассуждать в рамках данной дискуссии?

                                    Как я уже сказал маска она и в Африке маска. А вы можете как-то разделить термины для маски указывающей размерность сети на интерфейсе и маски указываемой в настройках динамических протоколов маршрутизации?

                                    P.S. А заодно ещё и той маски, которая используется в ACL, она ведь тоже не является МАСКОЙ ПОДСЕТИ через который проходит фильтруемый трафик?
                                    ;)
                                      0
                                      Такими темпами лучше уж совсем на английский перейти. Я согласен с тем, что терминологию лучше не переводить совсем («домен широковещательный рассылки» и «расщеплённый горизонт» я запомню на всю свою оставшуюся жизнь), но тогда на русском остаются в основном предлоги.

                                    Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.

                                    Самое читаемое