Настройка IPTV Билайн через WiFi с использовнием роутеров Mikrotik

Будучи абонентом Домашнего Интернет+ТВ от Билайн волей-неволей читаешь профильные форумы, видишь проблемы абонентов и пр. И вот среди этих «плачей Ярославны» определенно вырисовывается одна задача, которую либо никому не удалось осуществить, либо через костыли с обрезанным функционалом. А именно — передача IPTV на приставку через Wi-Fi. И вот недавно ко мне обратились за помощью именно с таким вопросом. Так как наш человек сначала делает, а потом думает, то ремонт в новой квартирке уже сделан, кабель каналов нет, RJ-45 розеток нет, красоту и эстетику портить никто не будет, а смотреть ТВ от Билайн на кухне хочется.

Что же делать?
Вырисовываются следующие задачи:
1) Выпустить все клиентские устройства (ноутбуки, компьютеры, планшеты и пр.) в интернет через Wi-Fi
2) На кухонный телевизор поставить арендованную у компании Билайн IPTV приставку и сделать так, чтобы она работала, с сохранением всего функционала.
Ну если первый пункт сложностей не вызывает, то второй заставляет задуматься.
Поскольку я являюсь приверженцем и давним пользователем продукции компании Mikrotik, то было принято решать возникшую проблему на оборудовании данного вендора. К тому же имеющийся сертификат MTCNA придавал сил и убеждал, что «не так страшен чёрт, как его малюют».
Итак, напомню принцип подключения абонентов Билайн к сети интернет.
Клиентское оборудование получает от DHCP-сервера «серый» адрес из подсети 10.0.0.0/8, что дает доступ к локальным ресурсам, L2TP-BRAS'ам, ну и собственно тут же бродит multicast нашего IPTV. Чтобы получить доступ непосредственно уже в саму сеть Интернет необходимо авторизоваться по L2TP-соединению по адресу tp.internet.beeline.ru. Данная схема в терминологии некоторых производителей домашних роутеров называется Russian Dual Access.
Выбор пал на маршрутизаторы RB/751G-2HnD.

Их характеристики:

— ОЗУ: 64MB DDR SDRAM
— Процессор: Atheros AR7241 400MHz CPU
— Жесткий диск: 64MB onboard NAND storage chip
— Частота: 2.4 ГГц
— Ethernet: 5 независимых портов 10/100/1000
— USB: 1 порт 2.0
— Питание: через ethernet-порт 1 8-30V DC, через джек 8-30V DC (БП в комплекте)
— Чувствительность: 802.11g: -96dBm @ 6Mbit/s to -81dBm @ 54Mbit/s, 802.11n: –96 dBm @ MCS0 to –78 dBm @ MCS7
— Усиление мощности: 802.11g: 30dBm @ 6Mbps to 27dBm @ 54 Mbps, 802.11n: 30dBm @ MCS0 to 26dBm @ MCS7
— мощность встроенного радиомодуля: 1W
— коэффициент усиления встроенных антенн: 2.5dBi
— Энергопотребление: до 7W
— ОС: RouterOS, уровень 4

Я не буду подробно описывать где найти winbox, что это и как им пользоваться. Этой информации очень много на просторах сети. Поэтому описывать буду тезисно, но с пояснениями.
На момент написания статьи версия ПО 5.24. Качаем ее здесь download2.mikrotik.com/routeros/5.24/routeros-mipsbe-5.24.npk закидываем в Files и перезагружаем роутер. На втором проделываем тоже самое.
Итак, определим для себя что R1 это будет роутер, куда приходит кабель от нашего провайдера, а R2 – это этакий Wi-Fi приемник для IPTV-приставки. Дефолтная конфигурация устройств предлагает нам DHCP-клиент на порту eth-1, а порты eth2-eth5 объединены в switch, плюс bridge к eth2 для wi-fi (wlan2) с dhcp-сервером в диапазоне 192.168.88.0/24.

Итак, настройка роутера R1

Подключаем к роутеру R1 кабель от билайна в eth1, а компьютер в eth2 и запускаем winbox. Соединяемся с 192.168.88.1 с логином admin и пустым паролем. В окне RouterOS Default Configuration жмем ОК.


Поскольку RouterOS не умеет в полях Connect-to использовать dns-имена, то предварительно, воткнув билайновский кабель в компьютер определяем адрес tp.internet.beeline.ru. В моем случае он оказался 10.255.255.239
/interface l2tp-client
add add-default-route=yes allow=pap,chap,mschap1,mschap2 connect-to=\
    10.255.255.239 dial-on-demand=no disabled=no max-mru=1460 max-mtu=1460 \
    mrru=disabled name=l2tp-out1 password=password profile=\
    default-encryption user=login

(в сети можно найти скрипты, которые будут сами определять текущий адрес браса tp.internet.beeline.ru и подставлять его в поле Connect-to. т.к. провайдер использует round-robin dns для определения менее загруженного браса)

Далее настраиваем два правила NAT. Одно для локальной сети, другое для интернета.
Заходим в IP-Firewall-NAT, удаляем правило default configuration, и создаем свои.
/ip firewall nat
add action=masquerade chain=srcnat disabled=no dst-address=10.0.0.0/8 \
    out-interface=ether1-gateway
add action=masquerade chain=srcnat disabled=no dst-address=!10.0.0.0/8 \
    out-interface=l2tp-out1

Проверяем оба правила:


Следующим шагом убираем членство wlan1 в бридже c ether2 и включаем его в бридж к ether1. Для этого открываем Bridge, создаем новый мост с именем, например, tv-wifi-bridge, а на вкладке Ports добавляем к нему интерфейсы wlan1 и ether1-gateway.


/interface bridge
add admin-mac=D4:CA:6D:20:E2:49 ageing-time=5m arp=enabled auto-mac=no \
    disabled=no forward-delay=15s l2mtu=1598 max-message-age=20s mtu=1500 name=\
    bridge-local priority=0x8000 protocol-mode=rstp transmit-hold-count=6
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto-mac=yes \
    disabled=no forward-delay=15s l2mtu=1598 max-message-age=20s mtu=1500 name=\
    tv-wifi-bridge priority=0x8000 protocol-mode=none transmit-hold-count=6
/interface bridge port
add bridge=bridge-local disabled=no edge=auto external-fdb=auto horizon=none \
    interface=ether2-master-local path-cost=10 point-to-point=auto priority=\
    0x80
add bridge=tv-wifi-bridge disabled=no edge=auto external-fdb=auto horizon=none \
    interface=wlan1 path-cost=10 point-to-point=auto priority=0x80
add bridge=tv-wifi-bridge disabled=no edge=auto external-fdb=auto horizon=none \
    interface=ether1-gateway path-cost=10 point-to-point=auto priority=0x80


Т.к. Iptv приставка тоже получает свой адрес от dhcp провайдера, то нам требуется изменить интерфейс dhcp-клиента. Если помните, то он назначен только на ether1. Переназначаем его на Bridge tv-wifi-bridge.

/ip dhcp-client
add add-default-route=yes comment="default configuration" \
    default-route-distance=1 disabled=no interface=tv-wifi-
    use-peer-dns=yes use-peer-ntp=yes


Теперь пришло время настраивать беспроводную часть нашей затеи. В первую очередь подготовим точку доступа именно для iptv приставки. Здесь нет ничего необычного, типовая настройка, за исключением самого важного пункта. Это Multicast Helper. Он должен стоять в положении full.

/interface wireless
set 0 adaptive-noise-immunity=none allow-sharedkey=no antenna-gain=0 antenna-mode=\
    ant-a area="" arp=enabled band=2ghz-b/g/n basic-rates-a/g=6Mbps basic-rates-b=\
    1Mbps bridge-mode=enabled channel-width=20/40mhz-ht-above compression=no \
    country=no_country_set default-ap-tx-limit=0 default-authentication=yes \
    default-client-tx-limit=0 default-forwarding=yes dfs-mode=none \
    disable-running-check=no disabled=no disconnect-timeout=3s distance=indoors \
    frame-lifetime=0 frequency=2412 frequency-mode=manual-txpower frequency-offset=0 \
    hide-ssid=no ht-ampdu-priorities=0 ht-amsdu-limit=8192 ht-amsdu-threshold=8192 \
    ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-guard-interval=\
    any ht-rxchains=0,1 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,m\
    cs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,m\
    cs-19,mcs-20,mcs-21,mcs-22,mcs-23" ht-txchains=0,1 hw-fragmentation-threshold=\
    disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 l2mtu=\
    2290 mac-address=D4:CA:6D:20:E2:4D max-station-count=2007 mode=ap-bridge mtu=\
    1500 multicast-helper=full name=wlan1 noise-floor-threshold=default \
    nv2-cell-radius=30 nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=\
    default nv2-queue-count=2 nv2-security=disabled on-fail-retry-time=100ms \
    periodic-calibration=default periodic-calibration-interval=60 preamble-mode=both \
    proprietary-extensions=post-2.9.25 radio-name=D4CA6D20E24D rate-selection=\
    advanced rate-set=default scan-list=default security-profile=default ssid=tv \
    station-bridge-clone-mac=00:00:00:00:00:00 supported-rates-a/g=\
    6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b=\
    1Mbps,2Mbps,5.5Mbps,11Mbps tdma-period-size=2 tx-power-mode=default \
    update-stats-interval=disabled wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=any \
    wmm-support=disabled


Шифрование настраиваете по своему вкусу через Security Profiles, останавливаться на этом я не стану.

Теперь создаем виртуальную точку доступа, через которую будут попадать в интернет все наши остальные железки (телефоны, планшеты, ноутбуки и пр.). Но сначала добавьте еще один security-profile, чтобы не запутаться.

/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods="" group-ciphers=aes-ccm \
    group-key-update=5m interim-update=0s management-protection=allowed \
    management-protection-key="" mode=dynamic-keys name=inet-sec \
    radius-eap-accounting=no radius-mac-accounting=no \
    radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username \
    static-algo-0=none static-algo-1=none static-algo-2=none static-algo-3=\
    none static-key-0="" static-key-1="" static-key-2="" static-key-3="" \
    static-sta-private-algo=none static-sta-private-key="" \
    static-transmit-key=key-0 supplicant-identity="" tls-certificate=none \
    tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" \
    wpa2-pre-shared-key=blablabla


Ну и сама VirtualAP

/interface wireless
add area="" arp=enabled bridge-mode=enabled default-ap-tx-limit=0 \
    default-authentication=yes default-client-tx-limit=0 default-forwarding=yes \
    disable-running-check=no disabled=no hide-ssid=no l2mtu=2290 mac-address=\
    D6:CA:6D:20:E2:4D master-interface=wlan1 max-station-count=2007 mtu=1500 \
    multicast-helper=default name=wlan2 proprietary-extensions=post-2.9.25 \
    security-profile=inet-sec ssid=Inet update-stats-interval=disabled \
    wds-cost-range=0 wds-default-bridge=none wds-default-cost=0 wds-ignore-ssid=no \
    wds-mode=disabled wmm-support=disabled


И добавляем полученный wlan2 в бридж к ether2

/interface bridge
add bridge=bridge-local disabled=no edge=auto external-fdb=auto horizon=none \
    interface=wlan2 path-cost=10 point-to-point=auto priority=0x80


На этом настройки роутера R1 закончены. Проводные девайсы выходит в интернет через порты 2-5, беспроводные через точку доступа wlan2 с SSID “Inet”

Настройка роутера R2

Настройка данного роутера вообще банальна. Т.к. Имея дефолтную конфигурацию, нам необходимо всего лишь выполнить сканирование эфира, найти точку с ssid “tv” и нажать кнопку Connect. Если вы используете шифрование, то сделать соответствующие поправки в Security profiles. После этого необходимо ether2 убрать из бриджа, а вместо него добавить ehter1. Осторожно! После этого вы потеряете соединение с роутером и winbox закроется.




Включаем приставку в порт eth1 и всё готово.




Здесь видим записывающийся канал 1HD и одновременную закачку файла. Правда, по такой схеме мне не удалось из VirtualAP выжать больше 7-8 Мегабит.
Загрузка процессора роутера, использующегося как точка доступа при такой картине не превышала 34-37% Скорость переключения каналов на глаз не отличается от кабельного подключения.
Во время экспериментов пробовал пустить через IGMP – proxy. Вроде и работает, но HD-каналы фризятся, ввод pin-кодов не работает, запись не работает.
Также был испробован метод, когда физический AP использовался для интернета, а VirtualAP для телевидения. В данном случае скорость передачи составляла не больше 1Мбит, что естественно недопустимо мало для просмотра ТВ. Вместо видеоряда были стоп-кадры, сменяющие друг друга раз в 30 секунд.
На этом эксперимент считаю удачным и оконченным. Имеется широкий простор для дальнейшего тюнинга. Готов ответить на все вопросы. Спасибо за внимание.
Поделиться публикацией

Комментарии 41

    0
    А почему бы ip tv не подать на телевизор через powerline адаптеры? искорость по больше и гемороя никакого.
      0
      я никогда не сталкивался с данной технологией, но погуглив нашел вот это www.mediamarkt.ru/mp/article/Powerline-%D0%B0%D0%B4%D0%B0%D0%BF%D1%82%D0%B5%D1%80,855007.html?catalogId=14251:
      Скорость передачи данных на бумаге

      Все Powerline-адаптеры, существующие в продаже (на сентябрь 2009 года), имеют скорость передачи данных 10/100 Мбит/с.

      В рекламных материалах и в руководстве можно встретить значение 200 Мбит/с. Все современные Powerline-адаптеры работают в полностью дуплексном режиме. Это означает, что максимальная скорость 100 Мбит/с обеспечивается одновременно в обе стороны, то есть, в общей сложности 200 Мбит/с.

      Анонсирован Powerline-адаптер со скоростью 1 000 Мбит/с.

      Скорость передачи данных на практике

      На практике следует рассчитывать на скорость в 7 Мбит/с – при условии наличия в проводке помех только из самого здания.

      Более правильно рассчитывать на 6 Мбит/с.

      При использовании в условиях офиса скорость снижается еще заметнее. Она составляет 2 Мбит/с.


      Пара адаптеров по ссылке zyxel-shop.ru/goods/Zyxel_PLA-400_EE.htm стоит дороже, чем один RB751, так что пара микротиков все равно получается практичней.
      P.S. для ссылок карма нужна?
    0
    У вас получается, что Билайн выдаёт два разных ип адреса на ваши два устройства. Вот что делать, если провайдер резервирует выдачу одного ип адреса на один порт клиента — тем самым запрещая последнему подключать больше одного устройства?
      0
      дело в том, что при регистраци приставки в личном кабинете указывается ее MAC-адрес, поэтому в данном случае проблем не возникает. а вот в вашем случае, видимо, все придется использовать схему с IGMP-proxy, жертвуя вводом пин-кодов и рывками при просмотре HD-каналов (кстати, их на самом деле немного, но меня раздражают). В таком случае VirtualAP не требуется. Нужно скачать пакет multicast. Если интересно, могу позже добавить информацию в топик.
        0
        Использовал этот способ ещё в 4.x версиях, но не хватило скорости wifi, чтобы нормально принимать качественную картинку. С тех пор бросил эту затею.
          0
          c IGMP-proxy? Попробуйте на 5.х и новом железе, если HD не критично
            0
            RB751 имеет 3 антенны и позволяет использовать MIMO 3x3. Цеплялся интереса ради к нему адаптером D-Link DWA-140, получил канальную скорость 300/300 Мбит/с
              0
              К сожалению уже переехал в другой город, поэтому попробовать не представляется возможным.
                0
                в RB751 две антенны и обе весьма слабые.
                  0

                  внизу три лепестка, это и есть антенны. Да, слабые, 2.5dBi, но компенсируются мощным передатчиком 1W
                    0
                    Мощность передатчика при таких антеннах бесполезна, бо у клиентов она не увеличится, а чувствительность хреновая.
                    Антенн там три, но одна умеет только прием, вторая только передачу, третья rx-tx.
                    image
                      0
                      Принцип работы антенн в MikroTik RB751

                      Прежде чем мы приступим к настройке роутера MikroTik RB751 на использование внешней антенны, необходимо понимать принцип работы встроенных антенн и их режимы работы.

                      В роутере есть три встроенные антенны и один разъем MMCX для подключения внешней антенны. Антенна №1 работает только на прием, Антенна №2 работает только на передачу, Антенна №3 работает на прием и передачу. С помощью такой организации антенн реализована технология MIMO 2×2 (2 приемника и 2 передатчика), которая позволяет передавать данные по Wi-Fi в два потока с большей скоростью, чем может передать одна Wi-Fi антенна.

                      В роутере MikroTik RB751 есть следующие режимы работы антенн:

                      -> Antenna A — роутер использует только внутренние антенны (Антенна №1, №2, №3) для приема и передачи данных по Wi-Fi;
                      -> Antenna В — роутер использует две внутренние антенны (Антенна №1, №2) и одну внешнюю для приема и передачи данных по Wi-Fi. Антенна №3 в этом режиме отключена. Роутер MikroTik RB751 также можно настроить на использование только внутренних или внешних антенн с помощью настроек Chain.
                      -> tx-a/rx-b — роутер использует внутреннюю Антенна №2 для передачи, а внешнюю антенну — для приема.
                      -> rx-a/tx-b — роутер использует внешнюю антенну для передачи, а Антенна №1 — для приема.
                        0
                        Вы говорили о трех антеннах для MIMO 3x3.
                        RB/751 _не_умеет_ этого ввиду конструктивных особенностей.
                          0
                          Прочел спецификацию на родном сайте. Признаю, был неправ. Только 2х2. Странно, т.к. где-то видел упоминание именно о 3х3.
                            0
                            3x3 умеет RB800, такие схемы даже собирали и вроде бы они работают
                              0
                              Это с использованием трех радиокарт? Читал, но вроде там были взаимные помехи от их близкого расположения внутри корпуса.
                                0
                                Да, с тремя карточками. Юстировать сложно, тестировали, насколько я знаю, только на столе, реальных инсталляций не видел. Больше друг на друга влияли не сами карточки, а антенны.
        0
        RB751, увы, не вытягивает HD-каналы, а RouterOS, что совсем неприятно, не умеет IGMP-Snooping. Мы пробовали включать IPTV-приставку через bridge или через master/slave-порты — не важно, все равно были фризы на HD-каналах и разлив мультикаста на все порты.
        А в целом железка неплохая, да
          0
          ну как это не умеет? я ж написал в теме, что нужно установить пакет Multicast.npk, после этого появится в меню Routing пункт IGMP-proxy. Для простой настройки добавить галочку upstream на интерфейс провайдера и сеть 0.0.0.0/0, вторым правилом указываете свой локальный бридж за натом
            0
            и еще, на данный момент вместо модели 751 с процессором 400 MHz и RAM 64Mb выходит модель 951 по той же цене, но уже имеющая на борту процессор в 600 MHz и RAM 128Mb
              0
              Честный IGMP-snooping он не умеет.
              IGMP-proxy это такой софтовый костыль в духе латвийских друзей, и, если бы он полностью подменял собой IGMP-snooping, последний не висел бы в feature request.
                0
                возможно, спорить не буду, но в моей практике данной реализации вполне хватало
              0
              попробуйте новую прошивку, у них долгое время были косяки с режимом моста.
              0
              Скажите, пожалуйста, что за пин-коды упомянутые в статье? (никогда не был абонентом пчелайна)
                0
                например для открытия каналов для взрослых
                  0
                  тогда картина совсем не ясна :) пин-кодами и прочей лабудой занимается middleware(клиентская часть и серверная): серверная взаимодействует с системой условного доступа, биллинговой системой и другими, а клиентская(SUI) — отображает всякие виджеты и прочие плюшки, обращаясь, как правило по http (устарело и накладно, проще использовать свой протокол передачи данных) с серверной частью. Как пример: Stalker, NetUP, HIBOX etc.
                  Так казалось бы, причем тут IGMP (RTSP,RTP,UDP) которые используются для передачи потокового видео (ну кроме RTSP, который нужен для управления потоком) и почему не должны работать свистоперделки при IGMP-Proxy?
                    0
                    Видимо, как написал выше Night_Snake
                    Честный IGMP-snooping он не умеет.
                    IGMP-proxy это такой софтовый костыль в духе латвийских друзей, и, если бы он полностью подменял собой IGMP-snooping, последний не висел бы в feature request.
                      0
                      подскажите в таком случае, что у Вас за модель приставки?
                      ибо как по-мне, так IGMP влияет только на отображение контента, но никак не на передачу pin-кодов и прочего «добра»
                        0
                        Cisco CIS-430
                0
                А можно или ссылку дать, или рассказать как настраивать миктоктик и билайновский l2tp? Собираюсь на днях покупать, т.к. пров дает хорошие скорости, а нынешний роутер плохо тянет уже 1.5 мегабайта в сек. А у микротика проблем со скоростью и l2tp нет? Настройка без танцев с бубной пройдет?
                  0
                  Настройки без всяких танцев, мануал гуглится быстро, на тот же НАГ зайдите, там точно найдете. Настройка штатная совершенно, проблем со скоростью не замечено, тот же RB751 прожевывает мегабит 100 на NATе не сильно мелкими пакетами, более мощные модели так тем более прожуют.
                    0
                    А какая из «домашних» моделей роутеров у микротика сейчас сама мощная и производительная? 951? А какая из модификаций?
                      0
                      RB951G-2HnD
                      RB2011UAS-2HnD-IN

                      Имхо, самые толковые модели сейчас.
                        0
                        А на стоковой прошике, как я понял, дополнительные плюшки в виде NAS, iTunes сервера и прочее — поднять не удасться?
                          0
                          Нет, не удастся.
                          Более того, поставить не-стоковую прошивку (тот же WRT) — дело весьма и весьма нетривиальное.
                    0
                    Так в начале статьи показано как настроить на основе дефолтовой конфигурации.
                    0
                    Я делал похожую схему несколько ранее (и, кстати, еще до получения своего MTCNA :) ), — выскажу свои наблюдения:
                    1) Пробовал на ростелекоме. От их роутера выделенный порт забриджевал с eoip-туннелем и прокинул его через WiFi, дабы не грузить воздух мультикастом. В режиме 802.11b работало идеально, но никаких HD-каналов, по понятным причинам. в G пошли квадраты, в N квадраты стали невыносимыми. Оптимизировал с горем пополам G — вроде заработало, но картинка все же периодически рассыпалась. Делал на RB951-2n, решение использовал только для прокидывания мультикаста (без интернета). Погрешил на роутеры. Хотя каким образом режим канала влияет на трафик внутри туннеля для меня осталось загадкой. ROS был 5.21, по-моему. Позже переделывал на 6.5 — но немного изменил схему — не помогло.
                    2) Более поздний опыт — билайн. Схема такая же как у Вас, но с единственным отличием: бридж клиента WiFi с локальным интерфейсом — это по сути не очень правильно. Микротик делает это с помощью проприетарной технологии, и где-то в wiki я читал, что такой вариант следует использовать только в крайнем случае. А по умолчанию для этой цели рекомендуется использовать wds, как я и сделал. По сути моя схема от Вашей отличается лишь этим и тем, что есть еще одна приставка, подключенная проводом. Ее я завел через slave-порт (дабы не грузить процессор задачей бриджинга, тем более проводных клиентов у меня вообще не было) Использовал RB951Ui и ROS 6.5. И опять квадраты. Пробовал и Вашу схему — с микротиковским бриджингом, — тоже самое, визуально квадратов еще больше. Самый интересный момент — виртуальная точка для интернета работает очень стабильно на все 20 мегабит по воздуху (столько дает провайдер), с минимальными пингами, при этом 12-17 мегабит HD потока через wds идет стабильно. Но вот в том и дело, что ничего не тормозит, а именно рассыпается картинка, в основном на динамичных моментах. Причем даже на не HD каналах.
                    Хотел реализовать еще одну схему с igmp-proxy после туннеля, примерно как описал Alex S. B. с форума NAG:
                    forum.nag.ru/forum/index.php?showtopic=64484&st=20&p=897175&#entry897175
                    Но… Igmp-proxy у меня с билайном вообще никак не заработал. Исходя из информации с форума билайна могу сделать вывод, что технологии передачи как-то отличаются в разных городах.
                    0
                    Вчера на другом роутере (951-2n) завел билайн через IGMP как по кабелю, так и по воздуху. Причем настройки переливал экспортом-импортом со своего. А свой (751G) поставил знакомым на ростелеком — забриджевал IPTV порт по воздуху через eoip на приставку — все работает. То есть я по сути просто поменялся экземплярами, не внося изменений в настройки. Только обновился до ROS 6.6.
                    Почему с билайном мой роутер не работал осталось загадкой. Он видел MPC источники, но не знал куда их направить (писал unknown в поле порта то ли источника, то ли назначения — точно не помню).
                    Да, все радиомодули работают сейчас в 802.11n.

                    Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.

                    Самое читаемое