Как стать автором
Обновить

Комментарии 6

Для браузера, на конец 2020, лучше выбирать ES6

Ну и отношение к людям. Желаю вам, чтобы при попытке установки какой-нибудь программы вас тоже бы отправили в магазин за новым компьютером.


Писать код надо используя такие фичи, которые поддерживаются как минимум браузерами за последние 5 лет, а лучше за 10 (то есть, минимум ES5, желательно с shim'ами).


Кто-то не обновляет браузер (так как новые версии программ практически всегда едят больше памяти и медленнее работают), кто-то не может обновить браузер, так как у него Windows Xp, кто-то пользуется встроенным браузером на телефоне, который никогда не обновит производитель, кто-то привык к Internet Explorer и не хочет ничего менять.


Только плохой разработчик не понимает таких вещей. Таковы большинство сегодняшних фронтенд-специалистов, которые просто не способны верстать кроссплатформенно. Они лепят как попало, а потом (если заказчик потребует) начинают лепить костыли для поддержки требуемых браузеров. А надо не так. Надо просто знать, какие фичи с какого года поддерживаются, какие браузеры требуется поддерживать, и верстать исходя из этого с самого начала. А не пытаться костылями и shim'ами потом закрыть свой непрофессионализм.


Вообще, современные фротендщики вызывают только раздражение. Например, сколько можно верстать сайты, рассчитанные на гигантские экраны, где на экран помещается три с половиной поля? Вы думаете, у каждого пользователя дизайнерский 30-дюймовый монитор что ли стоит? Даже здесь, на Хабре, приходится ставить масштаб 90% для комфортного просмотра.


micro-frontend

Какое неудачное название. Ведь если вы под каждую страницу делаете свой "фронтенд", то суммарный объем загружаемых файлов при обходе нескольких страниц получается больше, чем если бы был "монолитный" фронтенд. Правильнее было бы называть "мега-фронтенд" или даже "гига-фронтенд" (чувствую скоро дойдем и до этого).

Строчкой ниже вашей цитаты
Хороший сайт для проверки доступных функций: caniuse.com

ES6, он же ES2015 — поддерживается браузерами очень даже хорошо (es6 support) и браузеры с его поддержкой выходят уже пятый год как.

Как раз даунгрейд до ES5 может вызывать для множества пользователей больше накладных расходов. Сделать для этих браузеров preload нужных polyfill будет корректнее, чем заставлять всех остальных грузить es5 версию.

Поддержка IE в современном мире требуется не всегда, но для него можно собрать и отдельный bundle.

Не совсем понял как frontend-developer связан с дизайном? Если бизнес принял решение делать сайт только на десктоп и тебе дали макеты только для него. То их ты и будешь верстать.
Если есть макеты для Responsive (Отзывчивой) вёрстки, то она и верстается.

Кроме IE11 есть курьёзные частности. Например Angular до сих пор вынужден собираться в es2015 из-за того, что у zone.js уже много лет нет решения для работы с нативными промисами и async/await.

> потому что у него Windows Xp
Смешно, ага. Чего бы не поддерживать платформу которую уже даже вендор 6 лет как не поддерживает. А чего бы не равняться на ie1 или netcat вообще? Компабилити ведь…
Если в ваших кейсах присутствует поддержка Win XP, то это проблемы сугубо ваши и ваших клиентов, весь мир шагнул дальше уже как 6 лет назад.

Как-то слишком базово. Если интересно более масштабное применение ts в конфигах вебпака — выкладывал тут. Можно просто через babel-node запускать сборку, бабелем вырезая типы — практика показывает, что каждый раз проверять их бесполезно, достаточно ориентироваться на подсказки в IDE, т.к. вебпак при запуске сам проверит, правильно ли он сконфигурирован.

Только полноправные пользователи могут оставлять комментарии. Войдите, пожалуйста.