<!DOCTYPE html>
<html lang="ru" class="no-js">
  <head>
    <meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta content='width=1024' name='viewport'>
<title>Личный сервер shadowsocks за 10 минут без затрат / Хабр</title>

  <meta name="description" content="Несколько слов о shadowsocksshadowsocks - это шифрованный сетевой туннель, клиентская часть которого предоставляет доступ приложениям к сети как SOCKS-прокси, запущенный на этом же устройстве. В..." />

  <meta name="keywords" content="shadowsocks, heroku, прокси, proxy, free, бесплатно, без смс, vpn" />

  <meta property="fb:app_id" content="444736788986613" />
<meta property="og:type" content="article" />
<meta property="fb:pages" content="472597926099084"/>
<meta property="og:url" content="https://habr.com/ru/post/555768/" />
<meta property="og:title" content="Личный сервер shadowsocks за 10 минут без затрат" />

    <meta property="og:image" content="https://habrastorage.org/getpro/habr/upload_files/a67/12e/dac/a6712edac234bb4660279829086d6ec3.png?v=1" />
    <meta property="og:image:width" content="1200"/>
    <meta property="og:image:height" content="630"/>
    <link rel="image_src" href="https://habrastorage.org/getpro/habr/upload_files/a67/12e/dac/a6712edac234bb4660279829086d6ec3.png?v=1" />
    <meta name="twitter:image" content="https://habrastorage.org/getpro/habr/upload_files/a67/12e/dac/a6712edac234bb4660279829086d6ec3.png?v=1">
    <meta property="aiturec:image" content="https://habrastorage.org/getpro/habr/upload_files/a67/12e/dac/a6712edac234bb4660279829086d6ec3.png?v=1">
      <meta property="vk:image"  content="https://habrastorage.org/getpro/habr/upload_files/a67/12e/dac/a6712edac234bb4660279829086d6ec3.png&v=1" />
    <meta property="og:image" content="https://habr.com/share/publication/555768/48315a4caee9a2958a01894796a8044b/" />
    <link rel="image_src" href="https://habr.com/share/publication/555768/48315a4caee9a2958a01894796a8044b/" />
    <meta property="og:image" content="https://habrastorage.org/getpro/habr/upload_files/c1f/14d/bd7/c1f14dbd7ff1e51158df7a4cef8fd05b.png" />
    <link rel="image_src" href="https://habrastorage.org/getpro/habr/upload_files/c1f/14d/bd7/c1f14dbd7ff1e51158df7a4cef8fd05b.png" />
    <meta property="og:image" content="https://habrastorage.org/getpro/habr/upload_files/879/d08/7a9/879d087a93e8ed7236f8dac711b44850.png" />
    <link rel="image_src" href="https://habrastorage.org/getpro/habr/upload_files/879/d08/7a9/879d087a93e8ed7236f8dac711b44850.png" />

<meta property="aiturec:title" content="Личный сервер shadowsocks за 10 минут без затрат">
<meta property="aiturec:description" content="Несколько слов о shadowsocksshadowsocks - это шифрованный сетевой туннель, клиентская часть которого предоставляет доступ приложениям к сети как SOCKS-прокси, за...">
<meta property="aiturec:item_id" content="555768">
<meta property="aiturec:datetime" content="2021-05-05T04:42:56+03:00">

<meta property="og:description" content="Несколько слов о shadowsocksshadowsocks - это шифрованный сетевой туннель, клиентская часть которого предоставляет доступ приложениям к сети как SOCKS-прокси, за..." />
<meta name="twitter:description" content="Несколько слов о shadowsocksshadowsocks - это шифрованный сетевой туннель, клиентская часть которого предоставляет доступ приложениям к сети как SOCKS-прокси, за...">
<meta name="twitter:title" content="Личный сервер shadowsocks за 10 минут без затрат" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@habr_com" />

  <meta property="al:android:url" content="habrahabr://post/555768" />
<meta property="al:android:app_name" content="Habrahabr" />
<meta property="al:android:package" content="ru.habrahabr" />
<meta property="al:windows_phone:url" content="habrahabr://post/555768" />
<meta property="al:windows_phone:app_name" content="Habrahabr" />
<meta property="al:windows_phone:app_id" content="460a6bd6-8955-470f-935e-9ea1726a6060" />

  <link rel="canonical" href="https://habr.com/ru/post/555768/"/>
  <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.habr.com/ru/post/555768/" >
<link rel="amphtml" href="https://m.habr.com/ru/amp/post/555768/">

    <script type="application/ld+json">
      {
    "@context": "http:\/\/schema.org",
    "@type": "Article",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https:\/\/habr.com\/ru\/post\/555768\/"
    },
    "headline": "Личный сервер shadowsocks за 10 минут без затрат",
    "datePublished": "2021-05-05T04:42:56+03:00",
    "dateModified": "2021-05-05T04:42:56+03:00",
    "author": {
        "@type": "Person",
        "name": "Vladislav Yarmak"
    },
    "publisher": {
        "@type": "Organization",
        "name": "Habr",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/habrastorage.org\/webt\/a_\/lk\/9m\/a_lk9mjkccjox-zccjrpfolmkmq.png"
        }
    },
    "description": "Несколько слов о shadowsocksshadowsocks - это шифрованный сетевой туннель, клиентская часть которого предоставляет доступ приложениям к сети как SOCKS-прокси, за...",
    "url": "https:\/\/habr.com\/ru\/post\/555768\/#post-content-body",
    "about": [
        "h_infosecurity",
        "h_sys_admin",
        "h_network_technologies",
        "h_cloud_services",
        "h_soft",
        "f_develop",
        "f_admin",
        "f_popsci"
    ],
    "image": [
        "https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/c1f\/14d\/bd7\/c1f14dbd7ff1e51158df7a4cef8fd05b.png",
        "https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/879\/d08\/7a9\/879d087a93e8ed7236f8dac711b44850.png"
    ]
}
    </script>


<meta name='yandex-verification' content='71593b225aeafc4e' />
<meta name='referrer' content='unsafe-url' />
<meta name="pocket-site-verification" content="ed24b2b9721edf0a282c5b4a3232c4" />
<meta name="biu" content="https://dr.habracdn.net/habr/oldassets/6092b4a5/images/">

<style type="text/css">
  @font-face{font-family:'Fira Sans';font-style:normal;font-weight:500;src:url(https://dr.habracdn.net/habr/oldassets/6092b4a5/fonts/FiraSans/firaSans-medium.eot);src:local("Fira Sans Medium"),local("FiraSans-Medium"),url(https://dr.habracdn.net/habr/oldassets/6092b4a5/fonts/FiraSans/firaSans-medium.eot?#iefix) format("embedded-opentype"),url(https://dr.habracdn.net/habr/oldassets/6092b4a5/fonts/FiraSans/firaSans-medium.woff2) format("woff2"),url(https://dr.habracdn.net/habr/oldassets/6092b4a5/fonts/FiraSans/firaSans-medium.woff) format("woff"),url(https://dr.habracdn.net/habr/oldassets/6092b4a5/fonts/FiraSans/firaSans-medium.ttf) format("truetype")}
</style>

<link href="https://dr.habracdn.net/habr/oldassets/6092b4a5/styles/main.bundle.css" rel="stylesheet" media="all" />





<meta name='yandex-verification' content='67d46b975fa41645' />

<link rel="apple-touch-icon" sizes="180x180" href="https://dr.habracdn.net/habr/oldassets/6092b4a5/images/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://dr.habracdn.net/habr/oldassets/6092b4a5/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://dr.habracdn.net/habr/oldassets/6092b4a5/images/favicon-16x16.png">
<link rel="manifest" href="https://dr.habracdn.net/habr/oldassets/6092b4a5/site.webmanifest">
<link rel="mask-icon" href="https://dr.habracdn.net/habr/oldassets/6092b4a5/images/safari-pinned-tab.svg" color="#77a2b6">
<meta name="application-name" content="Хабр"/>
<meta name="msapplication-TileColor" content="#77a2b6">
<meta name="theme-color" content="#77a2b6">


  <link title="Комментарии к публикации «Личный сервер shadowsocks за 10 минут без затрат»" type="application/rss+xml" rel="alternate" href="https://habr.com/ru/rss/post/555768/"/>

<script>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</script>
<script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/libs/jquery-1.8.3.min.js"></script>
<script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/libs/chance.min.js"></script>
<script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/libs/html2canvas.min.js"></script>
<script>
  window.create_callback_for_blocked = function(key) {
    return function() {
      googletag.cmd.push(function () {
        googletag.display(key);
      });
    }
  }

  window.habr_blockers_checker = new function() {
    var result;
    var callbacksQueue = [];
    var calledOnce = false;

    function fireCallbacks() {
      callbacksQueue.forEach(function(callback) {
        callback(result);
      });
      callbacksQueue = [];
    }

    this.detect = function(imgUrl, callback) {
      var checksRemain = 2;
      var detected = false;
      var error1 = false;
      var error2 = false;

      if (typeof callback !== 'function') {
        return;
      };

      callbacksQueue.push(callback);

      if (typeof result !== 'undefined') {
        fireCallbacks();
      };

      if (calledOnce) {
        return;
      }
      calledOnce = true;

      imgUrl += '?ch=*&rn=*';

      function beforeCheck(timeout) {
        if (checksRemain === 0 || timeout > 1E3) {
          result = checksRemain === 0 && detected;
          fireCallbacks();
        } else {
          setTimeout(function() {
            beforeCheck(timeout * 2)
          }, timeout * 2);
        }
      }

      function checkImages() {
        if (--checksRemain) {
          return;
        };
        detected = !error1 && error2;
      }

      var random = Math.random() * 11;

      var img1 = new Image;
      img1.onload = checkImages;
      img1.onerror = function() {
        error1 = true;
        checkImages()
      };
      img1.src = imgUrl.replace(/\*/, 1).replace(/\*/, random);

      var img2 = new Image;
      img2.onload = checkImages;
      img2.onerror = function() {
        error2 = true;
        checkImages()
      };
      img2.src = imgUrl.replace(/\*/, 2).replace(/\*/, random);

      beforeCheck(250, callback)
    };

    this.detectWrapper = function(callback) {
      return this.detect('/images/px.gif', callback);
    };
  };

  window.display_dfp_slot = function(key) {
    if (window.habr_blockers_checker) {
      window.habr_blockers_checker.detectWrapper(window.create_callback_for_blocked(key));
    } else {
      window.create_callback_for_blocked(key)();
    }
  };
</script>


<script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/libs/raven.min.js"></script>
<script>Raven.config('https://9d127adffe724363a380a189afcdb015@sentry.srv.habr.com/11', {
  maxBreadcrumbs: 50,
  sampleRate: 0.5,
  whitelistUrls: [/https?:\/\/((www)\.)?(m\.)?habr\.com/],
}).install()</script>

<script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/_parts/advertise.js"></script>
<script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/_parts/adriver.js"></script>
<script src="https://www.googletagservices.com/tag/js/gpt.js" async></script>
<script src="https://static.criteo.net/js/ld/publishertag.js" async></script>

<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>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</script>



  </head>

  <body class="nl">

    <div class="layout">
      <div class="layout__row layout__row_services">
        <div id="TMpanel">
  <div class="container">
    <div class="logo-wrapper">
      <a href="https://habr.com/ru/" class="logo" title="">
          <svg width="62" height="24" viewBox="0 0 62 24" xmlns="http://www.w3.org/2000/svg">
    <path d="M16.875 19L11.075 10.225L16.825 1.4H12.6L8.75 7.4L4.94999 1.4H0.574994L6.32499 10.15L0.524994 19H4.79999L8.64999 12.975L12.525 19H16.875Z" />
    <path d="M24.2607 5.775C20.8857 5.775 18.9607 7.625 18.6107 9.85H22.0107C22.2107 9.175 22.8607 8.6 24.1107 8.6C25.3357 8.6 26.2357 9.225 26.2357 10.425V11.025H23.4107C20.1107 11.025 18.1107 12.55 18.1107 15.2C18.1107 17.8 20.1107 19.3 22.6107 19.3C24.2857 19.3 25.6357 18.65 26.4357 17.6V19H29.8107V10.55C29.8107 7.4 27.5857 5.775 24.2607 5.775ZM23.6107 16.475C22.4857 16.475 21.7607 15.925 21.7607 15.025C21.7607 14.1 22.5607 13.55 23.6857 13.55H26.2357V14.125C26.2357 15.625 25.0107 16.475 23.6107 16.475Z" />
    <path d="M39.925 6.3C38.125 6.3 36.65 6.95 35.7 8.275C35.95 5.85 36.925 4.65 39.375 4.275L44.3 3.55V0.375L39.025 1.25C33.925 2.1 32.35 5.5 32.35 11.175C32.35 16.275 34.825 19.3 39.2 19.3C43.125 19.3 45.55 16.3 45.55 12.7C45.55 8.825 43.3 6.3 39.925 6.3ZM39.025 16.25C37.125 16.25 36.075 14.725 36.075 12.675C36.075 10.7 37.175 9.275 39.05 9.275C40.875 9.275 41.9 10.75 41.9 12.7C41.9 14.65 40.9 16.25 39.025 16.25Z" />
    <path d="M55.2855 5.775C53.3855 5.775 52.1605 6.6 51.5105 7.575V6.075H48.0105V23.775H51.6605V17.75C52.3105 18.65 53.5355 19.3 55.1855 19.3C58.3605 19.3 60.8855 16.8 60.8855 12.55C60.8855 8.225 58.3605 5.775 55.2855 5.775ZM54.4105 16.15C52.7105 16.15 51.5855 14.775 51.5855 12.6V12.5C51.5855 10.325 52.7105 8.925 54.4105 8.925C56.1105 8.925 57.2105 10.35 57.2105 12.55C57.2105 14.75 56.1105 16.15 54.4105 16.15Z" />
</svg>

      </a>
      

        <span class="projects-dropdown" id="dropdown-control">
          <svg width="10" height="6" viewBox="0 0 10 6" fill="none" xmlns="http://www.w3.org/2000/svg">
    <path fill-rule="evenodd" clip-rule="evenodd" d="M5.70711 5.70711C5.31658 6.09763 4.68342 6.09763 4.29289 5.70711L0.292892 1.70711C-0.097632 1.31658 -0.0976319 0.683417 0.292892 0.292893C0.683417 -0.0976308 1.31658 -0.0976308 1.70711 0.292893L5 3.58579L8.29289 0.292894C8.68342 -0.0976301 9.31658 -0.0976301 9.70711 0.292894C10.0976 0.683418 10.0976 1.31658 9.70711 1.70711L5.70711 5.70711Z" />
</svg>

        </span>
        <div class="dropdown hidden" id="dropdown">
          <div class="dropdown-heading">
            Все сервисы Хабра
          </div>
          <a class="service" href="/">
            <div class="service-title">
              <svg width="52" height="22" viewBox="0 0 52 22" fill="none" xmlns="http://www.w3.org/2000/svg">
                <path d="M13.86 17.0001L8.514 9.23405L13.816 1.51205H11.528L7.26 7.76005L2.97 1.51205H0.659997L5.984 9.19005L0.615997 17.0001H2.926L7.194 10.6861L11.528 17.0001H13.86Z" fill="#333333"/>
                <path d="M20.181 5.67005C17.651 5.67005 16.111 7.10005 15.759 8.81605H17.585C17.893 8.00205 18.685 7.34205 20.137 7.34205C21.567 7.34205 22.645 8.11205 22.645 9.65205V10.4001H19.697C16.991 10.4001 15.341 11.6981 15.341 13.8321C15.341 15.9441 17.013 17.2421 19.169 17.2421C20.577 17.2421 21.897 16.7141 22.733 15.6801V17.0001H24.515V9.65205C24.515 7.16605 22.777 5.67005 20.181 5.67005ZM19.411 15.5921C18.179 15.5921 17.255 14.9761 17.255 13.8101C17.255 12.6221 18.289 12.0061 19.807 12.0061H22.645V12.8201C22.645 14.5141 21.171 15.5921 19.411 15.5921Z" fill="#333333"/>
                <path d="M32.9685 5.91205C31.2965 5.91205 29.9545 6.55005 29.1185 7.78205C29.3825 5.27405 30.3945 3.88805 32.9025 3.42605L36.9505 2.67805V0.852051L32.5065 1.75405C28.7665 2.52405 27.2045 4.96605 27.2045 10.5101C27.2045 14.8001 29.4045 17.2421 32.7925 17.2421C36.0265 17.2421 38.0505 14.7121 38.0505 11.5441C38.0505 7.91405 35.8285 5.91205 32.9685 5.91205ZM32.7045 15.5261C30.6145 15.5261 29.2065 13.9641 29.2065 11.4561C29.2065 8.97005 30.7685 7.60605 32.7265 7.60605C34.7725 7.60605 36.1145 9.23405 36.1145 11.5441C36.1145 13.8541 34.7945 15.5261 32.7045 15.5261Z" fill="#333333"/>
                <path d="M46.1431 5.67005C44.2291 5.67005 43.0631 6.55005 42.5131 7.49605V5.91205H40.6871V21.2021H42.5791V15.6361C43.1071 16.4501 44.2951 17.2421 46.0771 17.2421C48.6291 17.2421 51.1371 15.3721 51.1371 11.4561C51.1371 7.56205 48.6511 5.67005 46.1431 5.67005ZM45.9011 15.5261C43.8551 15.5261 42.5131 13.9641 42.5131 11.5001V11.4121C42.5131 8.94805 43.8551 7.38605 45.9011 7.38605C47.8811 7.38605 49.2011 9.03605 49.2011 11.4561C49.2011 13.8761 47.8811 15.5261 45.9011 15.5261Z" fill="#333333"/>
              </svg>
            </div>
            <p class="service-description">
              Сообщество IT-специалистов
            </p>
          </a>
          <a class="service" href="https://qna.habr.com?utm_source=habr&utm_medium=habr_top_panel">
            <h4 class="service-title">
            <svg width="46" height="18" viewBox="0 0 46 18" fill="none" xmlns="http://www.w3.org/2000/svg">
              <path d="M14.4 8.25602C14.4 3.65802 11.606 0.27002 7.27201 0.27002C2.93801 0.27002 0.144012 3.65802 0.144012 8.25602C0.144012 12.854 2.93801 16.242 7.27201 16.242C8.41601 16.242 9.45001 16.022 10.352 15.604L11.518 17.342H13.696L11.848 14.614C13.476 13.184 14.4 10.918 14.4 8.25602ZM7.27201 14.416C4.10401 14.416 2.14601 11.864 2.14601 8.25602C2.14601 4.64802 4.10401 2.09602 7.27201 2.09602C10.44 2.09602 12.398 4.64802 12.398 8.25602C12.398 10.236 11.826 11.908 10.77 12.986L9.64801 11.314H7.47001L9.29601 14.02C8.70201 14.284 8.02001 14.416 7.27201 14.416Z" fill="#333333"/>
              <path d="M30.965 16L27.973 12.766L30.921 9.11402H28.699L26.829 11.534L23.331 7.77202C25.377 6.80402 26.455 5.59402 26.455 3.85602C26.455 1.78802 24.871 0.27002 22.583 0.27002C20.207 0.27002 18.535 1.89802 18.535 3.87802C18.535 5.19802 19.305 6.12202 20.163 7.00202L20.427 7.26602C17.985 8.25602 16.753 9.73002 16.753 11.732C16.753 14.196 18.667 16.242 21.835 16.242C23.749 16.242 25.311 15.494 26.565 14.24L26.763 14.042L28.567 16H30.965ZM22.539 1.92002C23.705 1.92002 24.629 2.62402 24.629 3.83402C24.629 5.00002 23.793 5.90202 22.187 6.62802L21.571 6.01202C21.109 5.55002 20.405 4.82402 20.405 3.81202C20.405 2.66802 21.329 1.92002 22.539 1.92002ZM21.945 14.504C19.877 14.504 18.755 13.316 18.755 11.666C18.755 10.258 19.591 9.20202 21.593 8.43202L25.641 12.832L25.509 12.964C24.541 13.976 23.309 14.504 21.945 14.504Z" fill="#333333"/>
              <path d="M43.5619 16H45.6739L39.8219 0.512019H37.7979L31.9459 16H34.0579L35.5539 11.908H42.0439L43.5619 16ZM38.7879 2.97602L41.3839 10.104H36.2139L38.7879 2.97602Z" fill="#333333"/>
            </svg>
            </h4>
            <p class="service-description">
              Ответы на&nbsp;любые вопросы об&nbsp;IT
            </p>
          </a>
          <a class="service" href="https://career.habr.com?utm_source=habr&utm_medium=habr_top_panel">
            <div class="service-title">
            <svg width="84" height="21" viewBox="0 0 84 21" fill="none" xmlns="http://www.w3.org/2000/svg">
              <path d="M12.442 16L4.96201 7.92596L12.31 0.511963H9.78001L2.894 7.41996V0.511963H0.936005V16H2.894V8.60796L9.84601 16H12.442Z" fill="#333333"/>
              <path d="M18.3646 4.66996C15.8346 4.66996 14.2946 6.09996 13.9426 7.81596H15.7686C16.0766 7.00196 16.8686 6.34196 18.3206 6.34196C19.7506 6.34196 20.8286 7.11196 20.8286 8.65196V9.39996H17.8806C15.1746 9.39996 13.5246 10.698 13.5246 12.832C13.5246 14.944 15.1966 16.242 17.3526 16.242C18.7606 16.242 20.0806 15.714 20.9166 14.68V16H22.6986V8.65196C22.6986 6.16596 20.9606 4.66996 18.3646 4.66996ZM17.5946 14.592C16.3626 14.592 15.4386 13.976 15.4386 12.81C15.4386 11.622 16.4726 11.006 17.9906 11.006H20.8286V11.82C20.8286 13.514 19.3546 14.592 17.5946 14.592Z" fill="#333333"/>
              <path d="M31.3501 4.66996C29.4361 4.66996 28.2701 5.54996 27.7201 6.49596V4.91196H25.8941V20.202H27.7861V14.636C28.3141 15.45 29.5021 16.242 31.2841 16.242C33.8361 16.242 36.3441 14.372 36.3441 10.456C36.3441 6.56196 33.8581 4.66996 31.3501 4.66996ZM31.1081 14.526C29.0621 14.526 27.7201 12.964 27.7201 10.5V10.412C27.7201 7.94796 29.0621 6.38596 31.1081 6.38596C33.0881 6.38596 34.4081 8.03596 34.4081 10.456C34.4081 12.876 33.0881 14.526 31.1081 14.526Z" fill="#333333"/>
              <path d="M43.3561 8.49796H40.8701V4.91196H38.9781V16H43.3341C45.7101 16 47.2501 14.372 47.2501 12.216C47.2501 10.06 45.7101 8.49796 43.3561 8.49796ZM43.1141 14.328H40.8701V10.17H43.1141C44.5661 10.17 45.3581 11.028 45.3581 12.216C45.3581 13.404 44.5661 14.328 43.1141 14.328Z" fill="#333333"/>
              <path d="M59.1788 11.028V10.06C59.1788 6.75996 57.2868 4.66996 54.3388 4.66996C51.3028 4.66996 49.1248 6.86996 49.1248 10.456C49.1248 14.02 51.2808 16.242 54.4928 16.242C57.3748 16.242 58.7608 14.438 59.0468 13.14H57.1328C56.9348 13.712 56.0548 14.548 54.5148 14.548C52.4688 14.548 51.1048 13.052 51.1048 11.072V11.028H59.1788ZM54.2948 6.36396C56.0768 6.36396 57.1768 7.50796 57.2648 9.42196H51.1268C51.2808 7.59596 52.4468 6.36396 54.2948 6.36396Z" fill="#333333"/>
              <path d="M67.272 4.66996C65.358 4.66996 64.192 5.54996 63.642 6.49596V4.91196H61.816V20.202H63.708V14.636C64.236 15.45 65.424 16.242 67.206 16.242C69.758 16.242 72.266 14.372 72.266 10.456C72.266 6.56196 69.78 4.66996 67.272 4.66996ZM67.03 14.526C64.984 14.526 63.642 12.964 63.642 10.5V10.412C63.642 7.94796 64.984 6.38596 67.03 6.38596C69.01 6.38596 70.33 8.03596 70.33 10.456C70.33 12.876 69.01 14.526 67.03 14.526Z" fill="#333333"/>
              <path d="M79.058 4.66996C76.528 4.66996 74.988 6.09996 74.636 7.81596H76.462C76.77 7.00196 77.562 6.34196 79.014 6.34196C80.444 6.34196 81.522 7.11196 81.522 8.65196V9.39996H78.574C75.868 9.39996 74.218 10.698 74.218 12.832C74.218 14.944 75.89 16.242 78.046 16.242C79.454 16.242 80.774 15.714 81.61 14.68V16H83.392V8.65196C83.392 6.16596 81.654 4.66996 79.058 4.66996ZM78.288 14.592C77.056 14.592 76.132 13.976 76.132 12.81C76.132 11.622 77.166 11.006 78.684 11.006H81.522V11.82C81.522 13.514 80.048 14.592 78.288 14.592Z" fill="#333333"/>
            </svg>
            </div>
            <p class="service-description">
              Профессиональное развитие в&nbsp;IT
            </p>
          </a>
          <a class="service" href="https://freelance.habr.com?utm_source=habr&utm_medium=habr_top_panel">
            <div class="service-title">
            <svg width="91" height="21" viewBox="0 0 91 21" fill="none" xmlns="http://www.w3.org/2000/svg">
              <path d="M9.032 1.65602V0.0720215H7.118V1.65602C3.268 1.72202 0.0339966 4.01002 0.0339966 8.16802C0.0339966 12.304 3.268 14.592 7.118 14.658V16.242H9.032V14.658C12.882 14.592 16.116 12.304 16.116 8.16802C16.116 4.01002 12.882 1.72202 9.032 1.65602ZM7.118 12.898C4.082 12.832 2.014 11.05 2.014 8.16802C2.014 5.26402 4.082 3.48202 7.118 3.41602V12.898ZM9.032 12.898V3.41602C12.068 3.48202 14.136 5.26402 14.136 8.16802C14.136 11.05 12.068 12.832 9.032 12.898Z" fill="#333333"/>
              <path d="M24.2603 4.67002C22.3463 4.67002 21.1803 5.55002 20.6303 6.49602V4.91202H18.8043V20.202H20.6963V14.636C21.2243 15.45 22.4123 16.242 24.1943 16.242C26.7463 16.242 29.2543 14.372 29.2543 10.456C29.2543 6.56202 26.7683 4.67002 24.2603 4.67002ZM24.0183 14.526C21.9723 14.526 20.6303 12.964 20.6303 10.5V10.412C20.6303 7.94802 21.9723 6.38602 24.0183 6.38602C25.9983 6.38602 27.3183 8.03602 27.3183 10.456C27.3183 12.876 25.9983 14.526 24.0183 14.526Z" fill="#333333"/>
              <path d="M39.4123 4.91202L33.7583 13.074V4.91202H31.8883V16H33.7583L39.4123 7.83802V16H41.2823V4.91202H39.4123Z" fill="#333333"/>
              <path d="M46.0815 4.91202L45.5095 11.71C45.3555 13.624 44.9595 14.328 43.5735 14.328H43.2655V16.044H43.7935C46.0595 16.044 47.0935 14.856 47.3355 11.842L47.7755 6.60602H51.8455V16H53.7375V4.91202H46.0815Z" fill="#333333"/>
              <path d="M61.2045 4.67002C58.6745 4.67002 57.1345 6.10002 56.7825 7.81602H58.6085C58.9165 7.00202 59.7085 6.34202 61.1605 6.34202C62.5905 6.34202 63.6685 7.11202 63.6685 8.65202V9.40002H60.7205C58.0145 9.40002 56.3645 10.698 56.3645 12.832C56.3645 14.944 58.0365 16.242 60.1925 16.242C61.6005 16.242 62.9205 15.714 63.7565 14.68V16H65.5385V8.65202C65.5385 6.16602 63.8005 4.67002 61.2045 4.67002ZM60.4345 14.592C59.2025 14.592 58.2785 13.976 58.2785 12.81C58.2785 11.622 59.3125 11.006 60.8305 11.006H63.6685V11.82C63.6685 13.514 62.1945 14.592 60.4345 14.592Z" fill="#333333"/>
              <path d="M76.104 4.91202V9.37802H70.626V4.91202H68.734V16H70.626V11.094H76.104V16H77.996V4.91202H76.104Z" fill="#333333"/>
              <path d="M85.9003 14.526C83.8983 14.526 82.5783 12.876 82.5783 10.456C82.5783 8.05802 83.8543 6.38602 85.8783 6.38602C87.6383 6.38602 88.4523 7.53002 88.7383 8.45402H90.6303C90.3443 6.69402 88.8263 4.67002 85.8783 4.67002C82.6883 4.67002 80.6423 7.13402 80.6423 10.456C80.6423 13.844 82.7323 16.242 85.8783 16.242C88.6283 16.242 90.3883 14.394 90.6303 12.414H88.7383C88.4963 13.36 87.7483 14.526 85.9003 14.526Z" fill="#333333"/>
            </svg>
            </div>
            <p class="service-description">
              Удаленная работа для IT-специалистов
            </p>
          </a>
        </div>
    </div>
    <div class="bmenu">
      <a
        class="bmenu__conversion"
        href="https://habr.com/sandbox/start/"
        onclick="if (typeof ga === 'function') { ga('send', 'event', 'habr_top_panel', 'become_an_author'); }"
      >Как стать автором</a>

      <a
        id="feature-effect"
        class="bmenu__theme"
        style="display: none;"
        target="_blank"
      >
        <img alt="" width="20" style="position:relative; vertical-align: middle; top: -2px; margin-right: 4px;" />
        <span class="bmenu__text"></span>
      </a>
    </div>

      <div id="megapost-head-effect" class="bmenu_inner" style="display:flex!important;visibility:visible!important;">
  <span class="bmenu slink">
  </span>
</div>

  </div>
</div>

<script>
  var dropdown = document.querySelector('#dropdown');
  var dropdownControl = document.querySelector('#dropdown-control');
  var logoWrapper = document.querySelector('.logo-wrapper');

  document.addEventListener('click', function(e) {
      if (dropdown) {
        var isClickInside = logoWrapper.contains(e.target);
        var dropdownClosed = dropdown.classList.contains('hidden');
        if (!isClickInside && !dropdownClosed) {
          dropdown.classList.add('hidden');
          dropdownControl.classList.remove('reverted');
        }
      }
  });
  if (dropdownControl) {
    dropdownControl.onclick = function () {
      dropdown.classList.toggle('hidden');
      dropdownControl.classList.toggle('reverted');
    }
  }
</script>

      </div>

      <div class="layout__row layout__row_navbar">
        <div class="layout__cell">
          <div class="main-navbar">
  <div class="main-navbar__section main-navbar__section_left">
    <ul class="nav-links" id="navbar-links">
    <li class="nav-links__item">
      <a href="https://habr.com/ru/top/" class="nav-links__item-link ">Все потоки</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/develop/" class="nav-links__item-link ">Разработка</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/admin/" class="nav-links__item-link ">Администрирование</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/design/" class="nav-links__item-link ">Дизайн</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/management/" class="nav-links__item-link ">Менеджмент</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/marketing/" class="nav-links__item-link ">Маркетинг</a>
    </li>
    <li class="nav-links__item">
      <a href="https://habr.com/ru/flows/popsci/" class="nav-links__item-link ">Научпоп</a>
    </li>
</ul>

    <form action="https://habr.com/ru/search/#h" method="get" class="search-form" id="search-form">
  <button type="button" class="btn btn_navbar_search icon-svg_search" id="search-form-btn" title="Поиск по сайту">
    <svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M17 11C17 14.3137 14.3137 17 11 17C7.68629 17 5 14.3137 5 11C5 7.68629 7.68629 5 11 5C14.3137 5 17 7.68629 17 11ZM15.5838 17.5574C14.2857 18.4665 12.7051 19 11 19C6.58172 19 3 15.4183 3 11C3 6.58172 6.58172 3 11 3C15.4183 3 19 6.58172 19 11C19 12.9998 18.2662 14.8282 17.0533 16.2307C17.0767 16.2502 17.0994 16.2709 17.1214 16.2929L20.4143 19.5858C20.8048 19.9763 20.8048 20.6095 20.4143 21C20.0238 21.3905 19.3906 21.3905 19.0001 21L15.7072 17.7071C15.6605 17.6604 15.6194 17.6102 15.5838 17.5574Z" />
</svg>

  </button>
  <label class="search-form__field-wrapper">
    <input type="text" name="q" class="search-form__field" id="search-form-field" placeholder="Поиск" tabindex="-1"/>
    <button type="button" class="btn btn_search-close" id="search-form-clear" title="Закрыть">
      <svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>

    </button>
  </label>
</form>

  </div>

  <div class="main-navbar__section main-navbar__section_right">
      <button type="button" class="btn btn_medium btn_navbar_lang js-show_lang_settings">
        <svg class="icon-svg" width="18" height="18">
          <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#globus-v2" />
        </svg>
      </button>
      <a href="https://habr.com/ru/auth/login/" id="login" class="btn btn_medium btn_navbar_login">Войти</a>
      <a href="https://habr.com/ru/auth/register/" class="btn btn_medium btn_navbar_registration">Регистрация</a>


  </div>
</div>

        </div>
      </div>

      <div class="layout__row layout__row_body">
        <div class="layout__cell layout__cell_body">
          
            
  
  
  <section class="column-wrapper column-wrapper_post js-sticky-wrapper">
    <div class="content_left js-content_left">
      
    <article class="post post_full" id="post_555768" lang="ru">
  <div class="post__wrapper">
    <header class="post__meta">
        <a href="https://habr.com/ru/users/YourChief/" class="post__user-info user-info" title="Автор публикации">
            <span class="default-image_mini default-image_pink">
              <svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" version="1.1" role="img"><path d="M21.5 24h-19c-1.379 0-2.5-1.122-2.5-2.5v-19c0-1.379 1.122-2.5 2.5-2.5h19c1.379 0 2.5 1.122 2.5 2.5v19c0 1.379-1.122 2.5-2.5 2.5zm-19-23c-.827 0-1.5.673-1.5 1.5v19c0 .827.673 1.5 1.5 1.5h19c.827 0 1.5-.673 1.5-1.5v-19c0-.827-.673-1.5-1.5-1.5h-19zM15.598 12.385zM19.438 15.417l-.002-.005v-.001c-.875-2.226-2.484-3.054-3.445-3.549l-.273-.143c.029-.497-.025-1.034-.167-1.599l-.128.032.123-.044c-.765-2.152-1.757-2.585-2.632-2.967l-.006-.003-.535-2.121c.357-.065.628-.375.628-.752.001-.423-.342-.765-.765-.765s-.766.342-.766.765c0 .358.248.657.581.74l-.825 1.654-.014-.003-.024-.003c-1.053-.033-1.842.369-2.5.947-.633-.322-1.515-.729-2.158-1.814.107-.12.174-.276.174-.45 0-.375-.303-.678-.678-.678s-.678.303-.678.678.303.678.678.678l.221-.04c.416.597 1.09 1.181 1.347 2.828l-.072.091.104.081-.112-.067c-1.157 1.914-.793 4.248.207 5.37-.998 2.546-1.035 4.681-.097 5.868l.002.002.003.003c.119.162.313.233.524.233.189 0 .39-.057.559-.154.312-.179.441-.459.326-.713l-.12.054.119-.056c-.581-1.243-.474-2.713.314-4.37.4.131.778.208 1.145.234l.139.73c.264 1.418.514 2.757 1.297 4.006.132.264.453.387.777.387.122 0 .245-.018.357-.051.385-.116.591-.399.537-.738l-.129.021.125-.042c-.204-.606-.431-1.146-.649-1.67-.373-.894-.725-1.742-.891-2.737.407-.042.797-.129 1.161-.261.825.692 1.661 1.492 2.743 3.406h.001c.072.14.224.215.41.215.105 0 .222-.024.339-.073.365-.155.652-.531.477-1.006v-.001c-.432-1.849-1.426-2.778-2.428-3.547.162-.175.311-.366.442-.576.75.399 1.878 1.005 3.127 2.766l.047.067.011-.008c.151.156.317.24.48.24.096 0 .191-.027.279-.084.306-.194.439-.662.29-1.005zm-8.878-2.493c-.947 0-1.713-.767-1.713-1.713s.767-1.713 1.713-1.713c.947 0 1.713.767 1.713 1.713s-.767 1.713-1.713 1.713zm6.587 4.648l-.084.021v-.001l.084-.02zm-2.007-5.312zm.022 1.006zM11.225 11.604c0 .385-.312.697-.697.697s-.697-.312-.697-.697c0-.385.312-.697.697-.697s.697.312.697.697z"/></svg>
            </span>
          <span class="user-info__nickname user-info__nickname_small">YourChief</span>
        </a>

      <span class="post__time" data-time_published="2021-05-05T01:42Z">вчера в 04:42</span>

      
    </header>

    <h1 class="post__title post__title_full">
      <span class="post__title-text">Личный сервер shadowsocks за 10 минут без затрат</span>
    </h1>


      <ul class="post__hubs post__hubs_full-post inline-list">
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/infosecurity/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Информационная безопасность'); }">Информационная безопасность</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/sys_admin/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Системное администрирование'); }">Системное администрирование</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/network_technologies/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Сетевые технологии'); }">Сетевые технологии</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/cloud_services/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Облачные сервисы'); }">Облачные сервисы</a>, 
          </li>
          <li class="inline-list__item inline-list__item_hub">
            <a href="https://habr.com/ru/hub/soft/" class="inline-list__item-link hub-link " title="Вы не подписаны на этот хаб" onclick="if (typeof ga === 'function') { ga('send', 'event', 'hub', 'post page', 'Софт'); }">Софт</a>
          </li>
      </ul>

    <ul class="post__marks inline-list"><li class="inline-list__item inline-list__item_post-type"><span class="post__type-label" title="Обучающий материал">Tutorial</span></li></ul>

    <div class="post__body post__body_full">
      <div class="post__text post__text_v2" id="post-content-body"><figure class="full-width "><img src="https://habrastorage.org/getpro/habr/upload_files/c1f/14d/bd7/c1f14dbd7ff1e51158df7a4cef8fd05b.png" width="780" height="250"><figcaption></figcaption></figure><h2>Несколько слов о shadowsocks</h2><p><a href="https://shadowsocks.org/en/index.html" rel="noopener noreferrer nofollow">shadowsocks</a> - это шифрованный сетевой туннель, клиентская часть которого предоставляет доступ приложениям к сети как SOCKS-прокси, запущенный на этом же устройстве. В некотором смысле его можно использовать как VPN, потому что клиенты поддерживают прозрачное перенаправление трафика приложений в туннель.</p><p>С самого начала shadowsocks разрабатывался как средство для обхода блокировок в Китае. С некоторого момента он получил возможность подключения внешних модулей-плагинов для оборачивания трафика shadowsocks в различные виды сетевых соединений. Это значительно расширяет границы его применения.</p><p>На хабре shadowsocks уже освещался ранее в <a href="https://habr.com/ru/post/358126/" rel="noopener noreferrer nofollow">статье</a> от <a class="mention" href="/users/barafu_albino_cheetah">@Barafu_Albino_Cheetah</a>.</p><p>В этом руководстве описано развёртывание сервера shadowsocks с плагином v2ray на облачном провайдере <a href="https://www.heroku.com/" rel="noopener noreferrer nofollow">Heroku</a>. Платформа Heroku позволяет бесплатно разворачивать небольшие веб-приложения, а <a href="https://github.com/shadowsocks/v2ray-plugin" rel="noopener noreferrer nofollow">плагин v2ray</a> позволяет пропускать трафик shadowsocks внутри websocket-соединения, что в итоге и позволяет запускать всю конструкцию на Heroku.</p><h2>Развёртывание сервера</h2><p>В этом руководстве используется замечательный проект готового приложения для Heroku, которое реализует всё необходимое автоматически. <a href="https://github.com/aditya-shri/VPN" rel="noopener noreferrer nofollow">Ссылка на GitHub проекта</a>.</p><h3>Шаг 1. Регистрация в сервисе Heroku</h3><p>Для этого нужно зайти на сайт Heroku, нажать Sign up и заполнить требуемые сведения. Для регистрации нужна только электронная почта.</p><h3>Шаг 2. Начало развёртывания</h3><p>Нажмите на эту <a href="https://heroku.com/deploy?template=https://github.com/aditya-shri/VPN/tree/main" rel="noopener noreferrer nofollow">ссылку</a>.</p><h3>Шаг 3. Конфигурирование</h3><p>В появившейся форме заполните все поля как показано на скриншоте:</p><figure class="full-width "><img src="https://habrastorage.org/getpro/habr/upload_files/879/d08/7a9/879d087a93e8ed7236f8dac711b44850.png" width="648" height="1348"><figcaption></figcaption></figure><p>В качестве значений "App Name" и AppName впишите какое-то уникальное имя приложения, одинаковое в обоих полях. Это имя станет частью доменного имени &lt;appname&gt;.herokuapp.com, по которому станет доступен сервис.</p><p>Вместо PASSWORD задайте свой пароль. Можно задать подлиннее и понадёжнее - Вам, скорее всего, не придётся вводить его вручную.</p><p>Кроме того, желательно поменять пути QR и путь обработчика прокси V2_Path на какое-нибудь трудноугадываемое значение.</p><h3>Шаг 4. Запуск</h3><p>Заполнив форму, нажмите Deploy app.</p><p>После завершения сборки и запуска QR-код с конфигурацией для мобильных устройств будет доступен по адресу</p><p><code>https://APPNAME.herokuapp.com/qr/vpn.png</code></p><p>а строка с конфигурацией в виде URL будет доступна по адресу</p><p><code>https://APPNAME.herokuapp.com/qr/</code></p><p>где APPNAME - выбранное Вами имя приложения. Если Вы меняли путь к QR-коду, то ссылка изменится в соответственно. Во второй ссылке косая черта на конце обязательна.</p><p>Всё, можно пользоваться!</p><h2>Настройка мобильного клиента на примере Android</h2><ol><li><p>Установите на Ваше устройство <a href="https://play.google.com/store/apps/details?id=com.github.shadowsocks" rel="noopener noreferrer nofollow">клиент shadowsocks</a> и <a href="https://play.google.com/store/apps/details?id=com.github.shadowsocks.plugin.v2ray" rel="noopener noreferrer nofollow">плагин v2ray</a> к нему.</p></li><li><p>Запустите приложение и добавьте новый профиль кнопкой с плюсом в правом верхнем углу. Выберите сканирование QR-кода и отсканируйте его.</p></li><li><p>Выберите созданный профиль касанием.</p></li><li><p>Запустите соединение нажатием на круглую кнопку внизу.</p></li><li><p>Готово!</p></li></ol><h2>Настройка настольного клиента на примере Windows</h2><ol><li><p>Скачайте <a href="https://github.com/shadowsocks/shadowsocks-windows/releases/latest" rel="noopener noreferrer nofollow">отсюда</a> и распакуйте shadowsocks.</p></li><li><p>Скачайте <a href="https://github.com/shadowsocks/v2ray-plugin/releases/latest" rel="noopener noreferrer nofollow">отсюда</a> плагин v2ray, подходящий под вашу платформу. Достаньте из архива файл и переименуйте его в <code>v2ray.exe</code> (или просто <code>v2ray</code>, если ваш проводник не отображает расширения файлов). Поместите его в одну директорию с shadowsocks.</p></li><li><p>Запустите shadowsocks.</p></li><li><p>Скопируйте конфигурационный URL вашего личного сервера shadowsocks со страницы <code>https://APPNAME.herokuapp.com/qr/</code> , где APPNAME - имя приложения, которое вы выбрали.</p></li><li><p>Нажмите правой кнопкой мыши на значке shadowsocks в системном трее и выберите Servers - Import URL from Сlipboard.</p></li><li><p>Включите прокси, выбрав в том же контекстном меню System Proxy - Global.</p></li><li><p>Готово!</p></li></ol><h2>Ограничения Heroku</h2><p>Для приложений, запущенных на Heroku, в настоящий момент действуют следующие ограничения:</p><ul><li><p>Временная квота работы приложений при бесплатном уровне использования составляет 550 часов в месяц.</p></li><li><p>Контейнер приложения переходит в спящий режим после 30 минут отсутствия запросов к нему. С одной стороны это доставляет неудобства в виде задержек ответа до полминуты после перерыва в активности. С другой стороны, это экономит отведённую временную квоту.</p></li><li><p>Квота на передачу данных по сети равна 2 ТБ в месяц. То есть в случае с прокси это даёт чуть меньше 1 ТБ трафика в месяц.</p></li></ul></div>
      
    </div>

    

    <dl class="post__tags">
      <dt class="post__tags-label">Теги:</dt>
      <dd class="post__tags-list">    <ul class="inline-list inline-list_fav-tags js-post-tags">
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5Bshadowsocks%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">shadowsocks</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5Bheroku%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">heroku</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5B%D0%BF%D1%80%D0%BE%D0%BA%D1%81%D0%B8%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">прокси</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5Bproxy%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">proxy</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5Bfree%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">free</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5B%D0%B1%D0%B5%D1%81%D0%BF%D0%BB%D0%B0%D1%82%D0%BD%D0%BE%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">бесплатно</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5B%D0%B1%D0%B5%D0%B7%20%D1%81%D0%BC%D1%81%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">без смс</a></li>
        <li class="inline-list__item inline-list__item_tag"><a href="https://habr.com/ru/search/?q=%5Bvpn%5D&target_type=posts" rel="tag" class="inline-list__item-link post__tag  ">vpn</a></li>
    </ul>
    <button type="button" class="btn btn_outline_grey btn_mini hidden js-fav-edit-link" data-type="2" data-id="555768" onclick="show_edit_tags(this)">Добавить метки</button>
</dd>
    </dl>
      <dl class="post__tags">
        <dt class="post__tags-label">Хабы:</dt>
        <dd class="post__tags-list">
          <ul class="inline-list inline-list_fav-tags js-post-hubs">
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/infosecurity/" rel="tag" class="inline-list__item-link post__tag">
                  Информационная безопасность
                </a>
              </li>
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/sys_admin/" rel="tag" class="inline-list__item-link post__tag">
                  Системное администрирование
                </a>
              </li>
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/network_technologies/" rel="tag" class="inline-list__item-link post__tag">
                  Сетевые технологии
                </a>
              </li>
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/cloud_services/" rel="tag" class="inline-list__item-link post__tag">
                  Облачные сервисы
                </a>
              </li>
              <li class="inline-list__item inline-list__item_tag">
                <a href="https://habr.com/ru/hub/soft/" rel="tag" class="inline-list__item-link post__tag">
                  Софт
                </a>
              </li>
          </ul>
        </dd>
      </dl>
  </div>
    <div class="overlay hidden" id="js-vote-reason">
  <div class="popup popup_reasons">
    <div class="popup__head popup__head_lang-settings">
      <span class="popup__head-title">Укажите причину минуса, чтобы автор поработал над ошибками</span>
      <button type="button" class="btn btn_small btn_popup-close js-hide_vote-reason">
        <svg class="icon-svg" width="12" height="12">
          <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#close" />
        </svg>
      </button>
    </div>
    <div class="popup__body">
       <span class="radio radio_custom reasons-vote__item js-vote-popup_list-item">
          <input type="radio" id="reasonList" name="reasonList" class="radio__input js-vote_radio" value="">
          <label for="reasonList" class="radio__label radio__label_another js-vote_title"></label>
        </span>
      <div id="js-vote-popup_list"></div>
      <button type="button" class="btn btn_blue btn_huge js-vote_send" disabled>Отправить анонимно</button>
    </div>
  </div>
</div>

</article>


      <form action="/json/favorites/" method="post" class="form form_bordered form_favorites-tags hidden" id="edit_tags_form">
  <input type="hidden" name="action" value="add" />
  <input type="hidden" name="ti" value="0" />
  <input type="hidden" name="tt" value="0" />

  <button type="button" class="btn form__close-btn" onclick="closeForm(this)" title="Закрыть"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

  <fieldset class="form__fieldset">
    <legend class="form__legend">Пометьте публикацию своими метками</legend>
    <input type="text" name="tags_string" class="form__text-field" />
    <span class="form__desc">Метки лучше разделять запятой. Например: <i>программирование, алгоритмы</i></span>
  </fieldset>

  <div class="form__footer">
    <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Сохранить</button>
  </div>
</form>

    </div>

    <div class="sidebar">
      <div class="sidebar_right_ad">
        <!-- /235032688/HH/HH01_ATF_Poster -->
<div class="dfp-slot dfp-slot_top is_visible">
  <a href="https://tmtm.ru/services/advertising/" target="_blank" class="dfp-slot__label">Реклама</a>
<div class="dfp-slot__placeholder">
  <span class="dfp-slot__placeholder-text">AdBlock похитил этот баннер, но&nbsp;баннеры не&nbsp;зубы &mdash; отрастут<br/><br/> <a href="https://u.tmtm.ru/tmtalkadblock" class="btn btn_large btn_blue" style="display:inline-flex!important;" target="_blank">Подробнее</a></span>
</div>


  <div class="dfp-slot__banner" id="div-gpt-hh-atf">
    <script>
      window.display_dfp_slot('div-gpt-hh-atf');
    </script>
  </div>
</div>

      </div>
      <div class="sidebar_right sidebar_content-area">
            

  <div class="default-block default-block_sidebar" id="most-reading">
    <div class="default-block__header">
      <h3 class="default-block__header-title">Читают сейчас</h3>
    </div>

      <div class="default-block__content default-block__content_most-read" id="broadcast_most-read">
            <ul class="content-list content-list_most-read">
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/553752/" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'post'); }">Как рекламщики уничтожили электронную почту, и что сейчас они делают с мобильной связью</a>
                <div class="post-info__meta">
                  <span class="post-info__meta-item" title="Количество просмотров">
                    <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">116k</span>
                  </span>
                    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'comment'); }" href="https://habr.com/ru/post/553752/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg>
                      <span class="post-info__meta-counter post-info__meta-counter_small">
                        560
                        
                      </span>
                    </a>
                </div>
              </li>
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/555884/" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'post'); }">Что недоговаривают Тинькофф Инвестиции. Вытаскиваем все данные по портфелю через API в большую таблицу Excel</a>
                <div class="post-info__meta">
                  <span class="post-info__meta-item" title="Количество просмотров">
                    <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">25,2k</span>
                  </span>
                    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'comment'); }" href="https://habr.com/ru/post/555884/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg>
                      <span class="post-info__meta-counter post-info__meta-counter_small">
                        10
                        
                      </span>
                    </a>
                </div>
              </li>
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/556016/" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'post'); }">«Сбер» разослал собиравшимся участвовать в митингах сотрудникам письма с предупреждением утечки их данных</a>
                <div class="post-info__meta">
                  <span class="post-info__meta-item" title="Количество просмотров">
                    <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">10,9k</span>
                  </span>
                    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'comment'); }" href="https://habr.com/ru/news/t/556016/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg>
                      <span class="post-info__meta-counter post-info__meta-counter_small">
                        37
                        
                      </span>
                    </a>
                </div>
              </li>
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/556034/" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'post'); }">Учёные придумали, как извлекать металлы из-под земли без рытья</a>
                <div class="post-info__meta">
                  <span class="post-info__meta-item" title="Количество просмотров">
                    <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">5,1k</span>
                  </span>
                    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'comment'); }" href="https://habr.com/ru/news/t/556034/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg>
                      <span class="post-info__meta-counter post-info__meta-counter_small">
                        12
                        
                      </span>
                    </a>
                </div>
              </li>
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/556026/" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'post'); }">Sony перестала продавать цифровые зеркалки</a>
                <div class="post-info__meta">
                  <span class="post-info__meta-item" title="Количество просмотров">
                    <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">6,7k</span>
                  </span>
                    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'comment'); }" href="https://habr.com/ru/news/t/556026/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg>
                      <span class="post-info__meta-counter post-info__meta-counter_small">
                        28
                        
                      </span>
                    </a>
                </div>
              </li>
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/555794/" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'post'); }">Signal купил у Facebook рекламу и показывал в баннерах параметры таргетинга, что соцсети очень не понравилось</a>
                <div class="post-info__meta">
                  <span class="post-info__meta-item" title="Количество просмотров">
                    <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter post-info__meta-counter_small">14,6k</span>
                  </span>
                    <a onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'comment'); }" href="https://habr.com/ru/news/t/555794/#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg>
                      <span class="post-info__meta-counter post-info__meta-counter_small">
                        127
                        
                      </span>
                    </a>
                </div>
              </li>
              <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://u.habr.com/agritech_chitayut" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'read_now,post', 'https://u.habr.com/agritech_chitayut'); }">Плачу на агротехно: тест про зелёные технологии</a>
                  <div class="post-info__meta-label">
                    Мегатест
                  </div>
              </li>
          </ul>
    </div>
  </div>


            <div class="default-block default-block_sidebar hidden" id="tm-editoral-subscription">
    <div class="tm-editoral-subscription">
      <span class="tm-editoral-subscription__close" id="editoral-subscribe-close">
        <svg width="12" height="12">
          <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#close" />
        </svg>
      </span>

      <h3 class="tm-editoral-subscription__title">
        Редакторский дайджест
      </h3>
      <p class="tm-editoral-subscription__description">
        Присылаем лучшие статьи раз в месяц
      </p>
      <form method="POST" class="tm-editoral-subscription__form" id="editoral-subscribe">
        <input placeholder="Электропочта" name="email" type="email" id="editoral-subscribe-email" class="tm-editoral-subscription__input" />
        <input name="hl" type="hidden" value="ru" />
        <input name="fl" type="hidden" value="ru" />
        <button type="submit" class="tm-editoral-subscription__icon" id="editoral-subscribe-button">
          <svg width="24" height="24">
            <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-right" />
          </svg>
        </button>
      </form>
      <p class="tm-editoral-subscription__error hidden" id="editoral-subscribe-error"></p>
      <p class="tm-editoral-subscription__success hidden" id="editoral-subscribe-success">
        Скоро на этот адрес придет письмо. Подтвердите подписку, если всё в силе.
      </p>
  </div>
  <script>
    $(document).ready(function () {
      var block = $('#tm-editoral-subscription');
      var input = $('#editoral-subscribe-email');
      var button = $('#editoral-subscribe-button');
      var error = $('#editoral-subscribe-error');
      var success = $('#editoral-subscribe-success');

      var cookieOptions = {
        expires: 90,
        path: '/',
        secure: true,
      };

      if (!$.cookie('habr-editoral-subscription')) {
        block.removeClass('hidden');
      }

      $('#editoral-subscribe-close').click(function() {
        $.cookie('habr-editoral-subscription', 'close', cookieOptions);
        if (typeof ga === 'function') {
          ga('send', 'event', 'tm_block', 'edit-digest_post', 'close');
        }
        block.remove();
      });


      function onError(msg) {
        input.prop('disabled', false);
        button.prop('disabled', false);
        button.removeClass('loading');
        error.removeClass('hidden');
        error.text(msg);
      }

      $('#editoral-subscribe').submit(function (e) {
        var form = $(this);

        form.ajaxSubmit({
          url:'/json/digests/editorial/subscribe',
          dataType:'json',
          beforeSubmit: function() {
            input.prop('disabled', true);
            button.prop('disabled', true);
            error.addClass('hidden');
            button.addClass('loading');
          },
          error: function(err) {
            if (err.status !== 200) {
              onError(err.statusText);
            } else {
              onError(err);
            }
          },
          success: function(json) {
            if (json.system_errors) {
              onError(json.system_errors && json.system_errors[0]);
            } else {
              form.addClass('hidden');
              success.removeClass('hidden');
              button.removeClass('loading');
              $.cookie('habr-editoral-subscription', 'subscribe', cookieOptions);
              if (typeof ga === 'function') {
                ga('send', 'event', 'tm_block', 'edit-digest_post', 'subscribe');
              }
              setTimeout(function() {block.remove()}, 10000);
            }
          }
        });
        return false;
      });
    });
  </script>

      </div>
    </div>
  </section>

  <section class="column-wrapper">
    <div class="content_left">
      <div class="post-additionals">
          <ul class="post-stats post-stats_post js-user_" data-post-type="publish_ugc_ru,h_50,h_221,h_17123,h_21470,h_21918,f_develop,f_admin,f_popsci" id="infopanel_post_555768">
          <li class="post-stats__item post-stats__item_voting-wjt">
            <div class="voting-wjt voting-wjt_post js-post-vote" data-id="555768" data-type="2">
              <button type="button" class="btn voting-wjt__button " data-action="plus" onclick="posts_vote_plus(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

              <span class="voting-wjt__counter  voting-wjt__counter_positive  js-score" onclick="posts_vote_result(12, 12, 0)" title="Всего голосов 12: &uarr;12 и &darr;0">+12</span>

              <button type="button" class="btn voting-wjt__button " data-action="minus" title="Голосовать могут только зарегистрированные пользователи" onclick="posts_vote_minus(this);" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
            </div>
          </li>
    <li class="post-stats__item post-stats__item_bookmark">
      <button type="button" class="btn bookmark-btn bookmark-btn_post " data-post-type="publish_ugc_ru,h_50,h_221,h_17123,h_21470,h_21918,f_develop,f_admin,f_popsci" data-type="2" data-id="555768" data-action="add" title="Только зарегистрированные пользователи могут добавлять публикации в закладки" onclick="posts_add_to_favorite(this);" disabled>
        <span class="btn_inner"><svg class="icon-svg_bookmark" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="bookmark__counter js-favs_count" title="Количество пользователей, добавивших публикацию в закладки">100</span></span>
      </button>
    </li>

    <li class="post-stats__item post-stats__item_views">
      <div class="post-stats__views" title="Количество просмотров">
        <svg class="icon-svg_views-count" width="21" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-stats__views-count">9,7k</span>
      </div>
    </li>

      <li class="post-stats__item post-stats__item_comments">
          <a href="https://habr.com/ru/post/555768/#comments" class="post-stats__comments-link" rel="nofollow">
            <svg class="icon-svg_post-comments" width="16" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-stats__comments-count" id="post-stats-comments-count" title="Читать комментарии">17</span>
          </a>
      </li>


      <li class="post-stats__item post-stats__item_share">
        <div class="dropdown dropdown_share">
          <div href="https://habr.com/ru/post/555768/#comments" data-toggle="dropdown" class="post-stats__share" rel="nofollow">
            <svg class="icon-svg_post-share" width="24" height="24">
              <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#share">
            </svg>
            <span class="post-stats__comments-text" title="Поделиться">
              Поделиться
            </span>
          </div>

          <div class="dropdown-container">
            <div class="post-share">
  <ul class="post-share__buttons">
    <li class="post-share__item post-share__item_post">
      <span
        class="post-share__item-link post-share__item-link_normal post-share__item-link_copy"
        title="Скопировать ссылку"
        onclick="copyCurrentUrl(), $('.dropdown_share').removeClass('dropdown_active')"
      >
        Скопировать ссылку
      </span>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://www.facebook.com/sharer/sharer.php?u=https://habr.com/ru/post/555768/"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_facebook"
        title="Facebook"
        onclick="window.open(this.href, 'Facebook', 'width=640,height=436,toolbar=0,status=0'); return false"
      >
        Facebook
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://twitter.com/intent/tweet?text=%D0%9B%D0%B8%D1%87%D0%BD%D1%8B%D0%B9+%D1%81%D0%B5%D1%80%D0%B2%D0%B5%D1%80+shadowsocks+%D0%B7%D0%B0+10+%D0%BC%D0%B8%D0%BD%D1%83%D1%82+%D0%B1%D0%B5%D0%B7+%D0%B7%D0%B0%D1%82%D1%80%D0%B0%D1%82+https://habr.com/p/555768/+via+%40habr_com"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_twitter"
        title="Twitter"
        onclick="window.open(this.href, 'Twitter', 'width=800,height=300,resizable=yes,toolbar=0,status=0'); return false"
      >
        Twitter
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://vk.com/share.php?url=https://habr.com/ru/post/555768/"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_vkontakte"
        title="ВКонтакте"
        onclick="window.open(this.href, 'ВКонтакте', 'width=800,height=300,toolbar=0,status=0'); return false"
      >
        ВКонтакте
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://t.me/share/url?url=https://habr.com/ru/post/555768/&title=Личный сервер shadowsocks за 10 минут без затрат"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_telegram"
        title="Telegram"
        onclick="window.open(this.href, 'Telegram', 'width=800,height=300,toolbar=0,status=0'); return false"
      >
        Telegram
      </a>
    </li>
    <li class="post-share__item post-share__item_post">
      <a href="https://getpocket.com/edit?url=https://habr.com/ru/post/555768/&title=Личный сервер shadowsocks за 10 минут без затрат"
        class="post-share__item-link post-share__item-link_normal post-share__item-link_pocket"
        title="Pocket"
        target="_blank"
      >
        Pocket
      </a>
    </li>
  </ul>
</div>

          </div>
        </div>
      </li>






  </ul>

          
          <form action="/json/complaints/add/" class="form form_bordered form_abuse hidden" method="post" id="abuse_form">
  <input type="hidden" name="tt" value="2" />
  <input type="hidden" name="ti" value="555768" />

  <button type="button" class="btn form__close-btn" onclick="closeForm(this)"><svg class="icon-svg icon-svg_navbar-close-search" width="31" height="32" viewBox="0 0 31 32" aria-hidden="true" version="1.1" role="img"><path d="M26.67 0L15.217 11.448 3.77 0 0 3.77l11.447 11.45L0 26.666l3.77 3.77L15.218 18.99l11.45 11.448 3.772-3.77-11.448-11.45L30.44 3.772z"/></svg>
</button>

  <fieldset class="form__fieldset">
    <legend class="form__legend">Нарушение</legend>
    <input type="text" name="text" class="form__text-field" />
    <span class="form__desc">Опишите суть нарушения</span>
  </fieldset>

  <div class="form__footer">
    <button type="submit" class="btn btn_x-large btn_outline_blue" disabled>Отправить</button>
  </div>
</form>


          <div class="author-panel author-panel_user">
            <div class="author-panel__user-info">
              <div class="user-info" data-user-login="YourChief">
  <div class="user-info__stats">
      <div class="media-obj">
        <a href="https://habr.com/ru/users/YourChief/" class="media-obj__image" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_bottom', 'profile', 'YourChief');}">
            <span class="default-image default-image_medium default-image_pink">
              <svg class="icon-svg" width="24" height="24" viewBox="0 0 24 24" aria-hidden="true" version="1.1" role="img"><path d="M21.5 24h-19c-1.379 0-2.5-1.122-2.5-2.5v-19c0-1.379 1.122-2.5 2.5-2.5h19c1.379 0 2.5 1.122 2.5 2.5v19c0 1.379-1.122 2.5-2.5 2.5zm-19-23c-.827 0-1.5.673-1.5 1.5v19c0 .827.673 1.5 1.5 1.5h19c.827 0 1.5-.673 1.5-1.5v-19c0-.827-.673-1.5-1.5-1.5h-19zM15.598 12.385zM19.438 15.417l-.002-.005v-.001c-.875-2.226-2.484-3.054-3.445-3.549l-.273-.143c.029-.497-.025-1.034-.167-1.599l-.128.032.123-.044c-.765-2.152-1.757-2.585-2.632-2.967l-.006-.003-.535-2.121c.357-.065.628-.375.628-.752.001-.423-.342-.765-.765-.765s-.766.342-.766.765c0 .358.248.657.581.74l-.825 1.654-.014-.003-.024-.003c-1.053-.033-1.842.369-2.5.947-.633-.322-1.515-.729-2.158-1.814.107-.12.174-.276.174-.45 0-.375-.303-.678-.678-.678s-.678.303-.678.678.303.678.678.678l.221-.04c.416.597 1.09 1.181 1.347 2.828l-.072.091.104.081-.112-.067c-1.157 1.914-.793 4.248.207 5.37-.998 2.546-1.035 4.681-.097 5.868l.002.002.003.003c.119.162.313.233.524.233.189 0 .39-.057.559-.154.312-.179.441-.459.326-.713l-.12.054.119-.056c-.581-1.243-.474-2.713.314-4.37.4.131.778.208 1.145.234l.139.73c.264 1.418.514 2.757 1.297 4.006.132.264.453.387.777.387.122 0 .245-.018.357-.051.385-.116.591-.399.537-.738l-.129.021.125-.042c-.204-.606-.431-1.146-.649-1.67-.373-.894-.725-1.742-.891-2.737.407-.042.797-.129 1.161-.261.825.692 1.661 1.492 2.743 3.406h.001c.072.14.224.215.41.215.105 0 .222-.024.339-.073.365-.155.652-.531.477-1.006v-.001c-.432-1.849-1.426-2.778-2.428-3.547.162-.175.311-.366.442-.576.75.399 1.878 1.005 3.127 2.766l.047.067.011-.008c.151.156.317.24.48.24.096 0 .191-.027.279-.084.306-.194.439-.662.29-1.005zm-8.878-2.493c-.947 0-1.713-.767-1.713-1.713s.767-1.713 1.713-1.713c.947 0 1.713.767 1.713 1.713s-.767 1.713-1.713 1.713zm6.587 4.648l-.084.021v-.001l.084-.02zm-2.007-5.312zm.022 1.006zM11.225 11.604c0 .385-.312.697-.697.697s-.697-.312-.697-.697c0-.385.312-.697.697-.697s.697.312.697.697z"/></svg>
            </span>
        </a>

        <div class="media-obj__body media-obj__body_user-info">
              <a href="https://habr.com/ru/info/help/karma/" class="user-info__stats-item stacked-counter" title="226 голосов">
                <div class="stacked-counter__value stacked-counter__value_green ">73,5</div>
                <div class="stacked-counter__label">Карма</div>
              </a>

            <a href="https://habr.com/ru/info/help/karma/#rating" class="user-info__stats-item stacked-counter stacked-counter_rating" title="Рейтинг пользователя">
              <div class="stacked-counter__value stacked-counter__value_magenta">20,2</div>
              <div class="stacked-counter__label">Рейтинг</div>
            </a>
        </div>
      </div>

  </div>

  <div class="user-info__about">
    <div class="user-info__links">
        <a href="https://habr.com/ru/users/YourChief/" class="user-info__fullname" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_top', 'profile', 'YourChief');}">Vladislav Yarmak</a>&nbsp;<a href="/users/YourChief/" class="user-info__nickname user-info__nickname_doggy" onclick="if (typeof ga === 'function') { ga('send', 'event', 'author_info_top', 'profile', 'YourChief');}">YourChief</a>
        
    </div>

      <div class="user-info__specialization">Системный архитектор</div>
  </div>
</div>

<div class="overlay hidden" id="js-donate">
  <div class="popup">
    <div class="popup__head popup__head_lang-settings">
      <span class="popup__head-title js-popup_title" data-section="1">Платежная система</span>
      <button type="button" class="btn btn_small btn_popup-close js-hide-donate">
        <svg class="icon-svg" width="12" height="12">
          <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#close" />
        </svg>
      </button>
    </div>
    <div class="popup__body js-donate-popup_body">
        <a class="js-donate-popup_link" href="https://www.paypal.me/VladislavYarmak" target="_blank" onclick="if (typeof ga === 'function') { ga('send', 'event', 'donation', 'pay_sender', '%guest%'); ga('send', 'event', 'donation', 'pay_receiver', 'YourChief'); }">PayPal.Me</a>
    </div>
  </div>
</div>


            </div>
              <ul class="user-info__contacts inline-list">
        <li class="inline-list__item inline-list__item_contact-link"><a href="https://twitter.com/snawoot">Twitter</a></li>
        <li class="inline-list__item inline-list__item_contact-link"><a href="https://github.com/Snawoot/">Github</a></li>
        <li class="inline-list__item inline-list__item_contact-link"><a href="skype:solaris.snaut">Skype</a></li>
        <li class="inline-list__item inline-list__item_contact-link"><a href="xmpp:yarmak@openjabber.org">Jabber</a></li>
        <li class="inline-list__item inline-list__item_contact-link"><a href="https://telegram.me/Snawoot">Telegram</a></li>
  </ul>

          </div>
      </div>
    </div>
    <div class="sidebar_right">
    </div>
  </section>

  <section class="column-wrapper column-wrapper__last">
    <div class="content_left">
        

    <div class="default-block default-block_content">
      <div class="default-block__header default-block__header_large">
        <h2 class="default-block__header-title default-block__header-title_large">Похожие публикации</h2>
      </div>
      <div class="default-block__content">

        <ul class="content-list">
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">3 октября 2018 в 13:37</span>
                <h3 class="post-info__title post-info__title_large">
                  <a href="https://habr.com/ru/post/425165/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common', '1'); }">
                    Nemesida WAF Free — бесплатная версия, обеспечивающая базовую защиту веб-приложения от атак
                  </a>
                </h3>

              <div class="post-info__meta">
                <span class="post-info__meta-item" title="Рейтинг">
                  <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg>
                      <span class="post-info__meta-counter">10</span>
                </span>
                <span class="post-info__meta-item" title="Количество просмотров">
                  <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">4,9k</span>
                </span>
                <span class="post-info__meta-item" title="Закладки">
                  <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">30</span>
                </span>
                <a href="https://habr.com/ru/post/425165#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                  <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">2
                    
                  </span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">28 июля 2014 в 20:21</span>
                <h3 class="post-info__title post-info__title_large">
                  <a href="https://habr.com/ru/post/231375/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common', '2'); }">
                    Бесплатный аналог AnyConnect VPN Server
                  </a>
                </h3>

              <div class="post-info__meta">
                <span class="post-info__meta-item" title="Рейтинг">
                  <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg>
                      <span class="post-info__meta-counter">4</span>
                </span>
                <span class="post-info__meta-item" title="Количество просмотров">
                  <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">36,1k</span>
                </span>
                <span class="post-info__meta-item" title="Закладки">
                  <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">136</span>
                </span>
                <a href="https://habr.com/ru/post/231375#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                  <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">22
                    
                  </span>
                </a>
              </div>
            </li>
            <li class="content-list__item content-list__item_devided post-info">
              <span class="post-info__date">29 марта 2013 в 04:02</span>
                <h3 class="post-info__title post-info__title_large">
                  <a href="https://habr.com/ru/post/174651/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'similar_posts', 'common', '3'); }">
                    Bitcoin: Как получить 25+ Mhash/s бесплатно без смс
                  </a>
                </h3>

              <div class="post-info__meta">
                <span class="post-info__meta-item" title="Рейтинг">
                  <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg>
                      <span class="post-info__meta-counter">31</span>
                </span>
                <span class="post-info__meta-item" title="Количество просмотров">
                  <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">306</span>
                </span>
                <span class="post-info__meta-item" title="Закладки">
                  <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">479</span>
                </span>
                <a href="https://habr.com/ru/post/174651#comments" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                  <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">177
                    
                  </span>
                </a>
              </div>
            </li>
        </ul>

      </div>
    </div>

      <div class="default-block_content">
          


  <div class="promo-block promo-block_questions">
    <h2 class="promo-block__header">
      
      <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'blockname'); }" href="http://qna.habr.com/" target="_blank" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=block_name&utm_campaign=questions_post" class="promo-block__title-link" rel="nofollow">Вопросы и ответы</a>
    </h2>

        <div class="promo-block__content">
          <ul class="content-list content-list_promo" >
              <li class="content-list__item content-list__item_promo">
                <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'post'); }" href="https://qna.habr.com/q/983875" class="promo-item" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=question&utm_campaign=questions_post">
                  <div class="promo-item__wrap">
                    <h3 class="promo-item__title promo-item__title_hovered">Почему ошибка на хероку?</h3>

                    <div class="promo-item__attrs promo-item__attrs_toster">
                      <span class="promo-item__attrs-item">Heroku</span>
                      <span class="promo-item__attrs-item">Простой</span>
                      <span class="promo-item__attrs-item">0 ответов</span>
                    </div>
                  </div>
                </a>
              </li>
              <li class="content-list__item content-list__item_promo">
                <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'post'); }" href="https://qna.habr.com/q/983815" class="promo-item" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=question&utm_campaign=questions_post">
                  <div class="promo-item__wrap">
                    <h3 class="promo-item__title promo-item__title_hovered">Почему Тор не выдает новый ip адрес? Как его получить?</h3>

                    <div class="promo-item__attrs promo-item__attrs_toster">
                      <span class="promo-item__attrs-item">Proxy</span>
                      <span class="promo-item__attrs-item">Средний</span>
                      <span class="promo-item__attrs-item">0 ответов</span>
                    </div>
                  </div>
                </a>
              </li>
              <li class="content-list__item content-list__item_promo">
                <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'post'); }" href="https://qna.habr.com/q/982785" class="promo-item" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=question&utm_campaign=questions_post">
                  <div class="promo-item__wrap">
                    <h3 class="promo-item__title promo-item__title_hovered">Как сохранить данные на сервере?</h3>

                    <div class="promo-item__attrs promo-item__attrs_toster">
                      <span class="promo-item__attrs-item">Python</span>
                      <span class="promo-item__attrs-item">Простой</span>
                      <span class="promo-item__attrs-item">2 ответа</span>
                    </div>
                  </div>
                </a>
              </li>
              <li class="content-list__item content-list__item_promo">
                <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'post'); }" href="https://qna.habr.com/q/981779" class="promo-item" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=question&utm_campaign=questions_post">
                  <div class="promo-item__wrap">
                    <h3 class="promo-item__title promo-item__title_hovered">Как исправить ошибку heroku?</h3>

                    <div class="promo-item__attrs promo-item__attrs_toster">
                      <span class="promo-item__attrs-item">Heroku</span>
                      <span class="promo-item__attrs-item">Средний</span>
                      <span class="promo-item__attrs-item">1 ответ</span>
                    </div>
                  </div>
                </a>
              </li>
              <li class="content-list__item content-list__item_promo">
                <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'post'); }" href="https://qna.habr.com/q/981539" class="promo-item" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=question&utm_campaign=questions_post">
                  <div class="promo-item__wrap">
                    <h3 class="promo-item__title promo-item__title_hovered">Не могу подключиться к прокси socks5?</h3>

                    <div class="promo-item__attrs promo-item__attrs_toster">
                      <span class="promo-item__attrs-item">Proxy</span>
                      <span class="promo-item__attrs-item">Простой</span>
                      <span class="promo-item__attrs-item">1 ответ</span>
                    </div>
                  </div>
                </a>
              </li>
          </ul>
        </div>
    <div class="promo-block__footer">
      <a onclick="if (typeof ga === 'function') { if (g_is_ugc_post) { var action = 'qna_post' } else {  var action = 'qna_feed' } ga('send', 'event', 'tm_block', action, 'posts'); }" href="https://qna.habr.com/" data-utm="?utm_source=habr&utm_medium=habr_block&utm_content=questions_all&utm_campaign=questions_post" class="promo-block__footer-link promo-block__footer-link_selected" rel="nofollow">Больше вопросов на Хабр Q&A</a>
    </div>
  </div>


      </div>
      <!-- /235032688/HH/HH02_inpage_wide -->
<div class="dfp-slot">
  <a href="https://tmtm.ru/services/advertising/" target="_blank" class="dfp-slot__label">Реклама</a>
<div class="dfp-slot__placeholder">
  <span class="dfp-slot__placeholder-text">AdBlock похитил этот баннер, но&nbsp;баннеры не&nbsp;зубы &mdash; отрастут<br/><br/> <a href="https://u.tmtm.ru/tmtalkadblock" class="btn btn_large btn_blue" style="display:inline-flex!important;" target="_blank">Подробнее</a></span>
</div>

  <div class="dfp-slot__banner dfp-slot__banner_wide" id='div-gpt-hh-inpage-wide'>
    <script>
      window.display_dfp_slot('div-gpt-hh-inpage-wide');
    </script>
  </div>
</div>

    </div>
    <div class="sidebar">
      <div class="sidebar_right">
        <div class="default-block_content">
          <div class="content-list__item content-list__item_post shortcuts_item" id="effect-sidebar" style="display: none;">
   <div class="default-block">
    <div class="default-block__header">
      <h2 class="default-block__header-title">Минуточку внимания</h2>
    </div>
    <div class="default-block__content">
      <ul class="megapost-teasers" id="megapost-teasers-sidebar">

      </ul>
    </div>
  </div>
</div>
        </div>
      </div>
    </div>
  </section>

<section class="column-wrapper column-wrapper_comments js-comments-wrapper">
  <div class="content_left">
        <div class="comments-section" id="comments">
    <header class="comments-section__head">
      <h2 class="comments-section__head-title">
        Комментарии
        <span class="comments-section__head-counter" id="comments_count">
          17
        </span>
      </h2>
      
    </header>
    
    

    <ul class="content-list content-list_comments" id="comments-list">
        <li class="content-list__item content-list__item_comment js-comment " rel="23000176">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_23000176">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000176"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000176">
          <a href="https://habr.com/ru/users/Gogino2005/" class="user-info user-info_inline"  data-user-login="Gogino2005">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/8c4/664/457/8c46644579ef81d572b67985eccd1aee.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Gogino2005</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 05:59</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000176" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000176" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000176" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000176" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000176" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">Oracle Cloud Free (10Tb в месяц) + AmneziaVPN = всё своё и по взрослому.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_23000176">  <li class="content-list__item content-list__item_comment js-comment " rel="23000330">
    
    <span class="parent_id" data-parent_id="23000176"></span>
    <div class="comment" id="comment_23000330">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000330"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000330">
          <a href="https://habr.com/ru/users/grayfolk/" class="user-info user-info_inline"  data-user-login="grayfolk">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/946/642/b62/946642b6250b3c3b5a69ea49e3002f02.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">grayfolk</span>
</a>

          <svg class="icon_comment-edit" title="Комментарий был изменен" width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#pencil" /></svg>
          <time class="comment__date-time comment__date-time_published">вчера в 08:19</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000330" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000330" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23000330" data-parent_id="23000176" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000176" class="icon_comment-arrow-up js-comment_parent" data-id="23000330" data-parent_id="23000176" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000330" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000330" data-parent_id="23000176" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000330" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +2: &uarr;2 и &darr;0">+2</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><p>Только вот зарегистрироваться в Oracle Cloud Free Tier — та еще задача для меня оказалась. То денег на карте не хватает (около $20 было на карте), то вообще никакой реакции на регистрацию, а в последний раз пришло письмо, что на указанный мною при регистрации телефон не смогли дозвониться. Поменять — надо по-новой регистрироваться. С поддержкой общался — сказали, что вообще ничем не могут помочь, пробуйте зарегистрироваться снова.<br>
Ну и насчет &quot;free&quot;, а тем более, &quot;always&quot; — <a href="https://habr.com/ru/post/541466/#comment_22657718"></a><a href="https://habr.com/ru/post/541466/#comment_22657718">https://habr.com/ru/post/541466/#comment_22657718</a> — тут много поучительных историй.<br>
P.S. В итоге плюнул. Все же, тьфу-тьфу, не настолько нищие, чтобы не купить за $5 инстанс на DO или AWS Lightsail. В любом случае дешевле обойдется, чем возня с регистрацией в Oracle.</p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_23000330">  <li class="content-list__item content-list__item_comment js-comment " rel="23001492">
    
    <span class="parent_id" data-parent_id="23000330"></span>
    <div class="comment" id="comment_23001492">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23001492"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23001492">
          <a href="https://habr.com/ru/users/Ninil/" class="user-info user-info_inline"  data-user-login="Ninil">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/7d7/698/196/7d76981965d9d56d5a84b6dbfd099dfa.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Ninil</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 12:45</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23001492" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23001492" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23001492" data-parent_id="23000330" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000330" class="icon_comment-arrow-up js-comment_parent" data-id="23001492" data-parent_id="23000330" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23001492" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23001492" data-parent_id="23000330" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23001492" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><p>Тоже так и не смог в Oracle Cloud зарегистрироваться… Деньги с карты снимают, потом почти сразу возвращают и выводят ошибку — мол не смогли провести платеж...</p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-2" id="reply_comments_23001492">  <li class="content-list__item content-list__item_comment js-comment " rel="23001650">
    
    <span class="parent_id" data-parent_id="23001492"></span>
    <div class="comment" id="comment_23001650">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23001650"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23001650">
          <a href="https://habr.com/ru/users/runalsh/" class="user-info user-info_inline"  data-user-login="runalsh">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_blue" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">runalsh</span>
</a>

          <svg class="icon_comment-edit" title="Комментарий был изменен" width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#pencil" /></svg>
          <time class="comment__date-time comment__date-time_published">вчера в 13:18</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23001650" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23001650" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23001650" data-parent_id="23001492" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23001492" class="icon_comment-arrow-up js-comment_parent" data-id="23001650" data-parent_id="23001492" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23001650" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23001650" data-parent_id="23001492" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23001650" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">Причина, которую озвучили в ТП — high risk country. Поможет перемещение в менее рисковую страну и новый профиль браузера с подменой canvas.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-3" id="reply_comments_23001650">  <li class="content-list__item content-list__item_comment js-comment " rel="23003580">
    
    <span class="parent_id" data-parent_id="23001650"></span>
    <div class="comment" id="comment_23003580">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23003580"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23003580">
          <a href="https://habr.com/ru/users/Klajnor/" class="user-info user-info_inline"  data-user-login="Klajnor">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/8bd/f6e/9a8/8bdf6e9a8bdd66e7464664d0b4d24d40.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Klajnor</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 20:16</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23003580" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23003580" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23003580" data-parent_id="23001650" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23001650" class="icon_comment-arrow-up js-comment_parent" data-id="23003580" data-parent_id="23001650" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23003580" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23003580" data-parent_id="23001650" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23003580" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  comment__message_v2  "><p>Всей ветке выше</p><p>Странно, я легко зарегистрировался и легко создал машину. Посмотрим сколько проживет, пока два месяца </p><p>Живёт как запасная</p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-4" id="reply_comments_23003580"></ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="23004088">
    
    <span class="parent_id" data-parent_id="23001650"></span>
    <div class="comment" id="comment_23004088">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23004088"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23004088">
          <a href="https://habr.com/ru/users/Knkplua/" class="user-info user-info_inline"  data-user-login="Knkplua">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_blue" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Knkplua</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 22:14</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23004088" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23004088" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23004088" data-parent_id="23001650" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23001650" class="icon_comment-arrow-up js-comment_parent" data-id="23004088" data-parent_id="23001650" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23004088" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23004088" data-parent_id="23001650" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23004088" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">Не знаю, в какую страну еще переместиться. Я пробовал Чехию, Литву, Украину. Все данные настоящие (местные банки, телефоны, ip без прокси/впн). Результат один и тот же — не получилось. Не проходит авторизация банковской карты. Как объяснили в банке, в отличии от других (Amazon, Microsoft), очень своеобразная верификация: на карте блокируются деньги, блокировка сразу снимается, а потом попытка снять деньги по уже отмененной блокировке. Банк такую операцию отклоняет (возможно я использовал неправильные термины или неточно понял — не имею отношения к финансам).</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-4" id="reply_comments_23004088"></ul>
  </li>
</ul>
  </li>
</ul>
  </li>
</ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="23001312">
    
    <span class="parent_id" data-parent_id="23000176"></span>
    <div class="comment" id="comment_23001312">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23001312"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23001312">
          <a href="https://habr.com/ru/users/Andrusha/" class="user-info user-info_inline"  data-user-login="Andrusha">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/e39/c6c/44a/e39c6c44a83948cbf0a3334709cb9a97.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Andrusha</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 12:07</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23001312" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23001312" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23001312" data-parent_id="23000176" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000176" class="icon_comment-arrow-up js-comment_parent" data-id="23001312" data-parent_id="23000176" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23001312" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23001312" data-parent_id="23000176" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23001312" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">Боюсь, до релиза мобильных клиентов «по-взрослому» не получится.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_23001312"></ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="23002696">
    
    <span class="parent_id" data-parent_id="23000176"></span>
    <div class="comment" id="comment_23002696">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23002696"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23002696">
          <a href="https://habr.com/ru/users/osscombat/" class="user-info user-info_inline"  data-user-login="osscombat">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_pink" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">osscombat</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 16:55</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23002696" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23002696" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23002696" data-parent_id="23000176" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000176" class="icon_comment-arrow-up js-comment_parent" data-id="23002696" data-parent_id="23000176" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23002696" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23002696" data-parent_id="23000176" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23002696" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">не смог найти, какие у них официальные лимиты на трафик в always free?</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_23002696"></ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="23002792">
    
    <span class="parent_id" data-parent_id="23000176"></span>
    <div class="comment" id="comment_23002792">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23002792"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23002792">
          <a href="https://habr.com/ru/users/F0iL/" class="user-info user-info_inline"  data-user-login="F0iL">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/bcd/9c7/270/bcd9c7270c0727e164ac404a7f929971.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">F0iL</span>
</a>

          <svg class="icon_comment-edit" title="Комментарий был изменен" width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#pencil" /></svg>
          <time class="comment__date-time comment__date-time_published">вчера в 17:29</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23002792" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23002792" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23002792" data-parent_id="23000176" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000176" class="icon_comment-arrow-up js-comment_parent" data-id="23002792" data-parent_id="23000176" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23002792" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23002792" data-parent_id="23000176" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23002792" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><blockquote>AmneziaVPN</blockquote>А какой конкретно транспорт оно использует?<br>
У shadowsocks в связке с v2ray через ws основное преимущество — что он для стороннего наблюдателя неотличим от HTTPS и при правильной маскировке устойчив к active probing атакам со стороны DPI. Ну и бонусом возможность работать через Cloudflare.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_23002792">  <li class="content-list__item content-list__item_comment js-comment " rel="23002928">
    
    <span class="parent_id" data-parent_id="23002792"></span>
    <div class="comment" id="comment_23002928">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23002928"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head comment__head_topic-author  " rel="23002928">
          <a href="https://habr.com/ru/users/YourChief/" class="user-info user-info_inline"  data-user-login="YourChief">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_pink" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">YourChief</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 17:53</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23002928" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23002928" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23002928" data-parent_id="23002792" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23002792" class="icon_comment-arrow-up js-comment_parent" data-id="23002928" data-parent_id="23002792" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23002928" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23002928" data-parent_id="23002792" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23002928" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">OpenVPN в режиме UDP, либо OpenVPN в режиме TCP через shadowsocks без каких-либо плагинов:<br>
<br>
<a href="https://github.com/amnezia-vpn/desktop-client/blob/65acdc8c09874582c449332c54a37e64c442afd8/client/core/openvpnconfigurator.cpp#L229-L234" rel="nofollow noopener noreferrer">github.com/amnezia-vpn/desktop-client/blob/65acdc8c09874582c449332c54a37e64c442afd8/client/core/openvpnconfigurator.cpp#L229-L234</a><br>
<br>
<a href="https://github.com/amnezia-vpn/desktop-client/blob/65acdc8c09874582c449332c54a37e64c442afd8/client/server_scripts/setup_shadowsocks_server.sh" rel="nofollow noopener noreferrer">github.com/amnezia-vpn/desktop-client/blob/65acdc8c09874582c449332c54a37e64c442afd8/client/server_scripts/setup_shadowsocks_server.sh</a><br>
<br>
<a href="https://github.com/amnezia-vpn/desktop-client/blob/65acdc8c09874582c449332c54a37e64c442afd8/client/core/servercontroller.cpp#L387-L396" rel="nofollow noopener noreferrer">github.com/amnezia-vpn/desktop-client/blob/65acdc8c09874582c449332c54a37e64c442afd8/client/core/servercontroller.cpp#L387-L396</a></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-2" id="reply_comments_23002928"></ul>
  </li>
</ul>
  </li>
</ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="23000436">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_23000436">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000436"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000436">
          <a href="https://habr.com/ru/users/Revertis/" class="user-info user-info_inline"  data-user-login="Revertis">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/861/214/18a/86121418a642fd5b0d2bd0dd4ca93399.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Revertis</span>
</a>

          <svg class="icon_comment-edit" title="Комментарий был изменен" width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#pencil" /></svg>
          <time class="comment__date-time comment__date-time_published">вчера в 09:20</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000436" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000436" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000436" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000436" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000436" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><blockquote>После завершения сборки и запуска QR-код с конфигурацией для мобильных устройств будет доступен по адресу<br>
<code>https://APPNAME.herokuapp.com/qr/vpn.png</code></blockquote>Я так понимаю, он доступен вообще всем? Или там есть какая-то безопасность всё-таки?</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_23000436">  <li class="content-list__item content-list__item_comment js-comment " rel="23000450">
    
    <span class="parent_id" data-parent_id="23000436"></span>
    <div class="comment" id="comment_23000450">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000450"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000450">
          <a href="https://habr.com/ru/users/Aelliari/" class="user-info user-info_inline"  data-user-login="Aelliari">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_pink" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Aelliari</span>
</a>

          <svg class="icon_comment-edit" title="Комментарий был изменен" width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#pencil" /></svg>
          <time class="comment__date-time comment__date-time_published">вчера в 09:23</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000450" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000450" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23000450" data-parent_id="23000436" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000436" class="icon_comment-arrow-up js-comment_parent" data-id="23000450" data-parent_id="23000436" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000450" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000450" data-parent_id="23000436" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000450" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><p>Можно оставить в соответствующем поле no, и тогда он не будет генерироваться. Но настройка будет вручную. Или установить свой, кастомными путь, так же доступный всем. Иначе без доработок не выйдет</p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-1" id="reply_comments_23000450">  <li class="content-list__item content-list__item_comment js-comment " rel="23000552">
    
    <span class="parent_id" data-parent_id="23000450"></span>
    <div class="comment" id="comment_23000552">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000552"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000552">
          <a href="https://habr.com/ru/users/Revertis/" class="user-info user-info_inline"  data-user-login="Revertis">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/861/214/18a/86121418a642fd5b0d2bd0dd4ca93399.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Revertis</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 09:48</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000552" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000552" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23000552" data-parent_id="23000450" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000450" class="icon_comment-arrow-up js-comment_parent" data-id="23000552" data-parent_id="23000450" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000552" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000552" data-parent_id="23000450" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000552" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><blockquote>кастомными путь</blockquote>Три раза редактировал, а путь так и не получился :)</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-2" id="reply_comments_23000552">  <li class="content-list__item content-list__item_comment js-comment " rel="23000576">
    
    <span class="parent_id" data-parent_id="23000552"></span>
    <div class="comment" id="comment_23000576">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000576"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000576">
          <a href="https://habr.com/ru/users/Aelliari/" class="user-info user-info_inline"  data-user-login="Aelliari">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_pink" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Aelliari</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 09:52</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000576" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000576" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23000576" data-parent_id="23000552" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000552" class="icon_comment-arrow-up js-comment_parent" data-id="23000576" data-parent_id="23000552" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000576" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000576" data-parent_id="23000552" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000576" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><p>Странно, для теста вписывал нечто простое, типа /qwr, и по пути gestapo.heroku.com/qwr/vpn.png работало</p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-3" id="reply_comments_23000576">  <li class="content-list__item content-list__item_comment js-comment " rel="23000586">
    
    <span class="parent_id" data-parent_id="23000576"></span>
    <div class="comment" id="comment_23000586">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000586"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000586">
          <a href="https://habr.com/ru/users/Revertis/" class="user-info user-info_inline"  data-user-login="Revertis">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/861/214/18a/86121418a642fd5b0d2bd0dd4ca93399.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Revertis</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 09:55</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000586" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000586" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23000586" data-parent_id="23000576" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000576" class="icon_comment-arrow-up js-comment_parent" data-id="23000586" data-parent_id="23000576" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000586" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000586" data-parent_id="23000576" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000586" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">Цитату прочтите.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-4" id="reply_comments_23000586">  <li class="content-list__item content-list__item_comment js-comment " rel="23001076">
    
    <span class="parent_id" data-parent_id="23000586"></span>
    <div class="comment" id="comment_23001076">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23001076"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23001076">
          <a href="https://habr.com/ru/users/Aelliari/" class="user-info user-info_inline"  data-user-login="Aelliari">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <svg class="user-info__image-pic user-info__image-pic_small default-image default-image_mini default-image_pink" width="24" height="24"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#slug" /></svg>
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">Aelliari</span>
</a>

          
          <time class="comment__date-time comment__date-time_published">вчера в 11:32</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23001076" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23001076" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <span class="icon_comment-branch js-comment_tree" data-id="23001076" data-parent_id="23000586" title="Показать ветку комментариев"><svg width="8" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#tree" /></svg></span>
    </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <a href="#comment_23000586" class="icon_comment-arrow-up js-comment_parent" data-id="23001076" data-parent_id="23000586" title="Показать предыдущий комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
    </li>

  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23001076" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23001076" data-parent_id="23000586" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23001076" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter   js-score" title="Всего голосов 0: &uarr;0 и &darr;0">0</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  "><p>А, если вы по сообщение, я с телефона, и автозамена чудит. Выше testapp почему то заменило на gestapo &gt;.&lt;<br>
А ведь даже в подсказках не сейчас не выскочило когда я набирал данное сообщение</p></div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-5" id="reply_comments_23001076"></ul>
  </li>
</ul>
  </li>
</ul>
  </li>
</ul>
  </li>
</ul>
  </li>
</ul>
  </li>
  <li class="content-list__item content-list__item_comment js-comment " rel="23000632">
    
    <span class="parent_id" data-parent_id="0"></span>
    <div class="comment" id="comment_23000632">
      <span class="comment__collapse" title="Свернуть/развернуть ветку комментариев" data-id="23000632"></span>
        <span class="comment__folding-dotholder"></span>
        <div class="comment__head   " rel="23000632">
          <a href="https://habr.com/ru/users/F0iL/" class="user-info user-info_inline"  data-user-login="F0iL">
  <div class="user-comment__container user-info__image-pic user-info__image-pic_small">
      <img src="//habrastorage.org/getpro/habr/avatars/bcd/9c7/270/bcd9c7270c0727e164ac404a7f929971.jpg" class="user-info__image-pic user-info__image-pic_small" width="24" height="24" />
  </div>
  <span class="user-info__nickname user-info__nickname_small user-info__nickname_comment">F0iL</span>
</a>

          <svg class="icon_comment-edit" title="Комментарий был изменен" width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#pencil" /></svg>
          <time class="comment__date-time comment__date-time_published">вчера в 10:04</time>
          <ul class="inline-list inline-list_comment-nav">
  <li class="inline-list__item inline-list__item_comment-nav">
    <a href="#comment_23000632" class="icon_comment-anchor" title="Ссылка на комментарий"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#anchor" /></svg></a>
  </li>

    <li class="inline-list__item inline-list__item_comment-nav">
      <button class="icon_comment-bookmark " onclick="return comments_add_to_favorite(this)" data-type="3" data-id="23000632" data-action="add" title="Только зарегистрированные пользователи могут добавлять комментарии в избранное" disabled><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg></button>
    </li>


  <li class="inline-list__item inline-list__item_comment-nav hidden js-comment_children">
    <a href="#comment_23000632" class="icon_comment-arrow-down js-comment_parent back_to_children" data-id="23000632" data-parent_id="0" title="Вернуться к ответу"><svg width="12" height="12"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#rounded-arrow" /></svg></a>
  </li>
</ul>

           <div class="voting-wjt voting-wjt_comments js-comment-vote" data-id="23000632" data-post-target="555768" data-type="3">
   <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="plus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-up" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>

    <span class="voting-wjt__counter voting-wjt__counter_positive  js-score" title="Всего голосов +1: &uarr;1 и &darr;0">+1</span>

    <button type="button" class="btn voting-wjt__button voting-wjt__button_small " data-action="minus" onclick="comment_vote(this);" title="Голосовать могут только зарегистрированные пользователи" disabled><svg class="icon-svg_arrow-down" width="10" height="16"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#vote-arrow" /></svg></button>
  </div>

        </div>

        <div class="comment__message  ">Бегло проглядел скрипты, судя по всему, сделано весьма грамотно — v2ray в режиме websockets, nginx, пересылающий все остальные запросы на фейковый сайт, и т.д.<br>
<br>
Я бы еще добавил, что shadowsocks-v2ray в режиме websockets можно еще гонять через cloudflare, если набраться немного наглости. Что, конечно, не очень хорошо по отношению к cloudflare, но может спасти, если ваш сервер попал в черные списки.</div>

        <div class="comment__footer">
</div>

        <div class="comment__reply-form js-form_placeholder"></div>
    </div>

    <ul class="content-list content-list_nested-comments content-list_nested-comments-0" id="reply_comments_23000632"></ul>
  </li>

      
    </ul>
      <div class="js-form_placeholder">
                <p class="for_users_only_msg">Только&nbsp;<a href="/info/help/registration/">полноправные пользователи</a> могут оставлять комментарии. <a href="https://habr.com/ru/auth/login/">Войдите</a>, пожалуйста.</p>

      </div>
  </div>


  </div>
  <div class="sidebar">
    <div class="sidebar_right sidebar_comments js-sidebar_right">
          

  <div class="js-ad_sticky_comments">
    <div class="default-block">
      <div class="default-block__header">
        <h3 class="default-block__header-title">Что обсуждают</h3>
      </div>

      <div class="default-block__content default-block__content_most-comments" id="broadcast_tabs_comments">
        <ul class="toggle-menu toggle-menu_most-comments">
          <li class="toggle-menu__item">
            <a href="#broadcast_comments_now" class="toggle-menu__item-link active" rel="nofollow">Сейчас</a>
          </li>
          <li class="toggle-menu__item">
            <a href="#broadcast_comments_yesterday" class="toggle-menu__item-link" rel="nofollow">Вчера</a>
          </li>
          <li class="toggle-menu__item">
            <a href="#broadcast_comments_week" class="toggle-menu__item-link" rel="nofollow">Неделя</a>
          </li>
        </ul>

          <div class="tabs__content" id="broadcast_comments_now">
              <ul class="content-list content-list_most-comments" >
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/news/t/556026/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'now'); }" class="post-info__title">Sony перестала продавать цифровые зеркалки</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">6,7k</span>
                    </span>
                    <a href="https://habr.com/ru/news/t/556026/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">28
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/556000/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'now'); }" class="post-info__title">Python, наука о данных и выборы: часть 1</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">1,2k</span>
                    </span>
                    <a href="https://habr.com/ru/post/556000/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">2
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/company/pentestit/blog/555590/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'now'); }" class="post-info__title">Reverse engineering: обратная разработка приложений для самых маленьких</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">2,8k</span>
                    </span>
                    <a href="https://habr.com/ru/company/pentestit/blog/555590/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">7
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/555908/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'now'); }" class="post-info__title">Внимание, интереснейший опрос на Хабре — будьте бдительны</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">4,8k</span>
                    </span>
                    <a href="https://habr.com/ru/post/555908/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">17
                      
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://u.habr.com/rt_chitayut" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'prmlink'); }">Ракеты и снаряды дата-инженеров</a>
                  <div class="post-info__meta-label">
                    Подборка
                  </div>
                </li>
            </ul>
        </div>
          <div class="tabs__content" id="broadcast_comments_yesterday">
              <ul class="content-list content-list_most-comments" >
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/555976/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'yesterday'); }" class="post-info__title">Почему нам не нужно бессмертие</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">8k</span>
                    </span>
                    <a href="https://habr.com/ru/post/555976/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">189
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/company/skyeng/blog/555098/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'yesterday'); }" class="post-info__title">Люди не меняют свою жизнь, потому что в глубине души знают — они фиговые специалисты</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">17,7k</span>
                    </span>
                    <a href="https://habr.com/ru/company/skyeng/blog/555098/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">125
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/company/macloud/blog/555580/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'yesterday'); }" class="post-info__title">Невидимые убийцы в воздухе: как продлить себе жизнь, контролируя уровень чистого воздуха и PM₂,₅</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">5,8k</span>
                    </span>
                    <a href="https://habr.com/ru/company/macloud/blog/555580/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">24
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/555822/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'yesterday'); }" class="post-info__title">Строим твёрдотельный лазер без регистрации и смс</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">10,9k</span>
                    </span>
                    <a href="https://habr.com/ru/post/555822/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">26
                      
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://u.habr.com/allsoft_7_chitayut" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'prmlink'); }">E-com-корзины как полуфабрикат. Кейсы вендоров</a>
                  <div class="post-info__meta-label">
                    Мегапост
                  </div>
                </li>
            </ul>
        </div>
          <div class="tabs__content" id="broadcast_comments_week">
              <ul class="content-list content-list_most-comments" >
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/company/ruvds/blog/554702/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'week'); }" class="post-info__title">Безусловный базовый доход ближе, чем кажется</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">37,6k</span>
                    </span>
                    <a href="https://habr.com/ru/company/ruvds/blog/554702/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">1067
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/555526/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'week'); }" class="post-info__title">Из Basecamp уволилось больше трети сотрудников — они недовольны «аполитичностью» компании</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">48,9k</span>
                    </span>
                    <a href="https://habr.com/ru/post/555526/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">723
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/553752/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'week'); }" class="post-info__title">Как рекламщики уничтожили электронную почту, и что сейчас они делают с мобильной связью</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">116k</span>
                    </span>
                    <a href="https://habr.com/ru/post/553752/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">560
                      
                      </span>
                    </a>
                  </div>
                </li>
                  <li class="content-list__item content-list__item_devided post-info">
                    <a href="https://habr.com/ru/post/555210/" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'discussions', 'week'); }" class="post-info__title">Старение и бессмертие: взгляд биолога</a>

                  <div class="post-info__meta">
                    <span class="post-info__meta-item">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">50,1k</span>
                    </span>
                    <a href="https://habr.com/ru/post/555210/#comments" class="post-info__meta-item" rel="nofollow">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">238
                      
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://u.habr.com/rt_chitayut" class="post-info__title" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'most_read', 'prmlink'); }">Ракеты и снаряды дата-инженеров</a>
                  <div class="post-info__meta-label">
                    Подборка
                  </div>
                </li>
            </ul>
        </div>
    </div>
  </div>

    </div>
  </div>
  </section>


  <script type="text/javascript">
    var userLabel = 'reader';
  </script>

  


        </div>
      </div>

        <div class="layout__row layout__row_promo-blocks">
          <div class="layout__cell">
            <section class="column-wrapper column-wrapper_bottom column-wrapper_bordered">
  <div class="content_left">
    


  <div class="default-block default-block_content">
    <div class="default-block__header default-block__header_large">
      <h2 class="default-block__header-title default-block__header-title_large">Самое читаемое</h2>
    </div>
    <div class="default-block__content default-block__content_most-read" id="broadcast_tabs_posts">
      <ul class="toggle-menu toggle-menu__most-read">
        <li class="toggle-menu__item">
          <a href="#broadcast_posts_today" class="toggle-menu__item-link active" rel="nofollow">Сутки</a>
        </li>
        <li class="toggle-menu__item">
          <a href="#broadcast_posts_week" class="toggle-menu__item-link" rel="nofollow">Неделя</a>
        </li>
        <li class="toggle-menu__item">
          <a href="#broadcast_posts_month" class="toggle-menu__item-link" rel="nofollow">Месяц</a>
        </li>
      </ul>

        <div class="tabs__content tabs__content_reading" id="broadcast_posts_today">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/553752/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Как рекламщики уничтожили электронную почту, и что сейчас они делают с мобильной связью</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;134</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">116k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">82</span>
                    </span>
                    <a href="https://habr.com/ru/post/553752/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        560
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/555884/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Что недоговаривают Тинькофф Инвестиции. Вытаскиваем все данные по портфелю через API в большую таблицу Excel</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;67</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">25,2k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">200</span>
                    </span>
                    <a href="https://habr.com/ru/post/555884/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        10
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/skyeng/blog/555098/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Люди не меняют свою жизнь, потому что в глубине души знают — они фиговые специалисты</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;26</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">17,7k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">83</span>
                    </span>
                    <a href="https://habr.com/ru/company/skyeng/blog/555098/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        125
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/news/t/555794/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Signal купил у Facebook рекламу и показывал в баннерах параметры таргетинга, что соцсети очень не понравилось</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;75</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">14,6k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">10</span>
                    </span>
                    <a href="https://habr.com/ru/news/t/555794/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        127
                        
                      </span>
                    </a>
                  </div>
                </li>
              <li class="content-list__item content-list__item_devided post-info">
                <a href="https://u.habr.com/rt_chitayut" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'https://u.habr.com/rt_chitayut'); }">Ракеты и снаряды дата-инженеров</a>
                <div class="post-info__meta-label">
                  Подборка
                </div>
              </li>
            </ul>
        </div>
        <div class="tabs__content tabs__content_reading" id="broadcast_posts_week">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/553752/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Как рекламщики уничтожили электронную почту, и что сейчас они делают с мобильной связью</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;134</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">116k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">82</span>
                    </span>
                    <a href="https://habr.com/ru/post/553752/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        560
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/vdsina/blog/555474/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Как я обогреваю свой дом при помощи майнинга криптовалют</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;42</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">65k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">107</span>
                    </span>
                    <a href="https://habr.com/ru/company/vdsina/blog/555474/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        103
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/555430/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Учимся подтягиваться на одной руке по программе Пола Уэйда</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;31</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">61,9k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">310</span>
                    </span>
                    <a href="https://habr.com/ru/post/555430/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        68
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/555210/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Старение и бессмертие: взгляд биолога</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;61</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">50,1k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">131</span>
                    </span>
                    <a href="https://habr.com/ru/post/555210/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        238
                        
                      </span>
                    </a>
                  </div>
                </li>
              <li class="content-list__item content-list__item_devided post-info">
                <a href="https://u.habr.com/agritech_chitayut" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'https://u.habr.com/agritech_chitayut'); }">Плачу на агротехно: тест про зелёные технологии</a>
                <div class="post-info__meta-label">
                  Мегатест
                </div>
              </li>
            </ul>
        </div>
        <div class="tabs__content tabs__content_reading" id="broadcast_posts_month">
            <ul class="content-list content-list_most-read">
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/ruvds/blog/554046/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Разговор с майнером Chia, имеющим 1ПБ ёмкости</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;47</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">217k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">142</span>
                    </span>
                    <a href="https://habr.com/ru/company/ruvds/blog/554046/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        436
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/551218/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Уважаемые рекрутеры, а вы не офигели?</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;268</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">183k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">105</span>
                    </span>
                    <a href="https://habr.com/ru/post/551218/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        409
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/post/554810/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Все английские времена в одной простой схеме</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;58</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">135k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">697</span>
                    </span>
                    <a href="https://habr.com/ru/post/554810/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        120
                        
                      </span>
                    </a>
                  </div>
                </li>
                <li class="content-list__item content-list__item_devided post-info">
                  <a href="https://habr.com/ru/company/englishdom/blog/551098/" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'post'); }">Два с половиной странных правила английского языка, которых не учат в школе</a>
                  <div class="post-info__meta">
                    <span class="post-info__meta-item" title="Рейтинг">
                      <svg class="post-info__meta-icon icon-svg_rating" width="11" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#arrow-bold" /></svg><span class="post-info__meta-counter">&plus;68</span>
                    </span>
                    <span class="post-info__meta-item" title="Количество просмотров">
                      <svg class="post-info__meta-icon icon-svg_views" width="16" height="9"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#eye" /></svg><span class="post-info__meta-counter">126k</span>
                    </span>
                    <span class="post-info__meta-item" title="Закладки">
                      <svg class="post-info__meta-icon icon-svg_bookmark-mini" width="8" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#book" /></svg><span class="post-info__meta-counter">196</span>
                    </span>
                    <a href="https://habr.com/ru/company/englishdom/blog/551098/#comments" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'comment'); }" class="post-info__meta-item" rel="nofollow" title="Комментарии">
                      <svg class="post-info__meta-icon icon-svg_comments" width="14" height="13"><use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#comment" /></svg><span class="post-info__meta-counter">
                        183
                        
                      </span>
                    </a>
                  </div>
                </li>
              <li class="content-list__item content-list__item_devided post-info">
                <a href="https://u.habr.com/rt_chitayut" class="post-info__title post-info__title_large" onclick="if (typeof ga === 'function') { ga('send', 'event', 'tm_block',  'most_read,post' , 'https://u.habr.com/rt_chitayut'); }">Ракеты и снаряды дата-инженеров</a>
                <div class="post-info__meta-label">
                  Подборка
                </div>
              </li>
            </ul>
        </div>
    </div>
  </div>

  </div>

  <div class="sidebar">
    <div class="sidebar_right">
    </div>
  </div>
</section>

          </div>
        </div>

      <div class="layout__row layout__row_footer-links">
        <div class="layout__cell">
          <div class="footer-grid footer-grid_menu">
  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">
      Ваш аккаунт
    </h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
          <li class="footer-menu__item">
            <a href="https://habr.com/ru/auth/login/" class="footer-menu__item-link">Войти</a>
          </li>
          <li class="footer-menu__item">
            <a href="https://habr.com/ru/auth/register/" class="footer-menu__item-link">Регистрация</a>
          </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Разделы</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/posts/top/" class="footer-menu__item-link">Публикации</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/news/" class="footer-menu__item-link">Новости</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/hubs/" class="footer-menu__item-link">Хабы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/companies/" class="footer-menu__item-link">Компании</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/users/" class="footer-menu__item-link">Пользователи</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/sandbox/" class="footer-menu__item-link">Песочница</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Информация</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/help/" class="footer-menu__item-link">Устройство сайта</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/authors/" class="footer-menu__item-link">Для авторов</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/companies/" class="footer-menu__item-link">Для компаний</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/docs/docs/" class="footer-menu__item-link">Документы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://account.habr.com/info/agreement/?hl=ru_RU" class="footer-menu__item-link">Соглашение</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://account.habr.com/info/confidential/?hl=ru_RU" class="footer-menu__item-link">Конфиденциальность</a>
        </li>
      </ul>
    </div>
  </div>

  <div class="footer-grid__item footer-block">
    <h3 class="footer-block__title">Услуги</h3>
    <div class="footer-block__content">
      <ul class="footer-menu">
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/advertising/" target="_blank" class="footer-menu__item-link">Реклама</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/corpblog/" target="_blank" class="footer-menu__item-link">Тарифы</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/services/content/" target="_blank" class="footer-menu__item-link">Контент</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://tmtm.ru/workshops/" target="_blank" class="footer-menu__item-link">Семинары</a>
        </li>
        <li class="footer-menu__item">
          <a href="https://habr.com/ru/megaprojects/" target="_blank" class="footer-menu__item-link">Мегапроекты</a>
        </li>
          <li class="footer-menu__item">
            <a href="https://habr.market/" target="_blank" class="footer-menu__item-link">Мерч</a>
          </li>
      </ul>
    </div>
  </div>
</div>


        </div>
      </div>

      <div class="layout__row layout__row_footer">
        <div class="layout__cell">
          <script>
  $(document).ready(function () {
    window.voteReasonsList = JSON.parse('{"1":{"id":"1","title":"Низкий технический уровень материала","order":1},"2":{"id":"2","title":"Больше рекламы, чем пользы","order":2},"3":{"id":"3","title":"Не соответствует тематике Хабра","order":3},"4":{"id":"4","title":"В тексте много ошибок и опечаток","order":4},"5":{"id":"5","title":"Пост небрежно оформлен","order":5},"6":{"id":"6","title":"Личная неприязнь к автору или компании","order":6},"7":{"id":"7","title":"В статье нет новой для меня информации","order":7},"8":{"id":"8","title":"Ничего не понял после прочтения","order":8},"22":{"id":"22","title":"Не согласен с изложенным","order":9},"9":{"id":"9","title":"Другое","order":10}}');
  });
</script>
<script>

$(document).on('hljsUpdate', function () {
  if (typeof hljs === 'undefined') {
    initHighlightJS();
  } else {
    $('pre code').each(function (i, e) {
      hljs.highlightBlock(e, '    ');
    });
  }
})

function createScript(url) {
  var hljsScript = document.createElement("script");
  hljsScript.src = url;
  hljsScript.type = 'text/javascript';
  document.body.appendChild(hljsScript)

  return hljsScript;
}

function initHighlightJS() {
  if (typeof hljs !== 'undefined') {
    $('pre code').each(function (i, e) {
      hljs.highlightBlock(e, '    ');
    });
    return;
  };

  var hljsScript = createScript('https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/highlight.pack.js');

  hljsScript.onload = function() {
    var hljsLangs = createScript('https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/highlight.langs.js');
    hljsLangs.onload = function () {
      hljs.initHighlighting();
    }
  }
}


var codeElements = document.querySelectorAll('pre code');

if (codeElements.length) {
  initHighlightJS();
}

</script>

<script>

var mathElements = document.getElementsByTagName('math');

function mathJaxConfig() {
  MathJax.Hub.Config({
    showProcessingMessages: false,
    showMathMenu: true,
    tex2jax: {
      inlineMath: [['$inline$','$inline$']],
      displayMath: [['$$display$$','$$display$$']],
      processEscapes: true
    },
    MathMenu: {
      showRenderer: true,
      showContext:  true
    }
  });

  MathJax.Extension.Img2jax = {
    PreProcess: function (element) {
      var hasMath = false;
      var images = element.querySelectorAll('[data-tex]');
      for (var i = images.length - 1; i >= 0; i--) {
        var img = images[i];
        var tex = img.alt.replace(/(\r\n|\n|\r)/gm, " ");
        if (tex && tex[0] === '$'){
          var script = document.createElement("script"); script.type = "math/tex";
          hasMath = true;
          if (img.getAttribute('data-tex') == "display"){script.type += ";mode=display"}
          MathJax.HTML.setScript(script, tex.substring(1,tex.length-1));
          img.parentNode.replaceChild(script,img);
        }
      }
    }
  };

  MathJax.Hub.Register.PreProcessor(["PreProcess", MathJax.Extension.Img2jax]);
}

function mathjaxInit() {
 if (typeof MathJax === 'undefined') {
    var url = 'https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js?config=TeX-AMS_SVG-full&locale=ru';
    var mathScript = document.createElement("script");
    mathScript.src = url;
    mathScript.type = 'text/javascript';
    document.body.appendChild(mathScript)

    mathScript.onload = function() {
      mathJaxConfig();
    }
  } else {
    mathJaxConfig();
  }
}

if (mathElements.length) {
  mathjaxInit();
}

</script>
<div class="footer-grid footer">
  <div class="footer-grid__item footer-grid__item_copyright">
    <span class="footer__copyright">&copy; 2006 &ndash; 2021 «<a href="https://company.habr.com/" class="footer__link">Habr</a>»</span>
  </div>
  <div class="footer-grid__item footer-grid__item_link footer-grid__item_lang">
    <svg class="icon-svg icon-svg_lang-footer" width="16" height="16">
      <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#globus-v2" />
    </svg>
    <a href="#" class="footer__link js-show_lang_settings">Настройка языка</a>
  </div>
  <div class="footer-grid__item footer-grid__item_link">
      <a href="https://habr.com/ru/about/" class="footer__link">О сайте</a>
  </div>
  <div class="footer-grid__item footer-grid__item_link">
    <a href="https://habr.com/ru/feedback/" class="footer__link">Служба поддержки</a>
  </div>
  <div class="footer-grid__item footer-grid__item_link">
      <a href="https://m.habr.com/post/555768/?mobile=yes" class="footer__link">Мобильная версия</a>
  </div>

  <div class="footer-grid__item footer-grid__item_social">
    <ul class="social-icons">
      <li class="social-icons__item">
        <a href="https://twitter.com/habr_com"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_twitter"
          target="_blank"
          rel="nofollow noopener noreferrer"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'twitter'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.414 8.642c-.398.177-.826.296-1.276.35.459-.275.811-.71.977-1.229-.43.254-.905.439-1.41.539-.405-.432-.982-.702-1.621-.702-1.227 0-2.222.994-2.222 2.222 0 .174.019.344.058.506-1.846-.093-3.484-.978-4.579-2.322-.191.328-.301.71-.301 1.117 0 .77.392 1.45.988 1.849-.363-.011-.706-.111-1.006-.278v.028c0 1.077.766 1.974 1.782 2.178-.187.051-.383.078-.586.078-.143 0-.282-.014-.418-.04.282.882 1.103 1.525 2.075 1.542-.76.596-1.718.951-2.759.951-.179 0-.356-.01-.53-.031.983.63 2.15.998 3.406.998 4.086 0 6.321-3.386 6.321-6.321l-.006-.287c.433-.314.81-.705 1.107-1.15z"/></svg>
        </a>
      </li>
      <li class="social-icons__item">
        <a href="https://www.facebook.com/habrahabr.ru"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_facebook"
          target="_blank"
          rel="nofollow noopener noreferrer"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'facebook'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M14.889 8.608h-1.65c-.195 0-.413.257-.413.6v1.192h2.063v1.698h-2.063v5.102h-1.948v-5.102h-1.766v-1.698h1.766v-1c0-1.434.995-2.6 2.361-2.6h1.65v1.808z"/></svg>
        </a>
      </li>
        <li class="social-icons__item">
          <a href="https://vk.com/habr"
            class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_vkontakte"
            target="_blank"
            rel="nofollow noopener noreferrer"
            onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'vkontakte'); }"
          >
            <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M16.066 11.93s1.62-2.286 1.782-3.037c.054-.268-.064-.418-.343-.418h-1.406c-.322 0-.44.139-.537.343 0 0-.76 1.619-1.685 2.64-.297.33-.448.429-.612.429-.132 0-.193-.11-.193-.408v-2.607c0-.365-.043-.472-.343-.472h-2.254c-.172 0-.279.1-.279.236 0 .343.526.421.526 1.352v1.921c0 .386-.022.537-.204.537-.483 0-1.631-1.663-2.274-3.552-.129-.386-.268-.494-.633-.494h-1.406c-.204 0-.354.139-.354.343 0 .375.44 2.114 2.167 4.442 1.159 1.566 2.683 2.414 4.056 2.414.838 0 1.041-.139 1.041-.494v-1.202c0-.301.118-.429.29-.429.193 0 .534.062 1.33.848.945.901 1.01 1.276 1.525 1.276h1.578c.161 0 .311-.075.311-.343 0-.354-.462-.987-1.17-1.738-.29-.386-.762-.805-.912-.998-.215-.226-.151-.354-.001-.59z"/></svg>
          </a>
        </li>
      <li class="social-icons__item">
        <a href="https://telegram.me/habr_com"
          class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_telegram"
          target="_blank"
          rel="nofollow noopener noreferrer"
          onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'telegram'); }"
        >
          <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="24" height="24" viewBox="0 0 24 24"><path d="M17.17 7.621l-10.498 3.699c-.169.059-.206.205-.006.286l2.257.904 1.338.536 6.531-4.796s.189.057.125.126l-4.68 5.062-.27.299.356.192 2.962 1.594c.173.093.397.016.447-.199.058-.254 1.691-7.29 1.728-7.447.047-.204-.087-.328-.291-.256zm-6.922 8.637c0 .147.082.188.197.084l1.694-1.522-1.891-.978v2.416z"/></svg>
        </a>
      </li>
        <li class="social-icons__item">
          <a href="https://www.youtube.com/channel/UCd_sTwKqVrweTt4oAKY5y4w"
            class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_youtube"
            target="_blank"
            rel="nofollow noopener noreferrer"
            onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'youtube'); }"
          >
            <svg class="icon-svg" aria-hidden="true" aria-labelledby="title" version="1.1" role="img" width="32" height="32" viewBox="0 0 32 32"><path d="M3.2 0h25.6c1.767 0 3.2 1.433 3.2 3.2v25.6c0 1.767-1.433 3.2-3.2 3.2h-25.6c-1.767 0-3.2-1.433-3.2-3.2v-25.6c0-1.767 1.433-3.2 3.2-3.2zm18.133 16l-10.667-5.333v10.667l10.667-5.333z"/></svg>

          </a>
        </li>
        <li class="social-icons__item">
          <a href="https://zen.yandex.ru/habr"
            class="social-icons__item-link social-icons__item-link_normal social-icons__item-link_zen"
            target="_blank"
            rel="nofollow noopener noreferrer"
            onclick="if (typeof ga === 'function') { ga('send', 'event', 'footer', 'Social_icons', 'zen'); }"
          >
            <svg width="30" height="30" viewBox="0 0 30 30" fill="none" xmlns="http://www.w3.org/2000/svg">
    <rect width="30" height="30" rx="3" fill="#2C3036"/>
    <path fill-rule="evenodd" clip-rule="evenodd" d="M26.25 15.1241V14.9998V14.8759C21.2684 14.7252 18.9904 14.6009 17.1735 12.8263C15.3994 11.0098 15.2747 8.73179 15.1243 3.75H15H14.8757C14.7253 8.73179 14.6006 11.0098 12.8264 12.8263C11.0095 14.6009 8.73151 14.7252 3.75 14.8759V14.9998V15.1241C8.73151 15.2748 11.0095 15.3991 12.8264 17.1733C14.6006 18.9903 14.7253 21.2682 14.8757 26.25H15H15.1243C15.2747 21.2682 15.3994 18.9903 17.1735 17.1733C18.9904 15.3991 21.2684 15.2748 26.25 15.1241Z" fill="white"/>
</svg>

          </a>
        </li>
    </ul>
  </div>
</div>

        </div>
      </div>

      <a href="#" class="layout__elevator hidden" id="scroll_to_top" title="Наверх"  onclick="if (typeof ga === 'function') { ga('send', 'event', 'navigation_button', 'down'); }">
        <svg class="icon-svg icon-svg_scroll-up" width="32" height="32" viewBox="0 0 32 32" aria-hidden="true" version="1.1" role="img"><path d="M16 0C7.164 0 0 7.164 0 16s7.164 16 16 16 16-7.164 16-16S24.836 0 16 0zm8.412 19.523c-.517.512-1.355.512-1.872 0L16 13.516l-6.54 6.01c-.518.51-1.356.51-1.873 0-.516-.513-.517-1.343 0-1.855l7.476-7.326c.517-.512 1.356-.512 1.873 0l7.476 7.327c.516.513.516 1.342 0 1.854z"/></svg>
      </a>
    </div>

    <div class="overlay hidden" id="js-lang_settings">
  <div class="popup">
    <div class="popup__head popup__head_lang-settings">
      <span class="popup__head-title js-popup_title" data-section="1">Настройка языка</span>
      <button type="button" class="btn btn_small btn_popup-close js-hide_lang_settings">
        <svg class="icon-svg" width="12" height="12">
          <use xlink:href="https://habr.com/oldassets/6092b4a5/images/common-svg-sprite.svg#close" />
        </svg>
      </button>
    </div>
    <div class="popup__body">
      <form action="/json/settings/i18n/" method="post" class="form form_lang-settings" id="lang-settings-form">
        <fieldset class="form__fieldset form__fieldset_thin" data-section="2">
          <legend class="form__legend form__legend_lang-settings js-popup_hl_legend">Интерфейс</legend>
            <div class="form-field form-field_lang-settings">
              <span class="radio radio_custom ">
                <input type="radio" name="hl" id="hl_langs_ru" class="radio__input js-hl_langs" value="ru" checked>
                <label for="hl_langs_ru" class="radio__label radio__label_another">Русский</label>
              </span>
            </div>
            <div class="form-field form-field_lang-settings">
              <span class="radio radio_custom ">
                <input type="radio" name="hl" id="hl_langs_en" class="radio__input js-hl_langs" value="en" >
                <label for="hl_langs_en" class="radio__label radio__label_another">English</label>
              </span>
            </div>
        </fieldset>

        <fieldset class="form__fieldset form__fieldset_thin">
          <legend class="form__legend form__legend_lang-settings js-popup_fl_legend" data-section="3">Язык публикаций</legend>
            <div class="form-field form-field_lang-settings">
              <span class="checkbox checkbox_custom">
                <input type="checkbox" name="fl[]" id="fl_langs_ru" class="checkbox__input js-fl_langs" value="ru" checked>
                <label for="fl_langs_ru" class="checkbox__label checkbox__label_another js-popup_feed_ru">Русский</label>
              </span>
            </div>
            <div class="form-field form-field_lang-settings">
              <span class="checkbox checkbox_custom">
                <input type="checkbox" name="fl[]" id="fl_langs_en" class="checkbox__input js-fl_langs" value="en" >
                <label for="fl_langs_en" class="checkbox__label checkbox__label_another js-popup_feed_en">Английский</label>
              </span>
            </div>
        </fieldset>

        <div class="form__footer form__footer_lang-settings">
          <button type="submit" class="btn btn_blue btn_huge btn_full-width js-popup_save_btn">Сохранить настройки</button>
        </div>
      </form>
    </div>
  </div>
</div>



    <script>
  function composeTeaser(t, blockType) {
    const listener = " onclick=\"if (typeof ga === 'function') { ga('send', 'event', 'tm_block', 'promo,"
      + blockType + "', '"+ t.linkUrl +"'); }\"";
    let teaser = '<li class="megapost-teasers__item teaser">'
    + '<a href="' + t.linkUrl + '" target="_blank" class="teaser__image" rel="nofollow';

    if (t.external) teaser += ' sponsored';

    teaser += '"';

    teaser += listener;

    teaser += '>'
    + '<img src="' + t.imageUrl + '" class="teaser__image-pic"/>'
    + '<div class="megapost-teasers__label">'
    + t.label;

    if (t.external) teaser += `<svg width="11" height="11" viewBox="0 0 11 11" fill="none" xmlns="http://www.w3.org/2000/svg">
<path fill-rule="evenodd" clip-rule="evenodd" d="M7.5 0C7.22386 0 7 0.223858 7 0.5C7 0.776142 7.22386 1 7.5 1H9.29289L5.14645 5.14645C4.95118 5.34171 4.95118 5.65829 5.14645 5.85355C5.34171 6.04882 5.65829 6.04882 5.85355 5.85355L10 1.70711V3.5C10 3.77614 10.2239 4 10.5 4C10.7761 4 11 3.77614 11 3.5V0.5C11 0.223858 10.7761 0 10.5 0H7.5ZM0.5 1C0.223858 1 0 1.22386 0 1.5V10.5C0 10.7761 0.223858 11 0.5 11H9.5C9.77614 11 10 10.7761 10 10.5V6C10 5.72386 9.77614 5.5 9.5 5.5C9.22386 5.5 9 5.72386 9 6V10H1V2H5C5.27614 2 5.5 1.77614 5.5 1.5C5.5 1.22386 5.27614 1 5 1H0.5Z" fill="#6667A2"/>
</svg>
`;

    teaser += '</div></a>'
    + '<a href="' + t.linkUrl + '" target="_blank" class="teaser__body" rel="nofollow';

    if (t.external) teaser += ' sponsored';

    teaser += '"';

    teaser += listener;

    teaser += '>'
    + '<h3 class="teaser__body-title">'
    + t.title
    + '</h3></a></li>';

    return teaser;
  }
</script>
    <script type="text/javascript">
  // global vars
  var g_base_url = 'habr.com/ru';
  var g_base_fullurl = 'https://habr.com/ru/';
  var g_tmid_fullurl = 'https://account.habr.com/';
  var g_is_guest = false;
  var g_show_xpanel = false;
  var g_is_enableShortcuts = '1';
  var g_is_ugc_post = '1';
  var g_is_company_post = '';
  var g_current_hl = 'ru';
  var g_current_fl = 'ru';

</script>

    <script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/vendors.bundle.js"></script>
    <script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/main.bundle.js"></script>
        <script src="https://hsto.org/getpro/neuro-habr/2.1.1/neuro-habr.js"></script>

  <script>
  if (window.fetch) {
    var nh = window.neuroHabr;
    var host = 'https://b2b.ainews.kz/api';

    var projectId = '4bf28fae-b05a-4f44-b28e-9a0c4a658524';
    var widgetId = 'cab341f3-0932-4b6d-9664-d6b4d38dd2c5';

    nh.init(host, projectId, widgetId);

    var articleId = "555768";
    var articleLang = "ru";
    var articleCanonical = document.querySelector("link[rel='canonical']").getAttribute("href");

    if (articleId) {
      nh.send('p_view', articleId, articleCanonical, articleLang);
    }

    var nhState = {
      viewTime: 0,
      interval: null,
      scrolledDown: false,
      likeSent: false,
    };

    var hidden;
    var visibilityChange;

    if (typeof document.hidden !== 'undefined') { // Opera 12.10 and Firefox 18 and later support
      hidden = 'hidden';
      visibilityChange = 'visibilitychange';
    } else if (typeof document.msHidden !== 'undefined') {
      hidden = 'msHidden';
      visibilityChange = 'msvisibilitychange';
    } else if (typeof document.webkitHidden !== 'undefined') {
      hidden = 'webkitHidden';
      visibilityChange = 'webkitvisibilitychange';
    }


    var articleBody = document.querySelector('.post__body') || document.querySelector('.article__body');

    if (articleBody) {
      var MINIMUM_ARTICLE_READ_SECONDS = 10;

      var isInViewport = function(e) {
        if (!e) return false;
        var b = e.getBoundingClientRect();
        return b.top <= window.innerHeight && b.top + b.height >= 0;
      };

      var isAtTheEnd = function(e) {
        if (!e) return false;
        return e.getBoundingClientRect().bottom - window.innerHeight <= 0;
      };

      var hasReadArticle = function() {
        return nhState.scrolledDown && nhState.viewTime >= MINIMUM_ARTICLE_READ_SECONDS;
      };

      function incrementViewTime(e) {
        if (!nhState.likeSent && !nhState.interval) {
          nhState.interval = setInterval(() => {
            if (hasReadArticle()) {
              if (!nhState.likeSent) {
                nhState.likeSent = true;
                nh.send('p_like', articleId, articleCanonical, articleLang);
              }
              clearInterval(nhState.interval);
              nhState.interval = null;
            } else if (isInViewport(e)) {
              nhState.viewTime += 2;
            }
          }, 2000);
        }
      };

      incrementViewTime(articleBody);

      if (typeof document.addEventListener !== 'undefined' && hidden !== undefined) {
        document.addEventListener(visibilityChange, () => {
          if (!hasReadArticle() && !nhState.likeSent) {
            if (document[hidden]) {
              clearInterval(nhState.interval);
              nhState.interval = null;
            } else {
              incrementViewTime(articleBody);
            }
          }
        });

        document.addEventListener('scroll', () => {
          if (!nhState.scrolledDown) {
            if (isAtTheEnd(articleBody)) {
              nhState.scrolledDown = true;
            }
          }
        });
      } else {
        nhState.scrolledDown = true;
      }
    }
  }
  </script>



      <script src="https://dr.habracdn.net/habr/oldassets/6092b4a5/javascripts/check-login.js"></script>
      <script type="text/javascript" src="https://habr.com/ru/viewcount/post/555768/"></script>

    
<!-- Yandex.Metrika counter -->
<script type="text/javascript">
(function(m,e,t,r,i,k,a){
  m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)};
  m[i].l=1*new Date();
  k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)
})(window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym");

    ym(24049213, "init", {
      clickmap:true
      , trackLinks:true
      , accurateTrackBounce:true
    });
</script>
<noscript>
  <div>
      <img src="https://mc.yandex.ru/watch/24049213" style="position:absolute; left:-9999px;" alt="" />
  </div>
</noscript>
<!-- /Yandex.Metrika counter -->

    <script type="text/javascript">
  function stripUrl(currentUrl, queryParam) {
   return currentUrl.replace(/\?([^#]*)/, function(_, search) {
      var result = search.split('&').map(function(param) {
        var regexp = new RegExp(`^${queryParam}`);
        if (regexp.test(param)) {
          return '';
        }
        return param;
      }).filter(Boolean).join('&');
      return result ? '?' + result : '';
    });
  }

  (function() {
    if (location.search.indexOf('cv') != -1 && history.replaceState) {
      var currentUrl = location.toString();
      var strippedUrl = stripUrl(currentUrl, 'cv');
      history.replaceState({}, '', strippedUrl);
    }
  })();

  function callGA(usesABP) {
    if (typeof window.adb1 === 'undefined') { window.adb1 = 'yes';}
    if (usesABP) { window.adb1 = 'aa'; }

    var user_type = 'guest';

    var page_type = "publish_ugc_ru,h_50,h_221,h_17123,h_21470,h_21918,f_develop,f_admin,f_popsci";

    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
      (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
      m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-726094-1',  'auto');
        ga('create', 'UA-726094-24', 'auto', {'name': 'HGM', 'allowLinker': true});

    ga('HGM.require', 'linker');
    ga('HGM.linker:autoLink', ['toster.ru', 'habr.com', 'account.habr.com', 'm.habr.com']);

    ga('require', 'displayfeatures');
    ga('set', 'dimension1', user_type); // user type - guest/readonly/habrauser
    ga('set', 'dimension2', page_type);
    ga('set', 'dimension3', 'na');
    ga('set', 'dimension4', window.adb1);
    ga('set', 'dimension6', 'ru');
    


    (function() {
      var removeUtms = function(){
        var location = window.location;
        if (location.search.indexOf('utm_') != -1 && history.replaceState) {
          var currentUrl = location.toString();
          var strippedUrl = stripUrl(currentUrl, 'utm_');
          history.replaceState({}, '', strippedUrl);
        }
      };
      ga('require', 'GTM-559GVC8');
      ga('send', 'pageview', { 'hitCallback': removeUtms });
    })();

    ga('HGM.set', 'dimension1', user_type);
    ga('HGM.set', 'dimension2', "habrahabr");
    ga('HGM.set', 'dimension4', window.adb1);

    ga('HGM.send', 'pageview');
  }


  if (window.habr_blockers_checker) {
    window.habr_blockers_checker.detectWrapper(callGA);
  } else {
    callGA(false)
  }

</script>

    <!-- Facebook Pixel Code -->
<img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=317458588730613&ev=PageView&noscript=1"/>
<!-- End Facebook Pixel Code -->

    <img src="https://vk.com/rtrg?p=VK-RTRG-421343-57vKE" style="position:fixed; left:-999px;" alt=""/>
    
  </body>
</html>
