<!DOCTYPE html>
<html lang="ru" data-vue-meta="%7B%22lang%22:%7B%22ssr%22:%22ru%22%7D%7D">
<head >
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width,initial-scale=1.0,viewport-fit=cover">
  <title>Разработка одноплатного компьютера. Пособие для продвинутых / Хабр</title>
  <style>
    /* cyrillic-ext */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveSxf6TF0.woff2) format('woff2');
      unicode-range: U+0460-052F, U+1C80-1C88, U+20B4, U+2DE0-2DFF, U+A640-A69F, U+FE2E-FE2F;
    }

    /* cyrillic */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveQhf6TF0.woff2) format('woff2');
      unicode-range: U+0400-045F, U+0490-0491, U+04B0-04B1, U+2116;
    }

    /* latin-ext */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveSBf6TF0.woff2) format('woff2');
      unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
    }

    /* latin */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveRhf6.woff2) format('woff2');
      unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
    }
  </style>
  <link rel="preload" href="https://assets.habr.com/habr-web/css/chunk-vendors.db52f5c6.css" as="style"><link rel="preload" href="https://assets.habr.com/habr-web/js/chunk-vendors.33463c52.js" as="script"><link rel="preload" href="https://assets.habr.com/habr-web/css/app.ef0488cd.css" as="style"><link rel="preload" href="https://assets.habr.com/habr-web/js/app.99a1fd48.js" as="script"><link rel="preload" href="https://assets.habr.com/habr-web/css/chunk-f458c7c4.b28016e6.css" as="style"><link rel="preload" href="https://assets.habr.com/habr-web/js/chunk-f458c7c4.91c70f57.js" as="script">
  <link rel="stylesheet" href="https://assets.habr.com/habr-web/css/chunk-vendors.db52f5c6.css"><link rel="stylesheet" href="https://assets.habr.com/habr-web/css/app.ef0488cd.css"><link rel="stylesheet" href="https://assets.habr.com/habr-web/css/chunk-f458c7c4.b28016e6.css">
  <script>window.i18nFetch = new Promise((res, rej) => {
          const xhr = new XMLHttpRequest();
          xhr.open('GET', '/js/i18n/ru-compiled.b855418be477fd58da22f8d523e09bfc.json');
          xhr.responseType = 'json';
          xhr.onload = function(e) {
            if (this.status === 200) {
              res({ru: xhr.response});
            } else {
              rej(e);
            }
          };
          xhr.send();
        });</script>
  
  <script data-vue-meta="ssr" src="/js/ads.js" onload="window['zhY4i4nJ9K'] = true" data-vmid="checkad"></script><script data-vue-meta="ssr" type="application/ld+json" data-vmid="ldjson-schema">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/habr.com\/ru\/post\/577246\/"},"headline":"Разработка одноплатного компьютера. Пособие для продвинутых","datePublished":"2021-09-10T12:01:57+03:00","dateModified":"2021-09-10T22:56:07+03:00","author":{"@type":"Person","name":"Бушуев Андрей"},"publisher":{"@type":"Organization","name":"Habr","logo":{"@type":"ImageObject","url":"https:\/\/habrastorage.org\/webt\/a_\/lk\/9m\/a_lk9mjkccjox-zccjrpfolmkmq.png"}},"description":"NavQ+, герой сегодняшнего рассказаЯ занимаюсь разработкой электроники. Шесть лет назад я написал свою первую статью начинавшуюся этими же словами и увидел неподд...","url":"https:\/\/habr.com\/ru\/post\/577246\/#post-content-body","about":["h_analysis_design","h_system_programming","h_linux_dev","h_gadgets","h_easyelectronics","f_develop","f_popsci"],"image":["https:\/\/habr.com\/share\/publication\/577246\/e2fd005f6185bc6e5b322291d5e2ecdf\/","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/f01\/25d\/6be\/f0125d6bea869a01645556f6aa04e88f.png","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/b0a\/6fb\/09f\/b0a6fb09f154c40f6477f311ad7a07f7.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/518\/368\/f79\/518368f79be196abe946cc4191dae3b4.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/4ae\/a91\/284\/4aea91284a7d06ff34b578dc038b6b5a.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/ec3\/045\/aad\/ec3045aad0d198edb1d1c8d26be0a90c.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/d30\/c5a\/c81\/d30c5ac81679ad7d98d45a5dd7611372.png","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/626\/abd\/9ba\/626abd9ba9eb47e4d89db50110d3c396.png","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/01b\/437\/8fa\/01b4378fa517d03004e0e6ff50c95f89.png","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/b79\/9f4\/1f1\/b799f41f1062e77aa90683e12a2333f8.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/fb3\/cc1\/5e0\/fb3cc15e0d0d6afb285ca1d5cdad93e5.png","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/a5d\/1e9\/84e\/a5d1e984ec5988838bab1f28d9f0dc08.jpg"]}</script>
  <script src="//www.googletagservices.com/tag/js/gpt.js" async></script>
  <style>.grecaptcha-badge{visibility: hidden;}</style>
  <meta name="habr-version" content="2.46.0-1">
  
  <meta data-vue-meta="ssr" property="fb:app_id" content="444736788986613"><meta data-vue-meta="ssr" property="fb:pages" content="472597926099084"><meta data-vue-meta="ssr" name="twitter:card" content="summary_large_image"><meta data-vue-meta="ssr" name="twitter:site" content="@habr_eng"><meta data-vue-meta="ssr" property="og:title" content="Разработка одноплатного компьютера. Пособие для продвинутых" data-vmid="og:title"><meta data-vue-meta="ssr" name="twitter:title" content="Разработка одноплатного компьютера. Пособие для продвинутых" data-vmid="twitter:title"><meta data-vue-meta="ssr" name="aiturec:title" content="Разработка одноплатного компьютера. Пособие для продвинутых" data-vmid="aiturec:title"><meta data-vue-meta="ssr" name="description" content="NavQ+, герой сегодняшнего рассказаЯ занимаюсь разработкой электроники. Шесть лет назад я написал свою первую статью начинавшуюся этими же словами и увидел неподдельное внимание. Все эти годы я..." data-vmid="description"><meta data-vue-meta="ssr" itemprop="description" content="NavQ+, герой сегодняшнего рассказаЯ занимаюсь разработкой электроники. Шесть лет назад я написал свою первую статью начинавшуюся этими же словами и увидел неподдельное внимание. Все эти годы я..." data-vmid="description:itemprop"><meta data-vue-meta="ssr" property="og:description" content="NavQ+, герой сегодняшнего рассказаЯ занимаюсь разработкой электроники. Шесть лет назад я написал свою первую статью начинавшуюся этими же словами и увидел неподдельное внимание. Все эти годы я..." data-vmid="og:description"><meta data-vue-meta="ssr" name="twitter:description" content="NavQ+, герой сегодняшнего рассказаЯ занимаюсь разработкой электроники. Шесть лет назад я написал свою первую статью начинавшуюся этими же словами и увидел неподдельное внимание. Все эти годы я..." data-vmid="twitter:description"><meta data-vue-meta="ssr" property="aiturec:description" content="NavQ+, герой сегодняшнего рассказаЯ занимаюсь разработкой электроники. Шесть лет назад я написал свою первую статью начинавшуюся этими же словами и увидел неподдельное внимание. Все эти годы я..." data-vmid="aiturec:description"><meta data-vue-meta="ssr" itemprop="image" content="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-vmid="image:itemprop"><meta data-vue-meta="ssr" property="og:image" content="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-vmid="og:image"><meta data-vue-meta="ssr" property="aiturec:image" content="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-vmid="aiturec:image"><meta data-vue-meta="ssr" name="twitter:image" content="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-vmid="twitter:image"><meta data-vue-meta="ssr" property="vk:image" content="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-vmid="vk:image"><meta data-vue-meta="ssr" property="aiturec:item_id" content="577246" data-vmid="aiturec:item_id"><meta data-vue-meta="ssr" property="aiturec:datetime" content="2021-09-10T09:01:57.000Z" data-vmid="aiturec:datetime"><meta data-vue-meta="ssr" property="og:type" content="article" data-vmid="og:type"><meta data-vue-meta="ssr" property="og:locale" content="ru_RU" data-vmid="og:locale"><meta data-vue-meta="ssr" property="og:image:width" content="1200" data-vmid="og:image:width"><meta data-vue-meta="ssr" property="og:image:height" content="630" data-vmid="og:image:height">
  <link data-vue-meta="ssr" href="https://habr.com/ru/rss/post/577246/?fl=ru" type="application/rss+xml" title="" rel="alternate" name="rss"><link data-vue-meta="ssr" href="https://habr.com/ru/post/577246/" rel="canonical" data-vmid="canonical"><link data-vue-meta="ssr" rel="amphtml" href="https://habr.com/ru/amp/post/577246/"><link data-vue-meta="ssr" data-vmid="hreflang"><link data-vue-meta="ssr" image_src="image" href="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-vmid="image:href">
  <meta name="apple-mobile-web-app-status-bar-style" content="#303b44">
  <meta name="msapplication-TileColor" content="#629FBC">
  <meta name="apple-mobile-web-app-capable" content="yes">
  <meta name="mobile-web-app-capable" content="yes">
  <link
    rel="shortcut icon"
    type="image/png"
    sizes="16x16"
    href="https://assets.habr.com/habr-web/img/favicons/favicon-16.png"
  >
  <link
    rel="shortcut icon"
    type="image/png"
    sizes="32x32"
    href="https://assets.habr.com/habr-web/img/favicons/favicon-32.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="76x76"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-76.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="120x120"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-120.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="152x152"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-152.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="180x180"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-180.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="256x256"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-256.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1136x640.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2436x1125.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1792x828.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_828x1792.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1334x750.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1242x2668.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 736px) and (-webkit-device-pixel-ratio: 3) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2208x1242.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1125x2436.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 736px) and (-webkit-device-pixel-ratio: 3) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1242x2208.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2732x2048.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2688x1242.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2224x1668.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_750x1334.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2048x2732.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2388x1668.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1668x2224.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_640x1136.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1668x2388.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2048x1536.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1536x2048.png"
  >
  <link
    rel="mask-icon"
    color="#77a2b6"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-120.svg"
  >
  <link
    crossorigin="use-credentials"
    href="/manifest.webmanifest"
    rel="manifest"
  >
</head>
<body>


<div id="app" data-server-rendered="true" data-async-called="true"><div class="tm-layout__wrapper"><!----><div></div><!----><header class="tm-header"><div class="tm-page-width"><div class="tm-header__container"><!----><span class="tm-header__logo-wrap"><a href="/ru/" class="tm-header__logo tm-header__logo_ru"><svg height="16" width="16" class="tm-svg-img tm-header__icon"><title>Хабр</title><use xlink:href="/img/habr-logo-ru.svg#logo"></use></svg></a><span class="tm-header__beta-sign" style="display:none;">β</span></span><div class="tm-dropdown tm-header__projects"><div class="tm-dropdown__head"><button class="tm-header__dropdown-toggle"><svg height="16" width="16" class="tm-svg-img tm-header__icon tm-header__icon_dropdown"><title>Открыть список</title><use xlink:href="/img/megazord-v24.cee85629.svg#arrow-down"></use></svg></button></div><!----></div><a href="/ru/sandbox/start/" class="tm-header__become-author-btn">
              Как стать автором
            </a><div class="tm-feature tm-header__feature tm-feature_variant-inline"><!----></div><!----><!----></div></div></header><div class="tm-layout"><div class="tm-page-progress-bar"></div><div data-menu-sticky="true" class="tm-base-layout__header tm-base-layout__header_is-sticky"><div class="tm-page-width"><div class="tm-base-layout__header-wrapper"><div class="tm-main-menu"><div class="tm-main-menu__section"><nav class="tm-main-menu__section-content"><!----><a href="/ru/all/" class="tm-main-menu__item">
        Все потоки
      </a><a href="/ru/flows/develop/" class="tm-main-menu__item">
          Разработка
        </a><a href="/ru/flows/admin/" class="tm-main-menu__item">
          Администрирование
        </a><a href="/ru/flows/design/" class="tm-main-menu__item">
          Дизайн
        </a><a href="/ru/flows/management/" class="tm-main-menu__item">
          Менеджмент
        </a><a href="/ru/flows/marketing/" class="tm-main-menu__item">
          Маркетинг
        </a><a href="/ru/flows/popsci/" class="tm-main-menu__item">
          Научпоп
        </a></nav></div></div><div class="tm-header-user-menu tm-base-layout__user-menu"><a href="/ru/search/" class="tm-header-user-menu__item tm-header-user-menu__search"><svg height="24" width="24" class="tm-svg-img tm-header-user-menu__icon tm-header-user-menu__icon_search tm-header-user-menu__icon_dark"><title>Поиск</title><use xlink:href="/img/megazord-v24.cee85629.svg#search"></use></svg></a><!----><!----><!----><div class="tm-header-user-menu__item tm-header-user-menu__user_desktop"><div class="tm-dropdown"><div class="tm-dropdown__head"><svg height="24" width="24" data-test-id="menu-toggle-guest" class="tm-svg-img tm-header-user-menu__icon"><title>Профиль</title><use xlink:href="/img/megazord-v24.cee85629.svg#header-user"></use></svg><!----></div><!----></div><!----></div><!----></div></div></div></div><!----><div class="tm-page-width"></div><main class="tm-layout__container"><div hl="ru" data-async-called="true" class="tm-page"><div class="tm-page-width"><!----><div class="tm-page__wrapper"><div class="tm-page__main tm-page__main_has-sidebar"><div class="pull-down"><div class="pull-down__header" style="height:0px;"><div class="pull-down__content" style="bottom:10px;"><svg height="24" width="24" class="tm-svg-img pull-down__arrow"><title>Обновить</title><use xlink:href="/img/megazord-v24.cee85629.svg#pull-arrow"></use></svg></div></div><!----><div class="tm-page-article__body"><article class="tm-page-article__content tm-page-article__content_inner"><div class="tm-page-article__head-wrapper"><!----><div class="tm-article-snippet tm-page-article__snippet"><div class="tm-article-snippet__meta-container"><div class="tm-article-snippet__meta"><span class="tm-user-info tm-article-snippet__author"><a href="/ru/users/a_freeman/" title="a_freeman" class="tm-user-info__userpic"><div class="tm-entity-image"><img alt="" height="24" loading="lazy" src="//habrastorage.org/r/w32/getpro/habr/avatars/62f/fc9/c2c/62ffc9c2c9a478aff1be38c34aaf12b2.jpg" width="24" class="tm-entity-image__pic"></div></a><span class="tm-user-info__user"><a href="/ru/users/a_freeman/" class="tm-user-info__username">
      a_freeman
    </a></span></span><span class="tm-article-snippet__datetime-published"><time datetime="2021-09-10T09:01:57.000Z" title="2021-09-10, 12:01">вчера в 12:01</time></span></div><!----></div><h1 lang="ru" class="tm-article-snippet__title tm-article-snippet__title_h1"><span>Разработка одноплатного компьютера. Пособие для продвинутых</span></h1><div class="tm-article-snippet__hubs"><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/analysis_design/" class="tm-article-snippet__hubs-item-link"><span>Анализ и проектирование систем</span><span title="Профильный хаб" class="tm-article-snippet__profiled-hub">*</span></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/system_programming/" class="tm-article-snippet__hubs-item-link"><span>Системное программирование</span><span title="Профильный хаб" class="tm-article-snippet__profiled-hub">*</span></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/linux_dev/" class="tm-article-snippet__hubs-item-link"><span>Разработка под Linux</span><span title="Профильный хаб" class="tm-article-snippet__profiled-hub">*</span></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/gadgets/" class="tm-article-snippet__hubs-item-link"><span>Гаджеты</span><!----></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/easyelectronics/" class="tm-article-snippet__hubs-item-link"><span>Электроника для начинающих</span><!----></a></span></div><div class="tm-article-snippet__labels"><!----></div><!----><!----></div></div><!----><div data-gallery-root="" lang="ru" class="tm-article-body"><div id="post-content-body" class="article-formatted-body article-formatted-body_version-2"><div xmlns="http://www.w3.org/1999/xhtml"><figure class="full-width "><img src="/img/image-loader.svg" alt="NavQ+, герой сегодняшнего рассказа" title="NavQ+, герой сегодняшнего рассказа" height="893" data-src="https://habrastorage.org/getpro/habr/upload_files/f01/25d/6be/f0125d6bea869a01645556f6aa04e88f.png" data-width="1363"/><figcaption>NavQ+, герой сегодняшнего рассказа</figcaption></figure><p>Я занимаюсь разработкой электроники. Шесть лет назад я написал <a href="https://habr.com/ru/post/377677/" rel="noopener noreferrer nofollow">свою первую статью</a> начинавшуюся этими же словами и увидел неподдельное внимание. Все эти годы я продолжал оттачивать свое мастерство и на текущий момент я хочу перефразировать вступление:</p><p><u>Я занимаюсь разработкой электроники и мне этого мало.</u> </p><p>Чтобы немного понять, что я имею ввиду, предлагаю заглянуть под кат.&lt;/cut></p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/b0a/6fb/09f/b0a6fb09f154c40f6477f311ad7a07f7.jpg" alt="Первые результаты, которыми можно поделиться." title="Первые результаты, которыми можно поделиться." width="1264" height="1500" data-src="https://habrastorage.org/getpro/habr/upload_files/b0a/6fb/09f/b0a6fb09f154c40f6477f311ad7a07f7.jpg" data-blurred="true"/><figcaption>Первые результаты, которыми можно поделиться.</figcaption></figure><p>Да, я фотографирую себя с помощью встраиваемого компьютера, который я разработал и для которого я собрал софт, на камеру, которую мне пришлось поднимать вручную (хехе, какая двусмысленность). Да, я покрыл полный стек разработки: от идеи до воплощения, включая отладку железа и софта.</p><p>А теперь небольшое отступление, как я вообще докатился до жизни такой. Около двух лет назад наш коллектив влился в разработку электроники и софта для одной международной компании. Проект оказался несколько нервным: заказчики меняли архитектуру железа на лету (например, мы меняли систему питания два раза, с выпуском прототипов в железе, меняли контроллер, с разрабкой софта и для старого и для нового, разумеется с отладкой в железе, а под конец, когда железка уже работала с DDR3L памятью нас попросили переделать под DDR4). Тем не менее, железка вышла в свет, и вы можете не только посмотреть непредвзятый обзор онлайн: <a href="https://www.youtube.com/watch?v=12y3sCZG1bc" rel="noopener noreferrer nofollow">тыц</a>, но и купить ее по всему миру. К слову, как разработка схемы, так и трассировка печатной платы были выполнены лично мной. В этой истории есть масса интересных моментов, но не будем отвлекаться: в процессе работы над этим и другими проектами я получил серьезный опыт и у меня сформировалось понимание, как процесс разработки аппаратуры можно ускорить и улучшить. В двух словах: человек, который умеет как в железо, так и в софт, может ускорить этот процесс в разы. Например, отладка новой железки для программистов это кошмар: непонятные схемы, неизвестность, как изменения в софте отражаются в железе, соответственно, сложность с проверкой своего кода и полная потерянность. Отладка железки для железячника этот тот же кошмар, только в профиль: тонны кода, сложности навигации в нем и уж тем более сложности модификации этого кода, и как результат – потерянность. Сотрудничество двух команд это потерянность в большинстве случаев.</p><p>Второй важный навык, который я вынес из этого, и многих других проектов это навык оперативной разработки железа. Возможность выкатить первую версию железа через месяц после утверждения ТЗ это здорово. (Изменения в ТЗ это не здорово, но об этом в другой раз). Например, в проекте выше для первых прототипов мы взяли готовый процессорный модуль от NXP, а все остальные фичи реализовали в простой четырех-слойной плате. Да, на плате немного срач, но для медленных интерфейсов это абсолютно не важно. Важно то, что такую плату могут изготовить за неделю, а собрать и отлаживать такую комбинацию в разы проще: можно декомпозировать и отлаживать по частям:</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/518/368/f79/518368f79be196abe946cc4191dae3b4.jpg" alt="Плата в стадии EVT (Engineering Validation Test). На этой стадии проверятеся, что ТЗ вообще выполнимо." title="Плата в стадии EVT (Engineering Validation Test). На этой стадии проверятеся, что ТЗ вообще выполнимо." width="1920" height="1080" data-src="https://habrastorage.org/getpro/habr/upload_files/518/368/f79/518368f79be196abe946cc4191dae3b4.jpg" data-blurred="true"/><figcaption>Плата в стадии EVT (Engineering Validation Test). На этой стадии проверятеся, что ТЗ вообще выполнимо.</figcaption></figure><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/4ae/a91/284/4aea91284a7d06ff34b578dc038b6b5a.jpg" alt="Платы в стадии DVT (Design Validation Test). На этой стадии дизайн доводится до ума." title="Платы в стадии DVT (Design Validation Test). На этой стадии дизайн доводится до ума." width="896" height="507" data-src="https://habrastorage.org/getpro/habr/upload_files/4ae/a91/284/4aea91284a7d06ff34b578dc038b6b5a.jpg" data-blurred="true"/><figcaption>Платы в стадии DVT (Design Validation Test). На этой стадии дизайн доводится до ума.</figcaption></figure><p>В результате, эта стратегия позволила мне многие разработки переиспользовать и начать вести собственные проекты в аналогичном оперативном и гибком темпе. Один такой пилотный проект вышел в свет и полностью доступен здесь: <a href="https://nxp.gitbook.io/8mmnavq/" rel="noopener noreferrer nofollow">https://nxp.gitbook.io/8mmnavq/</a></p><p>Этот проект оказался коммерчески жизнеспособным, хоть и не таким масштабным. Тем не менее идея показалсь интересной, и мы продолжили работу. Отсюда и начинается главное повествование.</p><p>Итак, в ходе работы мы установили множество трудовых отношений, в том числе и с компанией NXP (как вы уже увидели по ссылке на гитбук), и когда эти ребята выпустили новый процессор IMX8M Plus (ниже), мы решили что стоит взяться за него посерьезнее, и переиспользовать все наработки, которые были получены как в пилотном проекте NavQ, так и опыт разработки в целом.</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/ec3/045/aad/ec3045aad0d198edb1d1c8d26be0a90c.jpg" alt="IMX8M Plus в одной картинке" title="IMX8M Plus в одной картинке" width="1601" height="900" data-src="https://habrastorage.org/getpro/habr/upload_files/ec3/045/aad/ec3045aad0d198edb1d1c8d26be0a90c.jpg" data-blurred="true"/><figcaption>IMX8M Plus в одной картинке</figcaption></figure><h2>Железо</h2><p>Собственно, в первой ревизии железа (на КДПВ) было реализовано следующее:</p><ul><li><p>Процессор IMX8M Plus (его блок-схема выше)</p></li><li><p>До 8Гбайт LPDDR4 памяти (32бит, до 4266MTs), до 1ТБ eMMC (8бит, до 3200Mbps)</p></li><li><p>Два USB-C порта (до 5Gbps на порт), с поддержкой Power Delivery</p></li><li><p>Два MIPI CSI (Camera Serial Interface), 4 канала данных на каждый порт</p></li><li><p>Два LVDS порта для вывода видео, 4 канала данных на каждый порт</p></li><li><p>Один MIPI DSI (Display Serial Interface), 4 канала данных на порт</p></li><li><p>Один PCIe Gen 3, (1 канал данных, до 8GTs)</p></li><li><p>Один 1000BASE-T Ethernet, с поддержкой IEEE 1588v2</p></li><li><p>Один WiFi модуль, 2.4/5GHz, c Bluetooth Low Energy</p></li><li><p>Масса низкоскортных интерфейсов (UART, SPI, I2C, JTAG)</p></li><li><p>Питание от USB или от 5-20В внешнего источника питания</p></li></ul><p>Практически все, что есть в процессоре. И это все в сборке размером с кредитку. Разводка всего этого в 6 слоях было тем еще приключением. Собственно, все это отражено на КДПВ. Но на этом решили не останавливаться, и решили еще немного добавить в новой ревизии:</p><ul><li><p>Двухпроводой автомобильный Ethernet (до 100 Mbps)</p></li><li><p>Два CAN интерфейса, каждый с индивидуальным с PHY </p></li><li><p>NFC и Trusted Platform модуль (криптография и все такое)</p></li><li><p>RTC с твердотельным суперконденсатором</p></li></ul><p>Кстати, о разводке: вот лицевая и тыльная сторона платы в том виде как это вижу я во время проектирования: в таких случаях начитается оптимизация на новых уровнях: например у USB-3.0 высокоскоростные диффпары можно переподключать с «неправильной» полярностью: линк в процессе тренировки подстроится. И это определено в стандарте USB. Такие знания позволяют творить с USB хорошие трюки: например разводка всего USB в одной плоскости. А это хорошо с точки зрения целостности сигналов: меньше переходов на другие слои – меньше искажений полезного сигнала. Да и разводка получается элегантнее и компактнее. И таких трюков десятки. </p><figure class="full-width "><img src="/img/image-loader.svg" alt="Да, каждый проводник, каждый разьем, каждый компонент поставлен вручную." title="Да, каждый проводник, каждый разьем, каждый компонент поставлен вручную." height="914" data-src="https://habrastorage.org/getpro/habr/upload_files/d30/c5a/c81/d30c5ac81679ad7d98d45a5dd7611372.png" data-width="1397"/><figcaption>Да, каждый проводник, каждый разьем, каждый компонент поставлен вручную.</figcaption></figure><figure class="full-width "><img src="/img/image-loader.svg" alt="Да, это как тетрис, только круче." title="Да, это как тетрис, только круче." height="915" data-src="https://habrastorage.org/getpro/habr/upload_files/626/abd/9ba/626abd9ba9eb47e4d89db50110d3c396.png" data-width="1325"/><figcaption>Да, это как тетрис, только круче.</figcaption></figure><p>Еще один приятный момент: навыки работы в нескольких САПР. Разумеется у каждой САПР есть свои плюсы и минусы. Например, мне нравится Orcad Allegro за его абсолютно серьезный подход к правилам и проверкам дизайна. Система от британцев, а уж они то ребята дисциплинированные. Но еще мне нравится Altium Designer. Разработчики стараются сделать софт приятным в использовании и со всеми современными графическими фичами: вот где еще я могу собрать всю свою поделку, включая хитро выгнутые шлейфы, да так, чтобы выглядело реалистично? </p><figure class="full-width "><img src="/img/image-loader.svg" alt="Предыдущее поколение. Кстати, вся работа выполнена в Orcad, но импорт в Allegro нужен именно ради таких рендеров." title="Предыдущее поколение. Кстати, вся работа выполнена в Orcad, но импорт в Allegro нужен именно ради таких рендеров." height="884" data-src="https://habrastorage.org/getpro/habr/upload_files/01b/437/8fa/01b4378fa517d03004e0e6ff50c95f89.png" data-width="1396"/><figcaption>Предыдущее поколение. Кстати, вся работа выполнена в Orcad, но импорт в Allegro нужен именно ради таких рендеров.</figcaption></figure><p>Сильным подспорьем оказываются и навыки в 3D моделировании: спроектированный корпус для модуля становится как и защитой этого модуля от внешних воздействий: его уже не повредишь случайным касанием, так и придает законченный вид изделию:</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/b79/9f4/1f1/b799f41f1062e77aa90683e12a2333f8.jpg" alt="Time Of Flight камеры. Реально измеряют время пролета света от лазерного диода до обьектов и обратно до фото-матрицы. " title="Time Of Flight камеры. Реально измеряют время пролета света от лазерного диода до обьектов и обратно до фото-матрицы. " width="3344" height="2872" data-src="https://habrastorage.org/getpro/habr/upload_files/b79/9f4/1f1/b799f41f1062e77aa90683e12a2333f8.jpg" data-blurred="true"/><figcaption>Time Of Flight камеры. Реально измеряют время пролета света от лазерного диода до обьектов и обратно до фото-матрицы. </figcaption></figure><p>Но это все покрывает только половину задачи. Следующий шаг – поднять все это в софте.</p><p><strong>Софт</strong></p><p>Очевидно, что такое обилие новых интерфейсов требует серьезной работы и на стороне софта. Итак, я понял, что я хочу с этим справится. Сборка ядра Linux это уже мелочи на сегодняшний день, никого этим не удивить, сборка Yocto тоже решаема парой пинков в нужных местах (если потребуется), модификация Device Tree Structure, собственно структуры которая сообщает ядру какая периферия для него доступна это тоже не страшно. Всяческие низкоскоростные интерфейсы просто «включаются» в ядре и заводятся в железе сразу. Но вот работа с видеоподсистемой, и особенно с камерами это был серьезный вызов. И я решил себя в этом попробовать. Я догадывался, что это кошмар, но глубину этой «кроличьей норы» оценить не мог. А оценить оказалось что.</p><p>Этот новый IMX8M Plus немного отличается от всех своих предшественников в организации всей своей медиа-подсистемы. NXP добавила в процессор так называемые ISI, Image Sensing Interfaces и ISP, Image Signal Processors, оба для обработки видео-потоков с камер. Помимо того, что все это новые модули, они еще сильно связаны с V4L2 (Video For Linux) подсистемой в Linux. И еще над всем этим ведется работа, и каждый релиз BSP от NXP отличается от предыдущего. И люди это пытаются использовать и разумеется это невероятно сложно. Быстрый взгляд в коммьюнити хаб разработчиков открыл страшную картину: я сходу столкнулся с дюжиной тем где люди обращались за помощью к NXP:    </p><ol><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/iMX8M-MIPI-CSI-4-lane-configuration/m-p/875755" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/iMX8M-MIPI-CSI-4-lane-configuration/m-p/875755</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/IMX8-MIPI-CSI2-video-capture-not-working/m-p/1222637" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/IMX8-MIPI-CSI2-video-capture-not-working/m-p/1222637</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/IMX8MP-MIPI-CSI2-Problems-in-custom-camera/m-p/1234225" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/IMX8MP-MIPI-CSI2-Problems-in-custom-camera/m-p/1234225</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/imx477-sensor-driver-for-i-MX8M-Plus/m-p/1271067" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/imx477-sensor-driver-for-i-MX8M-Plus/m-p/1271067</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/Unable-to-record-a-video-using-MINISASTOCSI/m-p/1293651" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/Unable-to-record-a-video-using-MINISASTOCSI/m-p/1293651</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/8MPLUSLPD4-EVK-with-MINISASTOCSI-usage/td-p/1259724" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/8MPLUSLPD4-EVK-with-MINISASTOCSI-usage/td-p/1259724</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/i-MX8-ov5640-mipi-v3-driver-problem-SOLVED/m-p/1022521" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/i-MX8-ov5640-mipi-v3-driver-problem-SOLVED/m-p/1022521</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/IMX8MM-Gerneric-MIPI-CSI-driver-available/m-p/1085966" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/IMX8MM-Gerneric-MIPI-CSI-driver-available/m-p/1085966</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/Explenation-for-HS-SETTLE-parameter-in-MIPI-CSI-D-PHY-registers/m-p/764265" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/Explenation-for-HS-SETTLE-parameter-in-MIPI-CSI-D-PHY-registers/m-p/764265</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Solutions/Post-TP2850-driver-on-i-MX8M-Plus/m-p/1241606" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Solutions/Post-TP2850-driver-on-i-MX8M-Plus/m-p/1241606</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/Problems-in-detecting-MINISASTOCSI-in-i-mx8mp-plus-evk-board/m-p/1284705" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/Problems-in-detecting-MINISASTOCSI-in-i-mx8mp-plus-evk-board/m-p/1284705</a></p></li><li><p><a href="https://community.nxp.com/t5/i-MX-Processors/How-to-set-up-the-MIPI-CSI-2-and-ISI-to-transfer-RAW10-images-on/td-p/1134413" rel="noopener noreferrer nofollow">https://community.nxp.com/t5/i-MX-Processors/How-to-set-up-the-MIPI-CSI-2-and-ISI-to-transfer-RAW10-images-on/td-p/1134413</a></p></li></ol><p>И это не праздный интерес «а что это вы тут сделали?», это конкретные вопросы «у нас не работают ваши изобретения на вашем-же железе». В общем, проблема становилась все масштабнее.</p><p>Небольшое отступление: разработка железа с моей точки зрения несколько проще: да, разумеется нужно обладать знаниями в области, понимать пути решения задачи и обладать опытом, но в случае когда железо проектируется с нуля присутствует полная свобода выбора: здесь я поставлю процессор, а тут разъемы (немного утрирую, конечно). В софте, особенно в Linux, есть 30 лет истории развития проекта, и в нем всё со всем тесно связано. «Нельзя просто так взять и добавить драйвер» © с нуля, нужно понимать все пути взаимодействия этого драйвера с системой, и систему соответственно. Особенно в таких случаях, когда это массивные штуки вроде медиа-подсистемы. </p><p>Невозможно передать всю гамму эмоций в одной статье, но в результате мне потребовалась неделя, чтобы заставить камеру работать. В процессе отладки рушилось все: ядро целиком, видео-подсистема, драйвер, вера в человечество и даже части собственной машины (был в глубокой задумчивости, а не пойти-ли мне в проститутки). Когда я в результате увидел картинку с камеры, я немного испугался: вид у меня был явно помятый:  </p><figure class="full-width "><img src="/img/image-loader.svg" alt="Да, Ubuntu была поднята практически сразу. Но расскажу я об этом далее." title="Да, Ubuntu была поднята практически сразу. Но расскажу я об этом далее." height="1080" data-src="https://habrastorage.org/getpro/habr/upload_files/fb3/cc1/5e0/fb3cc15e0d0d6afb285ca1d5cdad93e5.png" data-width="1920"/><figcaption>Да, Ubuntu была поднята практически сразу. Но расскажу я об этом далее.</figcaption></figure><p>В процессе отладки я полагался на свои знания в железе на все сто процентов: проверки того, что изменения в софте реально применяются к железу, и применяются правильно категорически важны: один неправильный бит и камера находится в состоянии сброса, неверный источник тактового сигнала в коде и камера не стартует: нет тактовой частоты.</p><p>В результате я доказал себе отладка как железа, так и софта одним человеком, особенно на таком уровне сложности ВОЗМОЖНА. Это для меня выглядит как level-up, и вот почему. Есть предположение, что это знание масштабируемо: работая меж двух команд (SW и HW) можно как разрешать многие ошибки на начальных этапах проектирования, так и в последующем значительно ускорять процесс разработки (понимая что и где нужно каждой из команд). </p><p>На этом работа над камерой была завершена. Но помимо этого есть еще и вывод видео. И это было второй частью приключения. Вывести картинку не сложно, но вот вывести на монтитор GUI целой операционной системы уже посложнее. Небольшой флэш-бэк из прошлой статьи: “В качестве собственно операционной системы я выбираю Debian. По-моему, отличный дистрибутив — простой и надежный, как деревянная палка. Беру готовую сборку, распаковываю на раздел карточки, и указываю при загрузке ядра, где искать его законную корневую.” </p><p>Так вот, с графикой такое не проходит. Графическая подсистема (скажем, оконный менеджер) тесно завязана на десятки библиотек, а эти библиотеки в свою очередь завязаны на ядро Linux, которое в свою очередь обращается к драйверу графического ускорителя. Драйвера собираются под конкретное железо, и могу предлагать только часть возможностей необходимых оконному менеджеру, соответственно, не любая комбинация возможна. </p><p>В моем случае мне несказанно повезло: NXP дружит с <a href="https://ru.wikipedia.org/wiki/Wayland" rel="noopener noreferrer nofollow">Wayland</a>, а Ubuntu (прямой потомок Debian) совсем недавно начала поддерживать Wayland со своей <a href="https://www.omgubuntu.co.uk/2021/01/ubuntu-21-04-will-use-wayland-by-default" rel="noopener noreferrer nofollow">стороны</a>.</p><p>То есть, пара дней гуглинга и медитаций дали желаемое: я завел Ubuntu на новом процессоре. А это уже открывает окно в целый мир: я сходу поcтавил ROS (Robot Operating System), подключил уже проверенный PCIe модуль с любимыми видео (а потом и аппаратный <a href="https://coral.ai/products/m2-accelerator-bm" rel="noopener noreferrer nofollow">Neural Network Accelerator</a>) и поставил соответствующий софт. Даже YouTube посмотрел, чего я не мог сделать на своем предыдущем одноплатнике:</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/a5d/1e9/84e/a5d1e984ec5988838bab1f28d9f0dc08.jpg" alt="Дружно вспомнили мем про видосики" title="Дружно вспомнили мем про видосики" width="2184" height="2236" data-src="https://habrastorage.org/getpro/habr/upload_files/a5d/1e9/84e/a5d1e984ec5988838bab1f28d9f0dc08.jpg" data-blurred="true"/><figcaption>Дружно вспомнили мем про видосики</figcaption></figure><p>Таким образом, получилась целая платформа, немного напоминающая Raspberry PI. То есть: подключил клавиатуру, мышь, дисплей и вот у тебя полноценный компьютер. Еще один level-up: я с детства мечтал спроектировать и собрать собственный компьютер, с теми интерфейсами какие я хочу, с той геометрией и тем софтом которым я привык пользоваться. Получилось здорово, мне нравится.</p><p><strong>Aftermath</strong></p><p>Разумеется, многие интерфейсы еще не проверены, работы непочатый край, разумеется, есть идеи как систему можно расширить благодаря ее модульности. Есть вещи, которые просто обязаны, случится, например Time Of Flight камеры лежат и ждут <a href="https://www.youtube.com/watch?v=juue1_VCvAg&amp;ab_channel=pmdtechnologiesUSA" rel="noopener noreferrer nofollow">когда за них возьмутся</a>.</p><p>Над проектом ведется работа, и не одним лишь мной. Будет вкусный софт и вся поддержка, и не только со стороны NXP. Всю эту систему с полным набором интерфейсов можно будет получить даже бесплатно, вот как это происходило с <a href="https://www.nxp.com/company/blog/winners-of-nxp-hovergames-2-show-innovative-solutions-for-drones-to-help-in-pandemics:BL-HOVERGAMES2" rel="noopener noreferrer nofollow">предыдущим поколением</a>.</p><p>При первой-же возможности доступ к файлам проекта будет открыт (как для <a href="https://nxp.gitbook.io/8mmnavq/" rel="noopener noreferrer nofollow">https://nxp.gitbook.io/8mmnavq/</a>), и мне будет крайне интересно услышать мнение от ребят с опытом. Реально интересно кто сможет найти проблемы в дизайне и буду рад за тех у кого вообще возникнет такое желание.</p><p>В целом, я рассматриваю это как хороший старт, и надеюсь что я немного раскрыл свою мысль из введения: «я занимаюсь разработкой электроники и мне этого мало». Stay tuned!</p><p>P.S. <a href="https://www.linkedin.com/pulse/debugging-bleeding-edge-linux-new-soc-nightmare-i-can-andrew-bushuev" rel="noopener noreferrer nofollow">На LinkedIn есть еще немного картинок</a></p></div></div><!----><!----></div><div class="tm-article-body__tags"><div class="tm-article-body__tags-links"><span class="tm-article-body__tags-title">Теги:</span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BNXP%5D" class="tm-article-body__tags-item-link">NXP</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BIMX8M%5D" class="tm-article-body__tags-item-link">IMX8M</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BLinux%5D" class="tm-article-body__tags-item-link">Linux</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BPCB%5D" class="tm-article-body__tags-item-link">PCB</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5Baltium%5D" class="tm-article-body__tags-item-link">altium</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5Borcad%5D" class="tm-article-body__tags-item-link">orcad</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5Bwayland%5D" class="tm-article-body__tags-item-link">wayland</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5Bv4l2%5D" class="tm-article-body__tags-item-link">v4l2</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5Busb%5D" class="tm-article-body__tags-item-link">usb</a></span><span class="tm-article-body__tags-item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5Bpcie%5D" class="tm-article-body__tags-item-link">pcie</a></span></div><div class="tm-article-body__tags-links"><span class="tm-article-body__tags-title">Хабы:</span><span class="tm-article-body__tags-item"><a href="/ru/hub/analysis_design/" class="tm-article-body__tags-item-link">
                  Анализ и проектирование систем
                </a></span><span class="tm-article-body__tags-item"><a href="/ru/hub/system_programming/" class="tm-article-body__tags-item-link">
                  Системное программирование
                </a></span><span class="tm-article-body__tags-item"><a href="/ru/hub/linux_dev/" class="tm-article-body__tags-item-link">
                  Разработка под Linux
                </a></span><span class="tm-article-body__tags-item"><a href="/ru/hub/gadgets/" class="tm-article-body__tags-item-link">
                  Гаджеты
                </a></span><span class="tm-article-body__tags-item"><a href="/ru/hub/easyelectronics/" class="tm-article-body__tags-item-link">
                  Электроника для начинающих
                </a></span></div></div></article><div class="tm-article__icons-wrapper"><div class="tm-data-icons tm-page-article__counters-panel"><div class="tm-article-rating tm-data-icons__item"><div class="tm-votes-meter tm-article-rating__votes-switcher"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_medium"><title>Всего голосов 57: ↑55 и ↓2</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 57: ↑55 и ↓2" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_medium">+53</span></div><DIV class="v-portal" style="display:none;"></DIV></div><!----><!----><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    50
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/577246/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      44
    </span></a><!----></div><div title="Поделиться" class="tm-sharing tm-data-icons__item"><button type="button" class="tm-sharing__button"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24" class="tm-sharing__icon"><path fill="currentColor" d="M10.33.275l9.047 7.572a.2.2 0 010 .306l-9.048 7.572a.2.2 0 01-.328-.153V11c-8 0-9.94 6-9.94 6S-1 5 10 5V.428a.2.2 0 01.328-.153z"></path></svg></button><!----></div><DIV class="v-portal" style="display:none;"></DIV></div></div><!----></div><!----><div class="tm-page-article__additional-blocks"><!----><section class="tm-block tm-block_spacing-bottom"><!----><div class="tm-block__body"><div class="tm-article-author tm-page-article__author"><!----><div class="tm-user-card tm-article-author__user-card tm-user-card_variant-two-column"><div class="tm-user-card__info-container"><div class="tm-user-card__header"><div class="tm-user-card__header-data"><a href="/ru/users/a_freeman/" class="tm-user-card__userpic tm-user-card__userpic_size-40"><div class="tm-entity-image"><img alt="" src="//habrastorage.org/getpro/habr/avatars/62f/fc9/c2c/62ffc9c2c9a478aff1be38c34aaf12b2.jpg" class="tm-entity-image__pic"></div></a><div class="tm-user-card__meta"><div title=" 123 голоса " class="tm-karma tm-user-card__karma"><div class="tm-karma__votes tm-karma__votes_positive">
    111.2
  </div><div class="tm-karma__text">
    Карма
  </div></div><div title="Рейтинг пользователя" class="tm-rating tm-user-card__rating"><div class="tm-rating__header"><div class="tm-rating__counter">53.2</div></div><div class="tm-rating__text">
    Рейтинг
  </div></div></div></div></div><div class="tm-user-card__info"><div class="tm-user-card__title"><span class="tm-user-card__name">Бушуев Андрей</span><a href="/ru/users/a_freeman/" class="tm-user-card__nickname">
          @a_freeman
        </a><!----></div><p class="tm-user-card__short-info">Инженер-электроник</p></div></div><div class="tm-user-card__buttons tm-user-card__buttons_variant-two-column"><!----><!----><!----><!----><!----></div></div><!----></div></div><!----></section><div class="tm-page-article__comments"><div class="tm-article-page-comments"><div class="tm-article-comments-counter-link tm-article-comments-counter-button"><a href="/ru/post/577246/comments/" class="tm-article-comments-counter-link__link tm-article-comments-counter-link__link_button-style"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon tm-article-comments-counter-link__icon_contrasted"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value tm-article-comments-counter-link__value_contrasted">
       Комментарии 44 
    </span></a><!----></div></div></div><div class="tm-ad-banner__container tm-page-article__banner"><!----><div id="articleBottomBanner" class="tm-ad-banner"></div></div><section class="tm-block tm-block_spacing-around"><header class="tm-block__header"><h2 class="tm-block__title">Похожие публикации</h2><!----></header><div class="tm-block__body"><ul class="tm-article-list-block__list"><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2021-09-10T10:43:48.000Z" title="2021-09-10, 13:43">вчера в 13:43</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/company/itsumma/news/t/577278/" class="tm-article-title__link"><span>Linux ”perf” ускорили в 60 раз</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 22: ↑20 и ↓2</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 22: ↑20 и ↓2" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+18</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">7.1K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    4
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/company/itsumma/news/t/577278/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      6
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2019-12-27T07:00:03.000Z" title="2019-12-27, 10:00">27  декабря  2019 в 10:00</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/post/482110/" class="tm-article-title__link"><span>На моей визитке работает Linux</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 220: ↑215 и ↓5</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 220: ↑215 и ↓5" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+210</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">102K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    366
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/482110/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      114
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2018-03-29T05:07:38.000Z" title="2018-03-29, 08:07">29  марта  2018 в 08:07</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/post/352254/" class="tm-article-title__link"><span>Linux-форензика в лице трекинга истории подключений USB-устройств</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 14: ↑14 и ↓0</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 14: ↑14 и ↓0" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+14</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">13K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    81
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/352254/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      6
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><!----></ul></div><!----></section><!----><!----><section class="tm-block tm-block_spacing-around"><header class="tm-block__header"><h2 class="tm-block__title">Лучшие публикации за сутки</h2><!----></header><div class="tm-block__body"><ul class="tm-article-list-block__list"><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2021-09-10T15:10:09.000Z" title="2021-09-10, 18:10">вчера в 18:10</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/post/577330/" class="tm-article-title__link"><span>Опыт коррекции зрения под общим наркозом по методике ReLEx Smile или Как лишиться нормального зрения на один глаз</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 91: ↑91 и ↓0</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 91: ↑91 и ↓0" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+91</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">11K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    74
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/577330/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      81
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2021-09-10T03:08:25.000Z" title="2021-09-10, 06:08">вчера в 06:08</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/post/577184/" class="tm-article-title__link"><span>Самодельный стратостат. Часть 2</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 58: ↑57 и ↓1</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 58: ↑57 и ↓1" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+56</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">7.4K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    39
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/577184/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      37
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2021-09-10T09:01:57.000Z" title="2021-09-10, 12:01">вчера в 12:01</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/post/577246/" aria-current="page" class="tm-article-title__link router-link-exact-active router-link-active"><span>Разработка одноплатного компьютера. Пособие для продвинутых</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 57: ↑55 и ↓2</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 57: ↑55 и ↓2" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+53</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">6K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    50
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/577246/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      44
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2021-09-10T07:23:01.000Z" title="2021-09-10, 10:23">вчера в 10:23</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/post/577190/" class="tm-article-title__link"><span>Циолковский — 33 несчастья</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 54: ↑48 и ↓6</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 54: ↑48 и ↓6" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+42</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">5.7K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    27
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/post/577190/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      12
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><li class="tm-article-list-block__item"><article class="tm-article-snippet-block-block tm-article-snippet-block-block_preview"><div class="tm-article-snippet-block__user-meta"><div class="tm-article-snippet-block__date"><time datetime="2021-09-10T10:16:54.000Z" title="2021-09-10, 13:16">вчера в 13:16</time></div></div><h2 class="tm-article-title tm-article-title_block"><a href="/ru/company/lamptest/blog/577266/" class="tm-article-title__link"><span>Начинаю тест старения батареек</span></a></h2><div class="tm-data-icons"><!----><div class="tm-votes-meter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_small"><title>Всего голосов 35: ↑35 и ↓0</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-rating"></use></svg><span title="Всего голосов 35: ↑35 и ↓0" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_small">+35</span></div><span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="16" width="16" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-views"></use></svg><span class="tm-icon-counter__value">3.1K</span></span><button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-favorite"></use></svg></span><span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    20
  </span></button><div title="Читать комментарии" class="tm-article-comments-counter-link tm-data-icons__item"><a href="/ru/company/lamptest/blog/577266/comments/" class="tm-article-comments-counter-link__link"><svg height="16" width="16" class="tm-svg-img tm-article-comments-counter-link__icon"><title>Комментарии</title><use xlink:href="/img/megazord-v24.cee85629.svg#counter-comments"></use></svg><span class="tm-article-comments-counter-link__value">
      9
    </span></a><!----></div><!----><DIV class="v-portal" style="display:none;"></DIV></div></article></li><!----></ul></div><!----></section><!----><!----></div></div></div><div class="tm-page__sidebar"><div hl="ru" id="577246" class="tm-layout-sidebar"><div class="tm-layout-sidebar__ads tm-layout-sidebar__ads_initial"><div class="tm-ad-banner__container tm-layout-sidebar__banner"><!----><div id="sidebarBanner" class="tm-ad-banner"></div></div></div><div class="tm-sexy-sidebar tm-sexy-sidebar_initial" style="margin-top:0px;"><!----></div></div></div></div></div></div></main><!----></div><div class="tm-footer-menu"><div class="tm-page-width"><div class="tm-footer-menu__container"><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Ваш аккаунт
        </h3><div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="/kek/v1/auth/habrahabr/?back=/ru/post/577246/&amp;hl=ru" rel="nofollow" target="_self">
                Войти
              </a></li><li class="tm-footer-menu__list-item"><a href="/kek/v1/auth/habrahabr-register/?back=/ru/post/577246/&amp;hl=ru" rel="nofollow" target="_self">
                Регистрация
              </a></li></ul></div></div><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Разделы
        </h3><div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="/ru/" class="footer-menu__item-link router-link-active">
                Публикации
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/news/" class="footer-menu__item-link">
                Новости
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/hubs/" class="footer-menu__item-link">
                Хабы
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/companies/" class="footer-menu__item-link">
                Компании
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/users/" class="footer-menu__item-link">
                Авторы
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/sandbox/" class="footer-menu__item-link">
                Песочница
              </a></li></ul></div></div><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Информация
        </h3><div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="/ru/docs/help/" class="footer-menu__item-link">
                Устройство сайта
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/docs/authors/codex/" class="footer-menu__item-link">
                Для авторов
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/docs/companies/corpblogs/" class="footer-menu__item-link">
                Для компаний
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/docs/docs/transparency/" class="footer-menu__item-link">
                Документы
              </a></li><li class="tm-footer-menu__list-item"><a href="https://account.habr.com/info/agreement" target="_blank">
                Соглашение
              </a></li><li class="tm-footer-menu__list-item"><a href="https://account.habr.com/info/confidential/" target="_blank">
                Конфиденциальность
              </a></li></ul></div></div><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Услуги
        </h3><div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="https://docs.google.com/presentation/d/e/2PACX-1vQLwRfQmXibiUlWaRg-BAc38s7oM3lJiaPju7qmdJsp8ysIvZ_G-Npem0njJLMozE2bPHMpDqiI5hhy/pub?start=false&amp;loop=false&amp;delayms=60000&amp;slide=id.g91a03369cd_4_297" target="_blank">
                Реклама
              </a></li><li class="tm-footer-menu__list-item"><a href="https://habrastorage.org/storage/stuff/habr/service_price.pdf" target="_blank">
                Тарифы
              </a></li><li class="tm-footer-menu__list-item"><a href="https://docs.google.com/presentation/d/e/2PACX-1vQJJds8-Di7BQSP_guHxICN7woVYoN5NP_22ra-BIo4bqnTT9FR6fB-Ku2P0AoRpX0Ds-LRkDeAoD8F/pub?start=false&amp;loop=false&amp;delayms=60000" target="_blank">
                Контент
              </a></li><li class="tm-footer-menu__list-item"><a href="https://tmtm.timepad.ru/" target="_blank">
                Семинары
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/megaprojects/" class="footer-menu__item-link">
                Мегапроекты
              </a></li></ul></div></div></div></div></div><div class="tm-footer"><div class="tm-page-width"><div class="tm-footer__container"><!----><div class="tm-footer__social"><a href="https://www.facebook.com/habrahabr.ru" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Facebook</title><use xlink:href="/img/social-icons-sprite.svg#social-logo-facebook"></use></svg></a><a href="https://twitter.com/habr_com" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Twitter</title><use xlink:href="/img/social-icons-sprite.svg#social-logo-twitter"></use></svg></a><a href="https://vk.com/habr" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>VK</title><use xlink:href="/img/social-icons-sprite.svg#social-logo-vkontakte"></use></svg></a><a href="https://telegram.me/habr_com" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Telegram</title><use xlink:href="/img/social-icons-sprite.svg#social-logo-telegram"></use></svg></a><a href="https://www.youtube.com/channel/UCd_sTwKqVrweTt4oAKY5y4w" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Youtube</title><use xlink:href="/img/social-icons-sprite.svg#social-logo-youtube"></use></svg></a><a href="https://zen.yandex.ru/habr" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Яндекс Дзен</title><use xlink:href="/img/social-icons-sprite.svg#social-logo-zen"></use></svg></a></div><DIV class="v-portal" style="display:none;"></DIV><button class="tm-footer__link"><!---->
        Настройка языка
      </button><a href="/ru/about" class="tm-footer__link">
        О сайте
      </a><a href="/ru/feedback/" class="tm-footer__link">
        Техническая поддержка
      </a><!----><a href="/berserk-mode-nope" class="tm-footer__link">
        Вернуться на старую версию
      </a><div class="tm-footer-copyright"><span class="tm-copyright"><span class="tm-copyright__years">© 2006–2021 </span><span class="tm-copyright__name">«<a href="https://company.habr.com/" rel="noopener" target="_blank" class="tm-copyright__link">Habr</a>»</span></span></div></div></div></div><!----><!----></div><div class="vue-portal-target"></div></div>
<script>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</script>
<script src="https://assets.habr.com/habr-web/js/chunk-vendors.33463c52.js" defer></script><script src="https://assets.habr.com/habr-web/js/chunk-f458c7c4.91c70f57.js" defer></script><script src="https://assets.habr.com/habr-web/js/app.99a1fd48.js" defer></script>



    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    </script>
  
  <script type="text/javascript" >
    (function(m,e,t,r,i,k,a){m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)};
    m[i].l=1*new Date();k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)})
    (window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym");

    ym(24049213, "init", {
      defer:true,
      trackLinks:true,
      accurateTrackBounce:true,
      webvisor:false,
    });
  </script>
  <noscript>
    <div>
      <img src="https://mc.yandex.ru/watch/24049213" style="position:absolute; left:-9999px;" alt="" />
    </div>
  </noscript>
  
    <script type="text/javascript">
      window.addEventListener('load', function () {
        setTimeout(() => {
          const img = new Image();
          img.src = 'https://vk.com/rtrg?p=VK-RTRG-421343-57vKE';
        }, 0);
      });
    </script>
  
</body>
</html>
