Установка Sparkle на Linux Mint 18.1

Доброго времени суток, форумчане. Когда-то давно, уже более пары лет назад, пересел я с Win 7 на Linux mint. Для большинства программ находил аналоги и инструкции по их установке, реже разбирался сам, когда инструкций не было, а недавно захотелось посмотреть пару фильмов, и тут до меня дошло, что привычной мне Zona для линуха нет.

Первый же запрос в гугл показал, что есть некий проект Sparkle, который является аналогом «зоны». Еще пара запросов показала, что инструкций по установке «для чайников» нет, да еще и несколько раз натыкался на сообщения вида «проект заброшен» итп. К этому моменту была испробована некая странная связка файлов: sparkle-repository_1-1_all.deb и бинарный файл sparkle-install, которая, в общем-то, не дала результата в виде установленного sparkle, но я получил некий установленный репозиторий, из-за которого команда

sudo apt-get update

начинала ругаться на неподписанный репозиторий. Репозиторий выпилил, но программы-то так и нет. Полез искать дальше. Спустя полчаса и изучив несколько веток на различных форумах в итоге вышел на то, что нужны .deb файлы sparkle-vlc, sqlite3-unicodesn, tufao и собственно sparkle, но вот где их взять было загадкой. Дальнейший поиск вывел меня на репозиторий sparkle, в котором лежали сразу все нужные файлики. Скачиваю, начинаю устанавливать, и после установки sparkle-vlc, sqlite3-unicodesn, tufao попытка установить сам sparkle успехом не увенчалась: часть зависимостей не была удовлетворена. Полез внутрь deb пакета, и пришел к выводу что для установки и работы нужны gksu (у меня уже был установлен), libqt5quickparticles5, libtinyxml2-2v5, qml-module-qtgraphicaleffects и qml-module-qtquick-particles2. Установил нужные пакеты командой

sudo apt-get install libqt5quickparticles5 libtinyxml2-2v5 qml-module-qtgraphicaleffects qml-module-qtquick-particles2

и после этого установился sparkle.deb, перезагружаю линух, запускаю sparkle из списка приложениий и… ничего не происходит. Точнее, получаю список ошибок, большинство которых ссылаются на «недостаточно прав». Ладно, вытягиваю ярлык на рабочий стол, в «Свойствах» ярлыка команду для запуска меняю с

sparkle %U

на

gksu sparkle %U

и пробую запустить. Ноут секунд десять думает и открывает sparkle, который просит принять условия лицензионного соглашениия, подгружает какие-то необходимые файлы и наконец-то работает.

Надеюсь, кому-нибудь будет полезным.
Теги:
sparkle, linux mint, zona для linux

Данная статья не подлежит комментированию, поскольку её автор ещё не является полноправным участником сообщества. Вы сможете связаться с автором только после того, как он получит приглашение от кого-либо из участников сообщества. До этого момента его username будет скрыт псевдонимом.