• Yii 2.0: релиз расширения Debug 2.0.8
    +1

    Это отвалилось не благодаря штуке, а в самой штуке.

  • Yii 2.0: релиз расширения Debug 2.0.8
    0

    И то и то интересно и нет, мы об этом не думали. Кидайте отдельными issue или pull request-ами в репозиторий.

  • Yii 2.0: релиз расширения Debug 2.0.8
    0

    Какой именно фильтр и что за переключение?

  • Yii 2.0: релиз расширения Debug 2.0.8
    +1

    Готово.

  • Передача электроэнергии без проводов- от начала до наших дней
    +1

    Шутите?

  • Yii 2.0.11
    0

    Не так просто выпилить… но уже начали.

  • Yii 2.0.11
    +1

    Этот вопрос уже много раз поднимался и много раз был дан ответ, что в 2.1 мы постепенно выпиливаем frontend-зависимости из ядра.


    Про плюсы и минусы медленного SAT-солвера для PHP и JS сразу мы, естественно знаем.

  • Yii 2.0.11
    +1

    А что нынче популярно в мире JS?

  • Yii 2.0.11
    0

    Когда соберёмся выкатывать, тогда пересмотрим этот вопрос ещё раз.

  • Yii 2.0.11
    +2

    Мне очень не хотелось бы в PHP видеть ту же картину, что и в JavaScript: новый тренд каждые два месяца. Начинаем делать проект на трендовом фреймворке, к релизу он уже безбожно "устарел" и не поддерживается официально. Одно дело программировать ради фана и просто забивать на любую поддержку, и совсем другое — делать основу, на которой строятся и поддерживаются годами отличные проекты.

  • Yii 2.0.11
    0

    Формальное несоблюдение SemVer да, в этом случае будет. Согласен.


    С другой стороны, какова вероятность того, что 2.1 с 5.6 проработает до начала 2019 без проблем? Как по мне, довольно высокая. Выбирать сейчас 7.1, как по мне — отбить охоту использовать фреймворк у тяжеловесов вроде IBM. Согласование мажорные версии у них проходит с большим скрипом как раз под конец официальной поддержки (знаю по Oracle и Siemens). Выбирать 7.0, если отбросить генерацию хайпа и рассматривать только проблемы с безопасностью, бессмысленно.

  • Yii 2.0.11
    0

    Ну а какие ещё варианты есть, если её нельзя не сломать?


    1. Сломать.
    2. Выпустить новую мажорную версию и задепрекейтить текущую.

    По сути это одно и то же. Версионирование только отличается.

  • Yii 2.0.11
    0

    Ну как уже, когда Laravel только собирается, Symfony — не ранее ноября. PHPUnit поднял версию ради поднятия версии. Просто потому что все прыгают и я прыгну. Технически в этом необходимости не было. Теперь будут поддерживать несколько веток.


    Профессионально развитее потому что фреймворк не работает на 5.6 и при этом не использует ничего из 7.0? Да ладно вам. Я бы ещё понял если бы аргументом была большая степень абстракции или меньшая связанность, но не это...

  • Yii 2.0.11
    0

    Если у нас в требованиях будет 5.4, руками мы не будем разводить, а решим проблему, если она решаема PHP-кодом, или поднимем минимальные требования, если нет.

  • Yii 2.0.11
    0

    Именно. Не требуется 7.0 для стабильной работы. Мы гарантируем, что 2.1 работает прекрасно на 5.6. Если в процессе разработки 2.1 потребуется технически 7.0 или найдут фатальный недостаток в 5.6, выставим в зависимостях 7.0.

  • Yii 2.0.11
    0

    а) Есть. IBM — сеть моллов в Китае. Альфа-групп — биржа. РТРС — весь интранет с внутренними процессами. FIFA — часть интранета. Facebook, мэрия Москвы, минфин Украины — да, по сути CMS.
    б) И как их поддерживать?

  • Yii 2.0.11
    0

    Для стимулирования мы уже написали в гайде "runs best with PHP 7.0+" и на сайте на главной напишем большими буквами. Но требовать это через composer.json, всё-таки, не стоит.

  • Yii 2.0.11
    +1

    Если свежая версия интерпретатора по факту не требуется для работы кода, зачем указывать её в composer.json?

  • Yii 2.0.11
    0

    Ну, если IBM, Facebook, Альфа-групп, мэрия Москвы, минфин Украины, РТРС, FIFA — это всё не enterprise, то хорошо...

  • Yii 2.0.11
    0

    Ну тогда почему обязательно 7, а не 5.6?

  • Yii 2.0.11
    0

    То, что трендово и модно — не отрицаю. Рационально — нет.

  • Yii 2.0.11
    0

    Ну чем разумнее-то? У неё поддержка по времени меньше, чем у 5.6. 7.1 — да, разумно выбрать с точки зрения поддержки, но не разумно потому как никто его ещё не использует и массового перехода в ближайший год не будет.

  • Yii 2.0.11
    0

    Безопасность тут не при чём. Смотрите: http://php.net/supported-versions.php


    5.6 в плане безопасности поддерживаться будет дольше, чем 7.0.

  • Yii 2.0.11
    +1

    В конструкторе есть.

  • Yii 2.0.11
    +2

    Вы привели совсем не эквивалент. То, что у вас — это обычный $cache->get, который в таком виде уже давно существует. То, что в релизе — это getOrSet. То есть попробовать получить из кеша и, в случае отсутствия, вычислить и сунуть в кеш.

  • Yii 2.0.11
    +1

    А данные откуда брать, если в кеше их не оказалось?

  • Yii 2.0.11
    0

    Если бы вопрос выбора сопровождался бы написанием тучи polyfill-ов для этой версии, повышали бы до семёрки не задумываясь. А так как уже всё написано, покрыто тестами и работает, смысла нет.

  • Yii 2.0.11
    +1

    И? Это не наша проблема. Если технически фреймворк работает с 5.4 и проблем ни в поддержке ни в работе с PHP 7 это не вызывает, зачем завышать требования?

  • Yii 2.0.11
    +1

    Неплохая реализация, кстати. Эх, скоординироваться бы вам всем...

  • Yii 2.0.11
    +1

    Будет принимать от всех желающих информацию о проектах, сделанных на Yii, и показывать её.

  • Yii 2.0.11
    +1

    https://github.com/zhuravljov/yii2-queue пока лучшая попытка.

  • Yii 2.0.11
    0

    Да так много кто сделал. В issue https://github.com/yiisoft/yii2-queue есть ссылки.

  • Yii 2.0.11
    0

    Когда-нибудь и его допилим.

  • Yii 2.0.11
    0

    Фреймворк и сейчас работает отлично на семёрке. И да, быстрее. Рекомендую обновиться, если ещё нет.

  • Yii 2.0.11
    +1

    Релизы расширений, новый сайт, yiipowered, 2.1.

  • Yii 2.0.11
    +1

    В 2.1.

  • Релиз LiveStreet 2.0
    +1

    Оптимистичные прикидки — они всегда такие ;)

  • Релиз LiveStreet 2.0
    0

    Ну, пока не планируется, да и 12-ый не быстро продвигается.

  • Релиз LiveStreet 2.0
    +1

    Конкретно это место, конечно, стоило бы переписать. С виду вроде всё проэкранировано, но уверенности всё равно нет.

  • Релиз LiveStreet 2.0
    0

    PSR-2 обязывает использовать PSR-1. Вообще, переводите уж всё на PSR-12. Как закончите, возможно, его примут :)