<!DOCTYPE html>
<html lang="ru" data-vue-meta="%7B%22lang%22:%7B%22ssr%22:%22ru%22%7D%7D">
<head >
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width,initial-scale=1.0,viewport-fit=cover">
  <title>Видеонаблюдение на даче / Хабр</title>
  <style>
    /* cyrillic-ext */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveSxf6TF0.woff2) format('woff2');
      unicode-range: U+0460-052F, U+1C80-1C88, U+20B4, U+2DE0-2DFF, U+A640-A69F, U+FE2E-FE2F;
    }

    /* cyrillic */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveQhf6TF0.woff2) format('woff2');
      unicode-range: U+0400-045F, U+0490-0491, U+04B0-04B1, U+2116;
    }

    /* latin-ext */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveSBf6TF0.woff2) format('woff2');
      unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
    }

    /* latin */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/s/firasans/v11/va9B4kDNxMZdWfMOD5VnZKveRhf6.woff2) format('woff2');
      unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
    }

    /* non-breaking hyphen */
    @font-face {
      font-family: 'Fira Sans';
      font-style: normal;
      font-weight: 500;
      font-display: swap;
      src: url(https://fonts.gstatic.com/l/font?kit=KFOlCnqEu92Fr1MmEU9vBh0_IsHAlmrO6g&skey=ee881451c540fdec&v=v29) format('woff2');
      unicode-range: U+02011;
    }
  </style>
  <link rel="preload" href="https://assets.habr.com/habr-web/css/chunk-vendors.e7843cc0.css" as="style"><link rel="preload" href="https://assets.habr.com/habr-web/js/chunk-vendors.1a591826.js" as="script"><link rel="preload" href="https://assets.habr.com/habr-web/css/app.c876a64a.css" as="style"><link rel="preload" href="https://assets.habr.com/habr-web/js/app.472b461a.js" as="script">
  <link rel="stylesheet" href="https://assets.habr.com/habr-web/css/chunk-vendors.e7843cc0.css"><link rel="stylesheet" href="https://assets.habr.com/habr-web/css/app.c876a64a.css">
  <script>window.i18nFetch = new Promise((res, rej) => {
          const xhr = new XMLHttpRequest();
          xhr.open('GET', '/js/i18n/ru-compiled.4fd66d0b0db277683556f49927a1e306.json');
          xhr.responseType = 'json';
          xhr.onload = function(e) {
            if (this.status === 200) {
              res({ru: xhr.response});
            } else {
              rej(e);
            }
          };
          xhr.send();
        });</script>
  
  <script data-vue-meta="ssr" type="application/ld+json" data-vmid="ldjson-schema">{"@context":"http:\/\/schema.org","@type":"Article","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/habr.com\/ru\/post\/645865\/"},"headline":"Видеонаблюдение на даче","datePublished":"2022-01-16T15:11:32+03:00","dateModified":"2022-01-16T16:00:57+03:00","author":{"@type":"Person","name":"Сергей"},"publisher":{"@type":"Organization","name":"Habr","logo":{"@type":"ImageObject","url":"https:\/\/habrastorage.org\/webt\/a_\/lk\/9m\/a_lk9mjkccjox-zccjrpfolmkmq.png"}},"description":"Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB кам...","url":"https:\/\/habr.com\/ru\/post\/645865\/#post-content-body","about":["h_linux","h_it-infrastructure","h_s_admin","h_video_tech","f_admin","f_popsci"],"image":["https:\/\/habr.com\/share\/publication\/645865\/d601349da16cb78810febc6e1633eb57\/","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/551\/b34\/5f1\/551b345f15024974993ab3cf816a009f.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/3b7\/642\/a52\/3b7642a52229508eea15a2ed697940a7.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/194\/654\/b49\/194654b49cb0e0de7d0ab846d76c0478.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/e5f\/7d2\/bae\/e5f7d2bae205da78eca194906571980c.png","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/ce0\/acb\/8b4\/ce0acb8b4b1179935b68e595b10c397c.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/7d1\/725\/28e\/7d172528e89574ae9e5fbfd9134d1c1d.jpg","https:\/\/habrastorage.org\/getpro\/habr\/upload_files\/9ae\/425\/84a\/9ae42584a451b39bf0d885797ed1f560.png"]}</script>
  <script src="//www.googletagservices.com/tag/js/gpt.js" async></script>
  <style>.grecaptcha-badge{visibility: hidden;}</style>
  <meta name="habr-version" content="2.57.0">
  
  <meta data-vue-meta="ssr" property="fb:app_id" content="444736788986613"><meta data-vue-meta="ssr" property="fb:pages" content="472597926099084"><meta data-vue-meta="ssr" name="twitter:card" content="summary_large_image"><meta data-vue-meta="ssr" name="twitter:site" content="@habr_com"><meta data-vue-meta="ssr" property="og:site_name" content="Хабр" data-vmid="og:site_name"><meta data-vue-meta="ssr" property="og:title" content="Видеонаблюдение на даче" data-vmid="og:title"><meta data-vue-meta="ssr" name="twitter:title" content="Видеонаблюдение на даче" data-vmid="twitter:title"><meta data-vue-meta="ssr" name="aiturec:title" content="Видеонаблюдение на даче" data-vmid="aiturec:title"><meta data-vue-meta="ssr" name="description" content="Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB камерами. И на работе была уже настроенная..." data-vmid="description"><meta data-vue-meta="ssr" itemprop="description" content="Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB камерами. И на работе была уже настроенная..." data-vmid="description:itemprop"><meta data-vue-meta="ssr" property="og:description" content="Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB камерами. И на работе была уже настроенная..." data-vmid="og:description"><meta data-vue-meta="ssr" name="twitter:description" content="Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB камерами. И на работе была уже настроенная..." data-vmid="twitter:description"><meta data-vue-meta="ssr" property="aiturec:description" content="Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB камерами. И на работе была уже настроенная..." data-vmid="aiturec:description"><meta data-vue-meta="ssr" itemprop="image" content="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" data-vmid="image:itemprop"><meta data-vue-meta="ssr" property="og:image" content="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" data-vmid="og:image"><meta data-vue-meta="ssr" property="og:image:width" content="1200" data-vmid="og:image:width"><meta data-vue-meta="ssr" property="og:image:height" content="630" data-vmid="og:image:height"><meta data-vue-meta="ssr" property="aiturec:image" content="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" data-vmid="aiturec:image"><meta data-vue-meta="ssr" name="twitter:image" content="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" data-vmid="twitter:image"><meta data-vue-meta="ssr" property="vk:image" content="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg?format=vk" data-vmid="vk:image"><meta data-vue-meta="ssr" property="aiturec:item_id" content="645865" data-vmid="aiturec:item_id"><meta data-vue-meta="ssr" property="aiturec:datetime" content="2022-01-16T12:11:32.000Z" data-vmid="aiturec:datetime"><meta data-vue-meta="ssr" property="og:type" content="article" data-vmid="og:type"><meta data-vue-meta="ssr" property="og:locale" content="ru_RU" data-vmid="og:locale"><meta data-vue-meta="ssr" name="keywords" content="Видеонаблюдение, Raspberry Pi, Bash, Expect, Hamachi, Опыт">
  <link data-vue-meta="ssr" href="https://habr.com/ru/post/645865/" rel="og:url" data-vmid="og:url"><link data-vue-meta="ssr" href="https://habr.com/ru/rss/post/645865/?fl=ru" type="application/rss+xml" title="" rel="alternate" name="rss"><link data-vue-meta="ssr" href="https://habr.com/ru/post/645865/" rel="canonical" data-vmid="canonical"><link data-vue-meta="ssr" data-vmid="hreflang"><link data-vue-meta="ssr" image_src="image" href="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" data-vmid="image:href"><link data-vue-meta="ssr" rel="amphtml" href="https://habr.com/ru/amp/post/645865/">
  <meta name="apple-mobile-web-app-status-bar-style" content="#303b44">
  <meta name="msapplication-TileColor" content="#629FBC">
  <meta name="apple-mobile-web-app-capable" content="yes">
  <meta name="mobile-web-app-capable" content="yes">
  <link
    rel="shortcut icon"
    type="image/png"
    sizes="16x16"
    href="https://assets.habr.com/habr-web/img/favicons/favicon-16.png"
  >
  <link
    rel="shortcut icon"
    type="image/png"
    sizes="32x32"
    href="https://assets.habr.com/habr-web/img/favicons/favicon-32.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="76x76"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-76.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="120x120"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-120.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="152x152"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-152.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="180x180"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-180.png"
  >
  <link
    rel="apple-touch-icon"
    type="image/png"
    sizes="256x256"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-256.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1136x640.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2436x1125.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1792x828.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_828x1792.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1334x750.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1242x2668.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 736px) and (-webkit-device-pixel-ratio: 3) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2208x1242.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 812px) and (-webkit-device-pixel-ratio: 3) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1125x2436.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 736px) and (-webkit-device-pixel-ratio: 3) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1242x2208.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2732x2048.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 414px) and (device-height: 896px) and (-webkit-device-pixel-ratio: 3) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2688x1242.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2224x1668.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 375px) and (device-height: 667px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_750x1334.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 1024px) and (device-height: 1366px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2048x2732.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2388x1668.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1112px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1668x2224.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 320px) and (device-height: 568px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_640x1136.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 834px) and (device-height: 1194px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1668x2388.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2) and (orientation: landscape)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_2048x1536.png"
  >
  <link
    rel="apple-touch-startup-image"
    media="screen and (device-width: 768px) and (device-height: 1024px) and (-webkit-device-pixel-ratio: 2) and (orientation: portrait)"
    href="https://assets.habr.com/habr-web/img/splashes/splash_1536x2048.png"
  >
  <link
    rel="mask-icon"
    color="#77a2b6"
    href="https://assets.habr.com/habr-web/img/favicons/apple-touch-icon-120.svg"
  >
  <link
    crossorigin="use-credentials"
    href="/manifest.webmanifest"
    rel="manifest"
  >
</head>
<body>


<div id="app" data-server-rendered="true" data-async-called="true"><div class="tm-layout__wrapper"><!----> <div></div> <!----> <header class="tm-header"><div class="tm-page-width"><div class="tm-header__container"><!----> <span class="tm-header__logo-wrap"><a href="/ru/" class="tm-header__logo tm-header__logo_ru"><svg height="16" width="16" class="tm-svg-img tm-header__icon"><title>Хабр</title> <use xlink:href="/img/habr-logo-ru.svg#logo"></use></svg></a> <span class="tm-header__beta-sign" style="display:none;">β</span></span> <div class="tm-dropdown tm-header__projects"><div class="tm-dropdown__head"><button class="tm-header__dropdown-toggle"><svg height="16" width="16" class="tm-svg-img tm-header__icon tm-header__icon_dropdown"><title>Открыть список</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#arrow-down"></use></svg></button></div> <!----></div> <a href="/ru/sandbox/start/" class="tm-header__become-author-btn">
            Как стать автором
          </a> <div class="tm-feature tm-header__feature tm-feature_variant-inline"><!----></div> <!----> <!----></div></div></header> <div class="tm-layout"><div class="tm-page-progress-bar"></div> <div data-menu-sticky="true" class="tm-base-layout__header tm-base-layout__header_is-sticky"><div class="tm-page-width"><div class="tm-base-layout__header-wrapper"><div class="tm-main-menu"><div class="tm-main-menu__section"><nav class="tm-main-menu__section-content"><!----> <a href="/ru/all/" class="tm-main-menu__item">
        Все потоки
      </a> <a href="/ru/flows/develop/" class="tm-main-menu__item">
          Разработка
        </a><a href="/ru/flows/admin/" class="tm-main-menu__item">
          Администрирование
        </a><a href="/ru/flows/design/" class="tm-main-menu__item">
          Дизайн
        </a><a href="/ru/flows/management/" class="tm-main-menu__item">
          Менеджмент
        </a><a href="/ru/flows/marketing/" class="tm-main-menu__item">
          Маркетинг
        </a><a href="/ru/flows/popsci/" class="tm-main-menu__item">
          Научпоп
        </a></nav></div></div> <div class="tm-header-user-menu tm-base-layout__user-menu"><a href="/ru/search/" class="tm-header-user-menu__item tm-header-user-menu__search"><svg height="24" width="24" class="tm-svg-img tm-header-user-menu__icon tm-header-user-menu__icon_search tm-header-user-menu__icon_dark"><title>Поиск</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#search"></use></svg></a> <!----> <!----> <!----> <div class="tm-header-user-menu__item tm-header-user-menu__user_desktop"><div class="tm-dropdown"><div class="tm-dropdown__head"><svg height="24" width="24" data-test-id="menu-toggle-guest" class="tm-svg-img tm-header-user-menu__icon"><title>Профиль</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#header-user"></use></svg> <!----></div> <!----></div> <!----></div> <!----></div></div></div></div> <!----> <div class="tm-page-width"></div> <main class="tm-layout__container"><div hl="ru" data-async-called="true" class="tm-page"><div class="tm-page-width"><!----> <div class="tm-page__wrapper"><div class="tm-page__main tm-page__main_has-sidebar"><div class="pull-down"><div class="pull-down__header" style="height:0px;"><div class="pull-down__content" style="bottom:10px;"><svg height="24" width="24" class="tm-svg-img pull-down__arrow"><title>Обновить</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#pull-arrow"></use></svg></div></div> <div class="tm-article-presenter"> <div class="tm-article-presenter__body"><div class="tm-misprint-area"><div class="tm-misprint-area__wrapper"><article class="tm-article-presenter__content tm-article-presenter__content_narrow"><div class="tm-article-presenter__header"> <div class="tm-article-snippet tm-article-presenter__snippet"><div class="tm-article-snippet__meta-container"><div class="tm-article-snippet__meta"><span class="tm-user-info tm-article-snippet__author"><a href="/ru/users/ArtShefer/" title="ArtShefer" class="tm-user-info__userpic"><div class="tm-entity-image"><img alt="" height="24" src="//habrastorage.org/r/w32/getpro/habr/avatars/421/20f/17a/42120f17a7b39cd4f6df91af512d61e2.jpg" width="24" class="tm-entity-image__pic"></div></a> <span class="tm-user-info__user"><a href="/ru/users/ArtShefer/" class="tm-user-info__username">
      ArtShefer
    </a> </span></span> <span class="tm-article-snippet__datetime-published"><time datetime="2022-01-16T12:11:32.000Z" title="2022-01-16, 15:11">сегодня в 15:11</time></span></div> <!----></div> <h1 lang="ru" class="tm-article-snippet__title tm-article-snippet__title_h1"><span>Видеонаблюдение на даче</span></h1> <div class="tm-article-snippet__hubs"><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/linux/" class="tm-article-snippet__hubs-item-link"><span>Настройка Linux</span> <span title="Профильный хаб" class="tm-article-snippet__profiled-hub">*</span></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/it-infrastructure/" class="tm-article-snippet__hubs-item-link"><span>IT-инфраструктура</span> <span title="Профильный хаб" class="tm-article-snippet__profiled-hub">*</span></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/s_admin/" class="tm-article-snippet__hubs-item-link"><span>Серверное администрирование</span> <span title="Профильный хаб" class="tm-article-snippet__profiled-hub">*</span></a></span><span class="tm-article-snippet__hubs-item"><a href="/ru/hub/video_tech/" class="tm-article-snippet__hubs-item-link"><span>Видеотехника</span> <!----></a></span></div> <div class="tm-article-snippet__labels"><div class="tm-article-snippet__label tm-article-snippet__label_variant-sandbox"><span>
        Из песочницы
      </span></div></div> <!----> <!----></div></div> <!----> <div data-gallery-root="" lang="ru" class="tm-article-body"><div></div> <div id="post-content-body"><div><div class="article-formatted-body article-formatted-body_version-2"><div xmlns="http://www.w3.org/1999/xhtml"><p>Обратились ко мне за помощью. Задача стояла: подключить и настроить комплект видеонаблюдения на даче. Опыт в этой сфере был минимальный, баловался дома с USB камерами. И на работе была уже настроенная система с отдельным сервером. Представление было как устроено видеонаблюдение, благо есть опыт в IT сфере.</p><p>Для статьи я старался найти оригиналы фото устройств. У некоторых качество хромает. Остальные будут взяты с интернета.</p><p>Установку видеонаблюдения начали в 2019 году. Вносили изменения вплоть до конца 2021 года. Интересное началось, когда заказчик захотел проверять камеры из дома.</p><h2>Часть 1 - монтаж, подключение, настройка</h2><p>Начнем со знакомства "виновника" маленького приключения.</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" alt="Комплект видеонаблюдения IP 5Мп Ps-Link KIT-C504IP-POE 4 камеры для улицы" title="Комплект видеонаблюдения IP 5Мп Ps-Link KIT-C504IP-POE 4 камеры для улицы" width="1024" height="770" data-src="https://habrastorage.org/getpro/habr/upload_files/551/b34/5f1/551b345f15024974993ab3cf816a009f.jpg" data-blurred="true"/><figcaption>Комплект видеонаблюдения IP 5Мп Ps-Link KIT-C504IP-POE 4 камеры для улицы</figcaption></figure><p>Комплект похожий. В состав комплекта входит:</p><ul><li><p>Видеорегистратор с жестким диском и встроенным POE</p></li><li><p>4 уличные IP камеры с ИК-подсветкой</p></li><li><p>Мышь</p></li><li><p>4 провода по 10м (возможно заказчик отдельно приобретал)</p></li></ul><p>По времени установки не было ограничений. Желательно было успеть до того, как на даче начнутся ремонтные работы внутри дома. Справились с этим заданием за пару дней.</p><p>Выбрали оптимальные точки для камер и принялись крепить к обшивке дома. Наружная часть дома была сделана из черепицы (Если честно не разбираюсь в стройматериалах). Сверлили ее аккуратно, а то в запасе была только одна штучка такого покрытия. Основа дома была из дерева. Через нее и утеплитель было легко проделать отверстия и попасть внутрь.</p><p>После установки каждой камеры, она проверялась на работоспособность. Чтоб можно было переобжать провод до завершения монтажных работ. В итоге все подключили к видеорегистратору без проблем. Осталось только его настроить.</p><p>Перевод прошивки у видеорегистратора был на корявом Русском. Иногда смысл какого-нибудь пункта не совпадал с его названием. На ютубе нашли настройки с похожей прошивкой, в некоторых случаях ориентировались по значкам в меню. Ну и танцы с бубном никто не отменял.</p><p>Настройка заключалась в оптимальном использовании места на жестком диске. Чтоб не было лишнего видео, и не затерлись важные моменты. Видеорегистратор поддерживает детекцию движения. Настраивается он выделением квадратов на видео, по которым определяет изменения картинки. Единственный минус, нету предварительной буферизации видео. После детекции начинает запись с задержкой.</p><p>В целом получилось отлично. Все работает как надо. Никто не пострадал. Я получил опыт в установке видеонаблюдения, а заказчик слежку за своей дачной территорией. Отметили это дело и разошлись.</p><h2>Часть 2 - все хорошо, но хочется лучше</h2><p>Ну а кому не хочется лучше. В очередной раз обращаются ко мне. Все работает замечательно, но вот хочется дома в городе, лежа на диванчике смотреть, что творится на даче.</p><p>Пораскидав мыслями, еще раз изучив видеорегистратор. Есть у него подключение через порт Ethernet. Значит к интернету подключим. Вопрос следующий, как смотреть камеры удаленно по web-интерфейсу? Связь с интернетом можно настроить, только через роутер с поддержкой 3G/4G модема. Но за серым IP адресом не попадешь на видеорегистратор. Нашлось два способа.</p><p>Способ 1. Лежал у меня без надобности Raspberry Pi 2. Можно установить его, и через хамачи настроить подключение.</p><p>Способ 2. Тот который мы использовали. Оказался в том, что видеорегистратор имеет свое облачное хранилище на xmeye. А так же есть и приложение для андроид.</p><p>Долго не думая, принялись за поиск роутера и USB модема. Выбрали роутер, не помню какой марки, но это и не важно, мы сдали его обратно в магазин. А USB модем выбирался проще, по сотовой связи что ловит лучше на даче. Им оказался мегафон.</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/3b7/642/a52/3b7642a52229508eea15a2ed697940a7.jpg" alt="4G+ (LTE) модем M150-2" title="4G+ (LTE) модем M150-2" width="689" height="550" data-src="https://habrastorage.org/getpro/habr/upload_files/3b7/642/a52/3b7642a52229508eea15a2ed697940a7.jpg" data-blurred="true"/><figcaption>4G+ (LTE) модем M150-2</figcaption></figure><p>Начали все это дело подключать в связку: видеорегистратор - роутер - USB модем. Началось самое печальное, как ни пробовал настроить подключение на роутере, он не подключался к интернету.</p><p>Я подумал, что придется отказаться от этой затеи с интернетом. А может дело в прошивке? Осталось рискнуть и поискать свежую прошивку на роутер. И действительно нашлась. Но даже после обновления, интернет никак не хотел работать.</p><p>USB модем действительно был из последних моделей. И скорее всего еще не успели выпустить прошивку с поддержкой нового устройства. Печально, но я решил не сдаваться и предложил пробовать другой роутер, хотя было не ловко.</p><p>Мы сдали тот роутер и я подобрал другой. Который видите ниже.</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/194/654/b49/194654b49cb0e0de7d0ab846d76c0478.jpg" alt="D-Link DIR-620S" title="D-Link DIR-620S" width="600" height="480" data-src="https://habrastorage.org/getpro/habr/upload_files/194/654/b49/194654b49cb0e0de7d0ab846d76c0478.jpg" data-blurred="true"/><figcaption>D-Link DIR-620S</figcaption></figure><p>В очередной раз из коробки подключить не удалось. Ищем прошивку. Прошиваем. И наконец нам удается достигнуть цели! С души прям камень упал. Оно работает!</p><p>К интернету подключили. На видеорегистраторе добавили учетную запись пользователя. Пришло время настроить приложение на андроид XMEye</p><figure class="float "><img src="/img/image-loader.svg" alt="Иконка приложения XMEye" title="Иконка приложения XMEye" height="180" data-src="https://habrastorage.org/getpro/habr/upload_files/e5f/7d2/bae/e5f7d2bae205da78eca194906571980c.png" data-width="180"/><figcaption>Иконка приложения XMEye</figcaption></figure><p>Подключение оказалось простым. В видеорегистраторе где информация о системе, есть два QR кода. Один с серийным номером, другой на установку приложения. После добавления в приложение устройства по серийному номеру, запросило логин/пароль. Авторизовавшись под учеткой пользователя мы увидели камеры.</p><p>Приложение простое в работе. Есть просмотр камер онлайн. Можно смотреть старые записи. Можно загрузить запись на телефон или сделать снимок. А так же некоторые настройки видеорегистратора, которые доступны с учетной записи админа. Но они не были интересны, т.к. все уже было настроено как надо.</p><p>Ну и как же без минусов. Тариф, который устроил, был с лимитным интернетом. Бывало, что кто-нибудь трафик использовал через Wi-Fi и до конца месяца камеры не были доступны.</p><p>Вот закончилась встреча. Все рады. Я понял, что надо тщательнее подбирать роутер или USB-модем для совместимости. На крайний случай всегда можно вернуть товар. Заказчик доволен. Отметили это дело и разошлись.</p><h2>Часть 3 - время спустя</h2><p>Это будет не большая промежуточная часть. Проблемы с видеонаблюдением не кончились. Роутер время от времени зависал и только перезагрузка спасала. Но не всегда на дачу ездит заказчик, чтоб перезагрузить роутер.</p><p>Сменили оператора с мегафона на мтс. Там безлимитный интернет, оказалось ловит тоже хорошо. Был один нюанс, не сразу подключился интернет. Как оказалось, USB модем имел свой локальный IP адрес, который конфликтовал с роутером. Пришлось на роутере сменить подсеть, а вместе с ним и перенастраивать видеорегистратор.</p><p>После сброса сетевых настроек камер, все настройки детекции движения остались. А это было самое главное. Меньше потратили бы время на настройку. Хотя все настройки заранее нафоткали на телефон. Искали в меню как перенастроить подключение камер. Прошел уже год как минимум все позабылось. Оказалось отдельного пункта нету в меню, настройка только через мастер установки.</p><p>Осталось разобраться с зависанием роутера. После устранения этой проблемы, я испытал эйфорию. По ощущениям, как прошел заброшенный квест. И об этом в следующей части.</p><h2>Часть 4 - малинка</h2><p>Меня атаковали постоянные жалобы на зависание. И можно ли что-то с этим сделать. В основном происходило зимой и заказчик думал, может надо другой роутер, у которого диапазон рабочей температуры побольше. Я если честно не нашел такой, или плохо искал. И вообще считал что дело в самом роутере. Периодически надо его перезагружать, тем более если работает с USB модемом.</p><p>Идея была такая. Установить на даче мой Raspberry Pi 2, который до сих пор был без надобности (наигрался). И настроить его на перезагрузку роутера, через telnet. Заодно по VPN можно подключить к моему домашнему серверу. Идея супер. Обоим понравилась. Только из всего предложенного я не знал как настроить перезагрузку роутера.</p><p>Благодаря гуглу я нашел решение. Expect. Для меня это было открытием.</p><blockquote><p>Expect поддерживает механизм регулярных выражений и основные возможности программирования, позволяющие простым скриптам эффективно управлять такими программами как telnet, ftp, и ssh, не обладающими встроенным скрипт-языком, макросами, или другими механизмами программирования.</p><p><a href="https://ru.wikipedia.org/wiki/Expect" rel="noopener noreferrer nofollow">https://ru.wikipedia.org/wiki/Expect</a></p></blockquote><p>Договорились о встрече, чтоб съездить установить и настроить. Было начало декабря, морозно. Нужно было часть настроек сделать дома. Дачу никто не отапливал, поэтому будет холодно настраивать.</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/ce0/acb/8b4/ce0acb8b4b1179935b68e595b10c397c.jpg" alt="Raspberry Pi 2 на момент приобретения" title="Raspberry Pi 2 на момент приобретения" width="1080" height="1080" data-src="https://habrastorage.org/getpro/habr/upload_files/ce0/acb/8b4/ce0acb8b4b1179935b68e595b10c397c.jpg" data-blurred="true"/><figcaption>Raspberry Pi 2 на момент приобретения</figcaption></figure><p>К этому моменту старый корпус развалился. И я сделал импровизированный из нерабочего свича. Выглядит этот франкенштейн сейчас вот так</p><figure class="full-width "><img src="https://habrastorage.org/r/w780q1/getpro/habr/upload_files/7d1/725/28e/7d172528e89574ae9e5fbfd9134d1c1d.jpg" alt="Колхозный корпус" title="Колхозный корпус" width="633" height="240" data-src="https://habrastorage.org/getpro/habr/upload_files/7d1/725/28e/7d172528e89574ae9e5fbfd9134d1c1d.jpg" data-blurred="true"/><figcaption>Колхозный корпус</figcaption></figure><p>В качестве ОС выбрал Raspbian Stretch. <a href="https://downloads.raspberrypi.org/raspbian/images/raspbian-2019-04-09/" rel="noopener noreferrer nofollow">Скачал я его из архива</a>.</p><p>Настраивал систему через SSH, т.к. под рукой не было ничего с HDMI входом. Для включения SSH на малине, нужно создать пустой файл в корне флешки с именем "ssh". После первой настройки осталось напичкать скриптами. Сразу отступлюсь, подключить к домашнему серверу по PPTP не удалось, скорее всего данный протокол не дружит с серыми IP адресами. Поэтому настраивали хамачи.</p><p>Первый скрипт "ping.sh" содержал проверку интернет соединения, а затем проверку соединения VPN. Выглядит это так:</p><pre><code class="bash">#!/bin/bash

# Есть интернет?
if ! /bin/ping -c 1 8.8.8.8
then
# Нету. Перезагружаем роутер
/home/pi/router.sh
fi


# Есть интернет?
if /bin/ping -c 1 8.8.8.8
then

# Есть. А есть VPN подключение? (IP моего сервера в хамачи изменен)
if ! /bin/ping -c 1 25.25.25.25
then
# Нету. Перезапускаем хамачи
/etc/init.d/logmein-hamachi restart
fi

fi</code></pre><p>Скрипт для загрузки я скопировал из вики, чтоб настроить его уже на месте.</p><p>Приехали на дачу. Подключили малину. Подключили ноутбук. В настройках роутера включил telnet. Пробуем подключиться. И вуаля, есть приглашение на ввод логина.</p><figure class="full-width "><img src="/img/image-loader.svg" alt="Фото сделано уже по удаленке" title="Фото сделано уже по удаленке" height="361" data-src="https://habrastorage.org/getpro/habr/upload_files/9ae/425/84a/9ae42584a451b39bf0d885797ed1f560.png" data-width="959"/><figcaption>Фото сделано уже по удаленке</figcaption></figure><p>Есть контакт. Далее настраиваю реакции скрипта на регулярные выражения. Представив, как скрипт будет взаимодействовать с роутером. И на примере как я подключаюсь вручную, настроил. Запускаю. Не подключается и выдает ошибку. Далеко ходить не надо было. Как оказалось не хватало установленного telnet клиента на малине.</p><p>Устанавливаю клиет. Запускаю скрипт. Молчание, скрипт завершает работу без ошибок. Ждем перезагрузки роутера. Урааа! Работает!</p><p>Скрипт перезагрузки роутера "router.sh" получился таким для D-Link DIR-620S:</p><pre><code class="bash">#!/usr/bin/expect -f

# Открываем telnet сессию на удалённом сервере, и ждем запроса имени пользователя.
spawn telnet 192.168.2.1

expect "dlinkrouter login:"
# Посылаем имя пользователя и ждем запроса пароля.
send "admin\r"

expect "Password:"
# Посылаем пароль и ждем приглашения ввода командного интерпретатора.
send "password\r"

expect "$"
# Посылаем команду, и ждем следующего приглашения ввода командного интерпретатора.
send "reboot\r"

expect eof</code></pre><p>Отправка команды выхода не нужна, т.к. при перезагрузке, соединение сбрасывается. И на последок настройка крона:</p><pre><code class="bash">SHELL=/bin/bash

#Перезагрузка каждый день в 6 утра
0 6 * * * /sbin/reboot

#Проверка интернета при старте системы
@reboot /home/pi/ping.sh

#Проверка интернета каждый час
0 * * * * /home/pi/ping.sh</code></pre><p>Еще несколько раз протестировав скрипты, убедились в работоспособности решения проблемы. И вы думаете на этом все? Пока да. Доступ к камерам ни разу не пропадал до сих пор.</p><p>Хамачи настраивается довольно таки легко, через dpkg. Пакетный файл можно скачать тут: <a href="https://www.vpn.net/linux" rel="noopener noreferrer nofollow">https://www.vpn.net/linux</a> называется logmein-hamachi_*.*.*.***-*_armhf.deb</p><p>Подключение к серверам хамачи:</p><p><code>sudo hamachi login</code></p><p>Добавление в группу (заранее настроенную в личном кабинете):</p><p><code>sudo hamachi do-join ***-***-***</code></p><p>Добавляем в автозагрузку:</p><p><code>sudo update-rc.d logmein-hamachi defaults</code></p><h2>Заключение</h2><p>Заказчик был мой друг. После того, как мы настроили первый раз систему, не ожидал что ее затронем не раз. Прошло два года, а по ощущениям как было вчера. Есть у него идея увеличить кол-во камер, для охвата большей территории. Как поступит просьба о помощи, я продолжу эту историю (не в рамках статьи).</p><p>Главное не забывать на даче отдыхать. Спасибо за внимание.</p><p><strong>UPD</strong>: Борьба с низкой температурой.</p><p>Роутер и малинка были помещены в коробку. С расчетом на то, что выделяемого тепла устройствами хватит в замкнутом пространстве. И навсякий случай поместили пару мешочков с влаговпитывающими шариками, взял с работы из коробки нового принтера.</p><p>Можно проверить темпаратуру процессора малинки, командой:</p><p><code>vcgencmd measure_temp</code></p><p>Температура процессора в холод достигала 17 'C<br/>Сейчас допустим на улице -6 'C, а температура малинки 25'C<br/>Все это с учетом, что малинка работает без нагрузки.</p></div></div></div> <DIV class="v-portal" style="display:none;"></DIV></div> <!----> <!----></div> <div class="tm-article-presenter__meta"><div class="tm-separated-list tm-article-presenter__meta-list"><span class="tm-separated-list__title">Теги:</span> <ul class="tm-separated-list__list"><li class="tm-separated-list__item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5B%D0%92%D0%B8%D0%B4%D0%B5%D0%BE%D0%BD%D0%B0%D0%B1%D0%BB%D1%8E%D0%B4%D0%B5%D0%BD%D0%B8%D0%B5%5D" class="tm-tags-list__link">Видеонаблюдение</a></li><li class="tm-separated-list__item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BRaspberry%20Pi%5D" class="tm-tags-list__link">Raspberry Pi</a></li><li class="tm-separated-list__item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BBash%5D" class="tm-tags-list__link">Bash</a></li><li class="tm-separated-list__item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BExpect%5D" class="tm-tags-list__link">Expect</a></li><li class="tm-separated-list__item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5BHamachi%5D" class="tm-tags-list__link">Hamachi</a></li><li class="tm-separated-list__item"><a href="/ru/search/?target_type=posts&amp;order=relevance&amp;q=%5B%D0%9E%D0%BF%D1%8B%D1%82%5D" class="tm-tags-list__link">Опыт</a></li></ul></div> <div class="tm-separated-list tm-article-presenter__meta-list"><span class="tm-separated-list__title">Хабы:</span> <ul class="tm-separated-list__list"><li class="tm-separated-list__item"><a href="/ru/hub/linux/" class="tm-hubs-list__link">
    Настройка Linux
  </a></li><li class="tm-separated-list__item"><a href="/ru/hub/it-infrastructure/" class="tm-hubs-list__link">
    IT-инфраструктура
  </a></li><li class="tm-separated-list__item"><a href="/ru/hub/s_admin/" class="tm-hubs-list__link">
    Серверное администрирование
  </a></li><li class="tm-separated-list__item"><a href="/ru/hub/video_tech/" class="tm-hubs-list__link">
    Видеотехника
  </a></li></ul></div></div></article></div> <!----></div> <div class="tm-article-sticky-panel"><div class="tm-data-icons tm-article-sticky-panel__icons"><div class="tm-article-rating tm-data-icons__item"><div class="tm-votes-meter tm-article-rating__votes-switcher"><svg height="24" width="24" class="tm-svg-img tm-votes-meter__icon tm-votes-meter__icon_appearance-article"><title>Всего голосов 7: ↑5 и ↓2</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#counter-rating"></use></svg> <span title="Всего голосов 7: ↑5 и ↓2" class="tm-votes-meter__value tm-votes-meter__value_positive tm-votes-meter__value_appearance-article tm-votes-meter__value_rating">+3</span></div> <DIV class="v-portal" style="display:none;"></DIV></div> <!----> <span title="Количество просмотров" class="tm-icon-counter tm-data-icons__item"><svg height="24" width="24" class="tm-svg-img tm-icon-counter__icon"><title>Просмотры</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#counter-views"></use></svg> <span class="tm-icon-counter__value">7.2K</span></span> <button title="Добавить в закладки" type="button" class="bookmarks-button tm-data-icons__item"><span title="Добавить в закладки" class="tm-svg-icon__wrapper bookmarks-button__icon"><svg height="24" width="24" class="tm-svg-img tm-svg-icon"><title>Добавить в закладки</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#counter-favorite"></use></svg></span> <span title="Количество пользователей, добавивших публикацию в закладки" class="bookmarks-button__counter">
    40
  </span></button> <!----> <div title="Поделиться" class="tm-sharing tm-data-icons__item"><button type="button" class="tm-sharing__button"><svg viewBox="0 0 24 24" xmlns="http://www.w3.org/2000/svg" class="tm-sharing__icon"><path fill="currentColor" d="M13.8 13.8V18l7.2-6.6L13.8 5v3.9C5 8.9 3 18.6 3 18.6c2.5-4.4 6-4.8 10.8-4.8z"></path></svg></button> <DIV class="v-portal" style="display:none;"></DIV></div> <DIV class="v-portal" style="display:none;"></DIV></div> </div></div> <DIV class="v-portal" style="display:none;"></DIV> <div class="tm-article-presenter__footer"><div class="tm-article-blocks"><!----> <section class="tm-block tm-block_spacing-bottom"><!----> <div class="tm-block__body tm-block__body_variant-balanced"><div class="tm-article-author"> <div class="tm-user-card tm-article-author__user-card tm-user-card_variant-article"><div class="tm-user-card__info-container"><div class="tm-user-card__header"><div class="tm-user-card__header-data"><a href="/ru/users/ArtShefer/" class="tm-user-card__userpic tm-user-card__userpic_size-40"><div class="tm-entity-image"><img alt="" src="//habrastorage.org/getpro/habr/avatars/421/20f/17a/42120f17a7b39cd4f6df91af512d61e2.jpg" class="tm-entity-image__pic"></div></a> <div class="tm-user-card__meta"><div title=" 7 голосов " class="tm-karma tm-user-card__karma"><div class="tm-karma__votes tm-karma__votes_positive">
    3
  </div> <div class="tm-karma__text">
    Карма
  </div></div> <div title="Рейтинг пользователя" class="tm-rating tm-user-card__rating"><div class="tm-rating__header"> <div class="tm-rating__counter">3</div></div> <div class="tm-rating__text">
    Рейтинг
  </div></div></div></div></div> <div class="tm-user-card__info tm-user-card__info_variant-article"><div class="tm-user-card__title tm-user-card__title_variant-article"><span class="tm-user-card__name tm-user-card__name_variant-article">Сергей</span> <a href="/ru/users/ArtShefer/" class="tm-user-card__nickname tm-user-card__nickname_variant-article">
          @ArtShefer
        </a> <!----></div> <p class="tm-user-card__short-info tm-user-card__short-info_variant-article">Аникейщик</p></div></div> <div class="tm-user-card__buttons tm-user-card__buttons_variant-article"><!----> <!----> <!----> <!----> <!----></div></div> <!----></div> <DIV class="v-portal" style="display:none;"></DIV></div> <!----></section> <!----> <div class="tm-article-blocks__comments"><div class="tm-article-page-comments"><div class="tm-article-comments-counter-link tm-article-comments-counter-button"><a href="/ru/post/645865/comments/" class="tm-article-comments-counter-link__link tm-article-comments-counter-link__link_button-style"><svg height="24" width="24" class="tm-svg-img tm-article-comments-counter-link__icon tm-article-comments-counter-link__icon_contrasted"><title>Комментарии</title> <use xlink:href="/img/megazord-v24.4a410f80.svg#counter-comments"></use></svg> <span class="tm-article-comments-counter-link__value tm-article-comments-counter-link__value_contrasted">
       Комментарии 47 
    </span></a> <!----></div></div></div> <div class="tm-ad-banner__container tm-page-article__banner"><!----> <div id="articleBottomBanner" class="tm-ad-banner"></div></div> <!----> <!----> <!----> <!----> </div></div></div></div></div> <div class="tm-page__sidebar"><div class="tm-layout-sidebar"><div class="tm-layout-sidebar__ads tm-layout-sidebar__ads_initial"><div class="tm-ad-banner__container tm-layout-sidebar__banner"><!----> <div id="sidebarBanner" class="tm-ad-banner"></div></div></div> <div class="tm-sexy-sidebar tm-sexy-sidebar_initial" style="margin-top:0px;"><!----> <section data-async-called="true" class="tm-block tm-block_spacing-bottom"><header class="tm-block__header"><h2 class="tm-block__title">Работа</h2> <!----></header> <div class="tm-block__body"><div class="tm-vacancies-block__item"><a href="https://career.habr.com/vacancies/sistemnij_administrator" target="_blank" class="tm-vacancies-block__vacancy-title">
        Системный администратор
      </a> <div class="tm-vacancies-block__vacancies-count">
        123
    вакансии
      </div></div></div> <footer class="tm-block__footer"><a href="https://career.habr.com/catalog" class="tm-block-extralink">
      Все вакансии
    </a></footer></section></div></div></div></div></div></div></main> <!----></div> <div class="tm-footer-menu"><div class="tm-page-width"><div class="tm-footer-menu__container"><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Ваш аккаунт
        </h3> <div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="/kek/v1/auth/habrahabr/?back=/ru/post/645865/&amp;hl=ru" rel="nofollow" target="_self">
                Войти
              </a></li><li class="tm-footer-menu__list-item"><a href="/kek/v1/auth/habrahabr-register/?back=/ru/post/645865/&amp;hl=ru" rel="nofollow" target="_self">
                Регистрация
              </a></li></ul></div></div><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Разделы
        </h3> <div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="/ru/" class="footer-menu__item-link router-link-active">
                Публикации
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/news/" class="footer-menu__item-link">
                Новости
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/hubs/" class="footer-menu__item-link">
                Хабы
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/companies/" class="footer-menu__item-link">
                Компании
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/users/" class="footer-menu__item-link">
                Авторы
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/sandbox/" class="footer-menu__item-link">
                Песочница
              </a></li></ul></div></div><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Информация
        </h3> <div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="/ru/docs/help/" class="footer-menu__item-link">
                Устройство сайта
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/docs/authors/codex/" class="footer-menu__item-link">
                Для авторов
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/docs/companies/corpblogs/" class="footer-menu__item-link">
                Для компаний
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/docs/docs/transparency/" class="footer-menu__item-link">
                Документы
              </a></li><li class="tm-footer-menu__list-item"><a href="https://account.habr.com/info/agreement" target="_blank">
                Соглашение
              </a></li><li class="tm-footer-menu__list-item"><a href="https://account.habr.com/info/confidential/" target="_blank">
                Конфиденциальность
              </a></li></ul></div></div><div class="tm-footer-menu__block"><h3 class="tm-footer-menu__block-title">
          Услуги
        </h3> <div class="tm-footer-menu__block-content"><ul class="tm-footer-menu__list"><li class="tm-footer-menu__list-item"><a href="https://docs.google.com/presentation/d/e/2PACX-1vQLwRfQmXibiUlWaRg-BAc38s7oM3lJiaPju7qmdJsp8ysIvZ_G-Npem0njJLMozE2bPHMpDqiI5hhy/pub?start=false&amp;loop=false&amp;delayms=60000&amp;slide=id.g91a03369cd_4_297" target="_blank">
                Реклама
              </a></li><li class="tm-footer-menu__list-item"><a href="https://habrastorage.org/storage/stuff/habr/service_price.pdf" target="_blank">
                Тарифы
              </a></li><li class="tm-footer-menu__list-item"><a href="https://docs.google.com/presentation/d/e/2PACX-1vQJJds8-Di7BQSP_guHxICN7woVYoN5NP_22ra-BIo4bqnTT9FR6fB-Ku2P0AoRpX0Ds-LRkDeAoD8F/pub?start=false&amp;loop=false&amp;delayms=60000" target="_blank">
                Контент
              </a></li><li class="tm-footer-menu__list-item"><a href="https://tmtm.timepad.ru/" target="_blank">
                Семинары
              </a></li><li class="tm-footer-menu__list-item"><a href="/ru/megaprojects/" class="footer-menu__item-link">
                Мегапроекты
              </a></li></ul></div></div></div></div></div> <div class="tm-footer"><div class="tm-page-width"><div class="tm-footer__container"><!----> <div class="tm-footer__social"><a href="https://www.facebook.com/habrahabr.ru" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Facebook</title> <use xlink:href="/img/social-icons-sprite.svg#social-logo-facebook"></use></svg></a><a href="https://twitter.com/habr_com" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Twitter</title> <use xlink:href="/img/social-icons-sprite.svg#social-logo-twitter"></use></svg></a><a href="https://vk.com/habr" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>VK</title> <use xlink:href="/img/social-icons-sprite.svg#social-logo-vkontakte"></use></svg></a><a href="https://telegram.me/habr_com" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Telegram</title> <use xlink:href="/img/social-icons-sprite.svg#social-logo-telegram"></use></svg></a><a href="https://www.youtube.com/channel/UCd_sTwKqVrweTt4oAKY5y4w" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Youtube</title> <use xlink:href="/img/social-icons-sprite.svg#social-logo-youtube"></use></svg></a><a href="https://zen.yandex.ru/habr" rel="nofollow noopener noreferrer" target="_blank" class="tm-svg-icon__wrapper tm-social-icons__icon"><svg height="16" width="16" class="tm-svg-img tm-svg-icon"><title>Яндекс Дзен</title> <use xlink:href="/img/social-icons-sprite.svg#social-logo-zen"></use></svg></a></div> <DIV class="v-portal" style="display:none;"></DIV> <button class="tm-footer__link"><!---->
        Настройка языка
      </button> <a href="/ru/about" class="tm-footer__link">
        О сайте
      </a> <a href="/ru/feedback/" class="tm-footer__link">
        Техническая поддержка
      </a> <!----> <a href="/berserk-mode-nope" class="tm-footer__link">
        Вернуться на старую версию
      </a> <div class="tm-footer-copyright"><span class="tm-copyright"><span class="tm-copyright__years">© 2006–2022 </span> <span class="tm-copyright__name">«<a href="https://company.habr.com/" rel="noopener" target="_blank" class="tm-copyright__link">Habr</a>»</span></span></div></div></div></div> <!----> <!----></div> <div class="vue-portal-target"></div></div>
<script>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</script>
<script src="https://assets.habr.com/habr-web/js/chunk-vendors.1a591826.js" defer></script><script src="https://assets.habr.com/habr-web/js/app.472b461a.js" defer></script>



    <script>
      (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
      })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
    </script>
  
  <script type="text/javascript" >
    (function(m,e,t,r,i,k,a){m[i]=m[i]||function(){(m[i].a=m[i].a||[]).push(arguments)};
    m[i].l=1*new Date();k=e.createElement(t),a=e.getElementsByTagName(t)[0],k.async=1,k.src=r,a.parentNode.insertBefore(k,a)})
    (window, document, "script", "https://mc.yandex.ru/metrika/tag.js", "ym");

    ym(24049213, "init", {
      defer:true,
      trackLinks:true,
      accurateTrackBounce:true,
      webvisor:false,
    });
  </script>
  <noscript>
    <div>
      <img src="https://mc.yandex.ru/watch/24049213" style="position:absolute; left:-9999px;" alt="" />
    </div>
  </noscript>
  
    <script type="text/javascript">
      window.addEventListener('load', function () {
        setTimeout(() => {
          const img = new Image();
          img.src = 'https://vk.com/rtrg?p=VK-RTRG-421343-57vKE';
        }, 0);
      });
    </script>
  
<script src="/js/ads.js" onload="window['zhY4i4nJ9K'] = true"></script>
</body>
</html>
