Pull to refresh
44
Karma
0
Rating

Сисадмин Linux (RHCE), Windows (MCSE), Mikrotik

Mikrotik RoS v7.1 OSPF — проблема с /32 адресами PtP клиентов

Reading time 2 min
Views 15K
System administration *Network technologies *Network hardware
Tutorial

Собственно один из сценариев с OSPF - распространение маршрутной информации от одного филиала в другой, и в 6-ке проблем не было. Настроил зону, включил туда диапазон выдаваемый любым PtP сервером и адреса клиентов полетели по всем филиалам. Да, очень неудобно, когда таких маршрутов много, их обычно можно агрегировать и проблемы нет. Но в 7-ке проблема в другом, то ли из-за бага, то ли я что-то делаю не так, но маршруты для PtP клиентов не распространяются.

Читать далее
Total votes 3: ↑3 and ↓0 +3
Comments 33

Mikrotik split-dns: они это сделали

Reading time 2 min
Views 58K
Network technologies *
Не прошло и 10 лет, как разработчики RoS (в stable 6.47) добавили функционал, который позволяет перенаправить DNS запросы в соответствии со специальными правилами. Если раньше надо было изворачиваться с Layer-7 правилами в firewall, то теперь это делается просто и изящно:

/ip dns static
add forward-to=192.168.88.3 regexp=".*\\.test1\\.localdomain" type=FWD
add forward-to=192.168.88.56 regexp=".*\\.test2\\.localdomain" type=FWD

Моему счастью нет предела!
Читать дальше →
Total votes 23: ↑20 and ↓3 +17
Comments 59

dracut + systemd + LUKS + usbflash = авторазблокировка

Reading time 7 min
Views 3.3K
Configuring Linux *System administration **nix *
История началась давно, еще при выходе Centos 7 (RHEL 7). Если вы использовали шифрование на дисках с Centos 6, то не было никаких проблем с автоматической разблокировкой дисков при подключении USB флешки с нужными ключами. Однако, при выходе 7-ки внезапно все не работало как вы привыкли. Тогда можно было найти решение в возврате dracut к sysvinit с помощью незамысловатой строчки в конфиге: echo 'omit_dracutmodules+=" systemd "' > /etc/dracut.conf.d/luks-workaround.conf

Что сразу лишало нас всей прелести systemd — быстрый и параллельный запуск системных служб, что значительно сокращало время запуска системы.

Воз и ныне там: 905683

Не дождавшись решения, я сделал его для себя сам, а теперь делюсь и с общественностью, кому интересно, читайте дальше.


Читать дальше →
Total votes 2: ↑2 and ↓0 +2
Comments 2

Mikrotik firewall filter: скрипт генерирующий основу для политики фильтрации

Reading time 14 min
Views 11K
Network technologies *
Кто хоть раз писал политику фильрации firewall знает, что это дело не простое и сопряжено с кучей ошибок, когда колличество сетевых зон больше 2-х. В этой сутации вам поможет скрипт из этой статьи.
Читать дальше →
Total votes 7: ↑7 and ↓0 +7
Comments 15

Ищем проблему не в том месте

Reading time 2 min
Views 6.2K
System administration *
Это небольшая история из реальной практики, когда небольшая проблема, хорошо замаскированная отказоустойчивостью, превращается в головную боль.
Читать дальше →
Total votes 16: ↑13 and ↓3 +10
Comments 10

Mikrotik RoS, полезные мелочи

Reading time 5 min
Views 152K
Network technologies *
Tutorial
Распространенность оборудования Mikrotik растет с каждым днем, все больше устройств, а значит и RoS, появляется не только в корпоративном секторе, но и у обычных, домашних пользователей.
К сожалению, не смотря на вполне нормальные настройки по умолчанию, которые можно сделать через Quick Set, в интернете можно встретить множество советов очистить конфигурацию, и сделать как-то по «особому», с «нуля». В этой статье я хочу поделится своим опытом и дать рекомендации, как изменить конфигурацию из Quick Set под свои нужды, при этом сохранив достаточный уровень защищенности.
Читать дальше →
Total votes 25: ↑25 and ↓0 +25
Comments 28

Mikrotik vs Старый ПК, проблема выбора в малом предприятии

Reading time 4 min
Views 29K
Network technologies *
В малых предприятиях остро стоит вопрос экономии при закупке оборудования, зачастую этот вопрос решается отказом от закупки, если можно заставить работать имеющиеся. В этой статье я хочу поделится своим опытом в этом вопросе и осветить основные причины, почему многие делают именно так.


Читать дальше →
Total votes 22: ↑19 and ↓3 +16
Comments 132

Mikrotik: Load Balance & QoS (Балансировка в КПСС и соблюдение скоростного режима)

Reading time 38 min
Views 18K
Network technologies *
Tutorial
В этой статье я хочу поделится своим решением балансировки с применением Классификатора по Сетевым Соединениям (Per Connection Classificator) и маркировкой трафика для QoS.

Предисловие


На просторах Хабра и интернета я встречал множество реализаций балансировки, включая и PPC, однако, в ряде этих реализаций, не во всех конечно, были моменты, совершенно дурацкого вида:
Читать дальше →
Total votes 17: ↑15 and ↓2 +13
Comments 2

ZFS: Тестируем надежность на плохих дисках

Reading time 10 min
Views 11K
System administration *Data storage *
ZFS славится своей надежностью, а тут у меня под рукой собралось несколько побитых жизнью дисков. Попробуем на raidz1 закинуть некоторый объем данных, а затем проверить их целостность, а zfs на устойчивость к такой ситуации.
Читать дальше →
Total votes 24: ↑22 and ↓2 +20
Comments 17

Mikrotik RoS 6.41: Большие изменения в Bridging и VLAN

Reading time 2 min
Views 66K
System administration *Network technologies *
Tutorial
Разработчики RoS уже достаточно давно анонсировали изменения в работе мостов (bridge), и включили эту новую функциональность в Release Candidate ветку, вот теперь они внесли это и в Current.
Читать дальше →
Total votes 18: ↑15 and ↓3 +12
Comments 8

Mikrotik L2TP/IPSec за NAT: ipsec,error failed to pre-process ph2 packet

Reading time 1 min
Views 79K
Network technologies *
Tutorial
При использовании Mikrotik за NAT (в частности за всякими USB GSM модемами) в режиме клиента L2TP/IPSec, у некоторых операторов в определенных режимах, получал проблему с ошибкой ipsec,error failed to pre-process ph2 packet.
Но с появлением RoS 6.38 появилась возможность справиться с ошибкой.
Читать дальше →
Total votes 17: ↑12 and ↓5 +7
Comments 54

Настройка DUNDi в Asterisk, под управлением FreePBX

Reading time 3 min
Views 9.4K
System administration *
Tutorial
Опытным администраторам VoIP эта статья будет мало интересна, адресована она админам малых IP-телефонных серверов для маленьких офисов.
Читать дальше →
Total votes 12: ↑11 and ↓1 +10
Comments 5

Бэкап сетевой шары (samba) в Linux по мотивам Windows Server Backup

Reading time 11 min
Views 19K
System administration **nix *Server Administration *Data storage *
Tutorial
Делаем удобный доступ к архивам (и создаем эти архивы) сетевых шар, для клиентов работающих под Windows.
Читать дальше →
Total votes 19: ↑18 and ↓1 +17
Comments 10

Mikrotik: маленькая хитрость switch chip

Reading time 2 min
Views 74K
Network technologies *
Tutorial
Моя прошлая статья про switch chip на Mikrotik вызвала неоднозначную реакцию, а комментарий одного из читателей натолкнул на идею. И так: как на RB952Ui-5ac2nD сделать более одной группы коммутации?
Читать дальше →
Total votes 14: ↑13 and ↓1 +12
Comments 7

Mikrotik: VLAN с использованием чипа коммутации

Reading time 5 min
Views 83K
Network technologies *
Tutorial
Оборудование Mikrotik богато возможностями, но к сожалению, разработчики не всегда успевают держать Wiki с документацией в актуальном состоянии, иногда информация относится к уже устаревшей версии RouterOS или в ней не раскрыты маленькие тонкости. Сегодня я хочу немного дополнить официальную Wiki, рассказав о настройке встроенного чипа коммутации, для работы с VLAN. В качестве подопытных у нас: RB951Ui-2HnD и CRS125-24G-1S-2HnD. Все проделано на RouterOS 6.37.1
Читать дальше →
Total votes 12: ↑10 and ↓2 +8
Comments 17

WD My Cloud Mirror — недоступность из под сетей диапазона 172.16.0.0/12

Reading time 1 min
Views 7.5K
Data storages *
Tutorial
Если в вашей сети используется адресное пространство 172.16.0.0/12, то можно столкнутся с ситуацией, кода NAS будет недоступен, хотя вроде всё Ок.
Читать дальше →
Total votes 25: ↑16 and ↓9 +7
Comments 13

OSPF (Quagga), Shorewall и Policy Routing: проблема inactive route

Reading time 2 min
Views 4.1K
Configuring Linux *System administration **nix *Network technologies *
Если кто-то использует quagga (OSPF) и планирует сделать балансировку каналов, через которые работает OSPF, используя Shorewall, прошу под кат.
Читать дальше →
Total votes 8: ↑8 and ↓0 +8
Comments 2
1

Information

Rating
Does not participate
Location
Москва, Москва и Московская обл., Россия
Date of birth
Registered
Activity