Pull to refresh

В jQuery 2.0 не будет поддержки IE 6/7/8

jQuery *
Разработчики jQuery опубликовали план выпуска новых версий библиотеки.

  • jQuery 1.8: выйдет в течение месяца.
  • jQuery 1.9 (начало 2013): удаляются многие интерфейсы, устаревшие в версии 1.8; некоторые из них останутся в виде плагинов или альтернативных APIs. Поддержка IE 6/7/8 пока сохраняется.
  • jQuery 1.9.x (в течение 2013 года и далее): версия с добавлением патчей, устранением багов, поддержкой новых браузеров и т.д.
  • jQuery 2.0 (начало 2013, вскоре после 1.9): поддержка тех же APIs, что и в jQuery 1.9, но удаление «странностей» IE 6/7/8, таких как модель event’ов, “attroperties” в IE7, HTML5shim и проч.

Цель состоит в том, что 1.9 и 2.0 должны быть взаимозаменяемыми в рамках поддерживаемых наборов API. Когда выйдет jQuery 2.0, разработчики получат выбор, какую из версий использовать: нужна ли им поддержка IE 6/7/8. Версия jQuery 2.0 будет меньшего размера и с лучшей производительностью.

Как вариант, можно перейти сразу на jQuery 2.0, но включить загрузку jQuery 1.9 для посетителей со старым IE.

<!--[if lt IE 9]>
    <script src="jquery-1.9.0.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
    <script src="jquery-2.0.0.js"><</script>
<!--<![endif]-->

Плагина oldIE для jQuery 2.0 не будет, это слишком усложняет код библиотеки.
Tags:
Hubs:
Total votes 125: ↑122 and ↓3 +119
Views 15K
Comments Comments 135