Pull to refresh

Новая уязвимость Wordpress — возможна DOS атака

WordPress *
Свежая уязвимость в Wordpress которая позволяет провести DOS атаку на блог жертвы используя файл wp-trackback.php

Для исправления этой уязвимости необходимо добавить следующий код в файл functions.php, который находится в папке шаблона блога:



function ft_stop_trackback_dos_attacks(){
global $pagenow;
if ( 'wp-trackback.php' == $pagenow ){
// DoS attack fix.
if ( isset($_POST['charset']) ){
$charset = $_POST['charset'];
if ( strlen($charset) > 50 ) { die; }
}
}
}
add_action('init','ft_stop_trackback_dos_attacks');


Если у вас нет возможности или знаний, для того, чтобы прописать данный код в вашем блоге, скачайте и установите плагин который исправляет эту уязвимость.

Эксплоит уязвимости: jarraltech.com/2009/10/new-0-day-wordpress-exploit
Источник: blogproblog.com/wp-trackback_dos_attack
Tags: WordpressБезопасностьПлагины
Hubs: WordPress
Total votes 44: ↑37 and ↓7 +30
Comments 52
Comments Comments 52

Popular right now