Обратная совместимость в iOS SDK


    Apple никогда официально не заявляла о несовместимостях между разными версиями своих OS. И всё же каждый крупный релиз они что-то меняют в ядре операционки — фиксят баги и привносят новые. И иногда именно фикс багов, с которыми все привыкли жить, добавляет новых трудностей – в iOS 3 ты не задумываясь добавлял 20 пикселей там, где iOS 4 добавляет их сама, и в итоге твоя модальная вьюшка уезжает на 20 лишних пикселей вверх.

    Но это не самая страшная разновидность несовместимостей – их можно продебажить, пофиксить и выпустить новый билд. Также легко устраняется, например, ставшее уже традиционным изменение стандартного контрола для проигрывания видео – в каждой новой iOS Apple что-то добавляет, модифицирует, причём полностью забивая на старый интерфейс без всяких там deprecated за пару версий до выпиливания – так, например, в iOS 3 он был обычной вьюшкой от UIView, а в iOS 4 стал резко вью-контроллером, а старая MPMoviePlayerView исчезла.

    Но это тоже подвластно дебагеру, на форумах можно за 10 секунд найти готовый гибридный код фикса такой, что код будет работать везде.

    Но относительно новая iOS 5 принесла ещё больше неожиданностей. Об этом свидетельствует хотя бы тот факт, что в последних релизах популярных айфон-приложений обязательно присутствует строчка “Fixed iOS 5 issues” – средний пользователь айпада находит примерно по 10 апдейтов приложений каждый день. Ниже я расскажу о неочевидной проблеме обратной совместимости iOS 4 и iOS 5, с которой мне пришлось столкнуться на своей шкуре и сполна хлебнуть горя.

    Проблема

    Как-то под конец октября моим заказчикам начали приходить сообщения от пользователей приложения о том, что внезапно перестала работать одна из второстепенных, но довольно важных вьюшек. Приложение не крашилось, навигация оставалась доступна, но вместо данных они созерцали белый экран Малевича.
    Ни у заказчиков, ни у моей команды, ни у более чем двухсот других пользователей этот баг не воспроизводился. Более того, приложение уже как 2 месяца находилось в AppStore и никто до этого не жаловался. Вьюшка была построена по абсолютно такому же принципу, как и десятки соседних – данные брались из базы, обрабатывались опеределённым образом и клались на довольно кастомный UI.
    Было решено до поры до времени ничего не предпринимать – подождать, пока баг воспроизведётся хоть на одном из обширного парка наших девайсов, и спокойно зафиксить.

    Кошмар

    Однако проблема не локализовалась – с каждым днём всё больше и больше пользователей стали жаловаться на отсутствие вьюшки. Надо признать, что она была далеко не ключевой и, судя по статистике Google Analytics, использовалась каждым десятым юзером раз в неделю. Но вспомним о психологии американцев – они сами того не осознавая, любым путём, пытаются выбить скидку на любую услугу – похоже, это у них в крови как у славян на… обмануть.
    Мысль о том, что платная программа не выполняет 100% своих функций, хоть и выполняет 99,9%, будоражит мозг буржуя, лишает его сна и вкуса к жизни.
    В письмах он подолгу описывает чувство невообразимого frustrating, когда видит белый экран вместо данных, за которые его компания заплатила $0,099, черпая вдохновение у Хэмингуэя. Please fix this ASAP!!!, we don’t know what we are paying for!!!, I don’t want to pay for something that does not work properly!!! – и это ещё только начало списка электронных писем, любезно форвардящихся заказчиками на мою электронную почту. В довершение ко всему баг стал воспроизводиться на трети (именно трети, не на всех!) девайсах моих заказчиков. К гневным письмам конечных покупателей стали добавляться 5-7 писем в день от самих заказчиков, написанные верхним регистром и молящих о помоще ASAP.
    Не стоит и говорить, что они стали ставить в копию руководство, которое в свою очередь также стало требовать фикса.

    Мы сделали всё, что могли, даже сделали больше. Тестили под дебагом все билды за последние месяцы, включая продакшн и продакшн Release Candidate. Ставили разное время и разные локали. У нас всё работало, не было ни одной конфигурации (iOS 4.2.1, iOS 4.3, iOS 5.0), на которой мы вообще могли бы воспроизвести баг!

    Наш QA беспомощно пожимал плечами, мы через день (потому что всё-таки нужно спать и иногда вовремя уходить с работы) дебажили по TeamViewer девайсы заказчика – под дебагером всё работало идеально. Но как только я собирал им очередной Ad-Hoc, всё продолжалось по новой. Моя почта потеряла упорядоченность. Мой скайп потерял покой и комфорт. Я потерял покой на несколько недель, осознавая собственное бессилие. Это был первый в моей карьере баг (я работаю в разных областях IT около 5 лет), к которому я не мог найти способа даже подойти – я перепробовал всё, что мог придумать и что могли придумать ребята.

    Решение

    Итак, опять повторю – под дебагером всё работало. Это стало первой зацепкой. Надо отметить, что на моём маке стоял xCode 3.2.6 c SDK 4.3, тогда как на маках моей команды – 4.2 c SDK 5. Просто мне пока лень было переходить на новый для меня, и такой непохожий на предыдущую версию, xCode 4.
    Я, как тимлид, всегда собирал AppStore и Ad-Hoc билды на своём маке. Когда же нужно было подебажить – мы дебажили айпады с iOS 4.X на моём маке (дебажить на маке с iOS SDK 5 можно, но нужно обязательно докачивать большой образ iOS 4.3), а айпады с iOS 5 – на их маках (дебажить такие на маке с предыдущей iOS SDK 4 невозможно). Надо сказать, что сам Objective-C в некоторых местах несовместим в SDK 4 и SDK 5 (тот же @autorelease{}), а ребята любят новомодные фишки, так что при переброске версий из нового xCode в старый приходилось перелинковывать некоторые либы и чуть-чуть править код. Это последнее обстоятельство и навело меня на финальную мысль.

    Проверили быстро – я поставил себе наконец SDK 5 и xCode 4 и выслал ipa файл (аналог старых Ad-Hoc билдов) заказчикам – как и ожидалось, всё заработало.
    Вероятно, вы уже догадались в чём проблема. Не важно, какой код компилировался – важно, где он компилировался. Тот же самый код, исправно работавший на AppStore многие месяцы, был скомпилен для iOS 4 в iOS 4 SDK ещё до выхода iOS 5. Потом стал неверно работать, когда пользователи обновились до iOS 5.

    Решается эта проблема простым пересобиранием того же самого кода на iOS SDK 5. Что именно изменила Эппл, так и осталось загадкой, т.к. дебажить девайс с SDK 5 из xCode c SDK 4 нельзя, а время на обвешиванеи кода ассертами нам никто оплачивать не будет. Остаётся только выпустить новый билд и ждать апрува от Apple. Что я и советую всем хабраюзерам – апдейтите свои приложения, просто пересобрав под iOS SDK и, следуя best practices от Apple, добавьте пару графических вкусняшек, чтобы средний пользователь в безвоздушном пространстве понял, для чего он качает новый билд.

    После написанного

    Всё же я считаю, что Apple делает правильно, забивая каждый новый релиз на все старые версии – это помогает операционке всегда пахнуть хорошо, удерживает ядро от обрастания хард-кодом и хард-фиксами. Ведь именно из-за необходимости поддержки обратной совместимости умерли Symbian и ветка Windows mobile. Да и большая Windows до недавнего времени была построена на старом как смерть ядре.

    К тому же Apple предоставляет превосходный механизм обновления операционок, знакомый всем пользователям продукции компании. Они не просто просят пользователей обновиться – пользователи сами хотят обновиться до новых версий, т.к. за это им обещают очередные улучшения UI почтового менеджера, больше рингтонов для будильника или другие простые и понятные ништяки. Фермерше из штата Канзас невдомёк, что, обновляя свой айфончик с выходом каждой новой ОС, она дарит часы спокойного сна программистам по ту сторону океана :)
    Share post
    AdBlock has stolen the banner, but banners are not teeth — they will be back

    More
    Ads

    Comments 63

      +5
      Странно что вам раньше это в голову не пришло.
      Я правда не особо пишу под iOS, но вообще проверять идентичность бинарников при трудноуловимых, но не-плавающих багах это фактически правило для меня :)
        0
        Спасибо за совет, теперь и я так же делать буду! Меня ввело в заблуждение то, что не показывалась одна вьюшка, а не всё приложение.
        +10
        Я думаю что это ваш долг, разобраться. Даже если за натыкивание ассертами не платят. Я всегда уковыриваю баги до прояснения ситуации. Иначе спать не могу.
          +10
          Вы меня мотивировали! Завтра останусь после работы и расставлю ассерты по всем проблемным местам, как только найду — допишу UPD в статью! За этим офшором и аутсорсингом иногда забываешь о программистской этике…
            0
            где можно почитать? :)
              0
              сарказм?
                0
                Да нет, как всегда появились «более важные дела»…
              +1
              У меня тоже возникла проблема при запуске моего приложения, написанного на SDK 4.2 под iOS 5.0.1, оно тупо падало, причем ровно один раз (почему-то происходил Segmentation Fault и приходил сигнал SIG_TERM приложению и никакого внятного, хоть сколь нибудь объясняющего ситуацию, стектрейса). Пришлось качать Xcode 4.2 с SDK 5, проект тоже не собрался с первого раза :) (пришлось ВООБЩЕ все cpp переименовывать в mm, чтобы в хедерах использовать NS классы). В итоге все равно падало один раз (удавалось воспроизводить только при перепрошивке девайса), в итоге я дошаманился, что не смог больше уронить, залил как есть. Ждемс чего скажет эппл. К чему я это, если раздобудешь мак (или хакинтош, или еще чего), с радостью предоставлю тебе код для ковыряния.
              P.S. с меня пиво, в случае успеха ;)
                0
                После нового года может и гляну, пока нет особо времени.
              +2
              Мистический баг. Я думаю вполне нормально, что для того чтобы все хорошо работало в iOS 5 надо компилировать под 5 SDK.

              У нас, так же, бывали мистические проблемы после компиляции для 5 SDK. Так некоторые анимации работали не правильно, причем только под iPhone 3G с iOS 4. Как оказалось позже баг проявлялся только при включенной оптимизации, что нас удивило, так как на остальных моделях и прошивках было все хорошо.
                0
                То же самое, но на другом проекте — анимации на iPhone 3G с iOS 4.2.1, когда билд компилился из-под SDK 5.0. Похоже, мой старичок 3G доживает свой век :( RIP, iPhone 3G!
                  0
                  У меня тоже 3G и похоже действительно доживает. Для четверки так и не вышло апдейта с новыми таймзонами имени Медведева? Пришлось отключить автосинхронизацию часов. В некоторых приложениях скачет время (свежие твиты показываются «час назад») и прочее…

                  А жаль, вполне устраивал.
                  +4
                  это только при использовании llvm для arm6, довольно известный баг.
                    0
                    Возможно известный, просто появился он только с переходом на iOS 5 SDK. До этого команда тестеров и собственно юзеры не жаловались.
                      +1
                      При использовании Release для armv6 (llvm и GCC).
                      Недавно сам с таким столкнулся
                        0
                        Да, llvm подгоняте ништяков. Недавно получил эррор:
                        Unknown type name 'BOOL'; did you mean 'BOOL'?

                        Вылечилось откатом на старый gcc, при чем это документированный баг, в новой версии обещали пофиксить.
                    –7
                    «Мысль о том, что платная программа не выполняет 100% своих функций, хоть и выполняет 99,9%, будоражит мозг буржуя, лишает его сна и вкуса к жизни.»
                    )))
                    В письмах он подолгу описывает чувство невообразимого frustrating, когда видит белый экран вместо данных, за которые его компания заплатила $0,099, черпая вдохновение у Хэмингуэя. Please fix this ASAP!!!, we don’t know what we are paying for!!!, I don’t want to pay for something that does not work properly!!!........."
                    )))
                    «Мы сделали всё, что могли, даже сделали больше. Тестили под дебагом все билды за последние месяцы, включая продакшн и продакшн Release Candidate. Ставили разное время и разные локали.»
                    ))))))))))))
                    «Наш QA беспомощно пожимал плечами, мы через день (потому что всё-таки нужно спать и иногда вовремя уходить с работы) дебажили по TeamViewer девайсы заказчика – под дебагером всё работало идеально. Но как только я собирал им очередной Ad-Hoc, всё продолжалось по новой.»
                    )))
                    "… Что именно изменила Эппл, так и осталось загадкой, т.к. дебажить девайс с SDK 5 из xCode c SDK 4 нельзя....."
                    )))
                    «Всё же я считаю, что Apple делает правильно, забивая каждый новый релиз на все старые версии»
                    ))) и в добавок в корне не верно

                    Мой вывод следующий: не будьте инертны и безразличны, читайте доки доступные на developer.apple.com/devcenter/ios/index.action (особенно новые, после выхода каждой очередной iOS) и вы сведете получение подобных проблем к минимуму.
                      0
                      Я бы не сказал, что я вёл себя инертно. На самом деле не очень приятно получать много плохих писем от end-кастомеров, заказчиков и руководства, так что если бы я мог прекратить это и пофиксить проблему — я бы сделал это тут же.

                      Также не вижу, как документация (тем более ссылка на её корневой каталог) могла помочь мне в решении данной проблемы. Но спасибо за небезразличие!
                        +3
                        На самом деле я не комментировал каждый сомнительный опус, т.к. не хотел вдаваться в бессмысленные дискуссии))) Я хотел лишь подчеркнуть, что со многим не согласен, либо некоторые высказывания спорны и не отражают реальность.

                        По части писем вы себе навязываете, я подчеркивал то, что вы сидите на хрен знает какой старой среде разработки — иммея ввиду высказывание о инертности (мне тоже новая xCode не по нраву была, но опыт поддал волшебный пинок по этой части, что помогло предупредить многие проблемы). Хотел также подчеркнуть чтение документации в частности изменений, которые не просто так пишутся с выходом новой SDK, что помогло бы иметь хотя бы минимальный багаж знаний о том что apple неплохо поработало над компилятором в iOS5 (о котором кстати упоминалось, хотя может вру еще при выходе 4-ки) да не только в принципе по этой части, если уж говорить об мажорных изменениях. Во всяком случае это точно подвигло бы на размышления при поиске логических предпосылок для возникновения бага. А не пальцем в небо меняя локали (зная ее реализацию, довольно странно предполагать, что там что-то не так) + про смену времени ситуация аналогичная. А ссылку я привел не как руководство к решению вашей проблемы, а просто в качестве указателя на официальную документацию, которая без проблем доступна и всегда актуальна.

                        На самом деле платформа имеет достаточно малый порог вхождения и не устанавливает четкие рамки. Скажем так мы сильно обнаглели и о многом не заботимся, что позволяет нам вот в таких случая зацикливаться на одном и буквально пытаться попасть пальцем в небо. Это и со мной случается, чего скрывать, но объективного и правильного способа и тем более подмены правильности решений и отгребания в случае их несоблюдений это не отменяет.
                      0
                      Ну именно по-этому Apple выпускает бета версии прошивок. Другое дело когда ты испольдуешь SDK 5.0, ставишь таргет 3.1.3, а XCode тебе не слова не говорит, что половина API которые ты используешь не существует в 3.1.3. Впрочем все это делается, чтобы мотивировать кодеров делать приложения с использованием новых API тем самым мотивируя пользователей покупать новые айфоны.
                        +1
                        Устаревшие методы всегда видны в «варнингах». А чтобы понять время жизни метода достаточно заглянуть в заголовок из «фрейморка», где он описывается. Нету тут никакого волшебства!
                          0
                          Устаревшие, но не новый. Я использовал метод который появился только в 4.x, в эмулятор все работало, а как только залил на девайс с iOS 3.1.3 приложение падало при вызове этого метода.
                            +1
                            Deployment target — не более чем формальное ограничение, не позволяющее приложению AppStore устанавливать билд на девайс, не подпадающий под ограничение. Оно ничего не говорит компилятору.

                            В отличие от Base SDK, которая решает всё — т.е. откуда конкретно будут линковаться при сборке SDK-шные функции.
                              +1
                              Во-первых не «эмулятор», а «симулятор». И не поверю, что на симуляторе 3.1 работало. Но завтра на работе проверю. Вы ведь правильно понимаете, под какой системой необходимо дебажить в случае если вы выставляете Deploymet Target SDK ниже версии Base SDK? И правильно понимаете, что такое обратная совместимость? как бы наличие нового метода, и отсутсвие в старом sdk по моему логически понятно, и не включает в себя понятие «обратной совместимости». А вот когда Apple выкашивает старый метод не сразу, а спустя n-ное количество новых SDK и через одну мажорную версию это уже другое. Не так ли?
                                +1
                                Да, да, симулятор. А с каких пор XCode имеет в наличии смулятор 3.1 при отсуствии SDK 3.1?

                                > И правильно понимаете, что такое обратная совместимость? как бы наличие нового метода, и отсутсвие в старом sdk по моему логически понятно, и не включает в себя понятие «обратной совместимости».

                                Да. Я говорю, что мне не понравилось, что XCode весь такой умный, а проверить, что метод появился после Target SDK не смог. Назвали бы это другими словами (вы же любите подбирать слова) у меня не было бы вопросов.

                                > А вот когда Apple выкашивает старый метод не сразу, а спустя n-ное количество новых SDK и через одну мажорную версию это уже другое. Не так ли?

                                Это тут причем? У меня нет никаких проблем с обратной совместимостью, мне поведение XCode не понравилось.
                                  +1
                                  > Да, да, симулятор. А с каких пор XCode имеет в наличии смулятор 3.1 при отсуствии SDK 3.1?

                                  может и не имеет, на самом деле не помню. Уже пол года как отказались от поддержки 3 и не помню о наличии конкретных версии после первой мажорной. Не пытайтесь уходить в сторону, вопрос лишь в том под какой версией вы дебажите при установке нижнего порога и того, что вы якобы чего можете не заметить. + глобальные брекпоинты для приложения рулят, что отчасти заменяет отсутствие необходимого вам функционала.

                                  > Да. Я говорю, что мне не понравилось, что XCode весь такой умный, а проверить, что метод появился после Target SDK не смог.

                                  По части умного xCode))). Так не такой уж он и умный, во всяком случае не умнее продуктов от jetbrains, VS или того же эклипса. Довольно долго очень близко не работал с другими IDE но на моей памяти всегда совместимость со старыми версиями перекладывалась по большей части на разработчика и QA, нежели на среду.

                                  >Это тут причем? У меня нет никаких проблем с обратной совместимостью, мне поведение XCode не понравилось.

                                  Не от вас вычитал кусок текста, либо просто не понял, уже не помню откуда взял. Извините, тяжелый день;)
                                    0
                                    > может и не имеет, на самом деле не помню. Уже пол года как отказались от поддержки 3 и не помню о наличии конкретных версии после первой мажорной. Не пытайтесь уходить в сторону, вопрос лишь в том под какой версией вы дебажите при установке нижнего порога и того, что вы якобы чего можете не заметить. + глобальные брекпоинты для приложения рулят, что отчасти заменяет отсутствие необходимого вам функционала.

                                    Нет, не имеет. Там даже старые версии SDK выпиливаются. Не ухожу я в сторону, я просто не говорил, что дебажил в эмуляторе под 3.1.3 :) Я понимаю, что косяк мой и только мой. Просто как-то странно выглядит деприкейшен ворнинги от отсуствие проверки по Target SDK. (нет, я не потратил неделю на поиск проблемы, я просто открыл тут же документацию к методы и увидел, что появился он только в 4.какая-то там)

                                    > По части умного xCode))). Так не такой уж он и умный, во всяком случае не умнее продуктов от jetbrains, VS или того же эклипса. Довольно долго очень близко не работал с другими IDE но на моей памяти всегда совместимость со старыми версиями перекладывалась по большей части на разработчика и QA, нежели на среду.

                                    Статический анализ у него божественный (да, я знаю это не заслуга Xcode, но apple стоит за работкой же). Однако, Xcode быстрее чем любая JVM IDE, мне нравится больше чем VS. Не смотрел IDE для iOS от JetBrains, но если она так же хороша как и WebStorm (которая кстати через чур завязана на классический javascript и совсем не помогла мне при работке под SproutCore.
                          +2
                          А я понять не могу, как то, что на разработчиков приложений перекладывают написание хард фиксов и хитроумных «комбинаций» вместо того, чтобы сделать это через удобный механизм deprecated в самой ОСи — это при том, что на рынке всегда болтаются минимум устройства 2 разных поколений (особенно учитывая, что старые модели не сразу получают обновление версии, а те же iPOD'ы — вообще никогда), в общем, как такая ситуация может выглядеть «правильной».
                            +3
                            > (особенно учитывая, что старые модели не сразу получают обновление версии, а те же iPOD'ы — вообще никогда), в общем, как такая ситуация может выглядеть «правильной».
                            Say what?

                            Они или получают обновление сразу в один день в один миг, или не получают совсем (о чем заранее известно) Вы кажется перепутали ситуацию с андроидом. Единственная ситуация когда владелец не обновляет устройство это окгда ему нужен jailbreak или unlock.
                            +2
                            просто нужно тестировать и на последних прошивках! Тим лид еще, блин… зря потратил время читая этот пост, думал что узнаю что-то нового…

                            у меня случаев с несовместимостью много было. К примеру, если кто не знает, то в 5-й MPMoviePlayer может тупо остановиться во время воспроизведения короткого ролика. И его воспроизведение длится дольше чем duration.
                              –1
                              Напишите 100 раз маркером на доске — я буду внимательно читать ваш пост, iago, перед тем как постить в комментах ерунду. Мы, естественно, тестировали на последних прошивках, только приложение устанавливали из нового xCode и SDK, т.к. из старого на новый девайс не поставишь. В общем перечитайте ещё раз
                                +2
                                какой же вы тимлид, если пользуетесь уже устаревшим сдк и версией ос…
                                  +2
                                  очень бородатый тимлид
                                    +1
                                    Идея собирать с поддержкой 4.3 на SDK 4.3 казалась мне тогда логичной… но учту опыт.

                                    А вам, я вижу, как и многим на хабре, чем-то не угодили тим-лиды и ПМ-ы? По любому вопросу пытаются доказать профнепригодность.
                                  +1
                                  А потом еще зря потратили время на написание своего комментария ;-)
                                    0
                                    это из-за недовольства :)
                                    вы правы, все последующие сообщения буду игнорировать, чтоб не тратить время попусту. ;)
                                  +1
                                  А еще удручает тот факт, что в АппСторе нет фильтрации по версии iOS. Вот у меня первый айпод тач, например, а большая часть приложений не поддерживается. Это ещё ладно, но зачем, зачем они отображаются в АппСторе?
                                    +8
                                    Чтобы вы кусали себе локти и купили новый айпад ;)
                                      0
                                      Да вот в том-то и дело, что новый айпад я себе не куплю, зато приложения покупать стал меньше. Потому что задолбала эта угадайка.
                                    +1
                                    Хороший пост, у нас кстати недавно была тоже проблема при переходе на 5 версию оси.
                                    Проблема была следующего характера — в одном из контролов в навигационной панели висела сегментированная вьюшка, переключение которой приводило к некоторым действиям в логике приложения. Соответственно на переключение его значения был подвешен таргет, и перед самым началом работы приложения контролу задавалось текущее значение выбранного сегмента, чтобы сделать преднастройку параметров приложения. Выглядело это грубо говоря следующим образом:

                                    UISegmentedControl* control = [[UISegmentedControl alloc] initWithItems:[NSArray arrayWithObjects:@"First", @"Second", nil]];
                                    [control addTarget:self action:@selector(controlChanged) forControlEvents:UIControlEventValueChanged];
                                    [control setSelectedSegmentIndex:1];


                                    Так вот, на четверке этот код замечательно работает, а на 5 оси вызов сообщения @selector(setSelectedSegmentIndex:) перестал приводить к вызову привязанного таргета. Лечили тупым вызовом самого привязанного селектора, дописав такую строчку:
                                    [self controlChanged];
                                      +1
                                      Была ситуация с переходом на XCode 4.2 c точностью до наоборот. Все отлично работало на всех прошивках в старом XCode. Компилировали и дебажили билды под новым — тоже все ок. Отправили ad-hoc на тестирование (хорошо, что не по старинке, просто загрузить да девайс билд) — приходит фидбек что вообще не работает ничего, даже тачи глючат. Вывожу на экран координаты тача — x и y совпадают, причем совпадают еще до моей какой-либо обработки. Выяснилось в итоге, что это срабатывает оптимизация нового компилятора. Поменял компилятор на gcc или отключил оптимизацию — все ок. Потому тут все не так однозначно. Мануалы мануалами а опыт опытом.
                                        0
                                        А какой стоял вместо gcc, если не секрет?
                                          0
                                          Наверное LLVM 3.0
                                        0
                                        У меня подобные проблемы были когда я напортачил в методе viewDidUnload. Не релизил созданную кодом вьюшку (только в dealloc релизил). В итоге когда приходил memory warning — начинались чудеса )
                                          –1
                                          Есть такая особенность, но это особо не связано с SDK и обратной совместимостью :) А так да, лик из ниоткуда. Я тоже помню года полтора назад пол-дня потратил. На мой взгляд, само название метода неудачное — по аналогии с viewDidLoad называли, но играет совсем не противоположную роль. Зато на собеседованиях хорошо спрашивать — и 50% «Senior iOS developer'ов» сыпятся на вопросе когда этот метод вызывается и что в нём надо делать :)
                                            +1
                                            Скорее от lifecycle отталкивались, причем тут назначение противоположное? Для таких методов (которых предостаточно для контроллера) все различное по назначение, хоть в названии и присутствует схожесть.
                                              –1
                                              Ага, только viewDidLoad вызывается каждый раз, а viewDidUnload — только при Memory Warning. Может хватит уже троллить по любому поводу? Надоел, честное слово!
                                                +2
                                                ))) хорошо не буду вас троллить, раз вы считаете что я вас обижаю тем что не согласен со многих. А по поводу viewDidUnload и вызов только при Memory Warning вот ссылка: stackoverflow.com/questions/1158788/when-should-i-release-objects-in-voidviewdidunload-rather-than-in-dealloc (тут более ли менее можно вычитать почему и как, что можно проверить на простом тестовом примере, попробуйте)) )
                                                надеюсь вам хватит ума понять, что вы говорите о частном случае как о единственном возможном.
                                                  –1
                                                  Что вы хотите этим сказать, тем более в такой грубой форме. В линке на StackOverflow приводится «It is called during low-memory conditions when the view controller needs to release its view and any objects associated with that view to free up memory.», цитата из SDK. ЧТД, о чём я и говорил. Всё, не кормлю, итак жирный стал.
                                          0
                                          У меня каких-то глобальных проблем не возникало, но на всякий случай все свои программы перевел на ARC.
                                            –1
                                            и отказались от поддержки 4.х, зачем?
                                              +1
                                              нет, он отлично компилится на 4.x, проверяю на iPhone 4S, 4(4.3.3) и 3GS(4.2.1)
                                            0
                                            А нельзя втыкать в одно приложения разные билды для разных операционок?
                                            Чтобы был какой-нибудь маленький загрузчик, ну starter типа, а он проверяет версию операционки и запускает уже подходящий бинарник или грузит правильную либу. Так можно было бы минимальными усилиями обеспечить совместимость приложения со всеми версиями ОС.
                                              +2
                                              оно и так совместимо со всеми версиями ОС, просто когда выходит новая ОС, не сразу становится понятно что в ней отвалилось, особенно если баг проявляется далеко не у всех.
                                                0
                                                Вопрос не в этом.
                                                Вот есть у вас приложения для 3.1.3, а вышла уже 5.0.1, и вы хотите использовать новые плюшки из SDK5 — оставляете старую версию приложения нетронутой, для владельцев старых аппаратов, которых лишили апдейта на iOS5, а новые плюшки делаете в новой версии программы. Потом засовываете обе версии в одно приложение и в зависимости от версии iOS запускаете подходящий бинарник.
                                                Возможно ли такое в принципе?
                                                Ну, примерно как в Windows можно было в один exe-файл засунуть консольное приложение для DOS и гуёвое (ну или тоже консольное) для винды. Или как у Apple был формат исполняемых файлов Universal Binaries — по сути два независимо скомпилированных бинарника в одном приложении.
                                                  0
                                                  Можно внутри кода проверить версию ОС, собственно так сейчас костыли и пишутся, вот например надо вам сделать кастомный навигейшен бар, для иОС 4 вы просто переопределяете метод drawRect, и рисуете там что угодно, но в иОС 5, это уже работать не будет. Потому что Аппл теперь для этих задач добавили специальные методы, вот и приходится еще для иОС 5 писать свою реализацию.
                                                    0
                                                    т.е. если пишется приложение с base sdk 4.3, где юзается drawRect, то оно не запустится на 5?
                                                      0
                                                      запустится, но т.к. в иОС бекграунд навигейшен бара меняется по другому, drawRect не будет запущен, и в приложение под 5.0 будет показываться дефолтный бекграунд.
                                                      +2
                                                      > сделать кастомный навигейшен бар, для иОС 4 вы просто переопределяете метод drawRect, и рисуете там что угодно, но в иОС 5, это уже работать не будет. Потому что Аппл теперь для этих задач добавили специальные методы, вот и приходится еще для иОС 5 писать свою реализацию.

                                                      Не совсем так: вкратце Вы «переопределяли» при помощи Categories метод drawRect, а в iO5 было изменено поведение Categories, после чего у вас все сломалось под iOS5. А то что для работы с UINavigationBar добавили дополнительные методы это дело уже третье, причем при достаточно более сложном представления они не совсем и помогают.

                                                      Поэтому более правильно в таком случае вернуть поведение Categories которое Вы скорее всего использовали не только для бара, и вставить один кастыль нежели отдельно на каждый момент, т.е. подправить классы категорий в которых идет упор на переопределение методов. Сделать это можно допустим так:

                                                      добавляем класс (к примеру): @interface UINavigationBarCustom: UINavigationBar в имплементации указываем переопределяемый метод вашего класса который вы пытались расширить через Category, в нашем случае это drawRect. Старый класс категории перейменовываем допустим в UINavigationBar+iOS5Support.h и добавляем в него метод:
                                                      + (Class)class {
                                                      return NSClassFromString(@«UINavigationBarCustom»);
                                                      }
                                                      (используемые именования подходят для меня, но скорее всего будут не подходить вам в зависимости от реализации + описание почему это работает для обоих версий опускаю) Таким образом мы повторили старое поведение для категории, несколько изменив ее и добавив дополнительный класс (хотя и это можно вынести в один). Таким образом вставив один костыль, мы решили все проблемы связанные с изменениями в поведении Categories, нежели…

                                                      Пользуйтесь, может кому пригодится)
                                                        0
                                                        торт!
                                                0
                                                Первый же параграф под заголовком «Решение» раскрывает, возможно, одну из первопричин возникновения самой ситуации: несколько… скажем так, «необычный» подход тимлида к среде разработки и билду бинарников.
                                                  +1
                                                  Отличная статья! Большое спасибо автору!
                                                    0
                                                    Спасибо! Очень рад что помогло :)

                                                  Only users with full accounts can post comments. Log in, please.