Агрегация каналов между Cisco Catalyst и Avaya ERS



    Сделаем небольшую лабу. Объедением два физических линка в один логический между коммутаторами двух разных вендоров при помощи протокола LACP.

    Link Aggregation Control Protocol позволяет объединять от двух до восьми 100 Мибит/с, 1 Гибит/с или 10 Гибит/с портов Ethernet, работающего по витой паре или оптоволокну, что позволяет достичь результирующей скорости до 80 Гибит/с. Это позволяет увеличить пропускную способность каналов и повысить их надежность.

    Протокол LACP поддерживается обоими вендорами, поэтому мы и будем его использовать.

    Несмотря на существование стандарта IEEE 802.3ad, многие компании ещё используют свои вендорские протоколы. В случае Cisco это PAgP. У Avaya это нортелевский MLT.

    Объедени 47 и 48 порт и пустим через них две виртуальные сети, например для данных и для телефонии. Первый vlan тоже оставим.

    Начнем с Cisco.

    enable
    conf t
    

    Создаем виртуальные сети. Второй vlan для данных.

    vlan 2
    name "Data"
    exit
    

    Пятый для телефонии.

    vlan 5
    name "Voice"
    exit
    

    Раскидываем порты по виртуальным сетям.

    1-2 порт будут в первом vlan.

    interface range gigabitEthernet 1/0/1-2
    switchport access vlan 1
    exit
    

    C 3 по 24 мы выделим под голос.

    interface range gigabitEthernet 1/0/3-24
    switchport access vlan 5
    exit
    

    С 25 по 46 под передачу данных.

    interface range gigabitEthernet 1/0/25-46
    switchport access vlan 2
    exit
    

    Настраиваем непосредственно 47 и 48 порт. Сначала делаем их транковыми, чтобы прокинуть через них две виртуальные сети.

    interface gigabitEthernet 1/0/47
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    
    interface gigabitEthernet 1/0/48
    switchport trunk encapsulation dot1q
    switchport mode trunk
    exit
    

    Теперь указываем, что они в одной агрегационной группе LACP. Групп может быть несколько, если мы захотим сделать несколько агрегированных линков.

    interface gigabitEthernet 1/0/47
    channel-protocol lacp
    channel-group 1 mode active
    exit
    
    interface gigabitEthernet 1/0/48
    channel-protocol lacp
    channel-group 1 mode active
    exit
    

    Назначаем ip для управления.

    vlan 1
    ip address 192.168.1.10 255.255.255.0
    no sh
    exit
    

    Проверяем как работает.

    show etherchannel summary
    

    show lacp neighbor
    


    Теперь займёмся Avaya.

    enable
    conf t
    

    По аналогии создаем две виртуальные сети.

    vlan create 2 name "Data" type port
    vlan create 5 name "Voice" type port
    

    Обозначаем, что 47 и 48 порт будут транковыми. У Avaya нету как такого понятия. Мы просто указываем, что будем ставить метки по стандарту 802.1Q.

    vlan ports 47,48 tagging tagAll
    

    Добавляем порты в виртуальные сети. 1 и 2 порт оставляем в первом vlan, остальные порты доступа из него убираем. В пятый добавляем с 3 по 24 и транковые порты. Соответственно во второй — порты с 25 по 46, плюс транковые.

    vlan members remove 1 3-46
    vlan members add 5 3-24,47-48
    vlan members add 2 25-48
    

    Настраиваем LACP. Здесь агрегационная группа обозначается параметром lacp key, можно поставить любую цифру, главное одинаковую.

    interface gigabitEthernet 47
    lacp key 20
    lacp mode active
    lacp timeout-time short
    lacp aggregation enable
    exit
    
    interface gigabitEthernet 48
    lacp key 20
    lacp mode active
    lacp timeout-time short
    lacp aggregation enable
    exit
    

    Назначаем ip для управления.

    interface vlan 1
    ip address 192.168.1.20 255.255.255.0
    exit
    

    Проверяем.

    show mlt
    

    show lacp port 47,48
    
    Share post
    AdBlock has stolen the banner, but banners are not teeth — they will be back

    More
    Ads

    Comments 16

      +9
      Если бы вы рассказали что такое lacp, vlan, что это за производители — то статья была бы полезна хотя бы новичкам. А так, для кого она? Все кто могут понять конфиги без комментариев, сами знают как такое сделать. А кто не может понять конфиги — тот в целом не понимает о чём это тут.
        0
        Конечно можно почитать что за протокол, но хотелось бы «для чайников».
        И заодно еще бы для свичей HP. У новых простеньких моделей даже нет telnet'a и все через веб-морду.
        И конечно же комментарии к конфигу хотелось бы.
          0
          А что за коммутаторы HP если не секрет?
            0
            можно узнать модель поконкретнее?
              0
              HP ProCurve 2650 — не нашел как сделать LACP.
              HP V1905-24 — LACP есть, но нет телнета :)
              Вообщем, хотелось бы статью про Cisco+HP
          +3
          Ждем статьи: «Агрегация каналов между Cisco и HP, Cisco и D-Link, Cisco — NetGear, etc .....»
            –1
            Ну между 3com и Juniper у меня были небольшие грабли, надо было в динамическом режиме настраивать на 3com. Хотя до этого при статическом определении портов работало в паре с FreeBSD LAGG.
            +1
            Странная статья. Ни введения, ни зачем это, ни что в итоге получили. Можно сказать, автор приложил конфигурационный файл со своими комментариями.
              +1
              Если уж говорить про LACP, можно было бы дописать побольше возможных настроек и на что они влияют. Например, Рассказать, что LACP бывает статический и динамический, существуют различные алгоритмы регулирования нагрузки.
                +1
                соглашусь, странная статья. Объединял huawei и allied telesis, но в мыслях небыло, что я сделал что-то особенное, хотя оборудование специфическое.
                  –3
                  Зря минусите статью. Мне, например интересно и полезно.

                  В качестве пожелания — хотелось бы узнать как настраивать коммутаторы Cisco для работы серверами HP у которых 2,4 сетевых карты? Чтобы повысить пропускную способность… Ну и как сервера настраивать для этого же.
                    +1
                    HP — гуглить NIC Teaming.
                    Со стороны циски — см. пост (да и вообще любой пример конфигурирования LACP, так как дело совершенно банальное и везде описанное).
                    Я бы не назвал это rocket science…

                    Вот агрегация между разными шасси свитчей линейки Nexus (т.е. vPC) — это тема, достойная довольно огромного по размеру хабрапоста, так как нюансов и гипотетических граблей море.
                    0
                    Увеличение пропускной способности агрегированного линка — это все лишь, побочный эффект работы алгоритма балансировки. И хочу предостеречь от громких фраз, ибо 8х10G ≠ 80G. Сравнимой полосы можно добиться только при выполений определенных условностей.
                      +1
                      от двух до восьми 100 Мибит/с, 1 Гибит/с или 10 Гибит/с портов Ethernet

                      Да хоть 10мб/с или 40гб/с.
                      Кстати, впервые вижу «Мибит/с». Забавное сокращение.
                      Несмотря на существование стандарта IEEE 802.3ad, многие компании ещё используют свои вендорские протоколы. В случае Cisco это EtherChannel.

                      Не-а. Etherchannel — это их название концепции агрегации. LACP — тоже etherchannel. Проприетарный протокол — PAGP.

                      Вообще, про LACP можно не так уж мало рассказать. Например, авайка настроена на fast hello, а каталист — нет (хотя мало какие каталисты это поддерживают, но все-таки надо было объяснить, что это за команда «lacp timeout-time short» и зачем она нужна). Можно рассказать про max-links + «active-port distribution automatic». Да хоть про тот самый метод хеширования, про что уже упоминалось.

                      Даже с пояснениями статья остается скучной :(

                      Only users with full accounts can post comments. Log in, please.