Opera 12.17 пытается обновиться до 25

    (Пост-предупреждение)

    Update: Подчёркиваю, что дело в молчаливом обновлении браузера до новой ветки, которое Opera обещала никогда не делать (update: pepelsbey говорит — не обещали). Это очень неожиданное поведение. Статья адресована тем, кто сознательно хочет иметь 12.17, в том числе и параллельно с новой версией.

    Несмотря на все превратности, мой основной браузер всё ещё — Opera 12.17, хотя, конечно, теперь приходится использовать и другие браузеры, в том числе и новую Opera.

    Как известно, Opera обещала, что 12 версия не будет делать попыток обновиться до версий следующего поколения. И, действительно, 12.15 обновилась до 12.16, а та — до 12.17.

    Поэтому когда сегодня при запуске Opera 12.17 предложила мне обновиться (не указывая, до какой версии), я был обрадован, что она ещё хоть как-то поддерживается — и я получу 12.18.

    Думаю, несложно представить моё удивление, когда я увидел в конце процесса вот такое окошко:



    Поэтому — будьте готовы отказаться от соблазна обновить 12 версию.

    Если вы таки установили новую версию, но не перезапустили браузер, возможно, вам поможет моё решение, чтобы избежать обновления.

    Я удалил из папки Opera три файла, которые, вероятно, относятся к новой Опере:

    launcher.exe
    installer_prefs.json
    installation_status.xml

    После перезапуска браузера я увидел окошко с прогресс-баром и текстом типа «Спасибо, что выбрали новую Opera», подтвердил, что opera — это браузер по умолчанию, и — запустилась родная старая опера.
    При следующем перезапуске ничего необычного не происходило.

    Возможно (я надеюсь), новая Опера ставится параллельно старой и при запуске спрашивает — не вернуться ли к старой, но я проверять не решился. Кроме того, новая у меня и так стоит, инсталлер мог бы и проверить это.

    Будьте бдительны.
    Share post

    Similar posts

    Comments 64

      +33
      Надеюсь никто не послушает этого совета и все же обновит свой браузер.
        +7
        У меня стоят все новые версии пяти основных браузеров, я регулярно работаю в новой опере и хроме.

        Но я совсем не хочу, чтобы моя старая опера, которая мне нужна именно в старом виде, неявно обновлялась до новой (которая, заметьте, у меня и так уже есть). Позвольте мне решить этот вопрос и помочь остальным.

        Представьте, что у вас есть старая любимая игрушка, и у вас насильно её отнимают и всучивают новую. Вы поддержите это действие?
          +5
          Вы — разработчик, на сколько я понимаю. Вы понимаете к чему может привести использование старого браузера.
          А вот абстрактная баба Галя не понимает, она увидит статью и подумает, что обновлять браузер ни в коем случае нельзя.
          В итоге такие как мы с вами получают дополнительные проблемы.

          Я не хочу разводить очередную войну про старые браузеры, но такие статьи, по моему скромному мнению, публиковать в общий доступ не стоит.

          P.S. У меня стоит даже 11-я Опера. Знаете откуда? Заказчик прислал скриншот с поехавшей в ней версткой.
            +10
            Баба Галя на хабре?
              0
              Баба Галя — абстрактый персонаж. Вполне возможно онан е может отличить монитор от телевизора, но вполне возможно, что баба галя учится в 9 классе и хочет обновить себе браузер. При этом пользуется примерно таким алгоритмом:

              — забить в строку браузера «яндекс»
              — забить в поиск яндекса «как обновить браузер»
              — а яндекс уже подскажет ей что нужно, например эту статью
                +8
                Если всё время следовать вашей логике, не стоит писать очень многие статьи.
                  +3
                  Баба Галя учится в 9 классе? :)
                  Ваша мысль понятна, но имхо вы зря беспокоитесь.
                  Раз уж опера молчаливо обновляется, Баба Галя станет жертвой этого дела в силу специфики распространенного подхода «жмакаю OK не глядя».
                0
                Я вот не разработчик, но имею с пяток разных браузеров для разных нужд, но 12.17 — основной.
                  –1
                  опера — для сёрфа
                  стринги — для кликов по ссылкам в приложениях и автопосещений страниц разработчика после установки программ и всяких магазинов
                  хром — для банков
                  огнелис — для того, что не работает в 12.17 и прочего баловства с плагинами которые кликают по рекламе и прочим ненужностям
                  ИЕ — для проверки, когда йота не работает и техподдержка просит проверить именно там (ну и раньше через него по самба сетке ходил без костылей)
                  0
                  Я не хочу разводить очередную войну про старые браузеры, но такие статьи, по моему скромному мнению, публиковать в общий доступ не стоит.

                  P.S. У меня стоит даже 11-я Опера. Знаете откуда? Заказчик прислал скриншот с поехавшей в ней версткой.


                  Это вы свои проблемы (неправильные процессы разработки) на всех экстаполируете. В нормальных компаниях имеют список браузеров, в которых приложение работает (типа IE >= 9, последний FF и Chrome).
                    0
                    P.S. У меня стоит даже 11-я Опера. Знаете откуда? Заказчик прислал скриншот с поехавшей в ней версткой.

                    А можно пример кода, где верстка едет?
                    +2
                    Если старая игрушка не поддерживает новые способы «игры» с ней — то почему бы и нет. От старых игрушек всегда рано или поздно приходится отказываться. Более того, возможно и угрозу уже в целом неподдерживаемый браузер представляет. Вы же не пользуетесь IE 6, правильно? Так зачем из Opera 12 делать второй объект поклонения? Да, Opera Software редиски, что так взяли и все перечеркнули — но это не повод дальше искать способы не обновлять браузер.
                      +1
                      Да, я всё понимаю, и полностью за обновление 12.17 у тех, кто этого хочет или кому это безразлично, как абстрактной бабе Гале.

                      Но Опера:

                      1) пообещала никогда молчаливо не обновлять 12.17 на новую ветку;
                      2) при обновлении никак не уведомила меня, что это будет 25 версия.

                      Если бы я видел заранее, что это будет 25 версия — этого было бы достаточно. Но попап об обновлении об этом не сообщал.
                        –1
                        Да, может это и было немного подло со стороны разработчиков оперы, но учитывая, что абстрактных Галь у нас в мире гораздо больше, то лучше уж пусть так и обновляется.
                          +1
                          Тогда я не понимаю осуждения этой статьи. Заметьте, я особо не порицаю действие оперы, я просто пытаюсь уведомить тех и помочь тем, для кого это важно и может отнять время.
                          –1
                          Как же не предупредила, если на вашем же скриншоте написано:
                          Opera 25.0 is ready for installation

                          ?
                            0
                            Это окошко показывается уже ПОСЛЕ того, как новый браузер скачивается и конфигурится к установке при следующем запуске оперы.

                            Перед этим спрашивается: «есть обновление, обновить?» — без указания версии.
                              0
                              Согласен, ну тогда — да нажать «Установить позднее», а тем временем удалить обновление.
                              Но есть одно но — почему вы в таком случае не отключили обновления — если хотите оставаться на старой версии?
                                0
                                Я так и сделал, но чтобы помочь другим — написал этот пост.

                                Обновление я не отключил потому, что уверен, что Опера обещала не обновлять старую ветку до новой, и раньше действительно обновляла 12.15->12.16->12.17.

                                Поймите, я вообще ничего не требую от Оперы постом, это просто предупреждение тем, кому нужна старая опера.
                                  0
                                  Спасибо, отключил обновление навсегда… У меня стояло «Спрашивать перед установкой».
                          +8
                          IE6 не был объектом поклонения, он был массовым в виду своей дефолтности для ХР. старой опере поклонялись только потому, что это был отличный продукт.
                          а новая опера это еще одна ненужная сборка хромиума

                          опера софтвер редиски, мягко говоря, потому что писали, что не будут форсить обновления с 12 на 25 версию, но они это делают.
                          • UFO just landed and posted this here
                              –1
                              Эх, молодняк…
                            +2
                            Дело в том, что как раз новая игрушка не поддерживает старые нужные способы игры. Я вынужден параллельно использовать оперу 12 и хром, хотя бы потому, что не могу на хабре залогиниться в старой опере. Та же беда в любом 4.х вордпрессе. Но кто бы что не говорил, опера 12 может держать 150 вкладок (да, мне иногда столько надо, одних прикрепленных штук 20), а хром у меня жутко тупит уже после 10.
                              +4
                              Насчет логина. Надо в настройках для сайта во вкладке «сеть» поставить галку «отправлять данные о ссылающейся странице». Мне помогло.
                                0
                                Спасибо огромное! Теперь хром нужен только для одной вкладки. Сюда плюсануть не могу, но посылаю лучи добра, за два дня получаю уже вторую полезную подсказку в комментариях.
                            0
                            А вот если бы пользователь ИЕ6 так бы говорил, что таким людям отвечать?

                            Хоть этот вопрос и с претензией на иронию, но через пару лет 12ая версия вполне может стать синонимом ИЕ6 (тьфу-тьфу) и тогда уж будет не до шуток ;)

                            *З.Ы. Пока писал ответ — уже провели параллель с ИЕ6
                              +1
                              Понимаете, если пользователь IE6 говорит: сделайте, чтобы у меня работало в IE6 — я ему отвечу, что фиг ему, это его проблемы, раз он использует старый браузер. И пойму, если мне скажут то же самое про 12.17.

                              Но у меня таких требований нет. Я просто не хочу, чтобы, игнорируя моё мнение и нарушая обещание, мне обновляли один из инструментов, которыми я пользуюсь, в духе «мы знаем лучше, что тебе надо».
                                –1
                                Для меня IE умер после выхода 6-й версии. Я тогда перелез на Netscape.
                                0
                                если так сравнивать, то IE6 это опухоль, а 12 опера это супер зрение. через 12 лет я бы расстроился, если бы у меня отняли супер зрение, а вот от опухоли я бы легко отказался.
                                тем более, что доля пользователей оперы ничтожна и никогда не будет проблемой по части стандартизации веба.
                                  +2
                                  Например я не считаю ИЕ6 опухолью. Скорее наоборот (хотя с другой стороны пользуются 12ой версией по вполне разумным причинам, в отличие от ИЕ6-8). Почему?

                                  Во всей серии ИЕ, все баги (большинство багов), недоделки и прочее — строго задокументированы. На любой косяк можно найти решение. И можно просто заранее знать что лучше не использовать и как обойти какую-либо проблему.

                                  С другой стороны Опера 12 даже сейчас, с точки зрения технологий, вполне может считаться современным браузером. Но каждый косяк этого браузера возникает из неимоверного сочетания звёзд на небе и настроения разработчиков. Начиная от того, что в 12ой версии браузера (одной из первых) был объект WebSocket без реализации (тупо заглушка), заканчивая тем, что сочетание каких-то стилей, например float: left, вместе с border: #900 1px solid; (это только пример) может приводить к полному раскорячиванию всей вёрстки. Если учесть встроенный в браузер js файлик, который исправляет конкретные сайты — многое становится вполне очевидным.

                                  Так что я считаю мнение BearOff (сообщением выше) — идеальным. Пользоваться — пользуйтесь, с точки зрения функционала даже Яндекс и Макстон пока что ещё очень далеко позади, разработчики Оперы постарались это организовать, т.е. замены в этом плане ему нет. Но просто не просите, чтобы в этом браузере что-то хорошо работало и не возмущайтесь, если кто-то из техподдержки указал на дверь, после сообщения «у меня Опера 12».
                                    +1
                                    никто не возмущается отсутствию поддержки, в данном случае имеет место быть попытка обманом вынудить пользователей обновиться
                                +1
                                Вам, как разработчику, стоит понимать, что если вы хотите иметь какой-то браузер определённой версии — организуйте себе это, отключите обновление и т.п. А вот типичному пользователю этого делать не стоит, чтобы разработчики не мучались с застрявшими в прошлом браузерами пятилетней давности.
                                  +2
                                  Я полностью понимаю, что проблема в организации версии в общем случае — моя.

                                  Ещё раз подчеркну — проблема в неожиданности. Ведь вы пообещали, что автообновления до новой версии не будет. Именно после вашего обещания я включил проверку обновлений обратно, и, помня о нём, согласился с обновлением сегодня — ожидая увидеть 12.18, как это было с 12.16 и 12.17.

                                  Если бы я увидел предупреждение о версии заранее, я бы просто не стал обновлять, отключил проверку и все дела.

                                  И ещё раз подчеркну — что я не виню оперву в форсировании новой версии в этом случае. Я виню её в нарушении обещаний и, как следствие, в отсутствии уважения к тем, кто сознательно использует 12.17.
                                    0
                                    а как разработчикам понимать обман?
                                  +1
                                  У меня, например, тоже стоит и новая опера и хром, но от старой я не собираюсь отказываться и частенько проклинаю разработчиков и опера, за то что забросили продукт, и сайтов, за то что из-за ненужных мне в большинстве своем красивостей и функциональностей сайтов я не могу пользоваться любимым браузером, а приходится запускать хрониумных выкидышей.
                                    +6
                                    Вот мне сейчас предлагают обновиться с кукурузника на новую Феррари. Вот только Феррари летать не умеет. Когда научится (желательно с вертикальным взлётом, кукурузнику ВПП какая-никакая нужна) — тогда и обновлюсь. Да и Бентли у меня есть уже, которая, впрочем, тоже не летает.
                                      0
                                      А использую Opera 12 в качестве браузера внутрикорпоративной CRM системы. Многие элементы CRM заточены именно под неё и некорректно ведут себя в новой опере… Так что не спешите её хоронить…
                                      +2
                                      В репозитории ArchLinux теперь тоже хропера. Старая 12я опера доступна в AUR под именем opera-legacy.
                                        +2
                                        Расскажите, когда это мы обещали никогда не обновлять пользователей 12.х до последних версий? Притом, то, что вы описываете — это не насильное обновление после перезапуска, а предложение обновиться.
                                          –5
                                          Будьте добры, выступайте без этого «ля-ля», пожалуйста. У меня тоже вылезло меню с обновлениями, я и отнюдь ему не рад.
                                          Лучше поведайте, как полностью заблокировать старой Опере обновления, чтобы эти навязчивые окна больше не появлялись.
                                            0
                                            Я не могу вам привести сейчас ссылку, но то, что не один я помню о таком обещании, подтверждает, что оно было.

                                            Обновление — не насильное, да («есть обновление. установить?»), но, как я и говорил, я ожидал обновления на 12.18, как это было с 12.16 и 12.17. Поэтому был удивлён, получив 25.

                                            (Почему, кстати, 25, если последняя версия — 26?)
                                              0
                                              Сам он не подтверждал, это были домыслы тут.
                                              А тут люди предположили, что всё же когда-то потом обновят насильно.

                                              Жаль конечно. Многих вещей до сих пор пока и не вернули.
                                                0
                                                Даже если явно этого не обещали, логика 12.15->12.16->12.17 говорила об этом.

                                                Если бы перед загрузкой и установкой была указана версия, вопросов бы не было.

                                                Поправлю пост, указав, что pepelsbey говорит, что не обещали.
                                                +1
                                                Я помню только то, что они обещали не обновлять старую оперу, пока не допилят новую до того состояния, когда смогут сказать, что она не сырая. Мне сложно сказать, что текущая версия не сырая (она до сих пор не получает старые закладки из Link), но всё же. Они решили, что готово и обновили.
                                                +4
                                                Я не помню где это было сказано, но я мне тоже помнится, что обещали не обновлять.
                                                Да и такое и предлагать странно, при той огромной деградации функциональности, которую несёт новая версия.
                                                0
                                                *здесь был комментарий, который уже не актуален*
                                                  –6
                                                  Кто то пользуется opera 12?
                                                  Наверно эти люди не имеют отношения к разработки сайтов.
                                                    +6
                                                    Я использую и имею отношение к разработке сайтов…
                                                      +2
                                                      Те кто пользуются и при этом верстают — не замечают основных косяков, т.к. исправляют их сразу же. Наоборот, это те люди, которые решили проверить работу в Опере 12, используя по умолчанию любой другой браузер очень удивляются как Опера умудряется переворачивать весь сайт ;) Именно в этих случаях начинает кипеть ярая ненависть к движку.
                                                        +2
                                                        Собственноручно пишу сайты. Собственноручно написал два движка с нуля. Не разу не было проблем в Opera.
                                                      +2
                                                      Всё ещё на Opera Presto. Не могу найти подходящую замену, хотя параллельно использую Opera Blink.
                                                      1. Maxthon. Хорош, но не нравится мне одной-единственно вещью: вместо того, чтобы подключиться к крупной системе дополнений, он делает свои дополнения. Где Ghostery, где SaveFrom?
                                                      2. Opera Blink. Слабоватая работа с закладками (они, кажется, написаны на JS, а не встроены в движок). Хотелось бы вкладки справа.
                                                      3. Яндекс. Ну мордой не понравился, просто мордой. Хотя пробовал несколько дней работать только на нём.
                                                      Сейчас ещё Рыжую попробую — авось на ней останусь.

                                                      Кстати, по поводу Рыжей на Андроиде. Лучший из известных мне браузер для небольших HD-экранов (остальные делают слишком мелко и никак не увеличишь). Но шрифт там — говно такое ещё: хинтинг делает косые элементы тяжелее вертикальных; спутан курсивный шрифт с наклонным («ф», например, курсивное, а «в» — наклонное)…
                                                        0
                                                        «Остальные» = все браузеры до единого на Blink
                                                          +1
                                                          Позвольте не согласиться про Андроид. Да, Firefox позволяет менять размер основного текста страницы, при этом нарушаются пропорции размеров заголовков и основного текста (Хабр выглядит очень странно и непривычно). И он не умеет переносить текст по границе экрана — фича, без которой я уже не представляю себе мобильный браузер.
                                                            0
                                                            Что взамен подскажете?
                                                              0
                                                              Ни в коем случае не хочу что-то однозначно рекомендовать, набор возможностей у разных мобильных браузеров разный и при этом во многом совпадающий. В Хроме, например, можно плавно менять размер шрифта (не пользуюсь этим, как уже сказал, потому что нарушаются пропорции элементов страницы), во встроенном андроидовском браузере вроде можно делать перенос… Поскольку на компьютере пользуюсь Яндекс-браузером, то и на мобильном он же; очень удобно, что при увеличении масштаба текст вписывается в границы экрана (если не помещается).

                                                              Но, насколько я знаю, ни в одном долбаном мобильном браузере нет такой нужной функции, как эмуляция наведения мыши. Очень не хватает.
                                                            +1
                                                            В FF на Android зачем-то выпилили подгонку текста при увеличении (то есть при увеличении текста приходится скролить текст влево-вправо). Благо в маркете есть еще Mobile Classic (старая Opera), но после нескольких обновлений она стала произвольно вылетать. Пришлось уйти на Dolphin Browser, несмотря на неудобный интерфейс он умеет подгонять текст. Еще UC Browser это умеет.
                                                            Честно говоря не понимаю почему почти не в одном Android браузере нет этой одной из самых важных для мобильного браузера функций, неужели всем так нравится щуриться, пытаясь вчитаться в текст размером 4px?
                                                            +2
                                                            Если я не ошибаюсь, опера обещала не обновлять старую ветку до тех пор, пока в новой не будут реализованы все фичи старой.
                                                            Хотя они как минимум не реализовали группировку вкладок (из того, чем я пользовался в старой).
                                                              0
                                                              Да что там, группировку — они успешно потеряли заметки…
                                                                0
                                                                Все равно новая опера мне нравится больше, чем хром. И из фишек, которых лично мне не хватало, сейчас нет как раз только группировки вкладок. И, что очень важно, веб избавился от еще одного движка, который занимал 2 место по количеству проблем в верстке. Не подумайте, мне очень нравился их движок, во многом он работал лучше аналогов и не был таким прожорливым как фф на тот момент и хром. Но это еще один движок, и, как следствие, еще один браузер для отладки, что с точки зрения разработчика не есть хорошо.
                                                                  +3
                                                                  И, что очень важно, веб избавился от еще одного движка, который занимал 2 место по количеству проблем в верстке.
                                                                  На забросайте меня помидорами, но меня просто бесят такие коментарии… Пристрелить готов… Каких проблем? Где? Я разрабатывал много под Opera и никогда не делал акцента, что пишу именно под нее. После чего код работал везде и только IE вел себя неадекватно (постоянные проблемы с Jquery и изредка верстка «ехала»).
                                                                    0
                                                                    Я вас понимаю, я сам когда на опере старой еще сидел — верстал изначально под нее и тоже проблем не было с другими браузерами. А вы спросите тех разработчиков, которые писали под хром — они вам скажут другое.
                                                                    Я немного не прав был в том плане, что опера была менее распространенной среди разработчиков, что и явилось причиной проблем с ней. 2 место потому, что на ней реально не все вещи работают так же, как в том же хроме или фф (обратное не верно), а люди, которые не тестируют верстку в опере изначально, соответственно, могут столкнуться с проблемами. Но это не осел, конечно. Количество проблем с ослом в разы больше, естественно.
                                                                    И не надо в меня стрелять, я сам «болею» за оперу)
                                                                  +2
                                                                  Если начать перечислять всё, что они потеряли, это будет нехилый полноценный пост.

                                                              Only users with full accounts can post comments. Log in, please.