Канал точка-точка Ethernet over L2TP на Cisco

Работая в небольшом ISP, часто приходилось предоставлять клиентам (юридическим лицам) ethernet-канал связи между их подразделениями, территориально разбросанными по всему городу или в соседних городах. Большинству клиентам удавалось просто предоставить VLAN. Но что делать, если по пути между филиалами есть только маршрутизируемые сети?

Сначала посмотрел в сторону GRE-туннеля + bridge между туннелем и портом абонента. Решение возможное, но корявое и официально «not supported», работало в зависимости от фазы луны. Смотреть в сторону MPLS идея утопичная, т.к. имеющееся оборудование его просто не поддерживает. Выбор пал на EoL2TP, который, как оказалось, не только работает нормально, но конфигурится намного проще, чем кажется на первый взгляд. Итак, приступим.



Задача: Необходимо объединить Workstation 1 и 2 в единый broadcast-домен, через маршрутизируемую сеть. При этом мы можем управлять только оконечными роутерами A и B.

Шаг 1. Настраиваем связь между роутерами. В режиме глобальной конфигурации:

hostname Router-A
!
! Задаем IP-адрес на интерфейсе к аплинку
!
interface FastEthernet1
 description Uplink
 ip address 198.51.100.1 255.255.255.0 
 no shutdown
!
! Прописываем основной шлюз
!
ip route 0.0.0.0 0.0.0.0 198.51.100.2


hostname Router-B
!
! Задаем IP-адрес на интерфейсе к аплинку
!
interface FastEthernet1
 description Uplink
 ip address 203.0.113.1 255.255.255.0
 no shutdown
!
! Прописываем основной шлюз
!
ip route 0.0.0.0 0.0.0.0 203.0.113.2

P.S. Я специально не стал рассматривать динамическую маршрутизацию, чтобы не отвлекать читателя дополнительной информацией не по теме.

Шаг 2. Проверяем связь между роутерами

Router-A#ping 203.0.113.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 203.0.113.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

Router-B#ping 198.51.100.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 198.51.100.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

Пинг проходит.

Шаг 3. Теперь можно перейти к настройке EoL2TP

hostname Router-A
!
pseudowire-class ether-pw
 encapsulation l2tpv3
 protocol none
  ! Интерфейс, с которого роутер будет устанавливать соединение L2TP
 ip local interface FastEthernet1   
!
interface FastEthernet0
 description User
 no ip address
 ! Ниже указывается IP-адрес роутера, с которым необходимо установить соединение L2TP (Router-B)
 xconnect 203.0.113.1 123 encapsulation l2tpv3 manual pw-class ether-pw
  l2tp id 2 3  ! Local ID=2, Remote ID=3. 
  ! На другом роутере ID должны быть такими же, но поменяны местами


hostname Router-B
!
pseudowire-class ether-pw
 encapsulation l2tpv3
 protocol none
 ! Интерфейс, с которого роутер будет устанавливать соединение L2TP
 ip local interface FastEthernet1    
!
interface FastEthernet0
 description User
 no ip address
 ! Ниже указывается IP-адрес роутера, с которым необходимо установить соединение L2TP (Router-A)
 xconnect 198.51.100.1 123 encapsulation l2tpv3 manual pw-class ether-pw   
  l2tp id 3 2 ! Local ID=3, Remote ID=2.


Шаг 4. Проверяем связь Workstation 1 <-> Workstation 2



Как видно, проброс ethernet'а через IP-сеть уже работает.

Шаг 5. Проверяем статистику на роутерах
Router-A#sh l2tun session
L2TP Session Information Total tunnels 0 sessions 1
LocID      RemID      TunID      Username, Intf/      State  Last Chg Uniq ID
                                 Vcid, Circuit
2          3          0          123, Fa0             est    00:14:45 5

Router-A#sh l2tun session packets
L2TP Session Information Total tunnels 0 sessions 1
LocID      RemID      TunID      Pkts-In    Pkts-Out   Bytes-In   Bytes-Out
2          3          0          486        461        74806      59070


Router-B#sh l2tun session
L2TP Session Information Total tunnels 0 sessions 1
LocID      RemID      TunID      Username, Intf/      State  Last Chg Uniq ID
                                 Vcid, Circuit
3          2          0          123, Fa0             est    00:28:10 8

Router-B#sh l2tun session packets
L2TP Session Information Total tunnels 0 sessions 1
LocID      RemID      TunID      Pkts-In    Pkts-Out   Bytes-In   Bytes-Out
3          2          0          461        487        59070      74957


На этом настройка и проверка полностью закончена. На мой взгляд довольно простое и быстрое решение. Дополнение, критика принимаются, но не судите строго, этой мой первый пост.
Источник www.cisco.com/en/US/docs/ios/12_3t/12_3t2/feature/guide/gtvoltun.html
Tags:
cisco, EoL2TP

You can't comment this post because its author is not yet a full member of the community. You will be able to contact the author only after he or she has been invited by someone in the community. Until then, author's username will be hidden by an alias.